Introduction

MADCAT logo
[image]

MADCAT Software Developer Guide
Introduction
Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Dear user,

Welcome to the MADCAT help file. This document covers all the aspect of the MADCAT from the installation process to the most advanced tool development process.

Of course, in addition to this guide, you can contact me to ask questions, report problems... Feel free to give feedback, I'd really appreciate your support to make the MADCAT as useful as possible.

Compilation Of Windows

What is the MADCAT ?

First, the MADCAT is an acronym which stands for Multipurpose Application for Data Collection And Treatment. Key words are :

  • Multipurpose : the MADCAT can virtually perform any task
  • Data Collection : the MADCAT is based on Xml data. The core function is data storage and maintenance : create, edit, delete Xml elements.
  • Treatment: the MADCAT can execute any task using your Xml data : generate report, produce new data, interact with your system...

How does the MADCAT work ?

The MADCAT is a light framework based on Xml and .Net : Xml is used to setup the interface and define your data model. .Net is used to develop types, tools and renderers for the MADCAT.

What does the MADCAT offer by default ?

The MADCAT provides :

  • a flexible and customizable graphical interface
  • a Xml data editor
  • a task manager
  • Xsl transformation to generate HTML reports

The graphical interface is designed in order to be as simple as possible for the end-user but also for the developer. For the user, only useful elements are visible. Functions are limited but fast. For the developer, the interface can be changed very easily using Xml files.

The Xml data editor is designed like the Windows' explorer. Xml elements are displayed like files in folders. It is also very flexible for the developer because it is based on Xml files and can be modified without impact on user's data. The editor is very easy to use and is powerful : it offers infinite undo/redo, baseline management, search tool, etc...

The task manager can run multiple actions in background or not. It offers user-friendly functions like : pause/resume, full log, detailed progress report, cancel. It also offers data protection against inconsistencies. Users can cancel any actions without fear : data changes are commited to the database only if action's ended properly. Users have full control on actions.

Finally, the report generator is a simply Xsl transformation tool which can produce HTML files from the Xml data. It offers configurable Xsl transformations : users can define the scope of the report.

Can we extend the MADCAT functions ?

Yes ! The MADCAT comes with a detailed API which can be used by developers to add new data types, new renderers and new tools to the MADCAT.

Possibilities are virtually limitless. The MADCAT's design allows you any combination of types/tools/renderers/models. You can create applications by simply assembling these MADCAT elements into workspaces. The MADCAT's elements must always be designed to be reusable with any other element without installation, compilation.... Users just need to move them in dedicated folders of their workspaces.

Why the MADCAT ?

The objective is to have a very fast and light framework which is also powerful and flexible. It can be seen as a light "Eclipse" environment using .Net assemblies (for tools, types and renderers) but without the numerous options and files of the official Eclipse system.

Table of contents

This document will guide you through every step of the MADCAT experience, starting from the surface to finally reach the deepest features :

  • The installation process (easy part !)
  • The graphical interface (Easy too, it is a classical Windows interface)
  • The workspace definition process (Difficulties start here : Xml knowledge is mandatory)
  • The MADCAT's element development process (For experts : Xml and .Net are needed)
Help documentation built with Sandcastle Help File Builder

Send comments on this topic to contact@themadcat.fr

(c)2012,2013 Eric Pageron


License Agreement

[image]

MADCAT Software Developer Guide
License Agreement
Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Microsoft Public License

This license governs use of the accompanying software. If you use the software, you accept this license. If you do not accept the license, do not use the software.

Definitions

  • The terms "reproduce," "reproduction," "derivative works," and "distribution" have the same meaning here as under U.S. copyright law.
  • A "contribution" is the original software, or any additions or changes to the software.
  • A "contributor" is any person that distributes its contribution under this license.
  • "Licensed patents" are a contributor's patent claims that read directly on its contribution.

Grant of Rights

  • (A) Copyright Grant - Subject to the terms of this license, including the license conditions and limitations in section 3, each contributor grants you a non-exclusive, worldwide, royalty-free copyright license to reproduce its contribution, prepare derivative works of its contribution, and distribute its contribution or any derivative works that you create.
  • (B) Patent Grant - Subject to the terms of this license, including the license conditions and limitations in section 3, each contributor grants you a non-exclusive, worldwide, royalty-free license under its licensed patents to make, have made, use, sell, offer for sale, import, and/or otherwise dispose of its contribution in the software or derivative works of the contribution in the software.

Conditions and Limitations

  • (A) No Trademark License - This license does not grant you rights to use any contributors' name, logo, or trademarks.
  • (B) If you bring a patent claim against any contributor over patents that you claim are infringed by the software, your patent license from such contributor to the software ends automatically.
  • (C) If you distribute any portion of the software, you must retain all copyright, patent, trademark, and attribution notices that are present in the software.
  • (D) If you distribute any portion of the software in source code form, you may do so only under this license by including a complete copy of this license with your distribution. If you distribute any portion of the software in compiled or object code form, you may only do so under a license that complies with this license.
  • (E) The software is licensed "as-is." You bear the risk of using it. The contributors give no express warranties, guarantees or conditions. You may have additional consumer rights under your local laws which this license cannot change. To the extent permitted under your local laws, the contributors exclude the implied warranties of merchantability, fitness for a particular purpose and non-infringement.

Third Parties

The MADCAT contains elements made with the following existing components :

  • Crom.Controls.Docking : Developed by Cristinel Mazarine. See the web site :

    Crom.Controls
  • Nullsoft Scriptable Install System
  • Sandcastle Help File Builder


Full API Reference

[image]

MADCAT Software Developer Guide
Full API Reference
Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

This section contains the complete API reference of MADCAT. You will find descriptions, examples and notes for all the public classes and interfaces exposed by MADCAT for developers. Only for .Net developers !


LogManager Namespace

[image]

MADCAT Software Developer Guide
LogManager Namespace
Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Logbook management services. Contains all the classes/interfaces used to generate and capture messages in MADCAT.

Classes

Class Description
Public class AnsweringMachine
Manage the automatic answers to any MADCAT's dialog box (confirmation or query) : It memorizes the last user's answer to any logbook messages and is able to reply automatically to the same message the next time it will be generated. It is used to avoid user interactions during long task executions.
Public class Confirmation
Confirmation message
Public class ErrorMessage
Error message
Public class InfoMessage
Information message
Public class LogBook
Logbooks store messages. They are used to capture messages corresponding to some criterias. They can save them to disk or just display them in the MADCAT logbook browser.
Public class LogBookBrowser
Form which can display and manage logbooks and their messages. Contains controls the user can use to create/edit/delete logbooks.
Public class LogBookDialog
Dialog box used to create/edit logbook properties. The user uses this dialog box to define the following properties :
  • The name
  • The captured levels of criticity
  • The filters (logger and actions)
  • The Direct-To-Disk feature
Public class LogbookWriter
Used to generate message. This is the main class to use to generate any kind of messages.
Public class LogMessage
Logbook message
Public class MessageDisplay
This form displays all the informations of a given logbook message.
Public class QueryBox
Form used to display confirmation or query messages (the messages which need a user input)
Public class Question
Query message
Public class WarningMessage
Warning message

Interfaces

 | Interface | Description
Public interface | ILogBookEnvironment | Interface to use when you want to implement a control which displays logbooks and their messages. It must be exposed by the control in order to let the logbook capture thread controlling it.
Public interface | ILogbookWriter | Interface used to generate messages and the automatic answering system.

Delegates

 | Delegate | Description
Public delegate | ILogBookEnvironment..::..AddItemToList | Method used by the logbook to add new message in the control.
Public delegate | ILogBookEnvironment..::..ResetList | Method used by the logbook to clear the content of the control.
Public delegate | ILogBookEnvironment..::..UpdateList | Method used by the logbook to update the content of the control.

Enumerations

 | Enumeration | Description
Public enumeration | ErrorLevel | Criticity of the message
Public enumeration | FileFormat | File format used to save logbook messages to disk.


AnsweringMachine Class

[image]

MADCAT Software Developer Guide
AnsweringMachine Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Manage the automatic answers to any MADCAT's dialog box (confirmation or query) : It memorizes the last user's answer to any logbook messages and is able to reply automatically to the same message the next time it will be generated. It is used to avoid user interactions during long task executions.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
[SerializableAttribute]
public class AnsweringMachine
Visual Basic
<SerializableAttribute> _
Public Class AnsweringMachine
Visual C++
[SerializableAttribute]
public ref class AnsweringMachine

Inheritance Hierarchy

System..::..Object
LogManager..::..AnsweringMachine

See Also

AnsweringMachine Members
LogManager Namespace


AnsweringMachine Members

[image] [image]

MADCAT Software Developer Guide
AnsweringMachine Members
AnsweringMachine Class Constructors Methods See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The AnsweringMachine type exposes the following members.

Constructors

 | Name | Description
Public method | AnsweringMachine | Constructor

Methods

 | Name | Description
Public method | AddAnswer | Saves a new logbook message in the answering machine. The message shall have the answer correctly recorded in the Answer property.
Public method | Answer | Gets the answer to one given logbook message.
Public method | GetAnswers | Gets all the memorized answers of the answering machine.

See Also

AnsweringMachine Class
LogManager Namespace


AnsweringMachine Constructor

[image]

MADCAT Software Developer Guide
AnsweringMachine Constructor
AnsweringMachine Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public AnsweringMachine()
Visual Basic
Public Sub New
Visual C++
public:
AnsweringMachine()

See Also

AnsweringMachine Class
AnsweringMachine Members
LogManager Namespace


AnsweringMachine Methods

[image] [image]

MADCAT Software Developer Guide
AnsweringMachine Methods
AnsweringMachine Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The AnsweringMachine type exposes the following members.

Methods

 | Name | Description
Public method | AddAnswer | Saves a new logbook message in the answering machine. The message shall have the answer correctly recorded in the Answer property.
Public method | Answer | Gets the answer to one given logbook message.
Public method | GetAnswers | Gets all the memorized answers of the answering machine.

See Also

AnsweringMachine Class
LogManager Namespace


AddAnswer Method

[image]

MADCAT Software Developer Guide
AnsweringMachine..::..AddAnswer Method
AnsweringMachine Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Saves a new logbook message in the answering machine. The message shall have the answer correctly recorded in the Answer property.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public void AddAnswer(
    LogMessage m
)
Visual Basic
Public Sub AddAnswer ( _
    m As LogMessage _
)
Visual C++
public:
void AddAnswer(
    LogMessage^ m
)

Parameters

m
Type: LogManager..::..LogMessage
New message to add

See Also

AnsweringMachine Class
AnsweringMachine Members
LogManager Namespace


Answer Method

[image]

MADCAT Software Developer Guide
AnsweringMachine..::..Answer Method
AnsweringMachine Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the answer to one given logbook message.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public string Answer(
    LogMessage m
)
Visual Basic
Public Function Answer ( _
    m As LogMessage _
) As String
Visual C++
public:
String^ Answer(
    LogMessage^ m
)

Parameters

m
Type: LogManager..::..LogMessage
The logbook message which requests a user's reply.

Return Value

The last reply given by the user to this message. Null if no answers is present for the given message.

See Also

AnsweringMachine Class
AnsweringMachine Members
LogManager Namespace


GetAnswers Method

[image]

MADCAT Software Developer Guide
AnsweringMachine..::..GetAnswers Method
AnsweringMachine Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets all the memorized answers of the answering machine.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public ArrayList GetAnswers()
Visual Basic
Public Function GetAnswers As ArrayList
Visual C++
public:
ArrayList^ GetAnswers()

Return Value

An array of LogMessage objects

See Also

AnsweringMachine Class
AnsweringMachine Members
LogManager Namespace


Confirmation Class

[image]

MADCAT Software Developer Guide
Confirmation Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Confirmation message

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public class Confirmation : LogMessage
Visual Basic
Public Class Confirmation _
    Inherits LogMessage
Visual C++
public ref class Confirmation : public LogMessage

Inheritance Hierarchy

System..::..Object
LogManager..::..LogMessage
LogManager..::..Confirmation

See Also

Confirmation Members
LogManager Namespace


Confirmation Members

[image] [image]

MADCAT Software Developer Guide
Confirmation Members
Confirmation Class Constructors Methods Fields See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The Confirmation type exposes the following members.

Constructors

 | Name | Description
Public method | Confirmation(String) | Creates a confirmation message with a text.
Public method | Confirmation(String, String) | Creates a confirmation message with a text and a help.

Methods

 | Name | Description
Public method | ErrorLevel | Gets the criticity in a string (Inherited from LogMessage.)

Fields

 | Name | Description
Public field | ActionName | Name of the action which has generated the message (Inherited from LogMessage.)
Public field | Answer | Value entered by the user to answer a query or acknowledge a confirmation (Inherited from LogMessage.)
Public field | BackColor | Background color to use to display the message in a list view. (Inherited from LogMessage.)
Public field | CaptureDate | Date and time of capture (Inherited from LogMessage.)
Public field | ConsoleOutput | Dump of the console when the message is generated because of an external program action. (Inherited from LogMessage.)
Public field | Displayed | Indicates if the message has been displayed on screen when generated. If true, the user has seen the message and has acknowledged it.. (Inherited from LogMessage.)
Public field | ForeColor | Text color to use to display the message in a list view. (Inherited from LogMessage.)
Public field | Help | Help in relation to the message. Some infos which may help the user to understand the message. (Inherited from LogMessage.)
Public field | ItemID | ID of the Xml Item concerned by the message (Inherited from LogMessage.)
Public field | Level | Criticity of the message (Inherited from LogMessage.)
Public field | LoggedBy | Name of the tool which has generated the message (Inherited from LogMessage.)
Public field | Parameter | Parameter to use to get the user's answer. Used only for query messages. (Inherited from LogMessage.)
Public field | Text | Body of the message (Inherited from LogMessage.)

See Also

Confirmation Class
LogManager Namespace


Confirmation Constructor

[image] [image]

MADCAT Software Developer Guide
Confirmation Constructor
Confirmation Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | Confirmation(String) | Creates a confirmation message with a text.
Public method | Confirmation(String, String) | Creates a confirmation message with a text and a help.

See Also

Confirmation Class
Confirmation Members
LogManager Namespace


Confirmation Constructor (String)

[image]

MADCAT Software Developer Guide
Confirmation Constructor (String)
Confirmation Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Creates a confirmation message with a text.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public Confirmation(
    string Text
)
Visual Basic
Public Sub New ( _
    Text As String _
)
Visual C++
public:
Confirmation(
    String^ Text
)

Parameters

Text
Type: System..::..String
Message to confirm.

See Also

Confirmation Class
Confirmation Members
Confirmation Overload
LogManager Namespace


Confirmation Constructor (String, String)

[image]

MADCAT Software Developer Guide
Confirmation Constructor (String, String)
Confirmation Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Creates a confirmation message with a text and a help.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public Confirmation(
    string Text,
    string Help
)
Visual Basic
Public Sub New ( _
    Text As String, _
    Help As String _
)
Visual C++
public:
Confirmation(
    String^ Text,
    String^ Help
)

Parameters

Text
Type: System..::..String
Message to confirm.
Help
Type: System..::..String
Help message

See Also

Confirmation Class
Confirmation Members
Confirmation Overload
LogManager Namespace


Confirmation Fields

[image] [image]

MADCAT Software Developer Guide
Confirmation Fields
Confirmation Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The Confirmation type exposes the following members.

Fields

 | Name | Description
Public field | ActionName | Name of the action which has generated the message (Inherited from LogMessage.)
Public field | Answer | Value entered by the user to answer a query or acknowledge a confirmation (Inherited from LogMessage.)
Public field | BackColor | Background color to use to display the message in a list view. (Inherited from LogMessage.)
Public field | CaptureDate | Date and time of capture (Inherited from LogMessage.)
Public field | ConsoleOutput | Dump of the console when the message is generated because of an external program action. (Inherited from LogMessage.)
Public field | Displayed | Indicates if the message has been displayed on screen when generated. If true, the user has seen the message and has acknowledged it.. (Inherited from LogMessage.)
Public field | ForeColor | Text color to use to display the message in a list view. (Inherited from LogMessage.)
Public field | Help | Help in relation to the message. Some infos which may help the user to understand the message. (Inherited from LogMessage.)
Public field | ItemID | ID of the Xml Item concerned by the message (Inherited from LogMessage.)
Public field | Level | Criticity of the message (Inherited from LogMessage.)
Public field | LoggedBy | Name of the tool which has generated the message (Inherited from LogMessage.)
Public field | Parameter | Parameter to use to get the user's answer. Used only for query messages. (Inherited from LogMessage.)
Public field | Text | Body of the message (Inherited from LogMessage.)

See Also

Confirmation Class
LogManager Namespace


Confirmation Methods

[image] [image]

MADCAT Software Developer Guide
Confirmation Methods
Confirmation Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The Confirmation type exposes the following members.

Methods

 | Name | Description
Public method | ErrorLevel | Gets the criticity in a string (Inherited from LogMessage.)

See Also

Confirmation Class
LogManager Namespace


ErrorLevel Enumeration

[image]

MADCAT Software Developer Guide
ErrorLevel Enumeration
See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Criticity of the message

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public enum ErrorLevel
Visual Basic
Public Enumeration ErrorLevel
Visual C++
public enum class ErrorLevel

Members

Member name | Value | Description
Confirmation | 16 | Message generated to ask the user to acknowledge something.
Question | 8 | Message generated to ask something to the user.
Info | 4 | Message generated to give informations to the user.
Warning | 2 | Message generated to warn the user about something.
Error | 1 | Message generated because an error has been detected.

See Also

LogManager Namespace


ErrorMessage Class

[image]

MADCAT Software Developer Guide
ErrorMessage Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Error message

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public class ErrorMessage : LogMessage
Visual Basic
Public Class ErrorMessage _
    Inherits LogMessage
Visual C++
public ref class ErrorMessage : public LogMessage

Inheritance Hierarchy

System..::..Object
LogManager..::..LogMessage
LogManager..::..ErrorMessage

See Also

ErrorMessage Members
LogManager Namespace


ErrorMessage Members

[image] [image]

MADCAT Software Developer Guide
ErrorMessage Members
ErrorMessage Class Constructors Methods Fields See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The ErrorMessage type exposes the following members.

Constructors

 | Name | Description
Public method | ErrorMessage(String) | Creates an error message with a body.
Public method | ErrorMessage(String, XmlNode) | Creates an error message with a body and an item.
Public method | ErrorMessage(String, XmlNode, String) | Creates an error message with a body, an item and a help.

Methods

 | Name | Description
Public method | ErrorLevel | Gets the criticity in a string (Inherited from LogMessage.)

Fields

 | Name | Description
Public field | ActionName | Name of the action which has generated the message (Inherited from LogMessage.)
Public field | Answer | Value entered by the user to answer a query or acknowledge a confirmation (Inherited from LogMessage.)
Public field | BackColor | Background color to use to display the message in a list view. (Inherited from LogMessage.)
Public field | CaptureDate | Date and time of capture (Inherited from LogMessage.)
Public field | ConsoleOutput | Dump of the console when the message is generated because of an external program action. (Inherited from LogMessage.)
Public field | Displayed | Indicates if the message has been displayed on screen when generated. If true, the user has seen the message and has acknowledged it.. (Inherited from LogMessage.)
Public field | ForeColor | Text color to use to display the message in a list view. (Inherited from LogMessage.)
Public field | Help | Help in relation to the message. Some infos which may help the user to understand the message. (Inherited from LogMessage.)
Public field | ItemID | ID of the Xml Item concerned by the message (Inherited from LogMessage.)
Public field | Level | Criticity of the message (Inherited from LogMessage.)
Public field | LoggedBy | Name of the tool which has generated the message (Inherited from LogMessage.)
Public field | Parameter | Parameter to use to get the user's answer. Used only for query messages. (Inherited from LogMessage.)
Public field | Text | Body of the message (Inherited from LogMessage.)

See Also

ErrorMessage Class
LogManager Namespace


ErrorMessage Constructor

[image] [image]

MADCAT Software Developer Guide
ErrorMessage Constructor
ErrorMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | ErrorMessage(String) | Creates an error message with a body.
Public method | ErrorMessage(String, XmlNode) | Creates an error message with a body and an item.
Public method | ErrorMessage(String, XmlNode, String) | Creates an error message with a body, an item and a help.

See Also

ErrorMessage Class
ErrorMessage Members
LogManager Namespace


ErrorMessage Constructor (String)

[image]

MADCAT Software Developer Guide
ErrorMessage Constructor (String)
ErrorMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Creates an error message with a body.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public ErrorMessage(
    string Text
)
Visual Basic
Public Sub New ( _
    Text As String _
)
Visual C++
public:
ErrorMessage(
    String^ Text
)

Parameters

Text
Type: System..::..String
Body of the message

See Also

ErrorMessage Class
ErrorMessage Members
ErrorMessage Overload
LogManager Namespace


ErrorMessage Constructor (String, XmlNode)

[image]

MADCAT Software Developer Guide
ErrorMessage Constructor (String, XmlNode)
ErrorMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Creates an error message with a body and an item.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public ErrorMessage(
    string Text,
    XmlNode Item
)
Visual Basic
Public Sub New ( _
    Text As String, _
    Item As XmlNode _
)
Visual C++
public:
ErrorMessage(
    String^ Text,
    XmlNode^ Item
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item concerned by the message. May be null.

See Also

ErrorMessage Class
ErrorMessage Members
ErrorMessage Overload
LogManager Namespace


ErrorMessage Constructor (String, XmlNode, String)

[image]

MADCAT Software Developer Guide
ErrorMessage Constructor (String, XmlNode, String)
ErrorMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Creates an error message with a body, an item and a help.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public ErrorMessage(
    string Text,
    XmlNode Item,
    string Help
)
Visual Basic
Public Sub New ( _
    Text As String, _
    Item As XmlNode, _
    Help As String _
)
Visual C++
public:
ErrorMessage(
    String^ Text,
    XmlNode^ Item,
    String^ Help
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item concerned by the message. May be null.
Help
Type: System..::..String
Help in relation with the message

See Also

ErrorMessage Class
ErrorMessage Members
ErrorMessage Overload
LogManager Namespace


ErrorMessage Fields

[image] [image]

MADCAT Software Developer Guide
ErrorMessage Fields
ErrorMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The ErrorMessage type exposes the following members.

Fields

 | Name | Description
Public field | ActionName | Name of the action which has generated the message (Inherited from LogMessage.)
Public field | Answer | Value entered by the user to answer a query or acknowledge a confirmation (Inherited from LogMessage.)
Public field | BackColor | Background color to use to display the message in a list view. (Inherited from LogMessage.)
Public field | CaptureDate | Date and time of capture (Inherited from LogMessage.)
Public field | ConsoleOutput | Dump of the console when the message is generated because of an external program action. (Inherited from LogMessage.)
Public field | Displayed | Indicates if the message has been displayed on screen when generated. If true, the user has seen the message and has acknowledged it.. (Inherited from LogMessage.)
Public field | ForeColor | Text color to use to display the message in a list view. (Inherited from LogMessage.)
Public field | Help | Help in relation to the message. Some infos which may help the user to understand the message. (Inherited from LogMessage.)
Public field | ItemID | ID of the Xml Item concerned by the message (Inherited from LogMessage.)
Public field | Level | Criticity of the message (Inherited from LogMessage.)
Public field | LoggedBy | Name of the tool which has generated the message (Inherited from LogMessage.)
Public field | Parameter | Parameter to use to get the user's answer. Used only for query messages. (Inherited from LogMessage.)
Public field | Text | Body of the message (Inherited from LogMessage.)

See Also

ErrorMessage Class
LogManager Namespace


ErrorMessage Methods

[image] [image]

MADCAT Software Developer Guide
ErrorMessage Methods
ErrorMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The ErrorMessage type exposes the following members.

Methods

 | Name | Description
Public method | ErrorLevel | Gets the criticity in a string (Inherited from LogMessage.)

See Also

ErrorMessage Class
LogManager Namespace


FileFormat Enumeration

[image]

MADCAT Software Developer Guide
FileFormat Enumeration
See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
File format used to save logbook messages to disk.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public enum FileFormat
Visual Basic
Public Enumeration FileFormat
Visual C++
public enum class FileFormat

Members

Member name | Value | Description
Xml | 0 | Messages are saved in a Xml file.
Text | 1 | Messages are saved in a Text file.

See Also

LogManager Namespace


ILogBookEnvironment Interface

[image]

MADCAT Software Developer Guide
ILogBookEnvironment Interface
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Interface to use when you want to implement a control which displays logbooks and their messages. It must be exposed by the control in order to let the logbook capture thread controlling it.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public interface ILogBookEnvironment
Visual Basic
Public Interface ILogBookEnvironment
Visual C++
public interface class ILogBookEnvironment

See Also

ILogBookEnvironment Members
LogManager Namespace


ILogBookEnvironment Members

[image] [image]

MADCAT Software Developer Guide
ILogBookEnvironment Members
ILogBookEnvironment Interface Methods See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The ILogBookEnvironment type exposes the following members.

Methods

 | Name | Description
Public method | DisplayLogbook | Method invoked to add a new logbook in the control.
Public method | GetActionListItems | Method used by the logbook properties window to get the list of all the actions which can generate messages.
Public method | GetLoggerListItems | Method used by the logbook properties window to get the list of all the tools which can generate messages.
Public method | IsLogbookPresent | Method used to check if the control is already displaying the content of a given logbook.

See Also

ILogBookEnvironment Interface
LogManager Namespace


ILogBookEnvironment Methods

[image] [image]

MADCAT Software Developer Guide
ILogBookEnvironment Methods
ILogBookEnvironment Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The ILogBookEnvironment type exposes the following members.

Methods

 | Name | Description
Public method | DisplayLogbook | Method invoked to add a new logbook in the control.
Public method | GetActionListItems | Method used by the logbook properties window to get the list of all the actions which can generate messages.
Public method | GetLoggerListItems | Method used by the logbook properties window to get the list of all the tools which can generate messages.
Public method | IsLogbookPresent | Method used to check if the control is already displaying the content of a given logbook.

See Also

ILogBookEnvironment Interface
LogManager Namespace


DisplayLogbook Method

[image]

MADCAT Software Developer Guide
ILogBookEnvironment..::..DisplayLogbook Method
ILogBookEnvironment Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Method invoked to add a new logbook in the control.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void DisplayLogbook(
    LogBook lgb
)
Visual Basic
Sub DisplayLogbook ( _
    lgb As LogBook _
)
Visual C++
void DisplayLogbook(
    LogBook^ lgb
)

Parameters

lgb
Type: LogManager..::..LogBook
Logbook to add.

See Also

ILogBookEnvironment Interface
ILogBookEnvironment Members
LogManager Namespace


GetActionListItems Method

[image]

MADCAT Software Developer Guide
ILogBookEnvironment..::..GetActionListItems Method
ILogBookEnvironment Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Method used by the logbook properties window to get the list of all the actions which can generate messages.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
ArrayList GetActionListItems()
Visual Basic
Function GetActionListItems As ArrayList
Visual C++
ArrayList^ GetActionListItems()

Return Value

Array of string objects. Each string has the full name of an action.

See Also

ILogBookEnvironment Interface
ILogBookEnvironment Members
LogManager Namespace


GetLoggerListItems Method

[image]

MADCAT Software Developer Guide
ILogBookEnvironment..::..GetLoggerListItems Method
ILogBookEnvironment Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Method used by the logbook properties window to get the list of all the tools which can generate messages.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
ArrayList GetLoggerListItems()
Visual Basic
Function GetLoggerListItems As ArrayList
Visual C++
ArrayList^ GetLoggerListItems()

Return Value

Array of string objects. Each string has the full name of a tool.

See Also

ILogBookEnvironment Interface
ILogBookEnvironment Members
LogManager Namespace


IsLogbookPresent Method

[image]

MADCAT Software Developer Guide
ILogBookEnvironment..::..IsLogbookPresent Method
ILogBookEnvironment Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Method used to check if the control is already displaying the content of a given logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
bool IsLogbookPresent(
    string name
)
Visual Basic
Function IsLogbookPresent ( _
    name As String _
) As Boolean
Visual C++
bool IsLogbookPresent(
    String^ name
)

Parameters

name
Type: System..::..String
Name of the logbook to look for.

Return Value

True if the control already has a logbook with the given name.

See Also

ILogBookEnvironment Interface
ILogBookEnvironment Members
LogManager Namespace


ILogBookEnvironment.AddItemToList Delegate

[image]

MADCAT Software Developer Guide
ILogBookEnvironment..::..AddItemToList Delegate
ILogBookEnvironment Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Method used by the logbook to add new message in the control.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public delegate void AddItemToList(
    LogMessage m
)
Visual Basic
Public Delegate Sub AddItemToList ( _
    m As LogMessage _
)
Visual C++
public delegate void AddItemToList(
    LogMessage^ m
)

Parameters

m
Type: LogManager..::..LogMessage
New incoming message to display

See Also

LogManager Namespace


ILogBookEnvironment.ResetList Delegate

[image]

MADCAT Software Developer Guide
ILogBookEnvironment..::..ResetList Delegate
ILogBookEnvironment Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Method used by the logbook to clear the content of the control.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public delegate void ResetList()
Visual Basic
Public Delegate Sub ResetList
Visual C++
public delegate void ResetList()

See Also

LogManager Namespace


ILogBookEnvironment.UpdateList Delegate

[image]

MADCAT Software Developer Guide
ILogBookEnvironment..::..UpdateList Delegate
ILogBookEnvironment Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Method used by the logbook to update the content of the control.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public delegate void UpdateList()
Visual Basic
Public Delegate Sub UpdateList
Visual C++
public delegate void UpdateList()

See Also

LogManager Namespace


ILogbookWriter Interface

[image]

MADCAT Software Developer Guide
ILogbookWriter Interface
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Interface used to generate messages and the automatic answering system.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public interface ILogbookWriter
Visual Basic
Public Interface ILogbookWriter
Visual C++
public interface class ILogbookWriter

See Also

ILogbookWriter Members
LogManager Namespace


ILogbookWriter Members

[image] [image]

MADCAT Software Developer Guide
ILogbookWriter Members
ILogbookWriter Interface Methods See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The ILogbookWriter type exposes the following members.

Methods

 | Name | Description
Public method | Confirm(String) | Requests the user's acknowledgment before performing something.
Public method | Confirm(String, String) | Requests the user's acknowledgment before performing something.
Public method | Query | Displays a query on screen.
Public method | SetQuietMode | Activates/Deactivates the automatic answering system.
Public method | ShowError(String) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowError(String, XmlNode) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowError(String, XmlNode, String) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowError(String, XmlNode, String, Color) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowError(String, XmlNode, String, Color, Color) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String, XmlNode) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String, XmlNode, String) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String, XmlNode, String, Color) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String, XmlNode, String, Color, Color) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String, XmlNode) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String, XmlNode, String) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String, XmlNode, String, Color) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String, XmlNode, String, Color, Color) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | StartAutoReply | Activates the answering machine. All the future queries will be replied automatically if the answer exists. Otherwise, the user will be able to record his answer.
Public method | StopAutoReply | Deactivates the answering machine. All the future queries won't be replied automatically. The user won't be asked to record his answers.
Public method | WriteError(String) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteError(String, XmlNode) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteError(String, XmlNode, String) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteError(String, XmlNode, String, Color) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteError(String, XmlNode, String, Color, Color) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String, XmlNode) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String, XmlNode, String) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String, XmlNode, String, Color) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String, XmlNode, String, Color, Color) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String) | Write a warning message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String, XmlNode) | Write a warning message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String, XmlNode, String) | Write a warning message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String, XmlNode, String, Color) | Write a warning message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String, XmlNode, String, Color, Color) | Write a warning message. The message is never displayed when generated but can be read in a logbook.

See Also

ILogbookWriter Interface
LogManager Namespace


ILogbookWriter Methods

[image] [image]

MADCAT Software Developer Guide
ILogbookWriter Methods
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The ILogbookWriter type exposes the following members.

Methods

 | Name | Description
Public method | Confirm(String) | Requests the user's acknowledgment before performing something.
Public method | Confirm(String, String) | Requests the user's acknowledgment before performing something.
Public method | Query | Displays a query on screen.
Public method | SetQuietMode | Activates/Deactivates the automatic answering system.
Public method | ShowError(String) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowError(String, XmlNode) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowError(String, XmlNode, String) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowError(String, XmlNode, String, Color) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowError(String, XmlNode, String, Color, Color) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String, XmlNode) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String, XmlNode, String) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String, XmlNode, String, Color) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String, XmlNode, String, Color, Color) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String, XmlNode) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String, XmlNode, String) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String, XmlNode, String, Color) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String, XmlNode, String, Color, Color) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | StartAutoReply | Activates the answering machine. All the future queries will be replied automatically if the answer exists. Otherwise, the user will be able to record his answer.
Public method | StopAutoReply | Deactivates the answering machine. All the future queries won't be replied automatically. The user won't be asked to record his answers.
Public method | WriteError(String) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteError(String, XmlNode) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteError(String, XmlNode, String) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteError(String, XmlNode, String, Color) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteError(String, XmlNode, String, Color, Color) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String, XmlNode) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String, XmlNode, String) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String, XmlNode, String, Color) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String, XmlNode, String, Color, Color) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String) | Write a warning message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String, XmlNode) | Write a warning message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String, XmlNode, String) | Write a warning message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String, XmlNode, String, Color) | Write a warning message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String, XmlNode, String, Color, Color) | Write a warning message. The message is never displayed when generated but can be read in a logbook.

See Also

ILogbookWriter Interface
LogManager Namespace


Confirm Method

[image] [image]

MADCAT Software Developer Guide
ILogbookWriter..::..Confirm Method
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | Confirm(String) | Requests the user's acknowledgment before performing something.
Public method | Confirm(String, String) | Requests the user's acknowledgment before performing something.

See Also

ILogbookWriter Interface
ILogbookWriter Members
LogManager Namespace


Confirm Method (String)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..Confirm Method (String)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Requests the user's acknowledgment before performing something.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
DialogResult Confirm(
    string Question
)
Visual Basic
Function Confirm ( _
    Question As String _
) As DialogResult
Visual C++
DialogResult Confirm(
    String^ Question
)

Parameters

Question
Type: System..::..String
Description of the thing which must be confirmed.

Return Value

Returns the code of the button pressed by the user : Yes, No or Cancel

See Also

ILogbookWriter Interface
ILogbookWriter Members
Confirm Overload
LogManager Namespace


Confirm Method (String, String)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..Confirm Method (String, String)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Requests the user's acknowledgment before performing something.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
DialogResult Confirm(
    string Question,
    string Help
)
Visual Basic
Function Confirm ( _
    Question As String, _
    Help As String _
) As DialogResult
Visual C++
DialogResult Confirm(
    String^ Question,
    String^ Help
)

Parameters

Question
Type: System..::..String
Description of the thing which must be confirmed.
Help
Type: System..::..String
Additional information to help the user take the good decision.

Return Value

Returns the code of the button pressed by the user : Yes, No or Cancel

See Also

ILogbookWriter Interface
ILogbookWriter Members
Confirm Overload
LogManager Namespace


Query Method

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..Query Method
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays a query on screen.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
DialogResult Query(
    string Question,
    IParameter Param
)
Visual Basic
Function Query ( _
    Question As String, _
    Param As IParameter _
) As DialogResult
Visual C++
DialogResult Query(
    String^ Question,
    IParameter^ Param
)

Parameters

Question
Type: System..::..String
Text of the question
Param
Type: Parameters..::..IParameter
Parameter used to get the user's reply.

Return Value

Returns the code of the button pressed by the user : OK or Cancel

See Also

ILogbookWriter Interface
ILogbookWriter Members
LogManager Namespace


SetQuietMode Method

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..SetQuietMode Method
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Activates/Deactivates the automatic answering system.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void SetQuietMode(
    bool active
)
Visual Basic
Sub SetQuietMode ( _
    active As Boolean _
)
Visual C++
void SetQuietMode(
    bool active
)

Parameters

active
Type: System..::..Boolean
If it is equal to true, the answering machine is activated. Otherwise, all messages which are shown are actually displayed on screen and must be acknowledged by the user.

See Also

ILogbookWriter Interface
ILogbookWriter Members
LogManager Namespace


ShowError Method

[image] [image]

MADCAT Software Developer Guide
ILogbookWriter..::..ShowError Method
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | ShowError(String) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowError(String, XmlNode) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowError(String, XmlNode, String) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowError(String, XmlNode, String, Color) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowError(String, XmlNode, String, Color, Color) | Displays an error message. The message is displayed when generated and can be read in a logbook.

See Also

ILogbookWriter Interface
ILogbookWriter Members
LogManager Namespace


ShowError Method (String)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..ShowError Method (String)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays an error message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void ShowError(
    string Text
)
Visual Basic
Sub ShowError ( _
    Text As String _
)
Visual C++
void ShowError(
    String^ Text
)

Parameters

Text
Type: System..::..String
Body of the message

See Also

ILogbookWriter Interface
ILogbookWriter Members
ShowError Overload
LogManager Namespace


ShowError Method (String, XmlNode)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..ShowError Method (String, XmlNode)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays an error message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void ShowError(
    string Text,
    XmlNode Item
)
Visual Basic
Sub ShowError ( _
    Text As String, _
    Item As XmlNode _
)
Visual C++
void ShowError(
    String^ Text,
    XmlNode^ Item
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.

See Also

ILogbookWriter Interface
ILogbookWriter Members
ShowError Overload
LogManager Namespace


ShowError Method (String, XmlNode, String)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..ShowError Method (String, XmlNode, String)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays an error message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void ShowError(
    string Text,
    XmlNode Item,
    string Help
)
Visual Basic
Sub ShowError ( _
    Text As String, _
    Item As XmlNode, _
    Help As String _
)
Visual C++
void ShowError(
    String^ Text,
    XmlNode^ Item,
    String^ Help
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.

See Also

ILogbookWriter Interface
ILogbookWriter Members
ShowError Overload
LogManager Namespace


ShowError Method (String, XmlNode, String, Color)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..ShowError Method (String, XmlNode, String, Color)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays an error message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void ShowError(
    string Text,
    XmlNode Item,
    string Help,
    Color fc
)
Visual Basic
Sub ShowError ( _
    Text As String, _
    Item As XmlNode, _
    Help As String, _
    fc As Color _
)
Visual C++
void ShowError(
    String^ Text,
    XmlNode^ Item,
    String^ Help,
    Color fc
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.
fc
Type: System.Drawing..::..Color
Color of the font to use to display the message in a list view.

See Also

ILogbookWriter Interface
ILogbookWriter Members
ShowError Overload
LogManager Namespace


ShowError Method (String, XmlNode, String, Color, Color)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..ShowError Method (String, XmlNode, String, Color, Color)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays an error message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void ShowError(
    string Text,
    XmlNode Item,
    string Help,
    Color fc,
    Color bc
)
Visual Basic
Sub ShowError ( _
    Text As String, _
    Item As XmlNode, _
    Help As String, _
    fc As Color, _
    bc As Color _
)
Visual C++
void ShowError(
    String^ Text,
    XmlNode^ Item,
    String^ Help,
    Color fc,
    Color bc
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.
fc
Type: System.Drawing..::..Color
Color of the font to use to display the message in a list view.
bc
Type: System.Drawing..::..Color
Color of the background to use to display the message in a list view

See Also

ILogbookWriter Interface
ILogbookWriter Members
ShowError Overload
LogManager Namespace


ShowInfo Method

[image] [image]

MADCAT Software Developer Guide
ILogbookWriter..::..ShowInfo Method
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | ShowInfo(String) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String, XmlNode) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String, XmlNode, String) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String, XmlNode, String, Color) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String, XmlNode, String, Color, Color) | Displays an information message. The message is displayed when generated and can be read in a logbook.

See Also

ILogbookWriter Interface
ILogbookWriter Members
LogManager Namespace


ShowInfo Method (String)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..ShowInfo Method (String)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays an information message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void ShowInfo(
    string Text
)
Visual Basic
Sub ShowInfo ( _
    Text As String _
)
Visual C++
void ShowInfo(
    String^ Text
)

Parameters

Text
Type: System..::..String
Body of the message

See Also

ILogbookWriter Interface
ILogbookWriter Members
ShowInfo Overload
LogManager Namespace


ShowInfo Method (String, XmlNode)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..ShowInfo Method (String, XmlNode)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays an information message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void ShowInfo(
    string Text,
    XmlNode Item
)
Visual Basic
Sub ShowInfo ( _
    Text As String, _
    Item As XmlNode _
)
Visual C++
void ShowInfo(
    String^ Text,
    XmlNode^ Item
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.

See Also

ILogbookWriter Interface
ILogbookWriter Members
ShowInfo Overload
LogManager Namespace


ShowInfo Method (String, XmlNode, String)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..ShowInfo Method (String, XmlNode, String)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays an information message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void ShowInfo(
    string Text,
    XmlNode Item,
    string Help
)
Visual Basic
Sub ShowInfo ( _
    Text As String, _
    Item As XmlNode, _
    Help As String _
)
Visual C++
void ShowInfo(
    String^ Text,
    XmlNode^ Item,
    String^ Help
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.

See Also

ILogbookWriter Interface
ILogbookWriter Members
ShowInfo Overload
LogManager Namespace


ShowInfo Method (String, XmlNode, String, Color)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..ShowInfo Method (String, XmlNode, String, Color)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays an information message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void ShowInfo(
    string Text,
    XmlNode Item,
    string Help,
    Color fc
)
Visual Basic
Sub ShowInfo ( _
    Text As String, _
    Item As XmlNode, _
    Help As String, _
    fc As Color _
)
Visual C++
void ShowInfo(
    String^ Text,
    XmlNode^ Item,
    String^ Help,
    Color fc
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.
fc
Type: System.Drawing..::..Color
Color of the font to use to display the message in a list view.

See Also

ILogbookWriter Interface
ILogbookWriter Members
ShowInfo Overload
LogManager Namespace


ShowInfo Method (String, XmlNode, String, Color, Color)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..ShowInfo Method (String, XmlNode, String, Color, Color)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays an information message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void ShowInfo(
    string Text,
    XmlNode Item,
    string Help,
    Color fc,
    Color bc
)
Visual Basic
Sub ShowInfo ( _
    Text As String, _
    Item As XmlNode, _
    Help As String, _
    fc As Color, _
    bc As Color _
)
Visual C++
void ShowInfo(
    String^ Text,
    XmlNode^ Item,
    String^ Help,
    Color fc,
    Color bc
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.
fc
Type: System.Drawing..::..Color
Color of the font to use to display the message in a list view.
bc
Type: System.Drawing..::..Color
Color of the background to use to display the message in a list view

See Also

ILogbookWriter Interface
ILogbookWriter Members
ShowInfo Overload
LogManager Namespace


ShowWarning Method

[image] [image]

MADCAT Software Developer Guide
ILogbookWriter..::..ShowWarning Method
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | ShowWarning(String) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String, XmlNode) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String, XmlNode, String) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String, XmlNode, String, Color) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String, XmlNode, String, Color, Color) | Displays a warning message. The message is displayed when generated and can be read in a logbook.

See Also

ILogbookWriter Interface
ILogbookWriter Members
LogManager Namespace


ShowWarning Method (String)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..ShowWarning Method (String)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays a warning message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void ShowWarning(
    string Text
)
Visual Basic
Sub ShowWarning ( _
    Text As String _
)
Visual C++
void ShowWarning(
    String^ Text
)

Parameters

Text
Type: System..::..String
Body of the message

See Also

ILogbookWriter Interface
ILogbookWriter Members
ShowWarning Overload
LogManager Namespace


ShowWarning Method (String, XmlNode)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..ShowWarning Method (String, XmlNode)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays a warning message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void ShowWarning(
    string Text,
    XmlNode Item
)
Visual Basic
Sub ShowWarning ( _
    Text As String, _
    Item As XmlNode _
)
Visual C++
void ShowWarning(
    String^ Text,
    XmlNode^ Item
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.

See Also

ILogbookWriter Interface
ILogbookWriter Members
ShowWarning Overload
LogManager Namespace


ShowWarning Method (String, XmlNode, String)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..ShowWarning Method (String, XmlNode, String)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays a warning message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void ShowWarning(
    string Text,
    XmlNode Item,
    string Help
)
Visual Basic
Sub ShowWarning ( _
    Text As String, _
    Item As XmlNode, _
    Help As String _
)
Visual C++
void ShowWarning(
    String^ Text,
    XmlNode^ Item,
    String^ Help
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.

See Also

ILogbookWriter Interface
ILogbookWriter Members
ShowWarning Overload
LogManager Namespace


ShowWarning Method (String, XmlNode, String, Color)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..ShowWarning Method (String, XmlNode, String, Color)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays a warning message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void ShowWarning(
    string Text,
    XmlNode Item,
    string Help,
    Color fc
)
Visual Basic
Sub ShowWarning ( _
    Text As String, _
    Item As XmlNode, _
    Help As String, _
    fc As Color _
)
Visual C++
void ShowWarning(
    String^ Text,
    XmlNode^ Item,
    String^ Help,
    Color fc
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.
fc
Type: System.Drawing..::..Color
Color of the font to use to display the message in a list view.

See Also

ILogbookWriter Interface
ILogbookWriter Members
ShowWarning Overload
LogManager Namespace


ShowWarning Method (String, XmlNode, String, Color, Color)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..ShowWarning Method (String, XmlNode, String, Color, Color)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays a warning message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void ShowWarning(
    string Text,
    XmlNode Item,
    string Help,
    Color fc,
    Color bc
)
Visual Basic
Sub ShowWarning ( _
    Text As String, _
    Item As XmlNode, _
    Help As String, _
    fc As Color, _
    bc As Color _
)
Visual C++
void ShowWarning(
    String^ Text,
    XmlNode^ Item,
    String^ Help,
    Color fc,
    Color bc
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.
fc
Type: System.Drawing..::..Color
Color of the font to use to display the message in a list view.
bc
Type: System.Drawing..::..Color
Color of the background to use to display the message in a list view

See Also

ILogbookWriter Interface
ILogbookWriter Members
ShowWarning Overload
LogManager Namespace


StartAutoReply Method

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..StartAutoReply Method
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Activates the answering machine. All the future queries will be replied automatically if the answer exists. Otherwise, the user will be able to record his answer.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void StartAutoReply()
Visual Basic
Sub StartAutoReply
Visual C++
void StartAutoReply()

See Also

ILogbookWriter Interface
ILogbookWriter Members
LogManager Namespace


StopAutoReply Method

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..StopAutoReply Method
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Deactivates the answering machine. All the future queries won't be replied automatically. The user won't be asked to record his answers.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void StopAutoReply()
Visual Basic
Sub StopAutoReply
Visual C++
void StopAutoReply()

See Also

ILogbookWriter Interface
ILogbookWriter Members
LogManager Namespace


WriteError Method

[image] [image]

MADCAT Software Developer Guide
ILogbookWriter..::..WriteError Method
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | WriteError(String) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteError(String, XmlNode) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteError(String, XmlNode, String) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteError(String, XmlNode, String, Color) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteError(String, XmlNode, String, Color, Color) | Write an error message. The message is never displayed when generated but can be read in a logbook.

See Also

ILogbookWriter Interface
ILogbookWriter Members
LogManager Namespace


WriteError Method (String)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..WriteError Method (String)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write an error message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void WriteError(
    string Text
)
Visual Basic
Sub WriteError ( _
    Text As String _
)
Visual C++
void WriteError(
    String^ Text
)

Parameters

Text
Type: System..::..String
Body of the message

See Also

ILogbookWriter Interface
ILogbookWriter Members
WriteError Overload
LogManager Namespace


WriteError Method (String, XmlNode)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..WriteError Method (String, XmlNode)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write an error message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void WriteError(
    string Text,
    XmlNode Item
)
Visual Basic
Sub WriteError ( _
    Text As String, _
    Item As XmlNode _
)
Visual C++
void WriteError(
    String^ Text,
    XmlNode^ Item
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.

See Also

ILogbookWriter Interface
ILogbookWriter Members
WriteError Overload
LogManager Namespace


WriteError Method (String, XmlNode, String)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..WriteError Method (String, XmlNode, String)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write an error message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void WriteError(
    string Text,
    XmlNode Item,
    string Help
)
Visual Basic
Sub WriteError ( _
    Text As String, _
    Item As XmlNode, _
    Help As String _
)
Visual C++
void WriteError(
    String^ Text,
    XmlNode^ Item,
    String^ Help
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.

See Also

ILogbookWriter Interface
ILogbookWriter Members
WriteError Overload
LogManager Namespace


WriteError Method (String, XmlNode, String, Color)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..WriteError Method (String, XmlNode, String, Color)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write an error message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void WriteError(
    string Text,
    XmlNode Item,
    string Help,
    Color fc
)
Visual Basic
Sub WriteError ( _
    Text As String, _
    Item As XmlNode, _
    Help As String, _
    fc As Color _
)
Visual C++
void WriteError(
    String^ Text,
    XmlNode^ Item,
    String^ Help,
    Color fc
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.
fc
Type: System.Drawing..::..Color
Color of the font to use to display the message in a list view.

See Also

ILogbookWriter Interface
ILogbookWriter Members
WriteError Overload
LogManager Namespace


WriteError Method (String, XmlNode, String, Color, Color)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..WriteError Method (String, XmlNode, String, Color, Color)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write an error message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void WriteError(
    string Text,
    XmlNode Item,
    string Help,
    Color fc,
    Color bc
)
Visual Basic
Sub WriteError ( _
    Text As String, _
    Item As XmlNode, _
    Help As String, _
    fc As Color, _
    bc As Color _
)
Visual C++
void WriteError(
    String^ Text,
    XmlNode^ Item,
    String^ Help,
    Color fc,
    Color bc
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.
fc
Type: System.Drawing..::..Color
Color of the font to use to display the message in a list view.
bc
Type: System.Drawing..::..Color
Color of the background to use to display the message in a list view

See Also

ILogbookWriter Interface
ILogbookWriter Members
WriteError Overload
LogManager Namespace


WriteInfo Method

[image] [image]

MADCAT Software Developer Guide
ILogbookWriter..::..WriteInfo Method
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | WriteInfo(String) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String, XmlNode) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String, XmlNode, String) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String, XmlNode, String, Color) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String, XmlNode, String, Color, Color) | Write an information message. The message is never displayed when generated but can be read in a logbook.

See Also

ILogbookWriter Interface
ILogbookWriter Members
LogManager Namespace


WriteInfo Method (String)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..WriteInfo Method (String)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write an information message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void WriteInfo(
    string Text
)
Visual Basic
Sub WriteInfo ( _
    Text As String _
)
Visual C++
void WriteInfo(
    String^ Text
)

Parameters

Text
Type: System..::..String
Body of the message

See Also

ILogbookWriter Interface
ILogbookWriter Members
WriteInfo Overload
LogManager Namespace


WriteInfo Method (String, XmlNode)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..WriteInfo Method (String, XmlNode)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write an information message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void WriteInfo(
    string Text,
    XmlNode Item
)
Visual Basic
Sub WriteInfo ( _
    Text As String, _
    Item As XmlNode _
)
Visual C++
void WriteInfo(
    String^ Text,
    XmlNode^ Item
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.

See Also

ILogbookWriter Interface
ILogbookWriter Members
WriteInfo Overload
LogManager Namespace


WriteInfo Method (String, XmlNode, String)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..WriteInfo Method (String, XmlNode, String)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write an information message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void WriteInfo(
    string Text,
    XmlNode Item,
    string Help
)
Visual Basic
Sub WriteInfo ( _
    Text As String, _
    Item As XmlNode, _
    Help As String _
)
Visual C++
void WriteInfo(
    String^ Text,
    XmlNode^ Item,
    String^ Help
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.

See Also

ILogbookWriter Interface
ILogbookWriter Members
WriteInfo Overload
LogManager Namespace


WriteInfo Method (String, XmlNode, String, Color)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..WriteInfo Method (String, XmlNode, String, Color)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write an information message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void WriteInfo(
    string Text,
    XmlNode Item,
    string Help,
    Color fc
)
Visual Basic
Sub WriteInfo ( _
    Text As String, _
    Item As XmlNode, _
    Help As String, _
    fc As Color _
)
Visual C++
void WriteInfo(
    String^ Text,
    XmlNode^ Item,
    String^ Help,
    Color fc
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.
fc
Type: System.Drawing..::..Color
Color of the font to use to display the message in a list view.

See Also

ILogbookWriter Interface
ILogbookWriter Members
WriteInfo Overload
LogManager Namespace


WriteInfo Method (String, XmlNode, String, Color, Color)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..WriteInfo Method (String, XmlNode, String, Color, Color)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write an information message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void WriteInfo(
    string Text,
    XmlNode Item,
    string Help,
    Color fc,
    Color bc
)
Visual Basic
Sub WriteInfo ( _
    Text As String, _
    Item As XmlNode, _
    Help As String, _
    fc As Color, _
    bc As Color _
)
Visual C++
void WriteInfo(
    String^ Text,
    XmlNode^ Item,
    String^ Help,
    Color fc,
    Color bc
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.
fc
Type: System.Drawing..::..Color
Color of the font to use to display the message in a list view.
bc
Type: System.Drawing..::..Color
Color of the background to use to display the message in a list view

See Also

ILogbookWriter Interface
ILogbookWriter Members
WriteInfo Overload
LogManager Namespace


WriteWarning Method

[image] [image]

MADCAT Software Developer Guide
ILogbookWriter..::..WriteWarning Method
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | WriteWarning(String) | Write a warning message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String, XmlNode) | Write a warning message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String, XmlNode, String) | Write a warning message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String, XmlNode, String, Color) | Write a warning message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String, XmlNode, String, Color, Color) | Write a warning message. The message is never displayed when generated but can be read in a logbook.

See Also

ILogbookWriter Interface
ILogbookWriter Members
LogManager Namespace


WriteWarning Method (String)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..WriteWarning Method (String)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write a warning message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void WriteWarning(
    string Text
)
Visual Basic
Sub WriteWarning ( _
    Text As String _
)
Visual C++
void WriteWarning(
    String^ Text
)

Parameters

Text
Type: System..::..String
Body of the message

See Also

ILogbookWriter Interface
ILogbookWriter Members
WriteWarning Overload
LogManager Namespace


WriteWarning Method (String, XmlNode)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..WriteWarning Method (String, XmlNode)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write a warning message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void WriteWarning(
    string Text,
    XmlNode Item
)
Visual Basic
Sub WriteWarning ( _
    Text As String, _
    Item As XmlNode _
)
Visual C++
void WriteWarning(
    String^ Text,
    XmlNode^ Item
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.

See Also

ILogbookWriter Interface
ILogbookWriter Members
WriteWarning Overload
LogManager Namespace


WriteWarning Method (String, XmlNode, String)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..WriteWarning Method (String, XmlNode, String)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write a warning message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void WriteWarning(
    string Text,
    XmlNode Item,
    string Help
)
Visual Basic
Sub WriteWarning ( _
    Text As String, _
    Item As XmlNode, _
    Help As String _
)
Visual C++
void WriteWarning(
    String^ Text,
    XmlNode^ Item,
    String^ Help
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.

See Also

ILogbookWriter Interface
ILogbookWriter Members
WriteWarning Overload
LogManager Namespace


WriteWarning Method (String, XmlNode, String, Color)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..WriteWarning Method (String, XmlNode, String, Color)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write a warning message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void WriteWarning(
    string Text,
    XmlNode Item,
    string Help,
    Color fc
)
Visual Basic
Sub WriteWarning ( _
    Text As String, _
    Item As XmlNode, _
    Help As String, _
    fc As Color _
)
Visual C++
void WriteWarning(
    String^ Text,
    XmlNode^ Item,
    String^ Help,
    Color fc
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.
fc
Type: System.Drawing..::..Color
Color of the font to use to display the message in a list view.

See Also

ILogbookWriter Interface
ILogbookWriter Members
WriteWarning Overload
LogManager Namespace


WriteWarning Method (String, XmlNode, String, Color, Color)

[image]

MADCAT Software Developer Guide
ILogbookWriter..::..WriteWarning Method (String, XmlNode, String, Color, Color)
ILogbookWriter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write a warning message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
void WriteWarning(
    string Text,
    XmlNode Item,
    string Help,
    Color fc,
    Color bc
)
Visual Basic
Sub WriteWarning ( _
    Text As String, _
    Item As XmlNode, _
    Help As String, _
    fc As Color, _
    bc As Color _
)
Visual C++
void WriteWarning(
    String^ Text,
    XmlNode^ Item,
    String^ Help,
    Color fc,
    Color bc
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.
fc
Type: System.Drawing..::..Color
Color of the font to use to display the message in a list view.
bc
Type: System.Drawing..::..Color
Color of the background to use to display the message in a list view

See Also

ILogbookWriter Interface
ILogbookWriter Members
WriteWarning Overload
LogManager Namespace


InfoMessage Class

[image]

MADCAT Software Developer Guide
InfoMessage Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Information message

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public class InfoMessage : LogMessage
Visual Basic
Public Class InfoMessage _
    Inherits LogMessage
Visual C++
public ref class InfoMessage : public LogMessage

Inheritance Hierarchy

System..::..Object
LogManager..::..LogMessage
LogManager..::..InfoMessage

See Also

InfoMessage Members
LogManager Namespace


InfoMessage Members

[image] [image]

MADCAT Software Developer Guide
InfoMessage Members
InfoMessage Class Constructors Methods Fields See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The InfoMessage type exposes the following members.

Constructors

 | Name | Description
Public method | InfoMessage(String) | Creates an information message with a body.
Public method | InfoMessage(String, XmlNode) | Creates an information message with a body and an item.
Public method | InfoMessage(String, XmlNode, String) | Creates an information message with a body, an item and a help.

Methods

 | Name | Description
Public method | ErrorLevel | Gets the criticity in a string (Inherited from LogMessage.)

Fields

 | Name | Description
Public field | ActionName | Name of the action which has generated the message (Inherited from LogMessage.)
Public field | Answer | Value entered by the user to answer a query or acknowledge a confirmation (Inherited from LogMessage.)
Public field | BackColor | Background color to use to display the message in a list view. (Inherited from LogMessage.)
Public field | CaptureDate | Date and time of capture (Inherited from LogMessage.)
Public field | ConsoleOutput | Dump of the console when the message is generated because of an external program action. (Inherited from LogMessage.)
Public field | Displayed | Indicates if the message has been displayed on screen when generated. If true, the user has seen the message and has acknowledged it.. (Inherited from LogMessage.)
Public field | ForeColor | Text color to use to display the message in a list view. (Inherited from LogMessage.)
Public field | Help | Help in relation to the message. Some infos which may help the user to understand the message. (Inherited from LogMessage.)
Public field | ItemID | ID of the Xml Item concerned by the message (Inherited from LogMessage.)
Public field | Level | Criticity of the message (Inherited from LogMessage.)
Public field | LoggedBy | Name of the tool which has generated the message (Inherited from LogMessage.)
Public field | Parameter | Parameter to use to get the user's answer. Used only for query messages. (Inherited from LogMessage.)
Public field | Text | Body of the message (Inherited from LogMessage.)

See Also

InfoMessage Class
LogManager Namespace


InfoMessage Constructor

[image] [image]

MADCAT Software Developer Guide
InfoMessage Constructor
InfoMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | InfoMessage(String) | Creates an information message with a body.
Public method | InfoMessage(String, XmlNode) | Creates an information message with a body and an item.
Public method | InfoMessage(String, XmlNode, String) | Creates an information message with a body, an item and a help.

See Also

InfoMessage Class
InfoMessage Members
LogManager Namespace


InfoMessage Constructor (String)

[image]

MADCAT Software Developer Guide
InfoMessage Constructor (String)
InfoMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Creates an information message with a body.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public InfoMessage(
    string Text
)
Visual Basic
Public Sub New ( _
    Text As String _
)
Visual C++
public:
InfoMessage(
    String^ Text
)

Parameters

Text
Type: System..::..String
Body of the message

See Also

InfoMessage Class
InfoMessage Members
InfoMessage Overload
LogManager Namespace


InfoMessage Constructor (String, XmlNode)

[image]

MADCAT Software Developer Guide
InfoMessage Constructor (String, XmlNode)
InfoMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Creates an information message with a body and an item.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public InfoMessage(
    string Text,
    XmlNode Item
)
Visual Basic
Public Sub New ( _
    Text As String, _
    Item As XmlNode _
)
Visual C++
public:
InfoMessage(
    String^ Text,
    XmlNode^ Item
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item concerned by the message. May be null.

See Also

InfoMessage Class
InfoMessage Members
InfoMessage Overload
LogManager Namespace


InfoMessage Constructor (String, XmlNode, String)

[image]

MADCAT Software Developer Guide
InfoMessage Constructor (String, XmlNode, String)
InfoMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Creates an information message with a body, an item and a help.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public InfoMessage(
    string Text,
    XmlNode Item,
    string Help
)
Visual Basic
Public Sub New ( _
    Text As String, _
    Item As XmlNode, _
    Help As String _
)
Visual C++
public:
InfoMessage(
    String^ Text,
    XmlNode^ Item,
    String^ Help
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item concerned by the message. May be null.
Help
Type: System..::..String
Help in relation with the message

See Also

InfoMessage Class
InfoMessage Members
InfoMessage Overload
LogManager Namespace


InfoMessage Fields

[image] [image]

MADCAT Software Developer Guide
InfoMessage Fields
InfoMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The InfoMessage type exposes the following members.

Fields

 | Name | Description
Public field | ActionName | Name of the action which has generated the message (Inherited from LogMessage.)
Public field | Answer | Value entered by the user to answer a query or acknowledge a confirmation (Inherited from LogMessage.)
Public field | BackColor | Background color to use to display the message in a list view. (Inherited from LogMessage.)
Public field | CaptureDate | Date and time of capture (Inherited from LogMessage.)
Public field | ConsoleOutput | Dump of the console when the message is generated because of an external program action. (Inherited from LogMessage.)
Public field | Displayed | Indicates if the message has been displayed on screen when generated. If true, the user has seen the message and has acknowledged it.. (Inherited from LogMessage.)
Public field | ForeColor | Text color to use to display the message in a list view. (Inherited from LogMessage.)
Public field | Help | Help in relation to the message. Some infos which may help the user to understand the message. (Inherited from LogMessage.)
Public field | ItemID | ID of the Xml Item concerned by the message (Inherited from LogMessage.)
Public field | Level | Criticity of the message (Inherited from LogMessage.)
Public field | LoggedBy | Name of the tool which has generated the message (Inherited from LogMessage.)
Public field | Parameter | Parameter to use to get the user's answer. Used only for query messages. (Inherited from LogMessage.)
Public field | Text | Body of the message (Inherited from LogMessage.)

See Also

InfoMessage Class
LogManager Namespace


InfoMessage Methods

[image] [image]

MADCAT Software Developer Guide
InfoMessage Methods
InfoMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The InfoMessage type exposes the following members.

Methods

 | Name | Description
Public method | ErrorLevel | Gets the criticity in a string (Inherited from LogMessage.)

See Also

InfoMessage Class
LogManager Namespace


LogBook Class

[image]

MADCAT Software Developer Guide
LogBook Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Logbooks store messages. They are used to capture messages corresponding to some criterias. They can save them to disk or just display them in the MADCAT logbook browser.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
[SerializableAttribute]
public class LogBook : IDisposable
Visual Basic
<SerializableAttribute> _
Public Class LogBook _
    Implements IDisposable
Visual C++
[SerializableAttribute]
public ref class LogBook : IDisposable

Inheritance Hierarchy

System..::..Object
LogManager..::..LogBook

See Also

LogBook Members
LogManager Namespace


LogBook Members

[image] [image]

MADCAT Software Developer Guide
LogBook Members
LogBook Class Constructors Methods Fields See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The LogBook type exposes the following members.

Constructors

 | Name | Description
Public method | LogBook | Constructor

Methods

 | Name | Description
Public method | Activate | Activate the capture process.
 | Add(LogMessage) | Post a message which has already been instanciated.
 | Add(ErrorLevel, String) | Post a new message from scratch.
 | Add(ErrorLevel, String, XmlNode) | Post a new message from scratch.
 | Add(ErrorLevel, String, XmlNode, String) | Post a new message from scratch.
Public method | AttachToFile | Activates the Direct-To-Disk feature.
Public method | AttachToListView | Connects the logbook to a list view. The list view will be configured and filled by the logbook to display the captured messages.
Public method | Deactivate | Stop the capture process.
Public method | DetachFromFile | Stops the Direct-To-Disk feature.
Public method | Dispose | Destructor
 | FormatMessageForDisk | Converts a logbook message to text.
 | FormatMessageForXml | Converts a logbook message to Xml.
Public method | GetAllMessages()()()() | Captures all the messages generated since the last capture.
Public method | GetAllMessages(Int32) | Captures all the messages generated since the given index.
Public method | GetDescription | Returns a description of the logbook. The description is a resume of the logbook capture criterias.
Public method | GetMessage | Gets a message from the logbook
Public method | GetSize | Gets the size of the logbook.
Public method | ReleaseFromListView | Disconnects the list view from the logbook. Future captured messages won't be displayed.
Public method | Reset | Empties the logbook.
Public method | SaveToDisk | Saves all the messages captured by the logbook into a file.

Fields

 | Name | Description
Public field | ActionName | If not null, only the messages produced by the action given by this parameter will be captured.
Public field | DirectToDisk | When true, activates the writing of captured messages in the log file given by LogFile at the time of capture.
Public field | Levels | Criticity levels which are captured by the logbook. Criticity values can be added if you want to capture messages with different criticity levels. Example : If Levels=3 (Error=1, Warning=2), it will capture only errors and warnings.
Public field | LogFile | Path of the log file. Used only if DirectToDisk is set to true.
Public field | LogFileFormat | Format of the log file.
Public field | Logger | If not null, only the messages produced by the tool given by this parameter will be captured.
Public field | MaxFileSize | If greater than zero, limits the size of the log file. Used only if DirectToDisk is set to true. When file size reaches the limit, old messages are discarded and a new log file is created.
Public field | Name | Name of the logbook

See Also

LogBook Class
LogManager Namespace


LogBook Constructor

[image]

MADCAT Software Developer Guide
LogBook Constructor
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public LogBook()
Visual Basic
Public Sub New
Visual C++
public:
LogBook()

See Also

LogBook Class
LogBook Members
LogManager Namespace


LogBook Fields

[image] [image]

MADCAT Software Developer Guide
LogBook Fields
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The LogBook type exposes the following members.

Fields

 | Name | Description
Public field | ActionName | If not null, only the messages produced by the action given by this parameter will be captured.
Public field | DirectToDisk | When true, activates the writing of captured messages in the log file given by LogFile at the time of capture.
Public field | Levels | Criticity levels which are captured by the logbook. Criticity values can be added if you want to capture messages with different criticity levels. Example : If Levels=3 (Error=1, Warning=2), it will capture only errors and warnings.
Public field | LogFile | Path of the log file. Used only if DirectToDisk is set to true.
Public field | LogFileFormat | Format of the log file.
Public field | Logger | If not null, only the messages produced by the tool given by this parameter will be captured.
Public field | MaxFileSize | If greater than zero, limits the size of the log file. Used only if DirectToDisk is set to true. When file size reaches the limit, old messages are discarded and a new log file is created.
Public field | Name | Name of the logbook

See Also

LogBook Class
LogManager Namespace


ActionName Field

[image]

MADCAT Software Developer Guide
LogBook..::..ActionName Field
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
If not null, only the messages produced by the action given by this parameter will be captured.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public string ActionName
Visual Basic
Public ActionName As String
Visual C++
public:
String^ ActionName

See Also

LogBook Class
LogBook Members
LogManager Namespace


DirectToDisk Field

[image]

MADCAT Software Developer Guide
LogBook..::..DirectToDisk Field
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
When true, activates the writing of captured messages in the log file given by LogFile at the time of capture.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public bool DirectToDisk
Visual Basic
Public DirectToDisk As Boolean
Visual C++
public:
bool DirectToDisk

See Also

LogBook Class
LogBook Members
LogManager Namespace


Levels Field

[image]

MADCAT Software Developer Guide
LogBook..::..Levels Field
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Criticity levels which are captured by the logbook. Criticity values can be added if you want to capture messages with different criticity levels. Example : If Levels=3 (Error=1, Warning=2), it will capture only errors and warnings.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public int Levels
Visual Basic
Public Levels As Integer
Visual C++
public:
int Levels

See Also

LogBook Class
LogBook Members
LogManager Namespace


LogFile Field

[image]

MADCAT Software Developer Guide
LogBook..::..LogFile Field
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Path of the log file. Used only if DirectToDisk is set to true.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public string LogFile
Visual Basic
Public LogFile As String
Visual C++
public:
String^ LogFile

See Also

LogBook Class
LogBook Members
LogManager Namespace


LogFileFormat Field

[image]

MADCAT Software Developer Guide
LogBook..::..LogFileFormat Field
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Format of the log file.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public FileFormat LogFileFormat
Visual Basic
Public LogFileFormat As FileFormat
Visual C++
public:
FileFormat LogFileFormat

See Also

LogBook Class
LogBook Members
LogManager Namespace


Logger Field

[image]

MADCAT Software Developer Guide
LogBook..::..Logger Field
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
If not null, only the messages produced by the tool given by this parameter will be captured.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public string Logger
Visual Basic
Public Logger As String
Visual C++
public:
String^ Logger

See Also

LogBook Class
LogBook Members
LogManager Namespace


MaxFileSize Field

[image]

MADCAT Software Developer Guide
LogBook..::..MaxFileSize Field
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
If greater than zero, limits the size of the log file. Used only if DirectToDisk is set to true. When file size reaches the limit, old messages are discarded and a new log file is created.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public int MaxFileSize
Visual Basic
Public MaxFileSize As Integer
Visual C++
public:
int MaxFileSize

See Also

LogBook Class
LogBook Members
LogManager Namespace


Name Field

[image]

MADCAT Software Developer Guide
LogBook..::..Name Field
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Name of the logbook

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public string Name
Visual Basic
Public Name As String
Visual C++
public:
String^ Name

See Also

LogBook Class
LogBook Members
LogManager Namespace


LogBook Methods

[image] [image]

MADCAT Software Developer Guide
LogBook Methods
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The LogBook type exposes the following members.

Methods

 | Name | Description
Public method | Activate | Activate the capture process.
 | Add(LogMessage) | Post a message which has already been instanciated.
 | Add(ErrorLevel, String) | Post a new message from scratch.
 | Add(ErrorLevel, String, XmlNode) | Post a new message from scratch.
 | Add(ErrorLevel, String, XmlNode, String) | Post a new message from scratch.
Public method | AttachToFile | Activates the Direct-To-Disk feature.
Public method | AttachToListView | Connects the logbook to a list view. The list view will be configured and filled by the logbook to display the captured messages.
Public method | Deactivate | Stop the capture process.
Public method | DetachFromFile | Stops the Direct-To-Disk feature.
Public method | Dispose | Destructor
 | FormatMessageForDisk | Converts a logbook message to text.
 | FormatMessageForXml | Converts a logbook message to Xml.
Public method | GetAllMessages()()()() | Captures all the messages generated since the last capture.
Public method | GetAllMessages(Int32) | Captures all the messages generated since the given index.
Public method | GetDescription | Returns a description of the logbook. The description is a resume of the logbook capture criterias.
Public method | GetMessage | Gets a message from the logbook
Public method | GetSize | Gets the size of the logbook.
Public method | ReleaseFromListView | Disconnects the list view from the logbook. Future captured messages won't be displayed.
Public method | Reset | Empties the logbook.
Public method | SaveToDisk | Saves all the messages captured by the logbook into a file.

See Also

LogBook Class
LogManager Namespace


Activate Method

[image]

MADCAT Software Developer Guide
LogBook..::..Activate Method
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Activate the capture process.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public void Activate()
Visual Basic
Public Sub Activate
Visual C++
public:
void Activate()

See Also

LogBook Class
LogBook Members
LogManager Namespace


Add Method

[image] [image]

MADCAT Software Developer Guide
LogBook..::..Add Method
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

Name | Description
Add(LogMessage) | Post a message which has already been instanciated.
Add(ErrorLevel, String) | Post a new message from scratch.
Add(ErrorLevel, String, XmlNode) | Post a new message from scratch.
Add(ErrorLevel, String, XmlNode, String) | Post a new message from scratch.

See Also

LogBook Class
LogBook Members
LogManager Namespace


Add Method (LogMessage)

[image]

MADCAT Software Developer Guide
LogBook..::..Add Method (LogMessage)
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Post a message which has already been instanciated.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public static void Add(
    LogMessage m
)
Visual Basic
Public Shared Sub Add ( _
    m As LogMessage _
)
Visual C++
public:
static void Add(
    LogMessage^ m
)

Parameters

m
Type: LogManager..::..LogMessage
Message to post.

See Also

LogBook Class
LogBook Members
Add Overload
LogManager Namespace


Add Method (ErrorLevel, String)

[image]

MADCAT Software Developer Guide
LogBook..::..Add Method (ErrorLevel, String)
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Post a new message from scratch.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public static void Add(
    ErrorLevel l,
    string Text
)
Visual Basic
Public Shared Sub Add ( _
    l As ErrorLevel, _
    Text As String _
)
Visual C++
public:
static void Add(
    ErrorLevel l,
    String^ Text
)

Parameters

l
Type: LogManager..::..ErrorLevel
Criticity of the message
Text
Type: System..::..String
Body of the message

See Also

LogBook Class
LogBook Members
Add Overload
LogManager Namespace


Add Method (ErrorLevel, String, XmlNode)

[image]

MADCAT Software Developer Guide
LogBook..::..Add Method (ErrorLevel, String, XmlNode)
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Post a new message from scratch.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public static void Add(
    ErrorLevel l,
    string Text,
    XmlNode Item
)
Visual Basic
Public Shared Sub Add ( _
    l As ErrorLevel, _
    Text As String, _
    Item As XmlNode _
)
Visual C++
public:
static void Add(
    ErrorLevel l,
    String^ Text,
    XmlNode^ Item
)

Parameters

l
Type: LogManager..::..ErrorLevel
Criticity of the message
Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item concerned by the message. May be null.

See Also

LogBook Class
LogBook Members
Add Overload
LogManager Namespace


Add Method (ErrorLevel, String, XmlNode, String)

[image]

MADCAT Software Developer Guide
LogBook..::..Add Method (ErrorLevel, String, XmlNode, String)
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Post a new message from scratch.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public static void Add(
    ErrorLevel l,
    string Text,
    XmlNode Item,
    string Help
)
Visual Basic
Public Shared Sub Add ( _
    l As ErrorLevel, _
    Text As String, _
    Item As XmlNode, _
    Help As String _
)
Visual C++
public:
static void Add(
    ErrorLevel l,
    String^ Text,
    XmlNode^ Item,
    String^ Help
)

Parameters

l
Type: LogManager..::..ErrorLevel
Criticity of the message
Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item concerned by the message. May be null.
Help
Type: System..::..String
Additional information about the message.

See Also

LogBook Class
LogBook Members
Add Overload
LogManager Namespace


AttachToFile Method

[image]

MADCAT Software Developer Guide
LogBook..::..AttachToFile Method
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Activates the Direct-To-Disk feature.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public void AttachToFile(
    string fileName
)
Visual Basic
Public Sub AttachToFile ( _
    fileName As String _
)
Visual C++
public:
void AttachToFile(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
Path of the file where the future captured messages will be written to. Note that already captured messages are not written to the file.

See Also

LogBook Class
LogBook Members
LogManager Namespace


AttachToListView Method

[image]

MADCAT Software Developer Guide
LogBook..::..AttachToListView Method
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Connects the logbook to a list view. The list view will be configured and filled by the logbook to display the captured messages.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public void AttachToListView(
    ListView lst
)
Visual Basic
Public Sub AttachToListView ( _
    lst As ListView _
)
Visual C++
public:
void AttachToListView(
    ListView^ lst
)

Parameters

lst
Type: System.Windows.Forms..::..ListView
ListView control

See Also

LogBook Class
LogBook Members
LogManager Namespace


Deactivate Method

[image]

MADCAT Software Developer Guide
LogBook..::..Deactivate Method
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Stop the capture process.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public void Deactivate()
Visual Basic
Public Sub Deactivate
Visual C++
public:
void Deactivate()

See Also

LogBook Class
LogBook Members
LogManager Namespace


DetachFromFile Method

[image]

MADCAT Software Developer Guide
LogBook..::..DetachFromFile Method
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Stops the Direct-To-Disk feature.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public void DetachFromFile()
Visual Basic
Public Sub DetachFromFile
Visual C++
public:
void DetachFromFile()

See Also

LogBook Class
LogBook Members
LogManager Namespace


Dispose Method

[image]

MADCAT Software Developer Guide
LogBook..::..Dispose Method
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Destructor

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

LogBook Class
LogBook Members
LogManager Namespace


FormatMessageForDisk Method

[image]

MADCAT Software Developer Guide
LogBook..::..FormatMessageForDisk Method
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Converts a logbook message to text.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public static string FormatMessageForDisk(
    LogMessage m
)
Visual Basic
Public Shared Function FormatMessageForDisk ( _
    m As LogMessage _
) As String
Visual C++
public:
static String^ FormatMessageForDisk(
    LogMessage^ m
)

Parameters

m
Type: LogManager..::..LogMessage
Logbook message

Return Value

String which contains the message.

See Also

LogBook Class
LogBook Members
LogManager Namespace


FormatMessageForXml Method

[image]

MADCAT Software Developer Guide
LogBook..::..FormatMessageForXml Method
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Converts a logbook message to Xml.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public static XmlNode FormatMessageForXml(
    LogMessage m
)
Visual Basic
Public Shared Function FormatMessageForXml ( _
    m As LogMessage _
) As XmlNode
Visual C++
public:
static XmlNode^ FormatMessageForXml(
    LogMessage^ m
)

Parameters

m
Type: LogManager..::..LogMessage
Logbook message

Return Value

Xml data of the message

See Also

LogBook Class
LogBook Members
LogManager Namespace


GetAllMessages Method

[image] [image]

MADCAT Software Developer Guide
LogBook..::..GetAllMessages Method
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | GetAllMessages()()()() | Captures all the messages generated since the last capture.
Public method | GetAllMessages(Int32) | Captures all the messages generated since the given index.

See Also

LogBook Class
LogBook Members
LogManager Namespace


GetAllMessages Method

[image]

MADCAT Software Developer Guide
LogBook..::..GetAllMessages Method
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Captures all the messages generated since the last capture.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public void GetAllMessages()
Visual Basic
Public Sub GetAllMessages
Visual C++
public:
void GetAllMessages()

See Also

LogBook Class
LogBook Members
GetAllMessages Overload
LogManager Namespace


GetAllMessages Method (Int32)

[image]

MADCAT Software Developer Guide
LogBook..::..GetAllMessages Method (Int32)
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Captures all the messages generated since the given index.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public void GetAllMessages(
    int StartIndex
)
Visual Basic
Public Sub GetAllMessages ( _
    StartIndex As Integer _
)
Visual C++
public:
void GetAllMessages(
    int StartIndex
)

Parameters

StartIndex
Type: System..::..Int32
Index of the 1st message to capture.

See Also

LogBook Class
LogBook Members
GetAllMessages Overload
LogManager Namespace


GetDescription Method

[image]

MADCAT Software Developer Guide
LogBook..::..GetDescription Method
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Returns a description of the logbook. The description is a resume of the logbook capture criterias.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public string GetDescription()
Visual Basic
Public Function GetDescription As String
Visual C++
public:
String^ GetDescription()

Return Value

The description of the logbook. Description is a multi-line string.

See Also

LogBook Class
LogBook Members
LogManager Namespace


GetMessage Method

[image]

MADCAT Software Developer Guide
LogBook..::..GetMessage Method
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets a message from the logbook

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public LogMessage GetMessage(
    int index
)
Visual Basic
Public Function GetMessage ( _
    index As Integer _
) As LogMessage
Visual C++
public:
LogMessage^ GetMessage(
    int index
)

Parameters

index
Type: System..::..Int32
Index of the message in the logbook list. Index starts at 0.

Return Value

The logbook message found at the given index.

See Also

LogBook Class
LogBook Members
LogManager Namespace


GetSize Method

[image]

MADCAT Software Developer Guide
LogBook..::..GetSize Method
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the size of the logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public int GetSize()
Visual Basic
Public Function GetSize As Integer
Visual C++
public:
int GetSize()

Return Value

Number of captured messages.

See Also

LogBook Class
LogBook Members
LogManager Namespace


ReleaseFromListView Method

[image]

MADCAT Software Developer Guide
LogBook..::..ReleaseFromListView Method
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Disconnects the list view from the logbook. Future captured messages won't be displayed.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public void ReleaseFromListView()
Visual Basic
Public Sub ReleaseFromListView
Visual C++
public:
void ReleaseFromListView()

See Also

LogBook Class
LogBook Members
LogManager Namespace


Reset Method

[image]

MADCAT Software Developer Guide
LogBook..::..Reset Method
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Empties the logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset
Visual C++
public:
void Reset()

See Also

LogBook Class
LogBook Members
LogManager Namespace


SaveToDisk Method

[image]

MADCAT Software Developer Guide
LogBook..::..SaveToDisk Method
LogBook Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Saves all the messages captured by the logbook into a file.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public void SaveToDisk(
    string fileName
)
Visual Basic
Public Sub SaveToDisk ( _
    fileName As String _
)
Visual C++
public:
void SaveToDisk(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
Path of the file where the messages must be written to.

See Also

LogBook Class
LogBook Members
LogManager Namespace


LogBookBrowser Class

[image]

MADCAT Software Developer Guide
LogBookBrowser Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Form which can display and manage logbooks and their messages. Contains controls the user can use to create/edit/delete logbooks.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public class LogBookBrowser : Form,
    ILogBookEnvironment
Visual Basic
Public Class LogBookBrowser _
    Inherits Form _
    Implements ILogBookEnvironment
Visual C++
public ref class LogBookBrowser : public Form,
    ILogBookEnvironment

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
LogManager..::..LogBookBrowser

See Also

LogBookBrowser Members
LogManager Namespace


LogBookBrowser Members

[image] [image]

MADCAT Software Developer Guide
LogBookBrowser Members
LogBookBrowser Class Constructors Methods See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The LogBookBrowser type exposes the following members.

Constructors

 | Name | Description
Public method | LogBookBrowser | Constructor

Methods

 | Name | Description
Public method | DisplayLogbook | Method invoked to add a new logbook in the browser.
Public method | GetActionListItems | Method used by the logbook properties window to get the list of all the actions which can generate messages.
Public method | GetLoggerListItems | Method used by the logbook properties window to get the list of all the tools which can generate messages.
Public method | InitializeComponent | Required method for Designer support - do not modify the contents of this method with the code editor.
Public method | IsLogbookPresent | Method used to check if the browser is already displaying the content of a given logbook.
Public method | UpdateInfo | Updates the status message of the browser

See Also

LogBookBrowser Class
LogManager Namespace


LogBookBrowser Constructor

[image]

MADCAT Software Developer Guide
LogBookBrowser Constructor
LogBookBrowser Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public LogBookBrowser(
    ArrayList Actions,
    ArrayList Loggers,
    ArrayList LogBooks
)
Visual Basic
Public Sub New ( _
    Actions As ArrayList, _
    Loggers As ArrayList, _
    LogBooks As ArrayList _
)
Visual C++
public:
LogBookBrowser(
    ArrayList^ Actions,
    ArrayList^ Loggers,
    ArrayList^ LogBooks
)

Parameters

Actions
Type: System.Collections..::..ArrayList
Array of names (String objects) of all the actions which can generate messages
Loggers
Type: System.Collections..::..ArrayList
Array of names (String objects) of all the MADCAT elements which can generate messages. This may be databases, tools or renderers.
LogBooks
Type: System.Collections..::..ArrayList
Array of Logbooks (LogBook objects) to display in the browser. This list contains all the logbooks already created by the user in previous session. May be empty if the user has no logbooks.

See Also

LogBookBrowser Class
LogBookBrowser Members
LogManager Namespace


LogBookBrowser Methods

[image] [image]

MADCAT Software Developer Guide
LogBookBrowser Methods
LogBookBrowser Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The LogBookBrowser type exposes the following members.

Methods

 | Name | Description
Public method | DisplayLogbook | Method invoked to add a new logbook in the browser.
Public method | GetActionListItems | Method used by the logbook properties window to get the list of all the actions which can generate messages.
Public method | GetLoggerListItems | Method used by the logbook properties window to get the list of all the tools which can generate messages.
Public method | InitializeComponent | Required method for Designer support - do not modify the contents of this method with the code editor.
Public method | IsLogbookPresent | Method used to check if the browser is already displaying the content of a given logbook.
Public method | UpdateInfo | Updates the status message of the browser

See Also

LogBookBrowser Class
LogManager Namespace


DisplayLogbook Method

[image]

MADCAT Software Developer Guide
LogBookBrowser..::..DisplayLogbook Method
LogBookBrowser Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Method invoked to add a new logbook in the browser.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void DisplayLogbook(
    LogBook lgb
)
Visual Basic
Public Overridable Sub DisplayLogbook ( _
    lgb As LogBook _
)
Visual C++
public:
virtual void DisplayLogbook(
    LogBook^ lgb
)

Parameters

lgb
Type: LogManager..::..LogBook
Logbook to add.

Implements

ILogBookEnvironment..::..DisplayLogbook(LogBook)

See Also

LogBookBrowser Class
LogBookBrowser Members
LogManager Namespace


GetActionListItems Method

[image]

MADCAT Software Developer Guide
LogBookBrowser..::..GetActionListItems Method
LogBookBrowser Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Method used by the logbook properties window to get the list of all the actions which can generate messages.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual ArrayList GetActionListItems()
Visual Basic
Public Overridable Function GetActionListItems As ArrayList
Visual C++
public:
virtual ArrayList^ GetActionListItems()

Return Value

Array of string objects. Each string has the full name of an action.

Implements

ILogBookEnvironment..::..GetActionListItems()()()()

See Also

LogBookBrowser Class
LogBookBrowser Members
LogManager Namespace


GetLoggerListItems Method

[image]

MADCAT Software Developer Guide
LogBookBrowser..::..GetLoggerListItems Method
LogBookBrowser Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Method used by the logbook properties window to get the list of all the tools which can generate messages.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual ArrayList GetLoggerListItems()
Visual Basic
Public Overridable Function GetLoggerListItems As ArrayList
Visual C++
public:
virtual ArrayList^ GetLoggerListItems()

Return Value

Array of string objects. Each string has the full name of a tool.

Implements

ILogBookEnvironment..::..GetLoggerListItems()()()()

See Also

LogBookBrowser Class
LogBookBrowser Members
LogManager Namespace


InitializeComponent Method

[image]

MADCAT Software Developer Guide
LogBookBrowser..::..InitializeComponent Method
LogBookBrowser Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Required method for Designer support - do not modify the contents of this method with the code editor.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public void InitializeComponent()
Visual Basic
Public Sub InitializeComponent
Visual C++
public:
void InitializeComponent()

See Also

LogBookBrowser Class
LogBookBrowser Members
LogManager Namespace


IsLogbookPresent Method

[image]

MADCAT Software Developer Guide
LogBookBrowser..::..IsLogbookPresent Method
LogBookBrowser Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Method used to check if the browser is already displaying the content of a given logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual bool IsLogbookPresent(
    string name
)
Visual Basic
Public Overridable Function IsLogbookPresent ( _
    name As String _
) As Boolean
Visual C++
public:
virtual bool IsLogbookPresent(
    String^ name
)

Parameters

name
Type: System..::..String
Name of the logbook to look for.

Return Value

True if the browser already has a logbook with the given name.

Implements

ILogBookEnvironment..::..IsLogbookPresent(String)

See Also

LogBookBrowser Class
LogBookBrowser Members
LogManager Namespace


UpdateInfo Method

[image]

MADCAT Software Developer Guide
LogBookBrowser..::..UpdateInfo Method
LogBookBrowser Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Updates the status message of the browser

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public void UpdateInfo()
Visual Basic
Public Sub UpdateInfo
Visual C++
public:
void UpdateInfo()

See Also

LogBookBrowser Class
LogBookBrowser Members
LogManager Namespace


LogBookDialog Class

[image]

MADCAT Software Developer Guide
LogBookDialog Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Dialog box used to create/edit logbook properties. The user uses this dialog box to define the following properties :
  • The name
  • The captured levels of criticity
  • The filters (logger and actions)
  • The Direct-To-Disk feature

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public class LogBookDialog : Form
Visual Basic
Public Class LogBookDialog _
    Inherits Form
Visual C++
public ref class LogBookDialog : public Form

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
LogManager..::..LogBookDialog

See Also

LogBookDialog Members
LogManager Namespace


LogBookDialog Members

[image] [image]

MADCAT Software Developer Guide
LogBookDialog Members
LogBookDialog Class Constructors See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Constructors

 | Name | Description
Public method | LogBookDialog()()()() | Constructor to call to create a new logbook
Public method | LogBookDialog(LogBook) | Constructor to call to edit an existing logbook

See Also

LogBookDialog Class
LogManager Namespace


LogBookDialog Constructor

[image] [image]

MADCAT Software Developer Guide
LogBookDialog Constructor
LogBookDialog Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | LogBookDialog()()()() | Constructor to call to create a new logbook
Public method | LogBookDialog(LogBook) | Constructor to call to edit an existing logbook

See Also

LogBookDialog Class
LogBookDialog Members
LogManager Namespace


LogBookDialog Constructor

[image]

MADCAT Software Developer Guide
LogBookDialog Constructor
LogBookDialog Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor to call to create a new logbook

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public LogBookDialog()
Visual Basic
Public Sub New
Visual C++
public:
LogBookDialog()

See Also

LogBookDialog Class
LogBookDialog Members
LogBookDialog Overload
LogManager Namespace


LogBookDialog Constructor (LogBook)

[image]

MADCAT Software Developer Guide
LogBookDialog Constructor (LogBook)
LogBookDialog Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor to call to edit an existing logbook

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public LogBookDialog(
    LogBook lgb
)
Visual Basic
Public Sub New ( _
    lgb As LogBook _
)
Visual C++
public:
LogBookDialog(
    LogBook^ lgb
)

Parameters

lgb
Type: LogManager..::..LogBook
Logbook to edit

See Also

LogBookDialog Class
LogBookDialog Members
LogBookDialog Overload
LogManager Namespace


LogbookWriter Class

[image]

MADCAT Software Developer Guide
LogbookWriter Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Used to generate message. This is the main class to use to generate any kind of messages.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public class LogbookWriter : ILogbookWriter
Visual Basic
Public Class LogbookWriter _
    Implements ILogbookWriter
Visual C++
public ref class LogbookWriter : ILogbookWriter

Inheritance Hierarchy

System..::..Object
LogManager..::..LogbookWriter

See Also

LogbookWriter Members
LogManager Namespace


LogbookWriter Members

[image] [image]

MADCAT Software Developer Guide
LogbookWriter Members
LogbookWriter Class Constructors Methods Fields See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The LogbookWriter type exposes the following members.

Constructors

 | Name | Description
Public method | LogbookWriter | Constructor

Methods

 | Name | Description
Public method | Confirm(String) | Requests the user's acknowledgment before performing something.
Public method | Confirm(String, String) | Requests the user's acknowledgment before performing something.
Public method | Query | Displays a query on screen.
 | SetAutoReply | Sets the answering machine to use to reply to queries and confirmations.
Public method | SetQuietMode | Activates/Deactivates the automatic answering system.
Public method | ShowError(String) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowError(String, XmlNode) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowError(String, XmlNode, String) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowError(String, XmlNode, String, Color) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowError(String, XmlNode, String, Color, Color) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String, XmlNode) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String, XmlNode, String) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String, XmlNode, String, Color) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String, XmlNode, String, Color, Color) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String, XmlNode) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String, XmlNode, String) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String, XmlNode, String, Color) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String, XmlNode, String, Color, Color) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | StartAutoReply | Activates the answering machine. All the future queries will be replied automatically if the answer exists. Otherwise, the user will be able to record his answer.
Public method | StopAutoReply | Deactivates the answering machine. All the future queries won't be replied automatically. The user won't be asked to record his answers.
Public method | WriteError(String) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteError(String, XmlNode) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteError(String, XmlNode, String) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteError(String, XmlNode, String, Color) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteError(String, XmlNode, String, Color, Color) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String, XmlNode) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String, XmlNode, String) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String, XmlNode, String, Color) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String, XmlNode, String, Color, Color) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String) | Write a warning message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String, XmlNode) | Write a warning message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String, XmlNode, String) | Write a warning message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String, XmlNode, String, Color) | Write a warning message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String, XmlNode, String, Color, Color) | Write a warning message. The message is never displayed when generated but can be read in a logbook.

Fields

 | Name | Description
Public field | ActionName | Name of the action which generates the messages. The name shall be the one defined in the Tool Definition File.
Public field | Author | Name of the author of the messages. For tools, it shall be the tool name. The name shall be the one defined in the Tool Definition File.
Public field | OutputToConsole | When set to true, the message will be displayed in the console window. Used only when action is run from the command line.

See Also

LogbookWriter Class
LogManager Namespace


LogbookWriter Constructor

[image]

MADCAT Software Developer Guide
LogbookWriter Constructor
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public LogbookWriter()
Visual Basic
Public Sub New
Visual C++
public:
LogbookWriter()

See Also

LogbookWriter Class
LogbookWriter Members
LogManager Namespace


LogbookWriter Fields

[image] [image]

MADCAT Software Developer Guide
LogbookWriter Fields
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The LogbookWriter type exposes the following members.

Fields

 | Name | Description
Public field | ActionName | Name of the action which generates the messages. The name shall be the one defined in the Tool Definition File.
Public field | Author | Name of the author of the messages. For tools, it shall be the tool name. The name shall be the one defined in the Tool Definition File.
Public field | OutputToConsole | When set to true, the message will be displayed in the console window. Used only when action is run from the command line.

See Also

LogbookWriter Class
LogManager Namespace


ActionName Field

[image]

MADCAT Software Developer Guide
LogbookWriter..::..ActionName Field
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Name of the action which generates the messages. The name shall be the one defined in the Tool Definition File.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public string ActionName
Visual Basic
Public ActionName As String
Visual C++
public:
String^ ActionName

See Also

LogbookWriter Class
LogbookWriter Members
LogManager Namespace


Author Field

[image]

MADCAT Software Developer Guide
LogbookWriter..::..Author Field
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Name of the author of the messages. For tools, it shall be the tool name. The name shall be the one defined in the Tool Definition File.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public string Author
Visual Basic
Public Author As String
Visual C++
public:
String^ Author

See Also

LogbookWriter Class
LogbookWriter Members
LogManager Namespace


OutputToConsole Field

[image]

MADCAT Software Developer Guide
LogbookWriter..::..OutputToConsole Field
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
When set to true, the message will be displayed in the console window. Used only when action is run from the command line.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public bool OutputToConsole
Visual Basic
Public OutputToConsole As Boolean
Visual C++
public:
bool OutputToConsole

See Also

LogbookWriter Class
LogbookWriter Members
LogManager Namespace


LogbookWriter Methods

[image] [image]

MADCAT Software Developer Guide
LogbookWriter Methods
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The LogbookWriter type exposes the following members.

Methods

 | Name | Description
Public method | Confirm(String) | Requests the user's acknowledgment before performing something.
Public method | Confirm(String, String) | Requests the user's acknowledgment before performing something.
Public method | Query | Displays a query on screen.
 | SetAutoReply | Sets the answering machine to use to reply to queries and confirmations.
Public method | SetQuietMode | Activates/Deactivates the automatic answering system.
Public method | ShowError(String) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowError(String, XmlNode) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowError(String, XmlNode, String) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowError(String, XmlNode, String, Color) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowError(String, XmlNode, String, Color, Color) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String, XmlNode) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String, XmlNode, String) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String, XmlNode, String, Color) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String, XmlNode, String, Color, Color) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String, XmlNode) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String, XmlNode, String) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String, XmlNode, String, Color) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String, XmlNode, String, Color, Color) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | StartAutoReply | Activates the answering machine. All the future queries will be replied automatically if the answer exists. Otherwise, the user will be able to record his answer.
Public method | StopAutoReply | Deactivates the answering machine. All the future queries won't be replied automatically. The user won't be asked to record his answers.
Public method | WriteError(String) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteError(String, XmlNode) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteError(String, XmlNode, String) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteError(String, XmlNode, String, Color) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteError(String, XmlNode, String, Color, Color) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String, XmlNode) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String, XmlNode, String) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String, XmlNode, String, Color) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String, XmlNode, String, Color, Color) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String) | Write a warning message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String, XmlNode) | Write a warning message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String, XmlNode, String) | Write a warning message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String, XmlNode, String, Color) | Write a warning message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String, XmlNode, String, Color, Color) | Write a warning message. The message is never displayed when generated but can be read in a logbook.

See Also

LogbookWriter Class
LogManager Namespace


Confirm Method

[image] [image]

MADCAT Software Developer Guide
LogbookWriter..::..Confirm Method
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | Confirm(String) | Requests the user's acknowledgment before performing something.
Public method | Confirm(String, String) | Requests the user's acknowledgment before performing something.

See Also

LogbookWriter Class
LogbookWriter Members
LogManager Namespace


Confirm Method (String)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..Confirm Method (String)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Requests the user's acknowledgment before performing something.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual DialogResult Confirm(
    string Question
)
Visual Basic
Public Overridable Function Confirm ( _
    Question As String _
) As DialogResult
Visual C++
public:
virtual DialogResult Confirm(
    String^ Question
)

Parameters

Question
Type: System..::..String
Description of the thing which must be confirmed.

Return Value

Returns the code of the button pressed by the user : Yes, No or Cancel

Implements

ILogbookWriter..::..Confirm(String)

See Also

LogbookWriter Class
LogbookWriter Members
Confirm Overload
LogManager Namespace


Confirm Method (String, String)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..Confirm Method (String, String)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Requests the user's acknowledgment before performing something.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual DialogResult Confirm(
    string Question,
    string Help
)
Visual Basic
Public Overridable Function Confirm ( _
    Question As String, _
    Help As String _
) As DialogResult
Visual C++
public:
virtual DialogResult Confirm(
    String^ Question,
    String^ Help
)

Parameters

Question
Type: System..::..String
Description of the thing which must be confirmed.
Help
Type: System..::..String
Additional information to help the user take the good decision.

Return Value

Returns the code of the button pressed by the user : Yes, No or Cancel

Implements

ILogbookWriter..::..Confirm(String, String)

See Also

LogbookWriter Class
LogbookWriter Members
Confirm Overload
LogManager Namespace


Query Method

[image]

MADCAT Software Developer Guide
LogbookWriter..::..Query Method
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays a query on screen.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual DialogResult Query(
    string Question,
    IParameter Param
)
Visual Basic
Public Overridable Function Query ( _
    Question As String, _
    Param As IParameter _
) As DialogResult
Visual C++
public:
virtual DialogResult Query(
    String^ Question,
    IParameter^ Param
)

Parameters

Question
Type: System..::..String
Text of the question
Param
Type: Parameters..::..IParameter
Parameter used to get the user's reply.

Return Value

Returns the code of the button pressed by the user : OK or Cancel

Implements

ILogbookWriter..::..Query(String, IParameter)

See Also

LogbookWriter Class
LogbookWriter Members
LogManager Namespace


SetAutoReply Method

[image]

MADCAT Software Developer Guide
LogbookWriter..::..SetAutoReply Method
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Sets the answering machine to use to reply to queries and confirmations.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public static void SetAutoReply(
    AnsweringMachine m
)
Visual Basic
Public Shared Sub SetAutoReply ( _
    m As AnsweringMachine _
)
Visual C++
public:
static void SetAutoReply(
    AnsweringMachine^ m
)

Parameters

m
Type: LogManager..::..AnsweringMachine
Answering machine which has the right answers.

See Also

LogbookWriter Class
LogbookWriter Members
LogManager Namespace


SetQuietMode Method

[image]

MADCAT Software Developer Guide
LogbookWriter..::..SetQuietMode Method
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Activates/Deactivates the automatic answering system.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void SetQuietMode(
    bool active
)
Visual Basic
Public Overridable Sub SetQuietMode ( _
    active As Boolean _
)
Visual C++
public:
virtual void SetQuietMode(
    bool active
)

Parameters

active
Type: System..::..Boolean
If it is equal to true, the answering machine is activated. Otherwise, all messages which are shown are actually displayed on screen and must be acknowledged by the user.

Implements

ILogbookWriter..::..SetQuietMode(Boolean)

See Also

LogbookWriter Class
LogbookWriter Members
LogManager Namespace


ShowError Method

[image] [image]

MADCAT Software Developer Guide
LogbookWriter..::..ShowError Method
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | ShowError(String) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowError(String, XmlNode) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowError(String, XmlNode, String) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowError(String, XmlNode, String, Color) | Displays an error message. The message is displayed when generated and can be read in a logbook.
Public method | ShowError(String, XmlNode, String, Color, Color) | Displays an error message. The message is displayed when generated and can be read in a logbook.

See Also

LogbookWriter Class
LogbookWriter Members
LogManager Namespace


ShowError Method (String)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..ShowError Method (String)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays an error message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void ShowError(
    string Text
)
Visual Basic
Public Overridable Sub ShowError ( _
    Text As String _
)
Visual C++
public:
virtual void ShowError(
    String^ Text
)

Parameters

Text
Type: System..::..String
Body of the message

Implements

ILogbookWriter..::..ShowError(String)

See Also

LogbookWriter Class
LogbookWriter Members
ShowError Overload
LogManager Namespace


ShowError Method (String, XmlNode)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..ShowError Method (String, XmlNode)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays an error message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void ShowError(
    string Text,
    XmlNode Item
)
Visual Basic
Public Overridable Sub ShowError ( _
    Text As String, _
    Item As XmlNode _
)
Visual C++
public:
virtual void ShowError(
    String^ Text,
    XmlNode^ Item
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.

Implements

ILogbookWriter..::..ShowError(String, XmlNode)

See Also

LogbookWriter Class
LogbookWriter Members
ShowError Overload
LogManager Namespace


ShowError Method (String, XmlNode, String)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..ShowError Method (String, XmlNode, String)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays an error message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void ShowError(
    string Text,
    XmlNode Item,
    string Help
)
Visual Basic
Public Overridable Sub ShowError ( _
    Text As String, _
    Item As XmlNode, _
    Help As String _
)
Visual C++
public:
virtual void ShowError(
    String^ Text,
    XmlNode^ Item,
    String^ Help
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.

Implements

ILogbookWriter..::..ShowError(String, XmlNode, String)

See Also

LogbookWriter Class
LogbookWriter Members
ShowError Overload
LogManager Namespace


ShowError Method (String, XmlNode, String, Color)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..ShowError Method (String, XmlNode, String, Color)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays an error message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void ShowError(
    string Text,
    XmlNode Item,
    string Help,
    Color fc
)
Visual Basic
Public Overridable Sub ShowError ( _
    Text As String, _
    Item As XmlNode, _
    Help As String, _
    fc As Color _
)
Visual C++
public:
virtual void ShowError(
    String^ Text,
    XmlNode^ Item,
    String^ Help,
    Color fc
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.
fc
Type: System.Drawing..::..Color
Color of the font to use to display the message in a list view.

Implements

ILogbookWriter..::..ShowError(String, XmlNode, String, Color)

See Also

LogbookWriter Class
LogbookWriter Members
ShowError Overload
LogManager Namespace


ShowError Method (String, XmlNode, String, Color, Color)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..ShowError Method (String, XmlNode, String, Color, Color)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays an error message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void ShowError(
    string Text,
    XmlNode Item,
    string Help,
    Color fc,
    Color bc
)
Visual Basic
Public Overridable Sub ShowError ( _
    Text As String, _
    Item As XmlNode, _
    Help As String, _
    fc As Color, _
    bc As Color _
)
Visual C++
public:
virtual void ShowError(
    String^ Text,
    XmlNode^ Item,
    String^ Help,
    Color fc,
    Color bc
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.
fc
Type: System.Drawing..::..Color
Color of the font to use to display the message in a list view.
bc
Type: System.Drawing..::..Color
Color of the background to use to display the message in a list view

Implements

ILogbookWriter..::..ShowError(String, XmlNode, String, Color, Color)

See Also

LogbookWriter Class
LogbookWriter Members
ShowError Overload
LogManager Namespace


ShowInfo Method

[image] [image]

MADCAT Software Developer Guide
LogbookWriter..::..ShowInfo Method
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | ShowInfo(String) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String, XmlNode) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String, XmlNode, String) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String, XmlNode, String, Color) | Displays an information message. The message is displayed when generated and can be read in a logbook.
Public method | ShowInfo(String, XmlNode, String, Color, Color) | Displays an information message. The message is displayed when generated and can be read in a logbook.

See Also

LogbookWriter Class
LogbookWriter Members
LogManager Namespace


ShowInfo Method (String)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..ShowInfo Method (String)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays an information message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void ShowInfo(
    string Text
)
Visual Basic
Public Overridable Sub ShowInfo ( _
    Text As String _
)
Visual C++
public:
virtual void ShowInfo(
    String^ Text
)

Parameters

Text
Type: System..::..String
Body of the message

Implements

ILogbookWriter..::..ShowInfo(String)

See Also

LogbookWriter Class
LogbookWriter Members
ShowInfo Overload
LogManager Namespace


ShowInfo Method (String, XmlNode)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..ShowInfo Method (String, XmlNode)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays an information message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void ShowInfo(
    string Text,
    XmlNode Item
)
Visual Basic
Public Overridable Sub ShowInfo ( _
    Text As String, _
    Item As XmlNode _
)
Visual C++
public:
virtual void ShowInfo(
    String^ Text,
    XmlNode^ Item
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.

Implements

ILogbookWriter..::..ShowInfo(String, XmlNode)

See Also

LogbookWriter Class
LogbookWriter Members
ShowInfo Overload
LogManager Namespace


ShowInfo Method (String, XmlNode, String)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..ShowInfo Method (String, XmlNode, String)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays an information message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void ShowInfo(
    string Text,
    XmlNode Item,
    string Help
)
Visual Basic
Public Overridable Sub ShowInfo ( _
    Text As String, _
    Item As XmlNode, _
    Help As String _
)
Visual C++
public:
virtual void ShowInfo(
    String^ Text,
    XmlNode^ Item,
    String^ Help
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.

Implements

ILogbookWriter..::..ShowInfo(String, XmlNode, String)

See Also

LogbookWriter Class
LogbookWriter Members
ShowInfo Overload
LogManager Namespace


ShowInfo Method (String, XmlNode, String, Color)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..ShowInfo Method (String, XmlNode, String, Color)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays an information message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void ShowInfo(
    string Text,
    XmlNode Item,
    string Help,
    Color fc
)
Visual Basic
Public Overridable Sub ShowInfo ( _
    Text As String, _
    Item As XmlNode, _
    Help As String, _
    fc As Color _
)
Visual C++
public:
virtual void ShowInfo(
    String^ Text,
    XmlNode^ Item,
    String^ Help,
    Color fc
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.
fc
Type: System.Drawing..::..Color
Color of the font to use to display the message in a list view.

Implements

ILogbookWriter..::..ShowInfo(String, XmlNode, String, Color)

See Also

LogbookWriter Class
LogbookWriter Members
ShowInfo Overload
LogManager Namespace


ShowInfo Method (String, XmlNode, String, Color, Color)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..ShowInfo Method (String, XmlNode, String, Color, Color)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays an information message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void ShowInfo(
    string Text,
    XmlNode Item,
    string Help,
    Color fc,
    Color bc
)
Visual Basic
Public Overridable Sub ShowInfo ( _
    Text As String, _
    Item As XmlNode, _
    Help As String, _
    fc As Color, _
    bc As Color _
)
Visual C++
public:
virtual void ShowInfo(
    String^ Text,
    XmlNode^ Item,
    String^ Help,
    Color fc,
    Color bc
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.
fc
Type: System.Drawing..::..Color
Color of the font to use to display the message in a list view.
bc
Type: System.Drawing..::..Color
Color of the background to use to display the message in a list view

Implements

ILogbookWriter..::..ShowInfo(String, XmlNode, String, Color, Color)

See Also

LogbookWriter Class
LogbookWriter Members
ShowInfo Overload
LogManager Namespace


ShowWarning Method

[image] [image]

MADCAT Software Developer Guide
LogbookWriter..::..ShowWarning Method
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | ShowWarning(String) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String, XmlNode) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String, XmlNode, String) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String, XmlNode, String, Color) | Displays a warning message. The message is displayed when generated and can be read in a logbook.
Public method | ShowWarning(String, XmlNode, String, Color, Color) | Displays a warning message. The message is displayed when generated and can be read in a logbook.

See Also

LogbookWriter Class
LogbookWriter Members
LogManager Namespace


ShowWarning Method (String)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..ShowWarning Method (String)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays a warning message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void ShowWarning(
    string Text
)
Visual Basic
Public Overridable Sub ShowWarning ( _
    Text As String _
)
Visual C++
public:
virtual void ShowWarning(
    String^ Text
)

Parameters

Text
Type: System..::..String
Body of the message

Implements

ILogbookWriter..::..ShowWarning(String)

See Also

LogbookWriter Class
LogbookWriter Members
ShowWarning Overload
LogManager Namespace


ShowWarning Method (String, XmlNode)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..ShowWarning Method (String, XmlNode)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays a warning message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void ShowWarning(
    string Text,
    XmlNode Item
)
Visual Basic
Public Overridable Sub ShowWarning ( _
    Text As String, _
    Item As XmlNode _
)
Visual C++
public:
virtual void ShowWarning(
    String^ Text,
    XmlNode^ Item
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.

Implements

ILogbookWriter..::..ShowWarning(String, XmlNode)

See Also

LogbookWriter Class
LogbookWriter Members
ShowWarning Overload
LogManager Namespace


ShowWarning Method (String, XmlNode, String)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..ShowWarning Method (String, XmlNode, String)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays a warning message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void ShowWarning(
    string Text,
    XmlNode Item,
    string Help
)
Visual Basic
Public Overridable Sub ShowWarning ( _
    Text As String, _
    Item As XmlNode, _
    Help As String _
)
Visual C++
public:
virtual void ShowWarning(
    String^ Text,
    XmlNode^ Item,
    String^ Help
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.

Implements

ILogbookWriter..::..ShowWarning(String, XmlNode, String)

See Also

LogbookWriter Class
LogbookWriter Members
ShowWarning Overload
LogManager Namespace


ShowWarning Method (String, XmlNode, String, Color)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..ShowWarning Method (String, XmlNode, String, Color)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays a warning message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void ShowWarning(
    string Text,
    XmlNode Item,
    string Help,
    Color fc
)
Visual Basic
Public Overridable Sub ShowWarning ( _
    Text As String, _
    Item As XmlNode, _
    Help As String, _
    fc As Color _
)
Visual C++
public:
virtual void ShowWarning(
    String^ Text,
    XmlNode^ Item,
    String^ Help,
    Color fc
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.
fc
Type: System.Drawing..::..Color
Color of the font to use to display the message in a list view.

Implements

ILogbookWriter..::..ShowWarning(String, XmlNode, String, Color)

See Also

LogbookWriter Class
LogbookWriter Members
ShowWarning Overload
LogManager Namespace


ShowWarning Method (String, XmlNode, String, Color, Color)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..ShowWarning Method (String, XmlNode, String, Color, Color)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Displays a warning message. The message is displayed when generated and can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void ShowWarning(
    string Text,
    XmlNode Item,
    string Help,
    Color fc,
    Color bc
)
Visual Basic
Public Overridable Sub ShowWarning ( _
    Text As String, _
    Item As XmlNode, _
    Help As String, _
    fc As Color, _
    bc As Color _
)
Visual C++
public:
virtual void ShowWarning(
    String^ Text,
    XmlNode^ Item,
    String^ Help,
    Color fc,
    Color bc
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.
fc
Type: System.Drawing..::..Color
Color of the font to use to display the message in a list view.
bc
Type: System.Drawing..::..Color
Color of the background to use to display the message in a list view

Implements

ILogbookWriter..::..ShowWarning(String, XmlNode, String, Color, Color)

See Also

LogbookWriter Class
LogbookWriter Members
ShowWarning Overload
LogManager Namespace


StartAutoReply Method

[image]

MADCAT Software Developer Guide
LogbookWriter..::..StartAutoReply Method
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Activates the answering machine. All the future queries will be replied automatically if the answer exists. Otherwise, the user will be able to record his answer.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void StartAutoReply()
Visual Basic
Public Overridable Sub StartAutoReply
Visual C++
public:
virtual void StartAutoReply()

Implements

ILogbookWriter..::..StartAutoReply()()()()

See Also

LogbookWriter Class
LogbookWriter Members
LogManager Namespace


StopAutoReply Method

[image]

MADCAT Software Developer Guide
LogbookWriter..::..StopAutoReply Method
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Deactivates the answering machine. All the future queries won't be replied automatically. The user won't be asked to record his answers.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void StopAutoReply()
Visual Basic
Public Overridable Sub StopAutoReply
Visual C++
public:
virtual void StopAutoReply()

Implements

ILogbookWriter..::..StopAutoReply()()()()

See Also

LogbookWriter Class
LogbookWriter Members
LogManager Namespace


WriteError Method

[image] [image]

MADCAT Software Developer Guide
LogbookWriter..::..WriteError Method
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | WriteError(String) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteError(String, XmlNode) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteError(String, XmlNode, String) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteError(String, XmlNode, String, Color) | Write an error message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteError(String, XmlNode, String, Color, Color) | Write an error message. The message is never displayed when generated but can be read in a logbook.

See Also

LogbookWriter Class
LogbookWriter Members
LogManager Namespace


WriteError Method (String)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..WriteError Method (String)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write an error message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void WriteError(
    string Text
)
Visual Basic
Public Overridable Sub WriteError ( _
    Text As String _
)
Visual C++
public:
virtual void WriteError(
    String^ Text
)

Parameters

Text
Type: System..::..String
Body of the message

Implements

ILogbookWriter..::..WriteError(String)

See Also

LogbookWriter Class
LogbookWriter Members
WriteError Overload
LogManager Namespace


WriteError Method (String, XmlNode)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..WriteError Method (String, XmlNode)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write an error message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void WriteError(
    string Text,
    XmlNode Item
)
Visual Basic
Public Overridable Sub WriteError ( _
    Text As String, _
    Item As XmlNode _
)
Visual C++
public:
virtual void WriteError(
    String^ Text,
    XmlNode^ Item
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.

Implements

ILogbookWriter..::..WriteError(String, XmlNode)

See Also

LogbookWriter Class
LogbookWriter Members
WriteError Overload
LogManager Namespace


WriteError Method (String, XmlNode, String)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..WriteError Method (String, XmlNode, String)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write an error message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void WriteError(
    string Text,
    XmlNode Item,
    string Help
)
Visual Basic
Public Overridable Sub WriteError ( _
    Text As String, _
    Item As XmlNode, _
    Help As String _
)
Visual C++
public:
virtual void WriteError(
    String^ Text,
    XmlNode^ Item,
    String^ Help
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.

Implements

ILogbookWriter..::..WriteError(String, XmlNode, String)

See Also

LogbookWriter Class
LogbookWriter Members
WriteError Overload
LogManager Namespace


WriteError Method (String, XmlNode, String, Color)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..WriteError Method (String, XmlNode, String, Color)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write an error message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void WriteError(
    string Text,
    XmlNode Item,
    string Help,
    Color fc
)
Visual Basic
Public Overridable Sub WriteError ( _
    Text As String, _
    Item As XmlNode, _
    Help As String, _
    fc As Color _
)
Visual C++
public:
virtual void WriteError(
    String^ Text,
    XmlNode^ Item,
    String^ Help,
    Color fc
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.
fc
Type: System.Drawing..::..Color
Color of the font to use to display the message in a list view.

Implements

ILogbookWriter..::..WriteError(String, XmlNode, String, Color)

See Also

LogbookWriter Class
LogbookWriter Members
WriteError Overload
LogManager Namespace


WriteError Method (String, XmlNode, String, Color, Color)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..WriteError Method (String, XmlNode, String, Color, Color)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write an error message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void WriteError(
    string Text,
    XmlNode Item,
    string Help,
    Color fc,
    Color bc
)
Visual Basic
Public Overridable Sub WriteError ( _
    Text As String, _
    Item As XmlNode, _
    Help As String, _
    fc As Color, _
    bc As Color _
)
Visual C++
public:
virtual void WriteError(
    String^ Text,
    XmlNode^ Item,
    String^ Help,
    Color fc,
    Color bc
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.
fc
Type: System.Drawing..::..Color
Color of the font to use to display the message in a list view.
bc
Type: System.Drawing..::..Color
Color of the background to use to display the message in a list view

Implements

ILogbookWriter..::..WriteError(String, XmlNode, String, Color, Color)

See Also

LogbookWriter Class
LogbookWriter Members
WriteError Overload
LogManager Namespace


WriteInfo Method

[image] [image]

MADCAT Software Developer Guide
LogbookWriter..::..WriteInfo Method
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | WriteInfo(String) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String, XmlNode) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String, XmlNode, String) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String, XmlNode, String, Color) | Write an information message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteInfo(String, XmlNode, String, Color, Color) | Write an information message. The message is never displayed when generated but can be read in a logbook.

See Also

LogbookWriter Class
LogbookWriter Members
LogManager Namespace


WriteInfo Method (String)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..WriteInfo Method (String)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write an information message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void WriteInfo(
    string Text
)
Visual Basic
Public Overridable Sub WriteInfo ( _
    Text As String _
)
Visual C++
public:
virtual void WriteInfo(
    String^ Text
)

Parameters

Text
Type: System..::..String
Body of the message

Implements

ILogbookWriter..::..WriteInfo(String)

See Also

LogbookWriter Class
LogbookWriter Members
WriteInfo Overload
LogManager Namespace


WriteInfo Method (String, XmlNode)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..WriteInfo Method (String, XmlNode)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write an information message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void WriteInfo(
    string Text,
    XmlNode Item
)
Visual Basic
Public Overridable Sub WriteInfo ( _
    Text As String, _
    Item As XmlNode _
)
Visual C++
public:
virtual void WriteInfo(
    String^ Text,
    XmlNode^ Item
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.

Implements

ILogbookWriter..::..WriteInfo(String, XmlNode)

See Also

LogbookWriter Class
LogbookWriter Members
WriteInfo Overload
LogManager Namespace


WriteInfo Method (String, XmlNode, String)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..WriteInfo Method (String, XmlNode, String)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write an information message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void WriteInfo(
    string Text,
    XmlNode Item,
    string Help
)
Visual Basic
Public Overridable Sub WriteInfo ( _
    Text As String, _
    Item As XmlNode, _
    Help As String _
)
Visual C++
public:
virtual void WriteInfo(
    String^ Text,
    XmlNode^ Item,
    String^ Help
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.

Implements

ILogbookWriter..::..WriteInfo(String, XmlNode, String)

See Also

LogbookWriter Class
LogbookWriter Members
WriteInfo Overload
LogManager Namespace


WriteInfo Method (String, XmlNode, String, Color)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..WriteInfo Method (String, XmlNode, String, Color)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write an information message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void WriteInfo(
    string Text,
    XmlNode Item,
    string Help,
    Color fc
)
Visual Basic
Public Overridable Sub WriteInfo ( _
    Text As String, _
    Item As XmlNode, _
    Help As String, _
    fc As Color _
)
Visual C++
public:
virtual void WriteInfo(
    String^ Text,
    XmlNode^ Item,
    String^ Help,
    Color fc
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.
fc
Type: System.Drawing..::..Color
Color of the font to use to display the message in a list view.

Implements

ILogbookWriter..::..WriteInfo(String, XmlNode, String, Color)

See Also

LogbookWriter Class
LogbookWriter Members
WriteInfo Overload
LogManager Namespace


WriteInfo Method (String, XmlNode, String, Color, Color)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..WriteInfo Method (String, XmlNode, String, Color, Color)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write an information message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void WriteInfo(
    string Text,
    XmlNode Item,
    string Help,
    Color fc,
    Color bc
)
Visual Basic
Public Overridable Sub WriteInfo ( _
    Text As String, _
    Item As XmlNode, _
    Help As String, _
    fc As Color, _
    bc As Color _
)
Visual C++
public:
virtual void WriteInfo(
    String^ Text,
    XmlNode^ Item,
    String^ Help,
    Color fc,
    Color bc
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.
fc
Type: System.Drawing..::..Color
Color of the font to use to display the message in a list view.
bc
Type: System.Drawing..::..Color
Color of the background to use to display the message in a list view

Implements

ILogbookWriter..::..WriteInfo(String, XmlNode, String, Color, Color)

See Also

LogbookWriter Class
LogbookWriter Members
WriteInfo Overload
LogManager Namespace


WriteWarning Method

[image] [image]

MADCAT Software Developer Guide
LogbookWriter..::..WriteWarning Method
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | WriteWarning(String) | Write a warning message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String, XmlNode) | Write a warning message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String, XmlNode, String) | Write a warning message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String, XmlNode, String, Color) | Write a warning message. The message is never displayed when generated but can be read in a logbook.
Public method | WriteWarning(String, XmlNode, String, Color, Color) | Write a warning message. The message is never displayed when generated but can be read in a logbook.

See Also

LogbookWriter Class
LogbookWriter Members
LogManager Namespace


WriteWarning Method (String)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..WriteWarning Method (String)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write a warning message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void WriteWarning(
    string Text
)
Visual Basic
Public Overridable Sub WriteWarning ( _
    Text As String _
)
Visual C++
public:
virtual void WriteWarning(
    String^ Text
)

Parameters

Text
Type: System..::..String
Body of the message

Implements

ILogbookWriter..::..WriteWarning(String)

See Also

LogbookWriter Class
LogbookWriter Members
WriteWarning Overload
LogManager Namespace


WriteWarning Method (String, XmlNode)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..WriteWarning Method (String, XmlNode)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write a warning message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void WriteWarning(
    string Text,
    XmlNode Item
)
Visual Basic
Public Overridable Sub WriteWarning ( _
    Text As String, _
    Item As XmlNode _
)
Visual C++
public:
virtual void WriteWarning(
    String^ Text,
    XmlNode^ Item
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.

Implements

ILogbookWriter..::..WriteWarning(String, XmlNode)

See Also

LogbookWriter Class
LogbookWriter Members
WriteWarning Overload
LogManager Namespace


WriteWarning Method (String, XmlNode, String)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..WriteWarning Method (String, XmlNode, String)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write a warning message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void WriteWarning(
    string Text,
    XmlNode Item,
    string Help
)
Visual Basic
Public Overridable Sub WriteWarning ( _
    Text As String, _
    Item As XmlNode, _
    Help As String _
)
Visual C++
public:
virtual void WriteWarning(
    String^ Text,
    XmlNode^ Item,
    String^ Help
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.

Implements

ILogbookWriter..::..WriteWarning(String, XmlNode, String)

See Also

LogbookWriter Class
LogbookWriter Members
WriteWarning Overload
LogManager Namespace


WriteWarning Method (String, XmlNode, String, Color)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..WriteWarning Method (String, XmlNode, String, Color)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write a warning message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void WriteWarning(
    string Text,
    XmlNode Item,
    string Help,
    Color fc
)
Visual Basic
Public Overridable Sub WriteWarning ( _
    Text As String, _
    Item As XmlNode, _
    Help As String, _
    fc As Color _
)
Visual C++
public:
virtual void WriteWarning(
    String^ Text,
    XmlNode^ Item,
    String^ Help,
    Color fc
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.
fc
Type: System.Drawing..::..Color
Color of the font to use to display the message in a list view.

Implements

ILogbookWriter..::..WriteWarning(String, XmlNode, String, Color)

See Also

LogbookWriter Class
LogbookWriter Members
WriteWarning Overload
LogManager Namespace


WriteWarning Method (String, XmlNode, String, Color, Color)

[image]

MADCAT Software Developer Guide
LogbookWriter..::..WriteWarning Method (String, XmlNode, String, Color, Color)
LogbookWriter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Write a warning message. The message is never displayed when generated but can be read in a logbook.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public virtual void WriteWarning(
    string Text,
    XmlNode Item,
    string Help,
    Color fc,
    Color bc
)
Visual Basic
Public Overridable Sub WriteWarning ( _
    Text As String, _
    Item As XmlNode, _
    Help As String, _
    fc As Color, _
    bc As Color _
)
Visual C++
public:
virtual void WriteWarning(
    String^ Text,
    XmlNode^ Item,
    String^ Help,
    Color fc,
    Color bc
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item which is in relation with the message. May be null.
Help
Type: System..::..String
Text of a helpful hint about the message.
fc
Type: System.Drawing..::..Color
Color of the font to use to display the message in a list view.
bc
Type: System.Drawing..::..Color
Color of the background to use to display the message in a list view

Implements

ILogbookWriter..::..WriteWarning(String, XmlNode, String, Color, Color)

See Also

LogbookWriter Class
LogbookWriter Members
WriteWarning Overload
LogManager Namespace


LogMessage Class

[image]

MADCAT Software Developer Guide
LogMessage Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Logbook message

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public class LogMessage
Visual Basic
Public Class LogMessage
Visual C++
public ref class LogMessage

Inheritance Hierarchy

System..::..Object
LogManager..::..LogMessage
LogManager..::..Confirmation
LogManager..::..ErrorMessage
LogManager..::..InfoMessage
LogManager..::..Question
LogManager..::..WarningMessage

See Also

LogMessage Members
LogManager Namespace


LogMessage Members

[image] [image]

MADCAT Software Developer Guide
LogMessage Members
LogMessage Class Constructors Methods Fields See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The LogMessage type exposes the following members.

Constructors

 | Name | Description
Public method | LogMessage(ErrorLevel, String) | Creates a message with a level and a body
Public method | LogMessage(ErrorLevel, String, XmlNode) | Creates a message with a level, a body and an item
Public method | LogMessage(ErrorLevel, String, XmlNode, String) | Creates a message with a level, a body, an item and a help

Methods

 | Name | Description
Public method | ErrorLevel | Gets the criticity in a string

Fields

 | Name | Description
Public field | ActionName | Name of the action which has generated the message
Public field | Answer | Value entered by the user to answer a query or acknowledge a confirmation
Public field | BackColor | Background color to use to display the message in a list view.
Public field | CaptureDate | Date and time of capture
Public field | ConsoleOutput | Dump of the console when the message is generated because of an external program action.
Public field | Displayed | Indicates if the message has been displayed on screen when generated. If true, the user has seen the message and has acknowledged it..
Public field | ForeColor | Text color to use to display the message in a list view.
Public field | Help | Help in relation to the message. Some infos which may help the user to understand the message.
Public field | ItemID | ID of the Xml Item concerned by the message
Public field | Level | Criticity of the message
Public field | LoggedBy | Name of the tool which has generated the message
Public field | Parameter | Parameter to use to get the user's answer. Used only for query messages.
Public field | Text | Body of the message

See Also

LogMessage Class
LogManager Namespace


LogMessage Constructor

[image] [image]

MADCAT Software Developer Guide
LogMessage Constructor
LogMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | LogMessage(ErrorLevel, String) | Creates a message with a level and a body
Public method | LogMessage(ErrorLevel, String, XmlNode) | Creates a message with a level, a body and an item
Public method | LogMessage(ErrorLevel, String, XmlNode, String) | Creates a message with a level, a body, an item and a help

See Also

LogMessage Class
LogMessage Members
LogManager Namespace


LogMessage Constructor (ErrorLevel, String)

[image]

MADCAT Software Developer Guide
LogMessage Constructor (ErrorLevel, String)
LogMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Creates a message with a level and a body

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public LogMessage(
    ErrorLevel l,
    string Text
)
Visual Basic
Public Sub New ( _
    l As ErrorLevel, _
    Text As String _
)
Visual C++
public:
LogMessage(
    ErrorLevel l,
    String^ Text
)

Parameters

l
Type: LogManager..::..ErrorLevel
Criticity of the message
Text
Type: System..::..String
Body of the message

See Also

LogMessage Class
LogMessage Members
LogMessage Overload
LogManager Namespace


LogMessage Constructor (ErrorLevel, String, XmlNode)

[image]

MADCAT Software Developer Guide
LogMessage Constructor (ErrorLevel, String, XmlNode)
LogMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Creates a message with a level, a body and an item

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public LogMessage(
    ErrorLevel l,
    string Text,
    XmlNode Item
)
Visual Basic
Public Sub New ( _
    l As ErrorLevel, _
    Text As String, _
    Item As XmlNode _
)
Visual C++
public:
LogMessage(
    ErrorLevel l,
    String^ Text,
    XmlNode^ Item
)

Parameters

l
Type: LogManager..::..ErrorLevel
Criticity of the message
Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item concerned by the message. May be null.

See Also

LogMessage Class
LogMessage Members
LogMessage Overload
LogManager Namespace


LogMessage Constructor (ErrorLevel, String, XmlNode, String)

[image]

MADCAT Software Developer Guide
LogMessage Constructor (ErrorLevel, String, XmlNode, String)
LogMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Creates a message with a level, a body, an item and a help

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public LogMessage(
    ErrorLevel l,
    string Text,
    XmlNode Item,
    string Help
)
Visual Basic
Public Sub New ( _
    l As ErrorLevel, _
    Text As String, _
    Item As XmlNode, _
    Help As String _
)
Visual C++
public:
LogMessage(
    ErrorLevel l,
    String^ Text,
    XmlNode^ Item,
    String^ Help
)

Parameters

l
Type: LogManager..::..ErrorLevel
Criticity of the message
Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item concerned by the message. May be null.
Help
Type: System..::..String
Help in relation with the message

See Also

LogMessage Class
LogMessage Members
LogMessage Overload
LogManager Namespace


LogMessage Fields

[image] [image]

MADCAT Software Developer Guide
LogMessage Fields
LogMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The LogMessage type exposes the following members.

Fields

 | Name | Description
Public field | ActionName | Name of the action which has generated the message
Public field | Answer | Value entered by the user to answer a query or acknowledge a confirmation
Public field | BackColor | Background color to use to display the message in a list view.
Public field | CaptureDate | Date and time of capture
Public field | ConsoleOutput | Dump of the console when the message is generated because of an external program action.
Public field | Displayed | Indicates if the message has been displayed on screen when generated. If true, the user has seen the message and has acknowledged it..
Public field | ForeColor | Text color to use to display the message in a list view.
Public field | Help | Help in relation to the message. Some infos which may help the user to understand the message.
Public field | ItemID | ID of the Xml Item concerned by the message
Public field | Level | Criticity of the message
Public field | LoggedBy | Name of the tool which has generated the message
Public field | Parameter | Parameter to use to get the user's answer. Used only for query messages.
Public field | Text | Body of the message

See Also

LogMessage Class
LogManager Namespace


ActionName Field

[image]

MADCAT Software Developer Guide
LogMessage..::..ActionName Field
LogMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Name of the action which has generated the message

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public string ActionName
Visual Basic
Public ActionName As String
Visual C++
public:
String^ ActionName

See Also

LogMessage Class
LogMessage Members
LogManager Namespace


Answer Field

[image]

MADCAT Software Developer Guide
LogMessage..::..Answer Field
LogMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Value entered by the user to answer a query or acknowledge a confirmation

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public string Answer
Visual Basic
Public Answer As String
Visual C++
public:
String^ Answer

See Also

LogMessage Class
LogMessage Members
LogManager Namespace


BackColor Field

[image]

MADCAT Software Developer Guide
LogMessage..::..BackColor Field
LogMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Background color to use to display the message in a list view.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public Color BackColor
Visual Basic
Public BackColor As Color
Visual C++
public:
Color BackColor

See Also

LogMessage Class
LogMessage Members
LogManager Namespace


CaptureDate Field

[image]

MADCAT Software Developer Guide
LogMessage..::..CaptureDate Field
LogMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Date and time of capture

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public ValueType CaptureDate
Visual Basic
Public CaptureDate As ValueType
Visual C++
public:
ValueType^ CaptureDate

See Also

LogMessage Class
LogMessage Members
LogManager Namespace


ConsoleOutput Field

[image]

MADCAT Software Developer Guide
LogMessage..::..ConsoleOutput Field
LogMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Dump of the console when the message is generated because of an external program action.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public string ConsoleOutput
Visual Basic
Public ConsoleOutput As String
Visual C++
public:
String^ ConsoleOutput

See Also

LogMessage Class
LogMessage Members
LogManager Namespace


Displayed Field

[image]

MADCAT Software Developer Guide
LogMessage..::..Displayed Field
LogMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Indicates if the message has been displayed on screen when generated. If true, the user has seen the message and has acknowledged it..

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public bool Displayed
Visual Basic
Public Displayed As Boolean
Visual C++
public:
bool Displayed

See Also

LogMessage Class
LogMessage Members
LogManager Namespace


ForeColor Field

[image]

MADCAT Software Developer Guide
LogMessage..::..ForeColor Field
LogMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Text color to use to display the message in a list view.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public Color ForeColor
Visual Basic
Public ForeColor As Color
Visual C++
public:
Color ForeColor

See Also

LogMessage Class
LogMessage Members
LogManager Namespace


Help Field

[image]

MADCAT Software Developer Guide
LogMessage..::..Help Field
LogMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Help in relation to the message. Some infos which may help the user to understand the message.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public string Help
Visual Basic
Public Help As String
Visual C++
public:
String^ Help

See Also

LogMessage Class
LogMessage Members
LogManager Namespace


ItemID Field

[image]

MADCAT Software Developer Guide
LogMessage..::..ItemID Field
LogMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
ID of the Xml Item concerned by the message

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public string ItemID
Visual Basic
Public ItemID As String
Visual C++
public:
String^ ItemID

See Also

LogMessage Class
LogMessage Members
LogManager Namespace


Level Field

[image]

MADCAT Software Developer Guide
LogMessage..::..Level Field
LogMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Criticity of the message

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public ErrorLevel Level
Visual Basic
Public Level As ErrorLevel
Visual C++
public:
ErrorLevel Level

See Also

LogMessage Class
LogMessage Members
LogManager Namespace


LoggedBy Field

[image]

MADCAT Software Developer Guide
LogMessage..::..LoggedBy Field
LogMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Name of the tool which has generated the message

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public string LoggedBy
Visual Basic
Public LoggedBy As String
Visual C++
public:
String^ LoggedBy

See Also

LogMessage Class
LogMessage Members
LogManager Namespace


Parameter Field

[image]

MADCAT Software Developer Guide
LogMessage..::..Parameter Field
LogMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Parameter to use to get the user's answer. Used only for query messages.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public IParameter Parameter
Visual Basic
Public Parameter As IParameter
Visual C++
public:
IParameter^ Parameter

See Also

LogMessage Class
LogMessage Members
LogManager Namespace


Text Field

[image]

MADCAT Software Developer Guide
LogMessage..::..Text Field
LogMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Body of the message

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public string Text
Visual Basic
Public Text As String
Visual C++
public:
String^ Text

See Also

LogMessage Class
LogMessage Members
LogManager Namespace


LogMessage Methods

[image] [image]

MADCAT Software Developer Guide
LogMessage Methods
LogMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The LogMessage type exposes the following members.

Methods

 | Name | Description
Public method | ErrorLevel | Gets the criticity in a string

See Also

LogMessage Class
LogManager Namespace


ErrorLevel Method

[image]

MADCAT Software Developer Guide
LogMessage..::..ErrorLevel Method
LogMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the criticity in a string

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public string ErrorLevel()
Visual Basic
Public Function ErrorLevel As String
Visual C++
public:
String^ ErrorLevel()

Return Value

The criticity :
    • ERR : Error
      WAR : Warning
      INF : Information
      QRY : Query
      ACK : Confirmation

    • See Also

    LogMessage Class
    LogMessage Members
    LogManager Namespace


MessageDisplay Class

[image]

MADCAT Software Developer Guide
MessageDisplay Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This form displays all the informations of a given logbook message.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public class MessageDisplay : Form
Visual Basic
Public Class MessageDisplay _
    Inherits Form
Visual C++
public ref class MessageDisplay : public Form

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
LogManager..::..MessageDisplay

See Also

MessageDisplay Members
LogManager Namespace


MessageDisplay Members

[image] [image]

MADCAT Software Developer Guide
MessageDisplay Members
MessageDisplay Class Constructors See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The MessageDisplay type exposes the following members.

Constructors

 | Name | Description
Public method | MessageDisplay | Constructor

See Also

MessageDisplay Class
LogManager Namespace


MessageDisplay Constructor

[image]

MADCAT Software Developer Guide
MessageDisplay Constructor
MessageDisplay Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public MessageDisplay(
    LogMessage m
)
Visual Basic
Public Sub New ( _
    m As LogMessage _
)
Visual C++
public:
MessageDisplay(
    LogMessage^ m
)

Parameters

m
Type: LogManager..::..LogMessage
Message to display

See Also

MessageDisplay Class
MessageDisplay Members
LogManager Namespace


QueryBox Class

[image]

MADCAT Software Developer Guide
QueryBox Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Form used to display confirmation or query messages (the messages which need a user input)

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public class QueryBox : Form
Visual Basic
Public Class QueryBox _
    Inherits Form
Visual C++
public ref class QueryBox : public Form

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
LogManager..::..QueryBox

See Also

QueryBox Members
LogManager Namespace


QueryBox Members

[image] [image]

MADCAT Software Developer Guide
QueryBox Members
QueryBox Class Constructors See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The QueryBox type exposes the following members.

Constructors

 | Name | Description
Public method | QueryBox | Constructor

See Also

QueryBox Class
LogManager Namespace


QueryBox Constructor

[image]

MADCAT Software Developer Guide
QueryBox Constructor
QueryBox Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public QueryBox(
    LogMessage m,
    bool SaveReply
)
Visual Basic
Public Sub New ( _
    m As LogMessage, _
    SaveReply As Boolean _
)
Visual C++
public:
QueryBox(
    LogMessage^ m,
    bool SaveReply
)

Parameters

m
Type: LogManager..::..LogMessage
The message to display to the user.
SaveReply
Type: System..::..Boolean
Set this to true if you want the user to be able to save his answer to the answering machine.

See Also

QueryBox Class
QueryBox Members
LogManager Namespace


Question Class

[image]

MADCAT Software Developer Guide
Question Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Query message

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public class Question : LogMessage
Visual Basic
Public Class Question _
    Inherits LogMessage
Visual C++
public ref class Question : public LogMessage

Inheritance Hierarchy

System..::..Object
LogManager..::..LogMessage
LogManager..::..Question

See Also

Question Members
LogManager Namespace


Question Members

[image] [image]

MADCAT Software Developer Guide
Question Members
Question Class Constructors Methods Fields See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The Question type exposes the following members.

Constructors

 | Name | Description
Public method | Question | Creates a query with a question and a parameter to get the answer

Methods

 | Name | Description
Public method | ErrorLevel | Gets the criticity in a string (Inherited from LogMessage.)

Fields

 | Name | Description
Public field | ActionName | Name of the action which has generated the message (Inherited from LogMessage.)
Public field | Answer | Value entered by the user to answer a query or acknowledge a confirmation (Inherited from LogMessage.)
Public field | BackColor | Background color to use to display the message in a list view. (Inherited from LogMessage.)
Public field | CaptureDate | Date and time of capture (Inherited from LogMessage.)
Public field | ConsoleOutput | Dump of the console when the message is generated because of an external program action. (Inherited from LogMessage.)
Public field | Displayed | Indicates if the message has been displayed on screen when generated. If true, the user has seen the message and has acknowledged it.. (Inherited from LogMessage.)
Public field | ForeColor | Text color to use to display the message in a list view. (Inherited from LogMessage.)
Public field | Help | Help in relation to the message. Some infos which may help the user to understand the message. (Inherited from LogMessage.)
Public field | ItemID | ID of the Xml Item concerned by the message (Inherited from LogMessage.)
Public field | Level | Criticity of the message (Inherited from LogMessage.)
Public field | LoggedBy | Name of the tool which has generated the message (Inherited from LogMessage.)
Public field | Parameter | Parameter to use to get the user's answer. Used only for query messages. (Inherited from LogMessage.)
Public field | Text | Body of the message (Inherited from LogMessage.)

See Also

Question Class
LogManager Namespace


Question Constructor

[image]

MADCAT Software Developer Guide
Question Constructor
Question Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Creates a query with a question and a parameter to get the answer

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public Question(
    string Text,
    IParameter Param
)
Visual Basic
Public Sub New ( _
    Text As String, _
    Param As IParameter _
)
Visual C++
public:
Question(
    String^ Text,
    IParameter^ Param
)

Parameters

Text
Type: System..::..String
The question
Param
Type: Parameters..::..IParameter
The parameter used to get the answer

See Also

Question Class
Question Members
LogManager Namespace


Question Fields

[image] [image]

MADCAT Software Developer Guide
Question Fields
Question Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The Question type exposes the following members.

Fields

 | Name | Description
Public field | ActionName | Name of the action which has generated the message (Inherited from LogMessage.)
Public field | Answer | Value entered by the user to answer a query or acknowledge a confirmation (Inherited from LogMessage.)
Public field | BackColor | Background color to use to display the message in a list view. (Inherited from LogMessage.)
Public field | CaptureDate | Date and time of capture (Inherited from LogMessage.)
Public field | ConsoleOutput | Dump of the console when the message is generated because of an external program action. (Inherited from LogMessage.)
Public field | Displayed | Indicates if the message has been displayed on screen when generated. If true, the user has seen the message and has acknowledged it.. (Inherited from LogMessage.)
Public field | ForeColor | Text color to use to display the message in a list view. (Inherited from LogMessage.)
Public field | Help | Help in relation to the message. Some infos which may help the user to understand the message. (Inherited from LogMessage.)
Public field | ItemID | ID of the Xml Item concerned by the message (Inherited from LogMessage.)
Public field | Level | Criticity of the message (Inherited from LogMessage.)
Public field | LoggedBy | Name of the tool which has generated the message (Inherited from LogMessage.)
Public field | Parameter | Parameter to use to get the user's answer. Used only for query messages. (Inherited from LogMessage.)
Public field | Text | Body of the message (Inherited from LogMessage.)

See Also

Question Class
LogManager Namespace


Question Methods

[image] [image]

MADCAT Software Developer Guide
Question Methods
Question Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The Question type exposes the following members.

Methods

 | Name | Description
Public method | ErrorLevel | Gets the criticity in a string (Inherited from LogMessage.)

See Also

Question Class
LogManager Namespace


WarningMessage Class

[image]

MADCAT Software Developer Guide
WarningMessage Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Warning message

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public class WarningMessage : LogMessage
Visual Basic
Public Class WarningMessage _
    Inherits LogMessage
Visual C++
public ref class WarningMessage : public LogMessage

Inheritance Hierarchy

System..::..Object
LogManager..::..LogMessage
LogManager..::..WarningMessage

See Also

WarningMessage Members
LogManager Namespace


WarningMessage Members

[image] [image]

MADCAT Software Developer Guide
WarningMessage Members
WarningMessage Class Constructors Methods Fields See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The WarningMessage type exposes the following members.

Constructors

 | Name | Description
Public method | WarningMessage(String) | Creates a warning message with a body.
Public method | WarningMessage(String, XmlNode) | Creates a warning message with a body and an item.
Public method | WarningMessage(String, XmlNode, String) | Creates a warning message with a body, an item and a help.

Methods

 | Name | Description
Public method | ErrorLevel | Gets the criticity in a string (Inherited from LogMessage.)

Fields

 | Name | Description
Public field | ActionName | Name of the action which has generated the message (Inherited from LogMessage.)
Public field | Answer | Value entered by the user to answer a query or acknowledge a confirmation (Inherited from LogMessage.)
Public field | BackColor | Background color to use to display the message in a list view. (Inherited from LogMessage.)
Public field | CaptureDate | Date and time of capture (Inherited from LogMessage.)
Public field | ConsoleOutput | Dump of the console when the message is generated because of an external program action. (Inherited from LogMessage.)
Public field | Displayed | Indicates if the message has been displayed on screen when generated. If true, the user has seen the message and has acknowledged it.. (Inherited from LogMessage.)
Public field | ForeColor | Text color to use to display the message in a list view. (Inherited from LogMessage.)
Public field | Help | Help in relation to the message. Some infos which may help the user to understand the message. (Inherited from LogMessage.)
Public field | ItemID | ID of the Xml Item concerned by the message (Inherited from LogMessage.)
Public field | Level | Criticity of the message (Inherited from LogMessage.)
Public field | LoggedBy | Name of the tool which has generated the message (Inherited from LogMessage.)
Public field | Parameter | Parameter to use to get the user's answer. Used only for query messages. (Inherited from LogMessage.)
Public field | Text | Body of the message (Inherited from LogMessage.)

See Also

WarningMessage Class
LogManager Namespace


WarningMessage Constructor

[image] [image]

MADCAT Software Developer Guide
WarningMessage Constructor
WarningMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | WarningMessage(String) | Creates a warning message with a body.
Public method | WarningMessage(String, XmlNode) | Creates a warning message with a body and an item.
Public method | WarningMessage(String, XmlNode, String) | Creates a warning message with a body, an item and a help.

See Also

WarningMessage Class
WarningMessage Members
LogManager Namespace


WarningMessage Constructor (String)

[image]

MADCAT Software Developer Guide
WarningMessage Constructor (String)
WarningMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Creates a warning message with a body.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public WarningMessage(
    string Text
)
Visual Basic
Public Sub New ( _
    Text As String _
)
Visual C++
public:
WarningMessage(
    String^ Text
)

Parameters

Text
Type: System..::..String
Body of the message

See Also

WarningMessage Class
WarningMessage Members
WarningMessage Overload
LogManager Namespace


WarningMessage Constructor (String, XmlNode)

[image]

MADCAT Software Developer Guide
WarningMessage Constructor (String, XmlNode)
WarningMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Creates a warning message with a body and an item.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public WarningMessage(
    string Text,
    XmlNode Item
)
Visual Basic
Public Sub New ( _
    Text As String, _
    Item As XmlNode _
)
Visual C++
public:
WarningMessage(
    String^ Text,
    XmlNode^ Item
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item concerned by the message. May be null.

See Also

WarningMessage Class
WarningMessage Members
WarningMessage Overload
LogManager Namespace


WarningMessage Constructor (String, XmlNode, String)

[image]

MADCAT Software Developer Guide
WarningMessage Constructor (String, XmlNode, String)
WarningMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Creates a warning message with a body, an item and a help.

Namespace: LogManager
Assembly: LogManager (in LogManager.dll) Version: 1.0.4787.39863

Syntax

C#
public WarningMessage(
    string Text,
    XmlNode Item,
    string Help
)
Visual Basic
Public Sub New ( _
    Text As String, _
    Item As XmlNode, _
    Help As String _
)
Visual C++
public:
WarningMessage(
    String^ Text,
    XmlNode^ Item,
    String^ Help
)

Parameters

Text
Type: System..::..String
Body of the message
Item
Type: System.Xml..::..XmlNode
Xml data of the item concerned by the message. May be null.
Help
Type: System..::..String
Help in relation with the message

See Also

WarningMessage Class
WarningMessage Members
WarningMessage Overload
LogManager Namespace


WarningMessage Fields

[image] [image]

MADCAT Software Developer Guide
WarningMessage Fields
WarningMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The WarningMessage type exposes the following members.

Fields

 | Name | Description
Public field | ActionName | Name of the action which has generated the message (Inherited from LogMessage.)
Public field | Answer | Value entered by the user to answer a query or acknowledge a confirmation (Inherited from LogMessage.)
Public field | BackColor | Background color to use to display the message in a list view. (Inherited from LogMessage.)
Public field | CaptureDate | Date and time of capture (Inherited from LogMessage.)
Public field | ConsoleOutput | Dump of the console when the message is generated because of an external program action. (Inherited from LogMessage.)
Public field | Displayed | Indicates if the message has been displayed on screen when generated. If true, the user has seen the message and has acknowledged it.. (Inherited from LogMessage.)
Public field | ForeColor | Text color to use to display the message in a list view. (Inherited from LogMessage.)
Public field | Help | Help in relation to the message. Some infos which may help the user to understand the message. (Inherited from LogMessage.)
Public field | ItemID | ID of the Xml Item concerned by the message (Inherited from LogMessage.)
Public field | Level | Criticity of the message (Inherited from LogMessage.)
Public field | LoggedBy | Name of the tool which has generated the message (Inherited from LogMessage.)
Public field | Parameter | Parameter to use to get the user's answer. Used only for query messages. (Inherited from LogMessage.)
Public field | Text | Body of the message (Inherited from LogMessage.)

See Also

WarningMessage Class
LogManager Namespace


WarningMessage Methods

[image] [image]

MADCAT Software Developer Guide
WarningMessage Methods
WarningMessage Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The WarningMessage type exposes the following members.

Methods

 | Name | Description
Public method | ErrorLevel | Gets the criticity in a string (Inherited from LogMessage.)

See Also

WarningMessage Class
LogManager Namespace


Parameters Namespace

[image]

MADCAT Software Developer Guide
Parameters Namespace
Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This namespace contains all the classes/interfaces used to manage attributes' values in MADCAT. Each kind of data (string, numeric, date, ...) has a dedicated group of classes which is used to edit, display, filter, sort items using them. The namespace also supports extensions to the base types and provides interfaces to handle any new type of data.

Classes

 | Class | Description
Public class | BaseFilter | Filter for string values. It is the most generic filter. All the filters of the namespace inherit this base class.
Public class | BaseFilterArgs | Arguments of the base filter. The base filter handles only strings.
Public class | BaseFilterForm | Form used to edit the Base Filter's arguments. See BaseFilterArgs.
Public class | BaseParameter | Base class for all parameter classes. Implements all the basic methods and properties needed to handle parameters.
Public class | BitmapDisplayForm | Form used to display the bitmap of a BitmapInput parameter.
Public class | BitmapInput | Used to handle bitmap file names. Controls over a direct preview of the selected file and a dedicated dialog box which selects only compatible bitmap files.
Public class | BooleanFilter | Filter for boolean parameters.
Public class | BooleanFilterArgs | Arguments for the boolean filters.
Public class | BooleanFilterForm | Form used to edit the Boolean Filter's arguments. See BooleanFilterArgs.
Public class | BooleanInput | Used to manage boolean values
Public class | ColorInput | Used to manage colors. User sees the color and can change it by clicking on it as it opens the color picker of Windows.
Public class | DateFilter | Filter for date/time parameters.
Public class | DateFilterArgs | Arguments of the date/time filter.
Public class | DateFilterForm | Form used to edit the Date/Time Filter's arguments. See DateFilterArgs.
Public class | DateInput | Used to manage date/time values in MADCAT.
Public class | DateSorter | Used to compare 2 date/time values.
Public class | DirectoryInput | Used to manage paths of directories of the host's filesystem.
Public class | EnumFilter | Filter for enumeration parameters.
Public class | EnumFilterArgs | Arguments of the filter for enumerate values
Public class | EnumFilterForm | Form used to edit the Enumeration Filter's arguments. See EnumFilterArgs.
Public class | EnumInput | Manages parameters which handle enumerate values
Public class | EnumValue | One possible value of a enumerated parameter
Public class | FileInput | Class used to create parameters which manage files
Public class | GroupOfFields | Manages group of parameters. This parameter doesn't actually store any value but can manage the display of several parameters inside a specific panel
Public class | IPAddrInput | Used to managed parameters which handle IP addresses
Public class | NumericFilter | Class used to filter items on numeric parameters
Public class | NumericFilterArgs | Arguments for the NumericFilter objects
Public class | NumericFilterForm | Form used to edit the Numeric Filter's arguments. See NumericFilterArgs.
Public class | NumericInput | Class used to manage numeric values in MADCAT. Numeric values may be integers or floats
Public class | NumericSorter | Class used to sort numeric values of NumericInput parameters
Public class | ParametersManager | Main class to use to manage parameters. It has methods which can build any parameter for MADCAT, use filters and sorters and also manage parameters' values. This is the main entry point for parameters.
Public class | ParameterValueChangedEventArgs | Arguments of the event ParameterValueChanged.

Interfaces

 | Interface | Description
Public interface | IFilter | Interface which shall be exposed by any parameter not using the standard string filter
Public interface | IParameter | Interface exposed by any type handler of MADCAT. A type handler is used to manage one parameter in MADCAT GUI.
Public interface | IPlottingServices | Interface for plotting services of the parameters. Parameters which can be plotted in charts (graphical series) shall expose this interface to provide conversion methods between parameter's values and global float coordinates.

Delegates

 | Delegate | Description
Public delegate | BitmapHandler | Delegate used to invoke Bitmap handlers. Bitmap handlers produce bitmap which are placed inside the cells of the listview renderer of MADCAT in details mode.
Public delegate | ParameterValueChangedEventHandler | Delegate used to invoke handlers for the ParameterValueChanged event fired when a parameter value changes.
Public delegate | StringHandler | Delegate used to invoke String handlers. String handlers produce human-readable strings which are placed inside the cells of the listview renderer of MADCAT in details mode. to be used when the value stored in the database is not human-readable.
Public delegate | XmlHandler | Delegate used to invoke XML handlers. XML handlers produce XML strings which are placed inside the XML reports of MADCAT.

Enumerations

 | Enumeration | Description
Public enumeration | BaseFilterMode | Modes of the base filter. The base filter handles only strings.
Public enumeration | BooleanDisplayTypes | Type of controls available for the Boolean Input
Public enumeration | DataToolTypes | Types of the base parameters
Public enumeration | DateFilterMode | Modes of the date/time filter
Public enumeration | EnumControlTypes | Type of controls available for the Enumerate Input
Public enumeration | EnumFilterMode | Modes of the filter for enumerate values
Public enumeration | GaugeType | Types of gauge when display mode of a parameter is Gauge. See NumericDisplay.
Public enumeration | LedColors | Available colors for the led of the Boolean Input
Public enumeration | NumericButtonCursor | Types of cursors to point the value of the button for numeric parameters
Public enumeration | NumericButtonType | Types of button for numeric parameters
Public enumeration | NumericDisplay | Display modes for numeric parameters
Public enumeration | NumericFilterMode | Modes of the filter for numeric values


BaseFilter Class

[image]

MADCAT Software Developer Guide
BaseFilter Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Filter for string values. It is the most generic filter. All the filters of the namespace inherit this base class.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public class BaseFilter : IFilter
Visual Basic
Public Class BaseFilter _
    Implements IFilter
Visual C++
public ref class BaseFilter : IFilter

Inheritance Hierarchy

System..::..Object
Parameters..::..BaseFilter

See Also

BaseFilter Members
Parameters Namespace


BaseFilter Members

[image] [image]

MADCAT Software Developer Guide
BaseFilter Members
BaseFilter Class Constructors Methods Properties See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BaseFilter type exposes the following members.

Constructors

 | Name | Description
Public method | BaseFilter | Constructor

Methods

 | Name | Description
Public method | GetTypeOptions | Not implemented. Reserved.
Public method | IsMatch | The filter function.

Properties

 | Name | Description
Public property | Args | Gets the arguments of the filter.
Public property | CaseSensitive | Gets/sets the mode of the filter. Overrides the filter arguments. See MatchCase.
Public property | Form | Gets the form to use to edit the arguments of the filter.
Public property | IsActive | Indicates if the filter is active or not.
Public property | Type | Gets the base type of the filter. This is the one given to the constructor of the class.
Public property | UseRegularExpression | Gets/sets the mode of the filter. Overrides the filter arguments. See UseRegExp.
Public property | XPathCondition | Gets the condition string of the filter's arguments. See Condition.

See Also

BaseFilter Class
Parameters Namespace


BaseFilter Constructor

[image]

MADCAT Software Developer Guide
BaseFilter Constructor
BaseFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public BaseFilter(
    DataToolTypes type
)
Visual Basic
Public Sub New ( _
    type As DataToolTypes _
)
Visual C++
public:
BaseFilter(
    DataToolTypes type
)

Parameters

type
Type: Parameters..::..DataToolTypes
Type of data which is handle by the filter. It is needed because several base types uses the same class to manage filtering : Text (CMN_Text) and Strings (CMN_String).

See Also

BaseFilter Class
BaseFilter Members
Parameters Namespace


BaseFilter Methods

[image] [image]

MADCAT Software Developer Guide
BaseFilter Methods
BaseFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BaseFilter type exposes the following members.

Methods

 | Name | Description
Public method | GetTypeOptions | Not implemented. Reserved.
Public method | IsMatch | The filter function.

See Also

BaseFilter Class
Parameters Namespace


GetTypeOptions Method

[image]

MADCAT Software Developer Guide
BaseFilter..::..GetTypeOptions Method
BaseFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Not implemented. Reserved.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual void GetTypeOptions(
    Hashtable opt
)
Visual Basic
Public Overridable Sub GetTypeOptions ( _
    opt As Hashtable _
)
Visual C++
public:
virtual void GetTypeOptions(
    Hashtable^ opt
)

Parameters

opt
Type: System.Collections..::..Hashtable
Not implemented

Implements

IFilter..::..GetTypeOptions(Hashtable)

See Also

BaseFilter Class
BaseFilter Members
Parameters Namespace


IsMatch Method

[image]

MADCAT Software Developer Guide
BaseFilter..::..IsMatch Method
BaseFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
The filter function.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual bool IsMatch(
    string value
)
Visual Basic
Public Overridable Function IsMatch ( _
    value As String _
) As Boolean
Visual C++
public:
virtual bool IsMatch(
    String^ value
)

Parameters

value
Type: System..::..String
Value to test

Return Value

True if the given string matches the filter's arguments.

Implements

IFilter..::..IsMatch(String)

See Also

BaseFilter Class
BaseFilter Members
Parameters Namespace


BaseFilter Properties

[image] [image]

MADCAT Software Developer Guide
BaseFilter Properties
BaseFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BaseFilter type exposes the following members.

Properties

 | Name | Description
Public property | Args | Gets the arguments of the filter.
Public property | CaseSensitive | Gets/sets the mode of the filter. Overrides the filter arguments. See MatchCase.
Public property | Form | Gets the form to use to edit the arguments of the filter.
Public property | IsActive | Indicates if the filter is active or not.
Public property | Type | Gets the base type of the filter. This is the one given to the constructor of the class.
Public property | UseRegularExpression | Gets/sets the mode of the filter. Overrides the filter arguments. See UseRegExp.
Public property | XPathCondition | Gets the condition string of the filter's arguments. See Condition.

See Also

BaseFilter Class
Parameters Namespace


Args Property

[image]

MADCAT Software Developer Guide
BaseFilter..::..Args Property
BaseFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the arguments of the filter.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual Object Args { get; set; }
Visual Basic
Public Overridable Property Args As Object
    Get
    Set
Visual C++
public:
virtual property Object^ Args {
    Object^ get ();
    void set (Object^ value);
}

Implements

IFilter..::..Args

See Also

BaseFilter Class
BaseFilter Members
Parameters Namespace


CaseSensitive Property

[image]

MADCAT Software Developer Guide
BaseFilter..::..CaseSensitive Property
BaseFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/sets the mode of the filter. Overrides the filter arguments. See MatchCase.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public bool CaseSensitive { get; set; }
Visual Basic
Public Property CaseSensitive As Boolean
    Get
    Set
Visual C++
public:
property bool CaseSensitive {
    bool get ();
    void set (bool value);
}

See Also

BaseFilter Class
BaseFilter Members
Parameters Namespace


Form Property

[image]

MADCAT Software Developer Guide
BaseFilter..::..Form Property
BaseFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the form to use to edit the arguments of the filter.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual Control Form { get; }
Visual Basic
Public Overridable ReadOnly Property Form As Control
    Get
Visual C++
public:
virtual property Control^ Form {
    Control^ get ();
}

Implements

IFilter..::..Form

See Also

BaseFilter Class
BaseFilter Members
Parameters Namespace


IsActive Property

[image]

MADCAT Software Developer Guide
BaseFilter..::..IsActive Property
BaseFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Indicates if the filter is active or not.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual bool IsActive { get; }
Visual Basic
Public Overridable ReadOnly Property IsActive As Boolean
    Get
Visual C++
public:
virtual property bool IsActive {
    bool get ();
}

Implements

IFilter..::..IsActive

See Also

BaseFilter Class
BaseFilter Members
Parameters Namespace


Type Property

[image]

MADCAT Software Developer Guide
BaseFilter..::..Type Property
BaseFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the base type of the filter. This is the one given to the constructor of the class.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual DataToolTypes Type { get; }
Visual Basic
Public Overridable ReadOnly Property Type As DataToolTypes
    Get
Visual C++
public:
virtual property DataToolTypes Type {
    DataToolTypes get ();
}

Implements

IFilter..::..Type

See Also

BaseFilter Class
BaseFilter Members
Parameters Namespace


UseRegularExpression Property

[image]

MADCAT Software Developer Guide
BaseFilter..::..UseRegularExpression Property
BaseFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/sets the mode of the filter. Overrides the filter arguments. See UseRegExp.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public bool UseRegularExpression { get; set; }
Visual Basic
Public Property UseRegularExpression As Boolean
    Get
    Set
Visual C++
public:
property bool UseRegularExpression {
    bool get ();
    void set (bool value);
}

See Also

BaseFilter Class
BaseFilter Members
Parameters Namespace


XPathCondition Property

[image]

MADCAT Software Developer Guide
BaseFilter..::..XPathCondition Property
BaseFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the condition string of the filter's arguments. See Condition.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual string XPathCondition { get; }
Visual Basic
Public Overridable ReadOnly Property XPathCondition As String
    Get
Visual C++
public:
virtual property String^ XPathCondition {
    String^ get ();
}

Implements

IFilter..::..XPathCondition

See Also

BaseFilter Class
BaseFilter Members
Parameters Namespace


BaseFilterArgs Class

[image]

MADCAT Software Developer Guide
BaseFilterArgs Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Arguments of the base filter. The base filter handles only strings.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
[SerializableAttribute]
public class BaseFilterArgs
Visual Basic
<SerializableAttribute> _
Public Class BaseFilterArgs
Visual C++
[SerializableAttribute]
public ref class BaseFilterArgs

Inheritance Hierarchy

System..::..Object
Parameters..::..BaseFilterArgs

See Also

BaseFilterArgs Members
Parameters Namespace


BaseFilterArgs Members

[image] [image]

MADCAT Software Developer Guide
BaseFilterArgs Members
BaseFilterArgs Class Constructors Fields See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BaseFilterArgs type exposes the following members.

Constructors

 | Name | Description
Public method | BaseFilterArgs | Constructor of the base filter. By default, filter accepts any string.

Fields

 | Name | Description
Public field | Condition | Filter's string. Used when Mode is MatchString
Public field | MatchCase | When true, the filter is case sensitive
Public field | Mode | Mode of the filter
Public field | UseRegExp | When true, the filter's string may contain regular expressions. Used when Mode is MatchString

See Also

BaseFilterArgs Class
Parameters Namespace


BaseFilterArgs Constructor

[image]

MADCAT Software Developer Guide
BaseFilterArgs Constructor
BaseFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor of the base filter. By default, filter accepts any string.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public BaseFilterArgs()
Visual Basic
Public Sub New
Visual C++
public:
BaseFilterArgs()

See Also

BaseFilterArgs Class
BaseFilterArgs Members
Parameters Namespace


BaseFilterArgs Fields

[image] [image]

MADCAT Software Developer Guide
BaseFilterArgs Fields
BaseFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BaseFilterArgs type exposes the following members.

Fields

 | Name | Description
Public field | Condition | Filter's string. Used when Mode is MatchString
Public field | MatchCase | When true, the filter is case sensitive
Public field | Mode | Mode of the filter
Public field | UseRegExp | When true, the filter's string may contain regular expressions. Used when Mode is MatchString

See Also

BaseFilterArgs Class
Parameters Namespace


Condition Field

[image]

MADCAT Software Developer Guide
BaseFilterArgs..::..Condition Field
BaseFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Filter's string. Used when Mode is MatchString

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public string Condition
Visual Basic
Public Condition As String
Visual C++
public:
String^ Condition

See Also

BaseFilterArgs Class
BaseFilterArgs Members
Parameters Namespace


MatchCase Field

[image]

MADCAT Software Developer Guide
BaseFilterArgs..::..MatchCase Field
BaseFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
When true, the filter is case sensitive

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public bool MatchCase
Visual Basic
Public MatchCase As Boolean
Visual C++
public:
bool MatchCase

See Also

BaseFilterArgs Class
BaseFilterArgs Members
Parameters Namespace


Mode Field

[image]

MADCAT Software Developer Guide
BaseFilterArgs..::..Mode Field
BaseFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Mode of the filter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public BaseFilterMode Mode
Visual Basic
Public Mode As BaseFilterMode
Visual C++
public:
BaseFilterMode Mode

See Also

BaseFilterArgs Class
BaseFilterArgs Members
Parameters Namespace


UseRegExp Field

[image]

MADCAT Software Developer Guide
BaseFilterArgs..::..UseRegExp Field
BaseFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
When true, the filter's string may contain regular expressions. Used when Mode is MatchString

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public bool UseRegExp
Visual Basic
Public UseRegExp As Boolean
Visual C++
public:
bool UseRegExp

See Also

BaseFilterArgs Class
BaseFilterArgs Members
Parameters Namespace


BaseFilterForm Class

[image]

MADCAT Software Developer Guide
BaseFilterForm Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Form used to edit the Base Filter's arguments. See BaseFilterArgs.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public class BaseFilterForm : Form
Visual Basic
Public Class BaseFilterForm _
    Inherits Form
Visual C++
public ref class BaseFilterForm : public Form

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
Parameters..::..BaseFilterForm

See Also

BaseFilterForm Members
Parameters Namespace


BaseFilterForm Members

[image] [image]

MADCAT Software Developer Guide
BaseFilterForm Members
BaseFilterForm Class Constructors See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BaseFilterForm type exposes the following members.

Constructors

 | Name | Description
Public method | BaseFilterForm | Constructor

See Also

BaseFilterForm Class
Parameters Namespace


BaseFilterForm Constructor

[image]

MADCAT Software Developer Guide
BaseFilterForm Constructor
BaseFilterForm Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public BaseFilterForm(
    BaseFilterArgs filter
)
Visual Basic
Public Sub New ( _
    filter As BaseFilterArgs _
)
Visual C++
public:
BaseFilterForm(
    BaseFilterArgs^ filter
)

Parameters

filter
Type: Parameters..::..BaseFilterArgs
Arguments of the filter

See Also

BaseFilterForm Class
BaseFilterForm Members
Parameters Namespace


BaseFilterMode Enumeration

[image]

MADCAT Software Developer Guide
BaseFilterMode Enumeration
See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Modes of the base filter. The base filter handles only strings.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
[SerializableAttribute]
public enum BaseFilterMode
Visual Basic
<SerializableAttribute> _
Public Enumeration BaseFilterMode
Visual C++
[SerializableAttribute]
public enum class BaseFilterMode

Members

Member name | Value | Description
Deactivated | 3 | Filter accepts all strings
NotEmpty | 1 | Filter accepts strings which are not empty
MatchString | 0 | Filter accepts strings which match the filter's string
Empty | 2 | Filter accepts strings which are empty

See Also

Parameters Namespace


BaseParameter Class

[image]

MADCAT Software Developer Guide
BaseParameter Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Base class for all parameter classes. Implements all the basic methods and properties needed to handle parameters.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public class BaseParameter : IParameter
Visual Basic
Public Class BaseParameter _
    Implements IParameter
Visual C++
public ref class BaseParameter : IParameter

Inheritance Hierarchy

System..::..Object
Parameters..::..BaseParameter
Parameters..::..BitmapInput
Parameters..::..BooleanInput
Parameters..::..ColorInput
Parameters..::..DateInput
Parameters..::..DirectoryInput
Parameters..::..EnumInput
Parameters..::..FileInput
Parameters..::..GroupOfFields
Parameters..::..IPAddrInput
Parameters..::..NumericInput

See Also

BaseParameter Members
Parameters Namespace


BaseParameter Members

[image] [image]

MADCAT Software Developer Guide
BaseParameter Members
BaseParameter Class Constructors Methods Properties Events See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BaseParameter type exposes the following members.

Constructors

 | Name | Description
Public method | BaseParameter()()()() | Default constructor
Public method | BaseParameter(String) | Constructor which initializes the value with a given string

Methods

 | Name | Description
Public method | BuildHTMLString | Gives the HTML code used to render the input field in HTML instead of Windows form control
Public method | BuildLabel | Gives the Windows Form control for the label of the input field of the parameter
Public method | Clone | Clones the parameter object into a new parameter object
 | HTMLToColor | Gets the color value from a color encoded into HTML form : #RRGGBB
Public method | RestoreValueFromItem | Gets the value of the parameter from a given project's Item
Public method | SaveValueInItem | Saves the value of the parameter into a given project's Item

Properties

Name Description
Public property ContextMenu
Property used by MADCAT to get the context menu of the parameter
Public property Description
Property used by MADCAT to get/set the description of the parameter
Public property DisplayOnly
Property used by MADCAT to set the access mode of the parameter
Public property DrawHandler
Property used by MADCAT to get the Bitmap handler of the parameter
Public property FormControl
Property used by MADCAT to get Form Control of the parameter. The Form Control shall take into account dynamically the values provided by MADCAT through the following properties :
  • IsMandatory
  • DisplayOnly
  • UserSettings
  • Options
  • Value
Public property HasChanged
Property used by MADCAT to check if the parameter has changed
Public property Hint
Property used by MADCAT to get/set the tip of the parameter. The tip contains a short help which popups when the user moves his mouse cursor over the parameter's name
Public property IsMandatory
Property used by MADCAT to indicate if the parameter is mandatory or not. When mandatory, the user must give a value to the parameter to continue his current operation.
Public property IsUndefined
Property used by MADCAT to check if the parameter has been set by the user or not
Public property MaxNumberOfChars
Gets/sets the maximum number of characters of the parameter's value
Public property Name
Property used by MADCAT to get/set the name of the parameter
Public property NumberOfLines
Gets/sets the number of lines visible in the text box of the parameter
Public property Options
Property used by MADCAT to get/set the options of the parameter. Common options are (applicable to all parameters):
  • mandatory=b : where b is 'yes' or 'no'. Indicates if the parameter must be filled by the user
  • readonly=b : where b is 'yes' or 'no'. Indicates if the parameter can be modified by the user
BaseParameter options are :
  • lines=999 : where 999 is the number of visible lines in the text box of the parameter
  • length=999 : where 999 is the maximum number of characters of the parameter's value
Public property Tag
Gets/sets the Tag property of the parameter's control object
Public property TextHandler
Property used by MADCAT to get the String handler of the parameter
Public property Tip
Property used by MADCAT to get/set the ToolTip object for the Form Control of the parameter
Public property Type
Property used by MADCAT to get the core type of the parameter
Public property TypeName
Gets the name of the type of the parameter as it is coded in the attribute TYPE of the parameter's Xml definition (ATTRIBUTE element definition) It is the core type's name of the parameter
Public property UserSettings
Property used by MADCAT to get/set the user settings of the parameter
Public property Value
Property used by MADCAT to get/set the value of the parameter
Public property XmlDefinition
Property used by MADCAT to get/set the XML definition of the parameter. Definition must be compliant with the schema MODELS.XSD
Public property XmlNodeHandler
Property used by MADCAT to get the XML handler of the parameter

Events

 | Name | Description
Public event | ValueChanged | Fired when the value of the parameter changes

See Also

BaseParameter Class
Parameters Namespace


BaseParameter Constructor

[image] [image]

MADCAT Software Developer Guide
BaseParameter Constructor
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | BaseParameter()()()() | Default constructor
Public method | BaseParameter(String) | Constructor which initializes the value with a given string

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


BaseParameter Constructor

[image]

MADCAT Software Developer Guide
BaseParameter Constructor
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Default constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public BaseParameter()
Visual Basic
Public Sub New
Visual C++
public:
BaseParameter()

See Also

BaseParameter Class
BaseParameter Members
BaseParameter Overload
Parameters Namespace


BaseParameter Constructor (String)

[image]

MADCAT Software Developer Guide
BaseParameter Constructor (String)
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor which initializes the value with a given string

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public BaseParameter(
    string initValue
)
Visual Basic
Public Sub New ( _
    initValue As String _
)
Visual C++
public:
BaseParameter(
    String^ initValue
)

Parameters

initValue
Type: System..::..String
Initial value of the parameter

See Also

BaseParameter Class
BaseParameter Members
BaseParameter Overload
Parameters Namespace


BaseParameter Methods

[image] [image]

MADCAT Software Developer Guide
BaseParameter Methods
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BaseParameter type exposes the following members.

Methods

 | Name | Description
Public method | BuildHTMLString | Gives the HTML code used to render the input field in HTML instead of Windows form control
Public method | BuildLabel | Gives the Windows Form control for the label of the input field of the parameter
Public method | Clone | Clones the parameter object into a new parameter object
 | HTMLToColor | Gets the color value from a color encoded into HTML form : #RRGGBB
Public method | RestoreValueFromItem | Gets the value of the parameter from a given project's Item
Public method | SaveValueInItem | Saves the value of the parameter into a given project's Item

See Also

BaseParameter Class
Parameters Namespace


BuildHTMLString Method

[image]

MADCAT Software Developer Guide
BaseParameter..::..BuildHTMLString Method
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gives the HTML code used to render the input field in HTML instead of Windows form control

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual string BuildHTMLString()
Visual Basic
Public Overridable Function BuildHTMLString As String
Visual C++
public:
virtual String^ BuildHTMLString()

Return Value

The HTML code equivalent to the Windows Form Control

Implements

IParameter..::..BuildHTMLString()()()()

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


BuildLabel Method

[image]

MADCAT Software Developer Guide
BaseParameter..::..BuildLabel Method
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gives the Windows Form control for the label of the input field of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual Control BuildLabel(
    string TypeFace,
    FontStyle Style,
    ushort Size
)
Visual Basic
Public Overridable Function BuildLabel ( _
    TypeFace As String, _
    Style As FontStyle, _
    Size As UShort _
) As Control
Visual C++
public:
virtual Control^ BuildLabel(
    String^ TypeFace,
    FontStyle Style,
    unsigned short Size
)

Parameters

TypeFace
Type: System..::..String
Font to use to build the label
Style
Type: System.Drawing..::..FontStyle
Font style to use to build the label
Size
Type: System..::..UInt16
Font size to use to build the label

Return Value

A Label object which contains the name of the parameter

Implements

IParameter..::..BuildLabel(String, FontStyle, UInt16)

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


Clone Method

[image]

MADCAT Software Developer Guide
BaseParameter..::..Clone Method
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Clones the parameter object into a new parameter object

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual Object Clone()
Visual Basic
Public Overridable Function Clone As Object
Visual C++
public:
virtual Object^ Clone()

Return Value

A clone of the current object

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


HTMLToColor Method

[image]

MADCAT Software Developer Guide
BaseParameter..::..HTMLToColor Method
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the color value from a color encoded into HTML form : #RRGGBB

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public static Color HTMLToColor(
    string HTMLValue
)
Visual Basic
Public Shared Function HTMLToColor ( _
    HTMLValue As String _
) As Color
Visual C++
public:
static Color HTMLToColor(
    String^ HTMLValue
)

Parameters

HTMLValue
Type: System..::..String
HTML format of the color (#RRGGBB)

Return Value

Color code

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


RestoreValueFromItem Method

[image]

MADCAT Software Developer Guide
BaseParameter..::..RestoreValueFromItem Method
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the value of the parameter from a given project's Item

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual void RestoreValueFromItem(
    XmlNode item
)
Visual Basic
Public Overridable Sub RestoreValueFromItem ( _
    item As XmlNode _
)
Visual C++
public:
virtual void RestoreValueFromItem(
    XmlNode^ item
)

Parameters

item
Type: System.Xml..::..XmlNode
XML node where the attribute's value shall be used to set the parameter's value

Implements

IParameter..::..RestoreValueFromItem(XmlNode)

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


SaveValueInItem Method

[image]

MADCAT Software Developer Guide
BaseParameter..::..SaveValueInItem Method
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Saves the value of the parameter into a given project's Item

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual void SaveValueInItem(
    XmlNode item
)
Visual Basic
Public Overridable Sub SaveValueInItem ( _
    item As XmlNode _
)
Visual C++
public:
virtual void SaveValueInItem(
    XmlNode^ item
)

Parameters

item
Type: System.Xml..::..XmlNode
XML node where the parameter's value shall be stored into as an attribute's value

Implements

IParameter..::..SaveValueInItem(XmlNode)

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


BaseParameter Properties

[image] [image]

MADCAT Software Developer Guide
BaseParameter Properties
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BaseParameter type exposes the following members.

Properties

Name Description
Public property ContextMenu
Property used by MADCAT to get the context menu of the parameter
Public property Description
Property used by MADCAT to get/set the description of the parameter
Public property DisplayOnly
Property used by MADCAT to set the access mode of the parameter
Public property DrawHandler
Property used by MADCAT to get the Bitmap handler of the parameter
Public property FormControl
Property used by MADCAT to get Form Control of the parameter. The Form Control shall take into account dynamically the values provided by MADCAT through the following properties :
  • IsMandatory
  • DisplayOnly
  • UserSettings
  • Options
  • Value
Public property HasChanged
Property used by MADCAT to check if the parameter has changed
Public property Hint
Property used by MADCAT to get/set the tip of the parameter. The tip contains a short help which popups when the user moves his mouse cursor over the parameter's name
Public property IsMandatory
Property used by MADCAT to indicate if the parameter is mandatory or not. When mandatory, the user must give a value to the parameter to continue his current operation.
Public property IsUndefined
Property used by MADCAT to check if the parameter has been set by the user or not
Public property MaxNumberOfChars
Gets/sets the maximum number of characters of the parameter's value
Public property Name
Property used by MADCAT to get/set the name of the parameter
Public property NumberOfLines
Gets/sets the number of lines visible in the text box of the parameter
Public property Options
Property used by MADCAT to get/set the options of the parameter. Common options are (applicable to all parameters):
  • mandatory=b : where b is 'yes' or 'no'. Indicates if the parameter must be filled by the user
  • readonly=b : where b is 'yes' or 'no'. Indicates if the parameter can be modified by the user
BaseParameter options are :
  • lines=999 : where 999 is the number of visible lines in the text box of the parameter
  • length=999 : where 999 is the maximum number of characters of the parameter's value
Public property Tag
Gets/sets the Tag property of the parameter's control object
Public property TextHandler
Property used by MADCAT to get the String handler of the parameter
Public property Tip
Property used by MADCAT to get/set the ToolTip object for the Form Control of the parameter
Public property Type
Property used by MADCAT to get the core type of the parameter
Public property TypeName
Gets the name of the type of the parameter as it is coded in the attribute TYPE of the parameter's Xml definition (ATTRIBUTE element definition) It is the core type's name of the parameter
Public property UserSettings
Property used by MADCAT to get/set the user settings of the parameter
Public property Value
Property used by MADCAT to get/set the value of the parameter
Public property XmlDefinition
Property used by MADCAT to get/set the XML definition of the parameter. Definition must be compliant with the schema MODELS.XSD
Public property XmlNodeHandler
Property used by MADCAT to get the XML handler of the parameter

See Also

BaseParameter Class
Parameters Namespace


ContextMenu Property

[image]

MADCAT Software Developer Guide
BaseParameter..::..ContextMenu Property
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get the context menu of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual ContextMenuStrip ContextMenu { get; }
Visual Basic
Public Overridable ReadOnly Property ContextMenu As ContextMenuStrip
    Get
Visual C++
public:
virtual property ContextMenuStrip^ ContextMenu {
    ContextMenuStrip^ get ();
}

Implements

IParameter..::..ContextMenu

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


Description Property

[image]

MADCAT Software Developer Guide
BaseParameter..::..Description Property
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the description of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual string Description { get; set; }
Visual Basic
Public Overridable Property Description As String
    Get
    Set
Visual C++
public:
virtual property String^ Description {
    String^ get ();
    void set (String^ value);
}

Implements

IParameter..::..Description

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


DisplayOnly Property

[image]

MADCAT Software Developer Guide
BaseParameter..::..DisplayOnly Property
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to set the access mode of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual bool DisplayOnly { get; set; }
Visual Basic
Public Overridable Property DisplayOnly As Boolean
    Get
    Set
Visual C++
public:
virtual property bool DisplayOnly {
    bool get ();
    void set (bool value);
}

Implements

IParameter..::..DisplayOnly

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


DrawHandler Property

[image]

MADCAT Software Developer Guide
BaseParameter..::..DrawHandler Property
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get the Bitmap handler of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual BitmapHandler DrawHandler { get; }
Visual Basic
Public Overridable ReadOnly Property DrawHandler As BitmapHandler
    Get
Visual C++
public:
virtual property BitmapHandler^ DrawHandler {
    BitmapHandler^ get ();
}

Implements

IParameter..::..DrawHandler

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


FormControl Property

[image]

MADCAT Software Developer Guide
BaseParameter..::..FormControl Property
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get Form Control of the parameter. The Form Control shall take into account dynamically the values provided by MADCAT through the following properties :
  • IsMandatory
  • DisplayOnly
  • UserSettings
  • Options
  • Value

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual Control FormControl { get; }
Visual Basic
Public Overridable ReadOnly Property FormControl As Control
    Get
Visual C++
public:
virtual property Control^ FormControl {
    Control^ get ();
}

Implements

IParameter..::..FormControl

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


HasChanged Property

[image]

MADCAT Software Developer Guide
BaseParameter..::..HasChanged Property
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to check if the parameter has changed

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual bool HasChanged { get; }
Visual Basic
Public Overridable ReadOnly Property HasChanged As Boolean
    Get
Visual C++
public:
virtual property bool HasChanged {
    bool get ();
}

Implements

IParameter..::..HasChanged

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


Hint Property

[image]

MADCAT Software Developer Guide
BaseParameter..::..Hint Property
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the tip of the parameter. The tip contains a short help which popups when the user moves his mouse cursor over the parameter's name

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual string Hint { get; set; }
Visual Basic
Public Overridable Property Hint As String
    Get
    Set
Visual C++
public:
virtual property String^ Hint {
    String^ get ();
    void set (String^ value);
}

Implements

IParameter..::..Hint

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


IsMandatory Property

[image]

MADCAT Software Developer Guide
BaseParameter..::..IsMandatory Property
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to indicate if the parameter is mandatory or not. When mandatory, the user must give a value to the parameter to continue his current operation.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual bool IsMandatory { get; set; }
Visual Basic
Public Overridable Property IsMandatory As Boolean
    Get
    Set
Visual C++
public:
virtual property bool IsMandatory {
    bool get ();
    void set (bool value);
}

Implements

IParameter..::..IsMandatory

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


IsUndefined Property

[image]

MADCAT Software Developer Guide
BaseParameter..::..IsUndefined Property
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to check if the parameter has been set by the user or not

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual bool IsUndefined { get; }
Visual Basic
Public Overridable ReadOnly Property IsUndefined As Boolean
    Get
Visual C++
public:
virtual property bool IsUndefined {
    bool get ();
}

Implements

IParameter..::..IsUndefined

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


MaxNumberOfChars Property

[image]

MADCAT Software Developer Guide
BaseParameter..::..MaxNumberOfChars Property
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/sets the maximum number of characters of the parameter's value

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public int MaxNumberOfChars { get; set; }
Visual Basic
Public Property MaxNumberOfChars As Integer
    Get
    Set
Visual C++
public:
property int MaxNumberOfChars {
    int get ();
    void set (int value);
}

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


Name Property

[image]

MADCAT Software Developer Guide
BaseParameter..::..Name Property
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the name of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual string Name { get; set; }
Visual Basic
Public Overridable Property Name As String
    Get
    Set
Visual C++
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}

Implements

IParameter..::..Name

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


NumberOfLines Property

[image]

MADCAT Software Developer Guide
BaseParameter..::..NumberOfLines Property
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/sets the number of lines visible in the text box of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public int NumberOfLines { get; set; }
Visual Basic
Public Property NumberOfLines As Integer
    Get
    Set
Visual C++
public:
property int NumberOfLines {
    int get ();
    void set (int value);
}

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


Options Property

[image]

MADCAT Software Developer Guide
BaseParameter..::..Options Property
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the options of the parameter. Common options are (applicable to all parameters):
  • mandatory=b : where b is 'yes' or 'no'. Indicates if the parameter must be filled by the user
  • readonly=b : where b is 'yes' or 'no'. Indicates if the parameter can be modified by the user
BaseParameter options are :
  • lines=999 : where 999 is the number of visible lines in the text box of the parameter
  • length=999 : where 999 is the maximum number of characters of the parameter's value

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual Hashtable Options { get; set; }
Visual Basic
Public Overridable Property Options As Hashtable
    Get
    Set
Visual C++
public:
virtual property Hashtable^ Options {
    Hashtable^ get ();
    void set (Hashtable^ value);
}

Implements

IParameter..::..Options

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


Tag Property

[image]

MADCAT Software Developer Guide
BaseParameter..::..Tag Property
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/sets the Tag property of the parameter's control object

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual Object Tag { get; set; }
Visual Basic
Public Overridable Property Tag As Object
    Get
    Set
Visual C++
public:
virtual property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


TextHandler Property

[image]

MADCAT Software Developer Guide
BaseParameter..::..TextHandler Property
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get the String handler of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual StringHandler TextHandler { get; }
Visual Basic
Public Overridable ReadOnly Property TextHandler As StringHandler
    Get
Visual C++
public:
virtual property StringHandler^ TextHandler {
    StringHandler^ get ();
}

Implements

IParameter..::..TextHandler

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


Tip Property

[image]

MADCAT Software Developer Guide
BaseParameter..::..Tip Property
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the ToolTip object for the Form Control of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual ToolTip Tip { get; set; }
Visual Basic
Public Overridable Property Tip As ToolTip
    Get
    Set
Visual C++
public:
virtual property ToolTip^ Tip {
    ToolTip^ get ();
    void set (ToolTip^ value);
}

Implements

IParameter..::..Tip

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


Type Property

[image]

MADCAT Software Developer Guide
BaseParameter..::..Type Property
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get the core type of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual DataToolTypes Type { get; }
Visual Basic
Public Overridable ReadOnly Property Type As DataToolTypes
    Get
Visual C++
public:
virtual property DataToolTypes Type {
    DataToolTypes get ();
}

Implements

IParameter..::..Type

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


TypeName Property

[image]

MADCAT Software Developer Guide
BaseParameter..::..TypeName Property
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the name of the type of the parameter as it is coded in the attribute TYPE of the parameter's Xml definition (ATTRIBUTE element definition) It is the core type's name of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual string TypeName { get; }
Visual Basic
Public Overridable ReadOnly Property TypeName As String
    Get
Visual C++
public:
virtual property String^ TypeName {
    String^ get ();
}

Implements

IParameter..::..TypeName

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


UserSettings Property

[image]

MADCAT Software Developer Guide
BaseParameter..::..UserSettings Property
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the user settings of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual Object UserSettings { get; set; }
Visual Basic
Public Overridable Property UserSettings As Object
    Get
    Set
Visual C++
public:
virtual property Object^ UserSettings {
    Object^ get ();
    void set (Object^ value);
}

Implements

IParameter..::..UserSettings

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


Value Property

[image]

MADCAT Software Developer Guide
BaseParameter..::..Value Property
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the value of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual string Value { get; set; }
Visual Basic
Public Overridable Property Value As String
    Get
    Set
Visual C++
public:
virtual property String^ Value {
    String^ get ();
    void set (String^ value);
}

Implements

IParameter..::..Value

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


XmlDefinition Property

[image]

MADCAT Software Developer Guide
BaseParameter..::..XmlDefinition Property
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the XML definition of the parameter. Definition must be compliant with the schema MODELS.XSD

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual XmlNode XmlDefinition { get; set; }
Visual Basic
Public Overridable Property XmlDefinition As XmlNode
    Get
    Set
Visual C++
public:
virtual property XmlNode^ XmlDefinition {
    XmlNode^ get ();
    void set (XmlNode^ value);
}

Implements

IParameter..::..XmlDefinition

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


XmlNodeHandler Property

[image]

MADCAT Software Developer Guide
BaseParameter..::..XmlNodeHandler Property
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get the XML handler of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual XmlHandler XmlNodeHandler { get; }
Visual Basic
Public Overridable ReadOnly Property XmlNodeHandler As XmlHandler
    Get
Visual C++
public:
virtual property XmlHandler^ XmlNodeHandler {
    XmlHandler^ get ();
}

Implements

IParameter..::..XmlNodeHandler

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


BaseParameter Events

[image] [image]

MADCAT Software Developer Guide
BaseParameter Events
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BaseParameter type exposes the following members.

Events

 | Name | Description
Public event | ValueChanged | Fired when the value of the parameter changes

See Also

BaseParameter Class
Parameters Namespace


ValueChanged Event

[image]

MADCAT Software Developer Guide
BaseParameter..::..ValueChanged Event
BaseParameter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Fired when the value of the parameter changes

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual event ParameterValueChangedEventHandler ValueChanged
Visual Basic
Public Overridable Event ValueChanged As ParameterValueChangedEventHandler
Visual C++
public:
virtual  event ParameterValueChangedEventHandler^ ValueChanged {
    void add (ParameterValueChangedEventHandler^ value);
    void remove (ParameterValueChangedEventHandler^ value);
}

Implements

IParameter..::..ValueChanged

See Also

BaseParameter Class
BaseParameter Members
Parameters Namespace


BitmapDisplayForm Class

[image]

MADCAT Software Developer Guide
BitmapDisplayForm Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Form used to display the bitmap of a BitmapInput parameter.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public class BitmapDisplayForm : Form
Visual Basic
Public Class BitmapDisplayForm _
    Inherits Form
Visual C++
public ref class BitmapDisplayForm : public Form

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
Parameters..::..BitmapDisplayForm

See Also

BitmapDisplayForm Members
Parameters Namespace


BitmapDisplayForm Members

[image] [image]

MADCAT Software Developer Guide
BitmapDisplayForm Members
BitmapDisplayForm Class Constructors Methods Properties See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BitmapDisplayForm type exposes the following members.

Constructors

 | Name | Description
Public method | BitmapDisplayForm | Constructor

Methods

 | Name | Description
Public method | InitializeComponent | Méthode requise pour la prise en charge du concepteur - ne modifiez pas le contenu de cette méthode avec l'éditeur de code.

Properties

 | Name | Description
Public property | Bitmap | Gets/sets the bitmap to display
Public property | Zoom | Gets/sets the zoom factor. Range is [0:500]. Expressed in percentage of the actual size.

See Also

BitmapDisplayForm Class
Parameters Namespace


BitmapDisplayForm Constructor

[image]

MADCAT Software Developer Guide
BitmapDisplayForm Constructor
BitmapDisplayForm Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public BitmapDisplayForm()
Visual Basic
Public Sub New
Visual C++
public:
BitmapDisplayForm()

See Also

BitmapDisplayForm Class
BitmapDisplayForm Members
Parameters Namespace


BitmapDisplayForm Methods

[image] [image]

MADCAT Software Developer Guide
BitmapDisplayForm Methods
BitmapDisplayForm Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BitmapDisplayForm type exposes the following members.

Methods

 | Name | Description
Public method | InitializeComponent | Méthode requise pour la prise en charge du concepteur - ne modifiez pas le contenu de cette méthode avec l'éditeur de code.

See Also

BitmapDisplayForm Class
Parameters Namespace


InitializeComponent Method

[image]

MADCAT Software Developer Guide
BitmapDisplayForm..::..InitializeComponent Method
BitmapDisplayForm Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Méthode requise pour la prise en charge du concepteur - ne modifiez pas le contenu de cette méthode avec l'éditeur de code.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public void InitializeComponent()
Visual Basic
Public Sub InitializeComponent
Visual C++
public:
void InitializeComponent()

See Also

BitmapDisplayForm Class
BitmapDisplayForm Members
Parameters Namespace


BitmapDisplayForm Properties

[image] [image]

MADCAT Software Developer Guide
BitmapDisplayForm Properties
BitmapDisplayForm Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BitmapDisplayForm type exposes the following members.

Properties

 | Name | Description
Public property | Bitmap | Gets/sets the bitmap to display
Public property | Zoom | Gets/sets the zoom factor. Range is [0:500]. Expressed in percentage of the actual size.

See Also

BitmapDisplayForm Class
Parameters Namespace


Bitmap Property

[image]

MADCAT Software Developer Guide
BitmapDisplayForm..::..Bitmap Property
BitmapDisplayForm Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/sets the bitmap to display

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public Image Bitmap { get; set; }
Visual Basic
Public Property Bitmap As Image
    Get
    Set
Visual C++
public:
property Image^ Bitmap {
    Image^ get ();
    void set (Image^ value);
}

See Also

BitmapDisplayForm Class
BitmapDisplayForm Members
Parameters Namespace


Zoom Property

[image]

MADCAT Software Developer Guide
BitmapDisplayForm..::..Zoom Property
BitmapDisplayForm Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/sets the zoom factor. Range is [0:500]. Expressed in percentage of the actual size.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public int Zoom { get; set; }
Visual Basic
Public Property Zoom As Integer
    Get
    Set
Visual C++
public:
property int Zoom {
    int get ();
    void set (int value);
}

See Also

BitmapDisplayForm Class
BitmapDisplayForm Members
Parameters Namespace


BitmapHandler Delegate

[image]

MADCAT Software Developer Guide
BitmapHandler Delegate
See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Delegate used to invoke Bitmap handlers. Bitmap handlers produce bitmap which are placed inside the cells of the listview renderer of MADCAT in details mode.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public delegate Image BitmapHandler(
    string val,
    int w,
    int h
)
Visual Basic
Public Delegate Function BitmapHandler ( _
    val As String, _
    w As Integer, _
    h As Integer _
) As Image
Visual C++
public delegate Image^ BitmapHandler(
    String^ val,
    int w,
    int h
)

Parameters

val
Type: System..::..String
w
Type: System..::..Int32
h
Type: System..::..Int32

See Also

Parameters Namespace


BitmapInput Class

[image]

MADCAT Software Developer Guide
BitmapInput Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Used to handle bitmap file names. Controls over a direct preview of the selected file and a dedicated dialog box which selects only compatible bitmap files.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
[SerializableAttribute]
public class BitmapInput : BaseParameter
Visual Basic
<SerializableAttribute> _
Public Class BitmapInput _
    Inherits BaseParameter
Visual C++
[SerializableAttribute]
public ref class BitmapInput : public BaseParameter

Inheritance Hierarchy

System..::..Object
Parameters..::..BaseParameter
Parameters..::..BitmapInput

See Also

BitmapInput Members
Parameters Namespace


BitmapInput Members

[image] [image]

MADCAT Software Developer Guide
BitmapInput Members
BitmapInput Class Constructors Methods Properties Events See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BitmapInput type exposes the following members.

Constructors

 | Name | Description
Public method | BitmapInput | Constructor

Methods

 | Name | Description
Public method | BuildHTMLString | Gives the HTML code used to render the input field in HTML instead of Windows form control (Inherited from BaseParameter.)
Public method | BuildLabel | Gives the Windows Form control for the label of the input field of the parameter (Inherited from BaseParameter.)
Public method | Clone | Creates a clone of the BitmapInput object (Overrides BaseParameter..::..Clone()()()().)
 | GetImageFormatWithExtension | Tries to identify the image format by using the extension of the given filename.
Public method | RestoreValueFromItem | Restores the value of the parameter from the given item's attributes. One attribute shall have the name of the parameter. (Overrides BaseParameter..::..RestoreValueFromItem(XmlNode).)
Public method | SaveValueInItem | Saves the value of the parameter into the given item's attributes (Overrides BaseParameter..::..SaveValueInItem(XmlNode).)

Properties

Name Description
Public property ContextMenu
Property used by MADCAT to get the context menu of the parameter
(Inherited from BaseParameter.)
Public property DefaultExtension
Default extension for the files managed by the parameter
Public property Description
Property used by MADCAT to get/set the description of the parameter
(Inherited from BaseParameter.)
Public property DisplayOnly
Set to true if the value can't be changed
(Overrides BaseParameter..::..DisplayOnly.)
Public property DrawHandler
Property used by MADCAT to get the Bitmap handler of the parameter
(Inherited from BaseParameter.)
Public property FormControl
Gets the control of the parameter. It is composed of a text box, a button which opens the dialog box and a preview area where the user can double-click to open a resizable preview window with zoom features.
(Overrides BaseParameter..::..FormControl.)
Public property ForOutput
Flag which indicates if the parameters manage input files (=false) or output files (=true). This has a direct impact on the dialog box which will be used to let the user select a file in his system.
Public property HasChanged
Property used by MADCAT to check if the parameter has changed
(Inherited from BaseParameter.)
Public property Hint
Property used by MADCAT to get/set the tip of the parameter. The tip contains a short help which popups when the user moves his mouse cursor over the parameter's name
(Inherited from BaseParameter.)
Public property IsMandatory
Property used by MADCAT to indicate if the parameter is mandatory or not. When mandatory, the user must give a value to the parameter to continue his current operation.
(Inherited from BaseParameter.)
Public property IsUndefined
Property used by MADCAT to check if the parameter has been set by the user or not
(Inherited from BaseParameter.)
Public property MaxNumberOfChars
Gets/sets the maximum number of characters of the parameter's value
(Inherited from BaseParameter.)
Public property Name
Property used by MADCAT to get/set the name of the parameter
(Inherited from BaseParameter.)
Public property NumberOfLines
Gets/sets the number of lines visible in the text box of the parameter
(Inherited from BaseParameter.)
Public property Options
Sets the options of the parameter. Accepted options are :
  • filters=*.ext|Desc of the type|... : the authorized file types of the dialog box
  • extension=ext : the default extension of the file
  • width=999 : where 999 is the width in pixel of the preview area
  • height=999 : where 999 is the height in pixel of the preview area
  • bgcolor=#RRGGBB : where #RRGGBB is the HTML code of the background color of the preview area
  • bordercolor=#RRGGBB : where #RRGGBB is the HTML code of the border color of the preview area
(Overrides BaseParameter..::..Options.)
Public property Preview
Get/Set the content of the preview. Set it when you use the field to save a bitmap to disk.
Public property PreviewSize
Get/Set the size of the preview of the bitmap
Public property ShowPreview
Get/Set the visibility of the preview of the bitmap
Public property Tag
Gets/sets the Tag property of the parameter's control object
(Inherited from BaseParameter.)
Public property TextHandler
Property used by MADCAT to get the String handler of the parameter
(Inherited from BaseParameter.)
Public property Tip
Hint text linked to the parameter
(Overrides BaseParameter..::..Tip.)
Public property Type
Gets the base type of the parameter. In this case, it is CMN_Bitmap
(Overrides BaseParameter..::..Type.)
Public property TypeName
Gets the name of the type of the parameter as it is coded in the attribute TYPE of the parameter's Xml definition (ATTRIBUTE element definition) It is the core type's name of the parameter
(Inherited from BaseParameter.)
Public property UserSettings
Property used by MADCAT to get/set the user settings of the parameter
(Inherited from BaseParameter.)
Public property Value
Gets/Sets the file name (including absolute path) of the bitmap file
(Overrides BaseParameter..::..Value.)
Public property XmlDefinition
Xml Definition of the parameter. See the ATTRIBUTE element in the schema (XSD) named MODELS.
(Overrides BaseParameter..::..XmlDefinition.)
Public property XmlNodeHandler
Property used by MADCAT to get the XML handler of the parameter
(Inherited from BaseParameter.)

Events

 | Name | Description
Public event | ValueChanged | Fired when the value of the parameter changes (Inherited from BaseParameter.)

See Also

BitmapInput Class
Parameters Namespace


BitmapInput Constructor

[image]

MADCAT Software Developer Guide
BitmapInput Constructor
BitmapInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public BitmapInput()
Visual Basic
Public Sub New
Visual C++
public:
BitmapInput()

See Also

BitmapInput Class
BitmapInput Members
Parameters Namespace


BitmapInput Methods

[image] [image]

MADCAT Software Developer Guide
BitmapInput Methods
BitmapInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BitmapInput type exposes the following members.

Methods

 | Name | Description
Public method | BuildHTMLString | Gives the HTML code used to render the input field in HTML instead of Windows form control (Inherited from BaseParameter.)
Public method | BuildLabel | Gives the Windows Form control for the label of the input field of the parameter (Inherited from BaseParameter.)
Public method | Clone | Creates a clone of the BitmapInput object (Overrides BaseParameter..::..Clone()()()().)
 | GetImageFormatWithExtension | Tries to identify the image format by using the extension of the given filename.
Public method | RestoreValueFromItem | Restores the value of the parameter from the given item's attributes. One attribute shall have the name of the parameter. (Overrides BaseParameter..::..RestoreValueFromItem(XmlNode).)
Public method | SaveValueInItem | Saves the value of the parameter into the given item's attributes (Overrides BaseParameter..::..SaveValueInItem(XmlNode).)

See Also

BitmapInput Class
Parameters Namespace


Clone Method

[image]

MADCAT Software Developer Guide
BitmapInput..::..Clone Method
BitmapInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Creates a clone of the BitmapInput object

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

A clone of the object

See Also

BitmapInput Class
BitmapInput Members
Parameters Namespace


GetImageFormatWithExtension Method

[image]

MADCAT Software Developer Guide
BitmapInput..::..GetImageFormatWithExtension Method
BitmapInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Tries to identify the image format by using the extension of the given filename.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public static ImageFormat GetImageFormatWithExtension(
    string f_name
)
Visual Basic
Public Shared Function GetImageFormatWithExtension ( _
    f_name As String _
) As ImageFormat
Visual C++
public:
static ImageFormat^ GetImageFormatWithExtension(
    String^ f_name
)

Parameters

f_name
Type: System..::..String
File name of the bitmap

Return Value

The ImageFormat object corresponding to the extension of the file. Supported extensions are : bmp,jpg,png,tiff,gif and wmf. By default the method returns Imaging::ImageFormat::Png

See Also

BitmapInput Class
BitmapInput Members
Parameters Namespace


RestoreValueFromItem Method

[image]

MADCAT Software Developer Guide
BitmapInput..::..RestoreValueFromItem Method
BitmapInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Restores the value of the parameter from the given item's attributes. One attribute shall have the name of the parameter.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override void RestoreValueFromItem(
    XmlNode item
)
Visual Basic
Public Overrides Sub RestoreValueFromItem ( _
    item As XmlNode _
)
Visual C++
public:
virtual void RestoreValueFromItem(
    XmlNode^ item
) override

Parameters

item
Type: System.Xml..::..XmlNode
Xml item where the value shall be restored from.

Implements

IParameter..::..RestoreValueFromItem(XmlNode)

See Also

BitmapInput Class
BitmapInput Members
Parameters Namespace


SaveValueInItem Method

[image]

MADCAT Software Developer Guide
BitmapInput..::..SaveValueInItem Method
BitmapInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Saves the value of the parameter into the given item's attributes

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override void SaveValueInItem(
    XmlNode item
)
Visual Basic
Public Overrides Sub SaveValueInItem ( _
    item As XmlNode _
)
Visual C++
public:
virtual void SaveValueInItem(
    XmlNode^ item
) override

Parameters

item
Type: System.Xml..::..XmlNode
Xml item where the value shall be stored

Implements

IParameter..::..SaveValueInItem(XmlNode)

See Also

BitmapInput Class
BitmapInput Members
Parameters Namespace


BitmapInput Properties

[image] [image]

MADCAT Software Developer Guide
BitmapInput Properties
BitmapInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BitmapInput type exposes the following members.

Properties

Name Description
Public property ContextMenu
Property used by MADCAT to get the context menu of the parameter
(Inherited from BaseParameter.)
Public property DefaultExtension
Default extension for the files managed by the parameter
Public property Description
Property used by MADCAT to get/set the description of the parameter
(Inherited from BaseParameter.)
Public property DisplayOnly
Set to true if the value can't be changed
(Overrides BaseParameter..::..DisplayOnly.)
Public property DrawHandler
Property used by MADCAT to get the Bitmap handler of the parameter
(Inherited from BaseParameter.)
Public property FormControl
Gets the control of the parameter. It is composed of a text box, a button which opens the dialog box and a preview area where the user can double-click to open a resizable preview window with zoom features.
(Overrides BaseParameter..::..FormControl.)
Public property ForOutput
Flag which indicates if the parameters manage input files (=false) or output files (=true). This has a direct impact on the dialog box which will be used to let the user select a file in his system.
Public property HasChanged
Property used by MADCAT to check if the parameter has changed
(Inherited from BaseParameter.)
Public property Hint
Property used by MADCAT to get/set the tip of the parameter. The tip contains a short help which popups when the user moves his mouse cursor over the parameter's name
(Inherited from BaseParameter.)
Public property IsMandatory
Property used by MADCAT to indicate if the parameter is mandatory or not. When mandatory, the user must give a value to the parameter to continue his current operation.
(Inherited from BaseParameter.)
Public property IsUndefined
Property used by MADCAT to check if the parameter has been set by the user or not
(Inherited from BaseParameter.)
Public property MaxNumberOfChars
Gets/sets the maximum number of characters of the parameter's value
(Inherited from BaseParameter.)
Public property Name
Property used by MADCAT to get/set the name of the parameter
(Inherited from BaseParameter.)
Public property NumberOfLines
Gets/sets the number of lines visible in the text box of the parameter
(Inherited from BaseParameter.)
Public property Options
Sets the options of the parameter. Accepted options are :
  • filters=*.ext|Desc of the type|... : the authorized file types of the dialog box
  • extension=ext : the default extension of the file
  • width=999 : where 999 is the width in pixel of the preview area
  • height=999 : where 999 is the height in pixel of the preview area
  • bgcolor=#RRGGBB : where #RRGGBB is the HTML code of the background color of the preview area
  • bordercolor=#RRGGBB : where #RRGGBB is the HTML code of the border color of the preview area
(Overrides BaseParameter..::..Options.)
Public property Preview
Get/Set the content of the preview. Set it when you use the field to save a bitmap to disk.
Public property PreviewSize
Get/Set the size of the preview of the bitmap
Public property ShowPreview
Get/Set the visibility of the preview of the bitmap
Public property Tag
Gets/sets the Tag property of the parameter's control object
(Inherited from BaseParameter.)
Public property TextHandler
Property used by MADCAT to get the String handler of the parameter
(Inherited from BaseParameter.)
Public property Tip
Hint text linked to the parameter
(Overrides BaseParameter..::..Tip.)
Public property Type
Gets the base type of the parameter. In this case, it is CMN_Bitmap
(Overrides BaseParameter..::..Type.)
Public property TypeName
Gets the name of the type of the parameter as it is coded in the attribute TYPE of the parameter's Xml definition (ATTRIBUTE element definition) It is the core type's name of the parameter
(Inherited from BaseParameter.)
Public property UserSettings
Property used by MADCAT to get/set the user settings of the parameter
(Inherited from BaseParameter.)
Public property Value
Gets/Sets the file name (including absolute path) of the bitmap file
(Overrides BaseParameter..::..Value.)
Public property XmlDefinition
Xml Definition of the parameter. See the ATTRIBUTE element in the schema (XSD) named MODELS.
(Overrides BaseParameter..::..XmlDefinition.)
Public property XmlNodeHandler
Property used by MADCAT to get the XML handler of the parameter
(Inherited from BaseParameter.)

See Also

BitmapInput Class
Parameters Namespace


DefaultExtension Property

[image]

MADCAT Software Developer Guide
BitmapInput..::..DefaultExtension Property
BitmapInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Default extension for the files managed by the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public string DefaultExtension { get; set; }
Visual Basic
Public Property DefaultExtension As String
    Get
    Set
Visual C++
public:
property String^ DefaultExtension {
    String^ get ();
    void set (String^ value);
}

See Also

BitmapInput Class
BitmapInput Members
Parameters Namespace


DisplayOnly Property

[image]

MADCAT Software Developer Guide
BitmapInput..::..DisplayOnly Property
BitmapInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Set to true if the value can't be changed

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override bool DisplayOnly { set; }
Visual Basic
Public Overrides WriteOnly Property DisplayOnly As Boolean
    Set
Visual C++
public:
virtual property bool DisplayOnly {
    void set (bool value) override;
}

Implements

IParameter..::..DisplayOnly

See Also

BitmapInput Class
BitmapInput Members
Parameters Namespace


FormControl Property

[image]

MADCAT Software Developer Guide
BitmapInput..::..FormControl Property
BitmapInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the control of the parameter. It is composed of a text box, a button which opens the dialog box and a preview area where the user can double-click to open a resizable preview window with zoom features.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Control FormControl { get; }
Visual Basic
Public Overrides ReadOnly Property FormControl As Control
    Get
Visual C++
public:
virtual property Control^ FormControl {
    Control^ get () override;
}

Implements

IParameter..::..FormControl

See Also

BitmapInput Class
BitmapInput Members
Parameters Namespace


ForOutput Property

[image]

MADCAT Software Developer Guide
BitmapInput..::..ForOutput Property
BitmapInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Flag which indicates if the parameters manage input files (=false) or output files (=true). This has a direct impact on the dialog box which will be used to let the user select a file in his system.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public bool ForOutput { get; set; }
Visual Basic
Public Property ForOutput As Boolean
    Get
    Set
Visual C++
public:
property bool ForOutput {
    bool get ();
    void set (bool value);
}

See Also

BitmapInput Class
BitmapInput Members
Parameters Namespace


Options Property

[image]

MADCAT Software Developer Guide
BitmapInput..::..Options Property
BitmapInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Sets the options of the parameter. Accepted options are :
  • filters=*.ext|Desc of the type|... : the authorized file types of the dialog box
  • extension=ext : the default extension of the file
  • width=999 : where 999 is the width in pixel of the preview area
  • height=999 : where 999 is the height in pixel of the preview area
  • bgcolor=#RRGGBB : where #RRGGBB is the HTML code of the background color of the preview area
  • bordercolor=#RRGGBB : where #RRGGBB is the HTML code of the border color of the preview area

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Hashtable Options { set; }
Visual Basic
Public Overrides WriteOnly Property Options As Hashtable
    Set
Visual C++
public:
virtual property Hashtable^ Options {
    void set (Hashtable^ value) override;
}

Implements

IParameter..::..Options

See Also

BitmapInput Class
BitmapInput Members
Parameters Namespace


Preview Property

[image]

MADCAT Software Developer Guide
BitmapInput..::..Preview Property
BitmapInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Get/Set the content of the preview. Set it when you use the field to save a bitmap to disk.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public Image Preview { get; set; }
Visual Basic
Public Property Preview As Image
    Get
    Set
Visual C++
public:
property Image^ Preview {
    Image^ get ();
    void set (Image^ value);
}

See Also

BitmapInput Class
BitmapInput Members
Parameters Namespace


PreviewSize Property

[image]

MADCAT Software Developer Guide
BitmapInput..::..PreviewSize Property
BitmapInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Get/Set the size of the preview of the bitmap

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public Size PreviewSize { get; set; }
Visual Basic
Public Property PreviewSize As Size
    Get
    Set
Visual C++
public:
property Size PreviewSize {
    Size get ();
    void set (Size value);
}

See Also

BitmapInput Class
BitmapInput Members
Parameters Namespace


ShowPreview Property

[image]

MADCAT Software Developer Guide
BitmapInput..::..ShowPreview Property
BitmapInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Get/Set the visibility of the preview of the bitmap

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public bool ShowPreview { get; set; }
Visual Basic
Public Property ShowPreview As Boolean
    Get
    Set
Visual C++
public:
property bool ShowPreview {
    bool get ();
    void set (bool value);
}

See Also

BitmapInput Class
BitmapInput Members
Parameters Namespace


Tip Property

[image]

MADCAT Software Developer Guide
BitmapInput..::..Tip Property
BitmapInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Hint text linked to the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override ToolTip Tip { set; }
Visual Basic
Public Overrides WriteOnly Property Tip As ToolTip
    Set
Visual C++
public:
virtual property ToolTip^ Tip {
    void set (ToolTip^ value) override;
}

Implements

IParameter..::..Tip

See Also

BitmapInput Class
BitmapInput Members
Parameters Namespace


Type Property

[image]

MADCAT Software Developer Guide
BitmapInput..::..Type Property
BitmapInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the base type of the parameter. In this case, it is CMN_Bitmap

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override DataToolTypes Type { get; }
Visual Basic
Public Overrides ReadOnly Property Type As DataToolTypes
    Get
Visual C++
public:
virtual property DataToolTypes Type {
    DataToolTypes get () override;
}

Implements

IParameter..::..Type

See Also

BitmapInput Class
BitmapInput Members
Parameters Namespace


Value Property

[image]

MADCAT Software Developer Guide
BitmapInput..::..Value Property
BitmapInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/Sets the file name (including absolute path) of the bitmap file

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override string Value { get; set; }
Visual Basic
Public Overrides Property Value As String
    Get
    Set
Visual C++
public:
virtual property String^ Value {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IParameter..::..Value

See Also

BitmapInput Class
BitmapInput Members
Parameters Namespace


XmlDefinition Property

[image]

MADCAT Software Developer Guide
BitmapInput..::..XmlDefinition Property
BitmapInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Xml Definition of the parameter. See the ATTRIBUTE element in the schema (XSD) named MODELS.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override XmlNode XmlDefinition { set; }
Visual Basic
Public Overrides WriteOnly Property XmlDefinition As XmlNode
    Set
Visual C++
public:
virtual property XmlNode^ XmlDefinition {
    void set (XmlNode^ value) override;
}

Implements

IParameter..::..XmlDefinition

See Also

BitmapInput Class
BitmapInput Members
Parameters Namespace


BitmapInput Events

[image] [image]

MADCAT Software Developer Guide
BitmapInput Events
BitmapInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BitmapInput type exposes the following members.

Events

 | Name | Description
Public event | ValueChanged | Fired when the value of the parameter changes (Inherited from BaseParameter.)

See Also

BitmapInput Class
Parameters Namespace


BooleanDisplayTypes Enumeration

[image]

MADCAT Software Developer Guide
BooleanDisplayTypes Enumeration
See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Type of controls available for the Boolean Input

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public enum BooleanDisplayTypes
Visual Basic
Public Enumeration BooleanDisplayTypes
Visual C++
public enum class BooleanDisplayTypes

Members

Member name | Value | Description
SlidingSwitch | 4 | Boolean values appear as a switch which can slide from left to right and vice versa
Led | 3 | Boolean values appear as a led.
SwitchWithLed | 2 | Boolean values appear as a switch with a led.
Checkbox | 0 | Boolean values appear as a standard checkbox.
Switch | 1 | Boolean values appear as a switch.

See Also

Parameters Namespace


BooleanFilter Class

[image]

MADCAT Software Developer Guide
BooleanFilter Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Filter for boolean parameters.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public class BooleanFilter : IFilter
Visual Basic
Public Class BooleanFilter _
    Implements IFilter
Visual C++
public ref class BooleanFilter : IFilter

Inheritance Hierarchy

System..::..Object
Parameters..::..BooleanFilter

See Also

BooleanFilter Members
Parameters Namespace


BooleanFilter Members

[image] [image]

MADCAT Software Developer Guide
BooleanFilter Members
BooleanFilter Class Constructors Methods Properties See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BooleanFilter type exposes the following members.

Constructors

 | Name | Description
Public method | BooleanFilter | Constructor

Methods

 | Name | Description
Public method | GetTypeOptions | Not implemented. Reserved.
Public method | IsMatch | Filtering function. Returns true when a given value matches the filter's criterias.

Properties

 | Name | Description
Public property | Args | Gets/sets the filter's arguments. Can be safely casted into BooleanFilterArgs object. See BooleanFilterArgs.
Public property | Form | Gets the filter's configuration form. See BooleanFilterForm.
Public property | IsActive | Indicates if the filter is active or not
Public property | Type | Gets the base type of the filter. Always CMN_Boolean.
Public property | XPathCondition | Not used for boolean filters. Always null.

See Also

BooleanFilter Class
Parameters Namespace


BooleanFilter Constructor

[image]

MADCAT Software Developer Guide
BooleanFilter Constructor
BooleanFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public BooleanFilter(
    DataToolTypes type
)
Visual Basic
Public Sub New ( _
    type As DataToolTypes _
)
Visual C++
public:
BooleanFilter(
    DataToolTypes type
)

Parameters

type
Type: Parameters..::..DataToolTypes
Sets the base type of the filter. Shall be CMN_Boolean.

See Also

BooleanFilter Class
BooleanFilter Members
Parameters Namespace


BooleanFilter Methods

[image] [image]

MADCAT Software Developer Guide
BooleanFilter Methods
BooleanFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BooleanFilter type exposes the following members.

Methods

 | Name | Description
Public method | GetTypeOptions | Not implemented. Reserved.
Public method | IsMatch | Filtering function. Returns true when a given value matches the filter's criterias.

See Also

BooleanFilter Class
Parameters Namespace


GetTypeOptions Method

[image]

MADCAT Software Developer Guide
BooleanFilter..::..GetTypeOptions Method
BooleanFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Not implemented. Reserved.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual void GetTypeOptions(
    Hashtable opt
)
Visual Basic
Public Overridable Sub GetTypeOptions ( _
    opt As Hashtable _
)
Visual C++
public:
virtual void GetTypeOptions(
    Hashtable^ opt
)

Parameters

opt
Type: System.Collections..::..Hashtable
Not implemented

Implements

IFilter..::..GetTypeOptions(Hashtable)

See Also

BooleanFilter Class
BooleanFilter Members
Parameters Namespace


IsMatch Method

[image]

MADCAT Software Developer Guide
BooleanFilter..::..IsMatch Method
BooleanFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Filtering function. Returns true when a given value matches the filter's criterias.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual bool IsMatch(
    string value
)
Visual Basic
Public Overridable Function IsMatch ( _
    value As String _
) As Boolean
Visual C++
public:
virtual bool IsMatch(
    String^ value
)

Parameters

value
Type: System..::..String
Value to test

Return Value

Filter's result. True if value matches the filter's criterias.

Implements

IFilter..::..IsMatch(String)

See Also

BooleanFilter Class
BooleanFilter Members
Parameters Namespace


BooleanFilter Properties

[image] [image]

MADCAT Software Developer Guide
BooleanFilter Properties
BooleanFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BooleanFilter type exposes the following members.

Properties

 | Name | Description
Public property | Args | Gets/sets the filter's arguments. Can be safely casted into BooleanFilterArgs object. See BooleanFilterArgs.
Public property | Form | Gets the filter's configuration form. See BooleanFilterForm.
Public property | IsActive | Indicates if the filter is active or not
Public property | Type | Gets the base type of the filter. Always CMN_Boolean.
Public property | XPathCondition | Not used for boolean filters. Always null.

See Also

BooleanFilter Class
Parameters Namespace


Args Property

[image]

MADCAT Software Developer Guide
BooleanFilter..::..Args Property
BooleanFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/sets the filter's arguments. Can be safely casted into BooleanFilterArgs object. See BooleanFilterArgs.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual Object Args { get; set; }
Visual Basic
Public Overridable Property Args As Object
    Get
    Set
Visual C++
public:
virtual property Object^ Args {
    Object^ get ();
    void set (Object^ value);
}

Implements

IFilter..::..Args

See Also

BooleanFilter Class
BooleanFilter Members
Parameters Namespace


Form Property

[image]

MADCAT Software Developer Guide
BooleanFilter..::..Form Property
BooleanFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the filter's configuration form. See BooleanFilterForm.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual Control Form { get; }
Visual Basic
Public Overridable ReadOnly Property Form As Control
    Get
Visual C++
public:
virtual property Control^ Form {
    Control^ get ();
}

Implements

IFilter..::..Form

See Also

BooleanFilter Class
BooleanFilter Members
Parameters Namespace


IsActive Property

[image]

MADCAT Software Developer Guide
BooleanFilter..::..IsActive Property
BooleanFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Indicates if the filter is active or not

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual bool IsActive { get; }
Visual Basic
Public Overridable ReadOnly Property IsActive As Boolean
    Get
Visual C++
public:
virtual property bool IsActive {
    bool get ();
}

Implements

IFilter..::..IsActive

See Also

BooleanFilter Class
BooleanFilter Members
Parameters Namespace


Type Property

[image]

MADCAT Software Developer Guide
BooleanFilter..::..Type Property
BooleanFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the base type of the filter. Always CMN_Boolean.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual DataToolTypes Type { get; }
Visual Basic
Public Overridable ReadOnly Property Type As DataToolTypes
    Get
Visual C++
public:
virtual property DataToolTypes Type {
    DataToolTypes get ();
}

Implements

IFilter..::..Type

See Also

BooleanFilter Class
BooleanFilter Members
Parameters Namespace


XPathCondition Property

[image]

MADCAT Software Developer Guide
BooleanFilter..::..XPathCondition Property
BooleanFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Not used for boolean filters. Always null.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual string XPathCondition { get; }
Visual Basic
Public Overridable ReadOnly Property XPathCondition As String
    Get
Visual C++
public:
virtual property String^ XPathCondition {
    String^ get ();
}

Implements

IFilter..::..XPathCondition

See Also

BooleanFilter Class
BooleanFilter Members
Parameters Namespace


BooleanFilterArgs Class

[image]

MADCAT Software Developer Guide
BooleanFilterArgs Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Arguments for the boolean filters.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
[SerializableAttribute]
public class BooleanFilterArgs
Visual Basic
<SerializableAttribute> _
Public Class BooleanFilterArgs
Visual C++
[SerializableAttribute]
public ref class BooleanFilterArgs

Inheritance Hierarchy

System..::..Object
Parameters..::..BooleanFilterArgs

See Also

BooleanFilterArgs Members
Parameters Namespace


BooleanFilterArgs Members

[image] [image]

MADCAT Software Developer Guide
BooleanFilterArgs Members
BooleanFilterArgs Class Constructors Fields See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BooleanFilterArgs type exposes the following members.

Constructors

 | Name | Description
Public method | BooleanFilterArgs | Constructor

Fields

 | Name | Description
Public field | Activated | Indicates if the filter is active (=true) or not (=false).
Public field | Condition | The condition value of the filter. Values must match this condition to be accepted.

See Also

BooleanFilterArgs Class
Parameters Namespace


BooleanFilterArgs Constructor

[image]

MADCAT Software Developer Guide
BooleanFilterArgs Constructor
BooleanFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public BooleanFilterArgs()
Visual Basic
Public Sub New
Visual C++
public:
BooleanFilterArgs()

See Also

BooleanFilterArgs Class
BooleanFilterArgs Members
Parameters Namespace


BooleanFilterArgs Fields

[image] [image]

MADCAT Software Developer Guide
BooleanFilterArgs Fields
BooleanFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BooleanFilterArgs type exposes the following members.

Fields

 | Name | Description
Public field | Activated | Indicates if the filter is active (=true) or not (=false).
Public field | Condition | The condition value of the filter. Values must match this condition to be accepted.

See Also

BooleanFilterArgs Class
Parameters Namespace


Activated Field

[image]

MADCAT Software Developer Guide
BooleanFilterArgs..::..Activated Field
BooleanFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Indicates if the filter is active (=true) or not (=false).

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public bool Activated
Visual Basic
Public Activated As Boolean
Visual C++
public:
bool Activated

See Also

BooleanFilterArgs Class
BooleanFilterArgs Members
Parameters Namespace


Condition Field

[image]

MADCAT Software Developer Guide
BooleanFilterArgs..::..Condition Field
BooleanFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
The condition value of the filter. Values must match this condition to be accepted.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public bool Condition
Visual Basic
Public Condition As Boolean
Visual C++
public:
bool Condition

See Also

BooleanFilterArgs Class
BooleanFilterArgs Members
Parameters Namespace


BooleanFilterForm Class

[image]

MADCAT Software Developer Guide
BooleanFilterForm Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Form used to edit the Boolean Filter's arguments. See BooleanFilterArgs.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public class BooleanFilterForm : Form
Visual Basic
Public Class BooleanFilterForm _
    Inherits Form
Visual C++
public ref class BooleanFilterForm : public Form

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
Parameters..::..BooleanFilterForm

See Also

BooleanFilterForm Members
Parameters Namespace


BooleanFilterForm Members

[image] [image]

MADCAT Software Developer Guide
BooleanFilterForm Members
BooleanFilterForm Class Constructors See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BooleanFilterForm type exposes the following members.

Constructors

 | Name | Description
Public method | BooleanFilterForm | Constructor

See Also

BooleanFilterForm Class
Parameters Namespace


BooleanFilterForm Constructor

[image]

MADCAT Software Developer Guide
BooleanFilterForm Constructor
BooleanFilterForm Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public BooleanFilterForm(
    BooleanFilterArgs filter
)
Visual Basic
Public Sub New ( _
    filter As BooleanFilterArgs _
)
Visual C++
public:
BooleanFilterForm(
    BooleanFilterArgs^ filter
)

Parameters

filter
Type: Parameters..::..BooleanFilterArgs
Arguments of the filter

See Also

BooleanFilterForm Class
BooleanFilterForm Members
Parameters Namespace


BooleanInput Class

[image]

MADCAT Software Developer Guide
BooleanInput Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Used to manage boolean values

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public class BooleanInput : BaseParameter
Visual Basic
Public Class BooleanInput _
    Inherits BaseParameter
Visual C++
public ref class BooleanInput : public BaseParameter

Inheritance Hierarchy

System..::..Object
Parameters..::..BaseParameter
Parameters..::..BooleanInput

See Also

BooleanInput Members
Parameters Namespace


BooleanInput Members

[image] [image]

MADCAT Software Developer Guide
BooleanInput Members
BooleanInput Class Constructors Methods Properties Events See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BooleanInput type exposes the following members.

Constructors

 | Name | Description
Public method | BooleanInput | Constructor

Methods

 | Name | Description
Public method | BuildHTMLString | Gives the HTML code used to render the input field in HTML instead of Windows form control (Overrides BaseParameter..::..BuildHTMLString()()()().)
Public method | BuildLabel | Gives the Windows Form control for the label of the input field of the parameter (Inherited from BaseParameter.)
Public method | Clone | Creates a clone of the BitmapInput object (Overrides BaseParameter..::..Clone()()()().)
Public method | RestoreValueFromItem | Gets the value of the parameter from a given project's Item (Inherited from BaseParameter.)
Public method | SaveValueInItem | Saves the value of the parameter into a given project's Item (Inherited from BaseParameter.)

Properties

Name Description
Public property ContextMenu
Property used by MADCAT to get the context menu of the parameter
(Inherited from BaseParameter.)
Public property Description
Property used by MADCAT to get/set the description of the parameter
(Inherited from BaseParameter.)
Public property Display
Property used to get or set the type of display of the parameter
Public property DisplayOnly
Set to true if the value can't be changed
(Overrides BaseParameter..::..DisplayOnly.)
Public property DrawHandler
Property used by MADCAT to get the Bitmap handler of the parameter
(Overrides BaseParameter..::..DrawHandler.)
Public property FormControl
Gets the control of the parameter. Depends on the option 'showas' : may be a graphical switch or led or a standard check box.
(Overrides BaseParameter..::..FormControl.)
Public property HasChanged
Property used by MADCAT to check if the parameter has changed
(Inherited from BaseParameter.)
Public property Hint
Property used by MADCAT to get/set the tip of the parameter. The tip contains a short help which popups when the user moves his mouse cursor over the parameter's name
(Inherited from BaseParameter.)
Public property IsMandatory
Property used by MADCAT to indicate if the parameter is mandatory or not. When mandatory, the user must give a value to the parameter to continue his current operation.
(Inherited from BaseParameter.)
Public property IsUndefined
Property used by MADCAT to check if the parameter has been set by the user or not
(Inherited from BaseParameter.)
Public property LedColor
Property used to get or set the color of the led of the parameter
Public property MaxNumberOfChars
Gets/sets the maximum number of characters of the parameter's value
(Inherited from BaseParameter.)
Public property Name
Property used by MADCAT to get/set the name of the parameter
(Inherited from BaseParameter.)
Public property NumberOfLines
Gets/sets the number of lines visible in the text box of the parameter
(Inherited from BaseParameter.)
Public property Options
Sets the options of the boolean parameter. Accepted options are :
  • showas=xxx : Display mode of the boolean value where xxx may be :
    • yellowswitch : metal switch with yellow led
    • greenswitch : metal switch with green led
    • redswitch : metal switch with red led
    • yellowled : yellow led only
    • greenled : green led only
    • redled : red led only
    • switch : metal switch only
    • slider : sliding switch
    By default, the boolean parameter is managed with a simple check box.
(Overrides BaseParameter..::..Options.)
Public property Tag
Gets/sets the Tag property of the parameter's control object
(Overrides BaseParameter..::..Tag.)
Public property TextHandler
Property used by MADCAT to get the String handler of the parameter
(Inherited from BaseParameter.)
Public property Tip
Property used by MADCAT to get/set the ToolTip object for the Form Control of the parameter
(Inherited from BaseParameter.)
Public property Type
Type of the parameter. For boolean, it is CMN_Boolean
(Overrides BaseParameter..::..Type.)
Public property TypeName
Gets the name of the type of the parameter as it is coded in the attribute TYPE of the parameter's Xml definition (ATTRIBUTE element definition) It is the core type's name of the parameter
(Inherited from BaseParameter.)
Public property UserSettings
Property used by MADCAT to get/set the user settings of the parameter
(Inherited from BaseParameter.)
Public property Value
Gets/Sets the value of the parameter. May be 'YES' (=true) or 'NO' (=false)
(Overrides BaseParameter..::..Value.)
Public property XmlDefinition
Xml Definition of the parameter. See the ATTRIBUTE element in the schema (XSD) named MODELS.
(Overrides BaseParameter..::..XmlDefinition.)
Public property XmlNodeHandler
Property used by MADCAT to get the XML handler of the parameter
(Inherited from BaseParameter.)

Events

 | Name | Description
Public event | ValueChanged | Fired when the value of the parameter changes (Inherited from BaseParameter.)

See Also

BooleanInput Class
Parameters Namespace


BooleanInput Constructor

[image]

MADCAT Software Developer Guide
BooleanInput Constructor
BooleanInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public BooleanInput()
Visual Basic
Public Sub New
Visual C++
public:
BooleanInput()

See Also

BooleanInput Class
BooleanInput Members
Parameters Namespace


BooleanInput Methods

[image] [image]

MADCAT Software Developer Guide
BooleanInput Methods
BooleanInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BooleanInput type exposes the following members.

Methods

 | Name | Description
Public method | BuildHTMLString | Gives the HTML code used to render the input field in HTML instead of Windows form control (Overrides BaseParameter..::..BuildHTMLString()()()().)
Public method | BuildLabel | Gives the Windows Form control for the label of the input field of the parameter (Inherited from BaseParameter.)
Public method | Clone | Creates a clone of the BitmapInput object (Overrides BaseParameter..::..Clone()()()().)
Public method | RestoreValueFromItem | Gets the value of the parameter from a given project's Item (Inherited from BaseParameter.)
Public method | SaveValueInItem | Saves the value of the parameter into a given project's Item (Inherited from BaseParameter.)

See Also

BooleanInput Class
Parameters Namespace


BuildHTMLString Method

[image]

MADCAT Software Developer Guide
BooleanInput..::..BuildHTMLString Method
BooleanInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gives the HTML code used to render the input field in HTML instead of Windows form control

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override string BuildHTMLString()
Visual Basic
Public Overrides Function BuildHTMLString As String
Visual C++
public:
virtual String^ BuildHTMLString() override

Return Value

The HTML code equivalent to the Windows Form Control

Implements

IParameter..::..BuildHTMLString()()()()

See Also

BooleanInput Class
BooleanInput Members
Parameters Namespace


Clone Method

[image]

MADCAT Software Developer Guide
BooleanInput..::..Clone Method
BooleanInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Creates a clone of the BitmapInput object

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

A clone of the object

See Also

BooleanInput Class
BooleanInput Members
Parameters Namespace


BooleanInput Properties

[image] [image]

MADCAT Software Developer Guide
BooleanInput Properties
BooleanInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BooleanInput type exposes the following members.

Properties

Name Description
Public property ContextMenu
Property used by MADCAT to get the context menu of the parameter
(Inherited from BaseParameter.)
Public property Description
Property used by MADCAT to get/set the description of the parameter
(Inherited from BaseParameter.)
Public property Display
Property used to get or set the type of display of the parameter
Public property DisplayOnly
Set to true if the value can't be changed
(Overrides BaseParameter..::..DisplayOnly.)
Public property DrawHandler
Property used by MADCAT to get the Bitmap handler of the parameter
(Overrides BaseParameter..::..DrawHandler.)
Public property FormControl
Gets the control of the parameter. Depends on the option 'showas' : may be a graphical switch or led or a standard check box.
(Overrides BaseParameter..::..FormControl.)
Public property HasChanged
Property used by MADCAT to check if the parameter has changed
(Inherited from BaseParameter.)
Public property Hint
Property used by MADCAT to get/set the tip of the parameter. The tip contains a short help which popups when the user moves his mouse cursor over the parameter's name
(Inherited from BaseParameter.)
Public property IsMandatory
Property used by MADCAT to indicate if the parameter is mandatory or not. When mandatory, the user must give a value to the parameter to continue his current operation.
(Inherited from BaseParameter.)
Public property IsUndefined
Property used by MADCAT to check if the parameter has been set by the user or not
(Inherited from BaseParameter.)
Public property LedColor
Property used to get or set the color of the led of the parameter
Public property MaxNumberOfChars
Gets/sets the maximum number of characters of the parameter's value
(Inherited from BaseParameter.)
Public property Name
Property used by MADCAT to get/set the name of the parameter
(Inherited from BaseParameter.)
Public property NumberOfLines
Gets/sets the number of lines visible in the text box of the parameter
(Inherited from BaseParameter.)
Public property Options
Sets the options of the boolean parameter. Accepted options are :
  • showas=xxx : Display mode of the boolean value where xxx may be :
    • yellowswitch : metal switch with yellow led
    • greenswitch : metal switch with green led
    • redswitch : metal switch with red led
    • yellowled : yellow led only
    • greenled : green led only
    • redled : red led only
    • switch : metal switch only
    • slider : sliding switch
    By default, the boolean parameter is managed with a simple check box.
(Overrides BaseParameter..::..Options.)
Public property Tag
Gets/sets the Tag property of the parameter's control object
(Overrides BaseParameter..::..Tag.)
Public property TextHandler
Property used by MADCAT to get the String handler of the parameter
(Inherited from BaseParameter.)
Public property Tip
Property used by MADCAT to get/set the ToolTip object for the Form Control of the parameter
(Inherited from BaseParameter.)
Public property Type
Type of the parameter. For boolean, it is CMN_Boolean
(Overrides BaseParameter..::..Type.)
Public property TypeName
Gets the name of the type of the parameter as it is coded in the attribute TYPE of the parameter's Xml definition (ATTRIBUTE element definition) It is the core type's name of the parameter
(Inherited from BaseParameter.)
Public property UserSettings
Property used by MADCAT to get/set the user settings of the parameter
(Inherited from BaseParameter.)
Public property Value
Gets/Sets the value of the parameter. May be 'YES' (=true) or 'NO' (=false)
(Overrides BaseParameter..::..Value.)
Public property XmlDefinition
Xml Definition of the parameter. See the ATTRIBUTE element in the schema (XSD) named MODELS.
(Overrides BaseParameter..::..XmlDefinition.)
Public property XmlNodeHandler
Property used by MADCAT to get the XML handler of the parameter
(Inherited from BaseParameter.)

See Also

BooleanInput Class
Parameters Namespace


Display Property

[image]

MADCAT Software Developer Guide
BooleanInput..::..Display Property
BooleanInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used to get or set the type of display of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public BooleanDisplayTypes Display { get; set; }
Visual Basic
Public Property Display As BooleanDisplayTypes
    Get
    Set
Visual C++
public:
property BooleanDisplayTypes Display {
    BooleanDisplayTypes get ();
    void set (BooleanDisplayTypes value);
}

See Also

BooleanInput Class
BooleanInput Members
Parameters Namespace


DisplayOnly Property

[image]

MADCAT Software Developer Guide
BooleanInput..::..DisplayOnly Property
BooleanInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Set to true if the value can't be changed

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override bool DisplayOnly { get; set; }
Visual Basic
Public Overrides Property DisplayOnly As Boolean
    Get
    Set
Visual C++
public:
virtual property bool DisplayOnly {
    bool get () override;
    void set (bool value) override;
}

Implements

IParameter..::..DisplayOnly

See Also

BooleanInput Class
BooleanInput Members
Parameters Namespace


DrawHandler Property

[image]

MADCAT Software Developer Guide
BooleanInput..::..DrawHandler Property
BooleanInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get the Bitmap handler of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override BitmapHandler DrawHandler { get; }
Visual Basic
Public Overrides ReadOnly Property DrawHandler As BitmapHandler
    Get
Visual C++
public:
virtual property BitmapHandler^ DrawHandler {
    BitmapHandler^ get () override;
}

Implements

IParameter..::..DrawHandler

See Also

BooleanInput Class
BooleanInput Members
Parameters Namespace


FormControl Property

[image]

MADCAT Software Developer Guide
BooleanInput..::..FormControl Property
BooleanInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the control of the parameter. Depends on the option 'showas' : may be a graphical switch or led or a standard check box.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Control FormControl { get; }
Visual Basic
Public Overrides ReadOnly Property FormControl As Control
    Get
Visual C++
public:
virtual property Control^ FormControl {
    Control^ get () override;
}

Implements

IParameter..::..FormControl

See Also

BooleanInput Class
BooleanInput Members
Parameters Namespace


LedColor Property

[image]

MADCAT Software Developer Guide
BooleanInput..::..LedColor Property
BooleanInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used to get or set the color of the led of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public LedColors LedColor { get; set; }
Visual Basic
Public Property LedColor As LedColors
    Get
    Set
Visual C++
public:
property LedColors LedColor {
    LedColors get ();
    void set (LedColors value);
}

See Also

BooleanInput Class
BooleanInput Members
Parameters Namespace


Options Property

[image]

MADCAT Software Developer Guide
BooleanInput..::..Options Property
BooleanInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Sets the options of the boolean parameter. Accepted options are :
  • showas=xxx : Display mode of the boolean value where xxx may be :
    • yellowswitch : metal switch with yellow led
    • greenswitch : metal switch with green led
    • redswitch : metal switch with red led
    • yellowled : yellow led only
    • greenled : green led only
    • redled : red led only
    • switch : metal switch only
    • slider : sliding switch
    By default, the boolean parameter is managed with a simple check box.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Hashtable Options { set; }
Visual Basic
Public Overrides WriteOnly Property Options As Hashtable
    Set
Visual C++
public:
virtual property Hashtable^ Options {
    void set (Hashtable^ value) override;
}

Implements

IParameter..::..Options

See Also

BooleanInput Class
BooleanInput Members
Parameters Namespace


Tag Property

[image]

MADCAT Software Developer Guide
BooleanInput..::..Tag Property
BooleanInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/sets the Tag property of the parameter's control object

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Object Tag { get; set; }
Visual Basic
Public Overrides Property Tag As Object
    Get
    Set
Visual C++
public:
virtual property Object^ Tag {
    Object^ get () override;
    void set (Object^ value) override;
}

See Also

BooleanInput Class
BooleanInput Members
Parameters Namespace


Type Property

[image]

MADCAT Software Developer Guide
BooleanInput..::..Type Property
BooleanInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Type of the parameter. For boolean, it is CMN_Boolean

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override DataToolTypes Type { get; }
Visual Basic
Public Overrides ReadOnly Property Type As DataToolTypes
    Get
Visual C++
public:
virtual property DataToolTypes Type {
    DataToolTypes get () override;
}

Implements

IParameter..::..Type

See Also

BooleanInput Class
BooleanInput Members
Parameters Namespace


Value Property

[image]

MADCAT Software Developer Guide
BooleanInput..::..Value Property
BooleanInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/Sets the value of the parameter. May be 'YES' (=true) or 'NO' (=false)

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override string Value { get; set; }
Visual Basic
Public Overrides Property Value As String
    Get
    Set
Visual C++
public:
virtual property String^ Value {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IParameter..::..Value

See Also

BooleanInput Class
BooleanInput Members
Parameters Namespace


XmlDefinition Property

[image]

MADCAT Software Developer Guide
BooleanInput..::..XmlDefinition Property
BooleanInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Xml Definition of the parameter. See the ATTRIBUTE element in the schema (XSD) named MODELS.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override XmlNode XmlDefinition { set; }
Visual Basic
Public Overrides WriteOnly Property XmlDefinition As XmlNode
    Set
Visual C++
public:
virtual property XmlNode^ XmlDefinition {
    void set (XmlNode^ value) override;
}

Implements

IParameter..::..XmlDefinition

See Also

BooleanInput Class
BooleanInput Members
Parameters Namespace


BooleanInput Events

[image] [image]

MADCAT Software Developer Guide
BooleanInput Events
BooleanInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BooleanInput type exposes the following members.

Events

 | Name | Description
Public event | ValueChanged | Fired when the value of the parameter changes (Inherited from BaseParameter.)

See Also

BooleanInput Class
Parameters Namespace


ColorInput Class

[image]

MADCAT Software Developer Guide
ColorInput Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Used to manage colors. User sees the color and can change it by clicking on it as it opens the color picker of Windows.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public class ColorInput : BaseParameter
Visual Basic
Public Class ColorInput _
    Inherits BaseParameter
Visual C++
public ref class ColorInput : public BaseParameter

Inheritance Hierarchy

System..::..Object
Parameters..::..BaseParameter
Parameters..::..ColorInput

See Also

ColorInput Members
Parameters Namespace


ColorInput Members

[image] [image]

MADCAT Software Developer Guide
ColorInput Members
ColorInput Class Constructors Methods Properties Events See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The ColorInput type exposes the following members.

Constructors

 | Name | Description
Public method | ColorInput | Constructor

Methods

 | Name | Description
Public method | BuildHTMLString | Gives the HTML code used to render the input field in HTML instead of Windows form control (Overrides BaseParameter..::..BuildHTMLString()()()().)
Public method | BuildLabel | Gives the Windows Form control for the label of the input field of the parameter (Inherited from BaseParameter.)
Public method | Clone | Clones the parameter object into a new parameter object (Overrides BaseParameter..::..Clone()()()().)
 | ColorToHTML | Helper used to convert Drawing Color code into HTML code
 | HTMLToColor | Helper used to convert HTML code into Drawing Color code
Public method | RestoreValueFromItem | Gets the value of the parameter from a given project's Item (Overrides BaseParameter..::..RestoreValueFromItem(XmlNode).)
Public method | SaveValueInItem | Saves the value of the parameter into a given project's Item (Overrides BaseParameter..::..SaveValueInItem(XmlNode).)

Properties

Name Description
Public property ContextMenu
Property used by MADCAT to get the context menu of the parameter
(Inherited from BaseParameter.)
Public property Description
Property used by MADCAT to get/set the description of the parameter
(Inherited from BaseParameter.)
Public property DisplayOnly
Property used by MADCAT to set the access mode of the parameter
(Inherited from BaseParameter.)
Public property DrawHandler
Property used by MADCAT to get the Bitmap handler of the parameter
(Overrides BaseParameter..::..DrawHandler.)
Public property FormControl
Control used to modify/display the color
(Overrides BaseParameter..::..FormControl.)
Public property HasChanged
Property used by MADCAT to check if the parameter has changed
(Inherited from BaseParameter.)
Public property Hint
Property used by MADCAT to get/set the tip of the parameter. The tip contains a short help which popups when the user moves his mouse cursor over the parameter's name
(Inherited from BaseParameter.)
Public property IsMandatory
Property used by MADCAT to indicate if the parameter is mandatory or not. When mandatory, the user must give a value to the parameter to continue his current operation.
(Inherited from BaseParameter.)
Public property IsUndefined
Property used by MADCAT to check if the parameter has been set by the user or not
(Inherited from BaseParameter.)
Public property MaxNumberOfChars
Gets/sets the maximum number of characters of the parameter's value
(Inherited from BaseParameter.)
Public property Name
Property used by MADCAT to get/set the name of the parameter
(Inherited from BaseParameter.)
Public property NumberOfLines
Gets/sets the number of lines visible in the text box of the parameter
(Inherited from BaseParameter.)
Public property Options
Property used by MADCAT to get/set the options of the parameter. Common options are (applicable to all parameters):
  • mandatory=b : where b is 'yes' or 'no'. Indicates if the parameter must be filled by the user
  • readonly=b : where b is 'yes' or 'no'. Indicates if the parameter can be modified by the user
BaseParameter options are :
  • lines=999 : where 999 is the number of visible lines in the text box of the parameter
  • length=999 : where 999 is the maximum number of characters of the parameter's value
(Inherited from BaseParameter.)
Public property Tag
Gets/sets the Tag property of the parameter's control object
(Overrides BaseParameter..::..Tag.)
Public property TextHandler
Property used by MADCAT to get the String handler of the parameter
(Inherited from BaseParameter.)
Public property Tip
Property used by MADCAT to get/set the ToolTip object for the Form Control of the parameter
(Inherited from BaseParameter.)
Public property Type
Gets the type of the parameter. For colors, it is CMN_Color
(Overrides BaseParameter..::..Type.)
Public property TypeName
Gets the name of the type of the parameter as it is coded in the attribute TYPE of the parameter's Xml definition (ATTRIBUTE element definition) It is the core type's name of the parameter
(Inherited from BaseParameter.)
Public property UserSettings
Property used by MADCAT to get/set the user settings of the parameter
(Inherited from BaseParameter.)
Public property Value
Gets/sets the value of the parameter. Colors are coded with HTML format in strings #RRGGBB.
(Overrides BaseParameter..::..Value.)
Public property XmlDefinition
Property used by MADCAT to get/set the XML definition of the parameter. Definition must be compliant with the schema MODELS.XSD
(Overrides BaseParameter..::..XmlDefinition.)
Public property XmlNodeHandler
Property used by MADCAT to get the XML handler of the parameter
(Inherited from BaseParameter.)

Events

 | Name | Description
Public event | ValueChanged | Fired when the value of the parameter changes (Inherited from BaseParameter.)

See Also

ColorInput Class
Parameters Namespace


ColorInput Constructor

[image]

MADCAT Software Developer Guide
ColorInput Constructor
ColorInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public ColorInput()
Visual Basic
Public Sub New
Visual C++
public:
ColorInput()

See Also

ColorInput Class
ColorInput Members
Parameters Namespace


ColorInput Methods

[image] [image]

MADCAT Software Developer Guide
ColorInput Methods
ColorInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The ColorInput type exposes the following members.

Methods

 | Name | Description
Public method | BuildHTMLString | Gives the HTML code used to render the input field in HTML instead of Windows form control (Overrides BaseParameter..::..BuildHTMLString()()()().)
Public method | BuildLabel | Gives the Windows Form control for the label of the input field of the parameter (Inherited from BaseParameter.)
Public method | Clone | Clones the parameter object into a new parameter object (Overrides BaseParameter..::..Clone()()()().)
 | ColorToHTML | Helper used to convert Drawing Color code into HTML code
 | HTMLToColor | Helper used to convert HTML code into Drawing Color code
Public method | RestoreValueFromItem | Gets the value of the parameter from a given project's Item (Overrides BaseParameter..::..RestoreValueFromItem(XmlNode).)
Public method | SaveValueInItem | Saves the value of the parameter into a given project's Item (Overrides BaseParameter..::..SaveValueInItem(XmlNode).)

See Also

ColorInput Class
Parameters Namespace


BuildHTMLString Method

[image]

MADCAT Software Developer Guide
ColorInput..::..BuildHTMLString Method
ColorInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gives the HTML code used to render the input field in HTML instead of Windows form control

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override string BuildHTMLString()
Visual Basic
Public Overrides Function BuildHTMLString As String
Visual C++
public:
virtual String^ BuildHTMLString() override

Return Value

The HTML code equivalent to the Windows Form Control

Implements

IParameter..::..BuildHTMLString()()()()

See Also

ColorInput Class
ColorInput Members
Parameters Namespace


Clone Method

[image]

MADCAT Software Developer Guide
ColorInput..::..Clone Method
ColorInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Clones the parameter object into a new parameter object

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

A clone of the current object

See Also

ColorInput Class
ColorInput Members
Parameters Namespace


ColorToHTML Method

[image]

MADCAT Software Developer Guide
ColorInput..::..ColorToHTML Method
ColorInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Helper used to convert Drawing Color code into HTML code

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public static string ColorToHTML(
    Color col
)
Visual Basic
Public Shared Function ColorToHTML ( _
    col As Color _
) As String
Visual C++
public:
static String^ ColorToHTML(
    Color col
)

Parameters

col
Type: System.Drawing..::..Color
Color to convert

Return Value

The HTML code equivalent to the Drawing Color

See Also

ColorInput Class
ColorInput Members
Parameters Namespace


HTMLToColor Method

[image]

MADCAT Software Developer Guide
ColorInput..::..HTMLToColor Method
ColorInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Helper used to convert HTML code into Drawing Color code

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public static Color HTMLToColor(
    string value
)
Visual Basic
Public Shared Function HTMLToColor ( _
    value As String _
) As Color
Visual C++
public:
static Color HTMLToColor(
    String^ value
)

Parameters

value
Type: System..::..String
HTML code of the color to convert. Must be in format #RRGGBB

Return Value

The Drawing Color equivalent to the HTML code

See Also

ColorInput Class
ColorInput Members
Parameters Namespace


RestoreValueFromItem Method

[image]

MADCAT Software Developer Guide
ColorInput..::..RestoreValueFromItem Method
ColorInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the value of the parameter from a given project's Item

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override void RestoreValueFromItem(
    XmlNode item
)
Visual Basic
Public Overrides Sub RestoreValueFromItem ( _
    item As XmlNode _
)
Visual C++
public:
virtual void RestoreValueFromItem(
    XmlNode^ item
) override

Parameters

item
Type: System.Xml..::..XmlNode
XML node where the attribute's value shall be used to set the parameter's value

Implements

IParameter..::..RestoreValueFromItem(XmlNode)

See Also

ColorInput Class
ColorInput Members
Parameters Namespace


SaveValueInItem Method

[image]

MADCAT Software Developer Guide
ColorInput..::..SaveValueInItem Method
ColorInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Saves the value of the parameter into a given project's Item

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override void SaveValueInItem(
    XmlNode item
)
Visual Basic
Public Overrides Sub SaveValueInItem ( _
    item As XmlNode _
)
Visual C++
public:
virtual void SaveValueInItem(
    XmlNode^ item
) override

Parameters

item
Type: System.Xml..::..XmlNode
XML node where the parameter's value shall be stored into as an attribute's value

Implements

IParameter..::..SaveValueInItem(XmlNode)

See Also

ColorInput Class
ColorInput Members
Parameters Namespace


ColorInput Properties

[image] [image]

MADCAT Software Developer Guide
ColorInput Properties
ColorInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The ColorInput type exposes the following members.

Properties

Name Description
Public property ContextMenu
Property used by MADCAT to get the context menu of the parameter
(Inherited from BaseParameter.)
Public property Description
Property used by MADCAT to get/set the description of the parameter
(Inherited from BaseParameter.)
Public property DisplayOnly
Property used by MADCAT to set the access mode of the parameter
(Inherited from BaseParameter.)
Public property DrawHandler
Property used by MADCAT to get the Bitmap handler of the parameter
(Overrides BaseParameter..::..DrawHandler.)
Public property FormControl
Control used to modify/display the color
(Overrides BaseParameter..::..FormControl.)
Public property HasChanged
Property used by MADCAT to check if the parameter has changed
(Inherited from BaseParameter.)
Public property Hint
Property used by MADCAT to get/set the tip of the parameter. The tip contains a short help which popups when the user moves his mouse cursor over the parameter's name
(Inherited from BaseParameter.)
Public property IsMandatory
Property used by MADCAT to indicate if the parameter is mandatory or not. When mandatory, the user must give a value to the parameter to continue his current operation.
(Inherited from BaseParameter.)
Public property IsUndefined
Property used by MADCAT to check if the parameter has been set by the user or not
(Inherited from BaseParameter.)
Public property MaxNumberOfChars
Gets/sets the maximum number of characters of the parameter's value
(Inherited from BaseParameter.)
Public property Name
Property used by MADCAT to get/set the name of the parameter
(Inherited from BaseParameter.)
Public property NumberOfLines
Gets/sets the number of lines visible in the text box of the parameter
(Inherited from BaseParameter.)
Public property Options
Property used by MADCAT to get/set the options of the parameter. Common options are (applicable to all parameters):
  • mandatory=b : where b is 'yes' or 'no'. Indicates if the parameter must be filled by the user
  • readonly=b : where b is 'yes' or 'no'. Indicates if the parameter can be modified by the user
BaseParameter options are :
  • lines=999 : where 999 is the number of visible lines in the text box of the parameter
  • length=999 : where 999 is the maximum number of characters of the parameter's value
(Inherited from BaseParameter.)
Public property Tag
Gets/sets the Tag property of the parameter's control object
(Overrides BaseParameter..::..Tag.)
Public property TextHandler
Property used by MADCAT to get the String handler of the parameter
(Inherited from BaseParameter.)
Public property Tip
Property used by MADCAT to get/set the ToolTip object for the Form Control of the parameter
(Inherited from BaseParameter.)
Public property Type
Gets the type of the parameter. For colors, it is CMN_Color
(Overrides BaseParameter..::..Type.)
Public property TypeName
Gets the name of the type of the parameter as it is coded in the attribute TYPE of the parameter's Xml definition (ATTRIBUTE element definition) It is the core type's name of the parameter
(Inherited from BaseParameter.)
Public property UserSettings
Property used by MADCAT to get/set the user settings of the parameter
(Inherited from BaseParameter.)
Public property Value
Gets/sets the value of the parameter. Colors are coded with HTML format in strings #RRGGBB.
(Overrides BaseParameter..::..Value.)
Public property XmlDefinition
Property used by MADCAT to get/set the XML definition of the parameter. Definition must be compliant with the schema MODELS.XSD
(Overrides BaseParameter..::..XmlDefinition.)
Public property XmlNodeHandler
Property used by MADCAT to get the XML handler of the parameter
(Inherited from BaseParameter.)

See Also

ColorInput Class
Parameters Namespace


DrawHandler Property

[image]

MADCAT Software Developer Guide
ColorInput..::..DrawHandler Property
ColorInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get the Bitmap handler of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override BitmapHandler DrawHandler { get; }
Visual Basic
Public Overrides ReadOnly Property DrawHandler As BitmapHandler
    Get
Visual C++
public:
virtual property BitmapHandler^ DrawHandler {
    BitmapHandler^ get () override;
}

Implements

IParameter..::..DrawHandler

See Also

ColorInput Class
ColorInput Members
Parameters Namespace


FormControl Property

[image]

MADCAT Software Developer Guide
ColorInput..::..FormControl Property
ColorInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Control used to modify/display the color

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Control FormControl { get; }
Visual Basic
Public Overrides ReadOnly Property FormControl As Control
    Get
Visual C++
public:
virtual property Control^ FormControl {
    Control^ get () override;
}

Implements

IParameter..::..FormControl

See Also

ColorInput Class
ColorInput Members
Parameters Namespace


Tag Property

[image]

MADCAT Software Developer Guide
ColorInput..::..Tag Property
ColorInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/sets the Tag property of the parameter's control object

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Object Tag { get; set; }
Visual Basic
Public Overrides Property Tag As Object
    Get
    Set
Visual C++
public:
virtual property Object^ Tag {
    Object^ get () override;
    void set (Object^ value) override;
}

See Also

ColorInput Class
ColorInput Members
Parameters Namespace


Type Property

[image]

MADCAT Software Developer Guide
ColorInput..::..Type Property
ColorInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the type of the parameter. For colors, it is CMN_Color

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override DataToolTypes Type { get; }
Visual Basic
Public Overrides ReadOnly Property Type As DataToolTypes
    Get
Visual C++
public:
virtual property DataToolTypes Type {
    DataToolTypes get () override;
}

Implements

IParameter..::..Type

See Also

ColorInput Class
ColorInput Members
Parameters Namespace


Value Property

[image]

MADCAT Software Developer Guide
ColorInput..::..Value Property
ColorInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/sets the value of the parameter. Colors are coded with HTML format in strings #RRGGBB.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override string Value { get; set; }
Visual Basic
Public Overrides Property Value As String
    Get
    Set
Visual C++
public:
virtual property String^ Value {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IParameter..::..Value

See Also

ColorInput Class
ColorInput Members
Parameters Namespace


XmlDefinition Property

[image]

MADCAT Software Developer Guide
ColorInput..::..XmlDefinition Property
ColorInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the XML definition of the parameter. Definition must be compliant with the schema MODELS.XSD

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override XmlNode XmlDefinition { set; }
Visual Basic
Public Overrides WriteOnly Property XmlDefinition As XmlNode
    Set
Visual C++
public:
virtual property XmlNode^ XmlDefinition {
    void set (XmlNode^ value) override;
}

Implements

IParameter..::..XmlDefinition

See Also

ColorInput Class
ColorInput Members
Parameters Namespace


ColorInput Events

[image] [image]

MADCAT Software Developer Guide
ColorInput Events
ColorInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The ColorInput type exposes the following members.

Events

 | Name | Description
Public event | ValueChanged | Fired when the value of the parameter changes (Inherited from BaseParameter.)

See Also

ColorInput Class
Parameters Namespace


DataToolTypes Enumeration

[image]

MADCAT Software Developer Guide
DataToolTypes Enumeration
See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Types of the base parameters

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public enum DataToolTypes
Visual Basic
Public Enumeration DataToolTypes
Visual C++
public enum class DataToolTypes

Members

Member name | Value | Description
External | 19 | Parameters which can manage user-specific data types. Type name is the name of the DLL file which contains the type class.
CMN_String | 18 | Parameters which can manage strings. Type name is 'STR'.
CMN_Enumerate | 17 | Parameters which can manage enumerated values. Type name is 'ENUM'.
CMN_Bitmap | 16 | Parameters which can manage bitmap files. Type name is 'BMP'.
CMN_Register | 15 | NOT IMPLEMENTED YET - Reserved
CMN_Group | 14 | Parameters which can manage groups of parameters. Type name is 'GRP'.
CMN_IPAddress | 13 | Parameters which can manage IP v4 addresses. Type name is 'IPADDR'.
CMN_Directory | 12 | Parameters which can manage folders of the host file system. Type name is 'DIR'.
CMN_File | 11 | Parameters which can manage any files of the host file system. Type name is 'FILE'.
CMN_Color | 10 | Parameters which can manage colors. Type name is 'COLOR'.
CMN_DateTime | 9 | Parameters which can manage date and time values. Type name is 'DATETIME'.
CMN_Boolean | 8 | Parameters which can manage boolean values. Type name is 'BOOL'.
CMN_Text | 7 | Parameters which can manage strings. Type name is 'TXT'.
CMN_Numeric | 6 | Parameters which can manage numeric values. Type name is 'NUM'.
DTT_SeriesItem | 5 | Parameters which can manage a selection of series'items in the database
DTT_Series | 4 | Parameters which can manage a selection of series in the database
DTT_Query | 3 | Parameters which can manage a selection of queries in the database
DTT_Link | 2 | Parameters which can manage a selection of links in the database
DTT_Folder | 1 | Parameters which can manage a selection of folders in the database
DTT_Item | 0 | Parameters which can manage a selection of items in the database

See Also

Parameters Namespace


DateFilter Class

[image]

MADCAT Software Developer Guide
DateFilter Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Filter for date/time parameters.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public class DateFilter : IFilter
Visual Basic
Public Class DateFilter _
    Implements IFilter
Visual C++
public ref class DateFilter : IFilter

Inheritance Hierarchy

System..::..Object
Parameters..::..DateFilter

See Also

DateFilter Members
Parameters Namespace


DateFilter Members

[image] [image]

MADCAT Software Developer Guide
DateFilter Members
DateFilter Class Constructors Methods Properties See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The DateFilter type exposes the following members.

Constructors

 | Name | Description
Public method | DateFilter | Constructor

Methods

 | Name | Description
Public method | GetTypeOptions | Not implemented. Reserved.
Public method | IsMatch | The filter function.

Properties

 | Name | Description
Public property | Args | Gets/sets the filter's arguments. Can be safely casted into DateFilterArgs object. See DateFilterArgs.
Public property | Form | Gets the filter's configuration form. See DateFilterForm.
Public property | IsActive | Indicates if the filter is active or not.
Public property | Type | Gets the base type of the filter. Always CMN_DateTime.
Public property | XPathCondition | Not used for Date/Time filters. Always null.

See Also

DateFilter Class
Parameters Namespace


DateFilter Constructor

[image]

MADCAT Software Developer Guide
DateFilter Constructor
DateFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public DateFilter(
    DataToolTypes type
)
Visual Basic
Public Sub New ( _
    type As DataToolTypes _
)
Visual C++
public:
DateFilter(
    DataToolTypes type
)

Parameters

type
Type: Parameters..::..DataToolTypes
Sets the base type of the filter. Shall be CMN_DateTime.

See Also

DateFilter Class
DateFilter Members
Parameters Namespace


DateFilter Methods

[image] [image]

MADCAT Software Developer Guide
DateFilter Methods
DateFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The DateFilter type exposes the following members.

Methods

 | Name | Description
Public method | GetTypeOptions | Not implemented. Reserved.
Public method | IsMatch | The filter function.

See Also

DateFilter Class
Parameters Namespace


GetTypeOptions Method

[image]

MADCAT Software Developer Guide
DateFilter..::..GetTypeOptions Method
DateFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Not implemented. Reserved.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual void GetTypeOptions(
    Hashtable opt
)
Visual Basic
Public Overridable Sub GetTypeOptions ( _
    opt As Hashtable _
)
Visual C++
public:
virtual void GetTypeOptions(
    Hashtable^ opt
)

Parameters

opt
Type: System.Collections..::..Hashtable
Not implemented

Implements

IFilter..::..GetTypeOptions(Hashtable)

See Also

DateFilter Class
DateFilter Members
Parameters Namespace


IsMatch Method

[image]

MADCAT Software Developer Guide
DateFilter..::..IsMatch Method
DateFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
The filter function.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual bool IsMatch(
    string value
)
Visual Basic
Public Overridable Function IsMatch ( _
    value As String _
) As Boolean
Visual C++
public:
virtual bool IsMatch(
    String^ value
)

Parameters

value
Type: System..::..String
Value to test

Return Value

True if the given string matches the filter's arguments.

Implements

IFilter..::..IsMatch(String)

See Also

DateFilter Class
DateFilter Members
Parameters Namespace


DateFilter Properties

[image] [image]

MADCAT Software Developer Guide
DateFilter Properties
DateFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The DateFilter type exposes the following members.

Properties

 | Name | Description
Public property | Args | Gets/sets the filter's arguments. Can be safely casted into DateFilterArgs object. See DateFilterArgs.
Public property | Form | Gets the filter's configuration form. See DateFilterForm.
Public property | IsActive | Indicates if the filter is active or not.
Public property | Type | Gets the base type of the filter. Always CMN_DateTime.
Public property | XPathCondition | Not used for Date/Time filters. Always null.

See Also

DateFilter Class
Parameters Namespace


Args Property

[image]

MADCAT Software Developer Guide
DateFilter..::..Args Property
DateFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/sets the filter's arguments. Can be safely casted into DateFilterArgs object. See DateFilterArgs.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual Object Args { get; set; }
Visual Basic
Public Overridable Property Args As Object
    Get
    Set
Visual C++
public:
virtual property Object^ Args {
    Object^ get ();
    void set (Object^ value);
}

Implements

IFilter..::..Args

See Also

DateFilter Class
DateFilter Members
Parameters Namespace


Form Property

[image]

MADCAT Software Developer Guide
DateFilter..::..Form Property
DateFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the filter's configuration form. See DateFilterForm.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual Control Form { get; }
Visual Basic
Public Overridable ReadOnly Property Form As Control
    Get
Visual C++
public:
virtual property Control^ Form {
    Control^ get ();
}

Implements

IFilter..::..Form

See Also

DateFilter Class
DateFilter Members
Parameters Namespace


IsActive Property

[image]

MADCAT Software Developer Guide
DateFilter..::..IsActive Property
DateFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Indicates if the filter is active or not.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual bool IsActive { get; }
Visual Basic
Public Overridable ReadOnly Property IsActive As Boolean
    Get
Visual C++
public:
virtual property bool IsActive {
    bool get ();
}

Implements

IFilter..::..IsActive

See Also

DateFilter Class
DateFilter Members
Parameters Namespace


Type Property

[image]

MADCAT Software Developer Guide
DateFilter..::..Type Property
DateFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the base type of the filter. Always CMN_DateTime.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual DataToolTypes Type { get; }
Visual Basic
Public Overridable ReadOnly Property Type As DataToolTypes
    Get
Visual C++
public:
virtual property DataToolTypes Type {
    DataToolTypes get ();
}

Implements

IFilter..::..Type

See Also

DateFilter Class
DateFilter Members
Parameters Namespace


XPathCondition Property

[image]

MADCAT Software Developer Guide
DateFilter..::..XPathCondition Property
DateFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Not used for Date/Time filters. Always null.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual string XPathCondition { get; }
Visual Basic
Public Overridable ReadOnly Property XPathCondition As String
    Get
Visual C++
public:
virtual property String^ XPathCondition {
    String^ get ();
}

Implements

IFilter..::..XPathCondition

See Also

DateFilter Class
DateFilter Members
Parameters Namespace


DateFilterArgs Class

[image]

MADCAT Software Developer Guide
DateFilterArgs Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Arguments of the date/time filter.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
[SerializableAttribute]
public class DateFilterArgs
Visual Basic
<SerializableAttribute> _
Public Class DateFilterArgs
Visual C++
[SerializableAttribute]
public ref class DateFilterArgs

Inheritance Hierarchy

System..::..Object
Parameters..::..DateFilterArgs

See Also

DateFilterArgs Members
Parameters Namespace


DateFilterArgs Members

[image] [image]

MADCAT Software Developer Guide
DateFilterArgs Members
DateFilterArgs Class Constructors Fields See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The DateFilterArgs type exposes the following members.

Constructors

 | Name | Description
Public method | DateFilterArgs | Constructor

Fields

 | Name | Description
Public field | Inverted | Flag which indicates if the filter's logic should be inverted. If it is inverted (=true), accepted values will be rejected and vice versa.
Public field | Mode | Filter's mode
Public field | NbLastDays | Number of accepted days for the modes LastDays or NextDays.
Public field | RangeEnd | 2nd boundary of the range of accepted dates for the mode InRange.
Public field | RangeStart | 1st boundary of the range of accepted dates for the mode InRange.
Public field | WithBounds | Flag which indicates if boundaries should be accepted (=true) or rejected (=false)

See Also

DateFilterArgs Class
Parameters Namespace


DateFilterArgs Constructor

[image]

MADCAT Software Developer Guide
DateFilterArgs Constructor
DateFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public DateFilterArgs()
Visual Basic
Public Sub New
Visual C++
public:
DateFilterArgs()

See Also

DateFilterArgs Class
DateFilterArgs Members
Parameters Namespace


DateFilterArgs Fields

[image] [image]

MADCAT Software Developer Guide
DateFilterArgs Fields
DateFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The DateFilterArgs type exposes the following members.

Fields

 | Name | Description
Public field | Inverted | Flag which indicates if the filter's logic should be inverted. If it is inverted (=true), accepted values will be rejected and vice versa.
Public field | Mode | Filter's mode
Public field | NbLastDays | Number of accepted days for the modes LastDays or NextDays.
Public field | RangeEnd | 2nd boundary of the range of accepted dates for the mode InRange.
Public field | RangeStart | 1st boundary of the range of accepted dates for the mode InRange.
Public field | WithBounds | Flag which indicates if boundaries should be accepted (=true) or rejected (=false)

See Also

DateFilterArgs Class
Parameters Namespace


Inverted Field

[image]

MADCAT Software Developer Guide
DateFilterArgs..::..Inverted Field
DateFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Flag which indicates if the filter's logic should be inverted. If it is inverted (=true), accepted values will be rejected and vice versa.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public bool Inverted
Visual Basic
Public Inverted As Boolean
Visual C++
public:
bool Inverted

See Also

DateFilterArgs Class
DateFilterArgs Members
Parameters Namespace


Mode Field

[image]

MADCAT Software Developer Guide
DateFilterArgs..::..Mode Field
DateFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Filter's mode

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public DateFilterMode Mode
Visual Basic
Public Mode As DateFilterMode
Visual C++
public:
DateFilterMode Mode

See Also

DateFilterArgs Class
DateFilterArgs Members
Parameters Namespace


NbLastDays Field

[image]

MADCAT Software Developer Guide
DateFilterArgs..::..NbLastDays Field
DateFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Number of accepted days for the modes LastDays or NextDays.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public int NbLastDays
Visual Basic
Public NbLastDays As Integer
Visual C++
public:
int NbLastDays

See Also

DateFilterArgs Class
DateFilterArgs Members
Parameters Namespace


RangeEnd Field

[image]

MADCAT Software Developer Guide
DateFilterArgs..::..RangeEnd Field
DateFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
2nd boundary of the range of accepted dates for the mode InRange.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public DateTime RangeEnd
Visual Basic
Public RangeEnd As DateTime
Visual C++
public:
DateTime RangeEnd

See Also

DateFilterArgs Class
DateFilterArgs Members
Parameters Namespace


RangeStart Field

[image]

MADCAT Software Developer Guide
DateFilterArgs..::..RangeStart Field
DateFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
1st boundary of the range of accepted dates for the mode InRange.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public DateTime RangeStart
Visual Basic
Public RangeStart As DateTime
Visual C++
public:
DateTime RangeStart

See Also

DateFilterArgs Class
DateFilterArgs Members
Parameters Namespace


WithBounds Field

[image]

MADCAT Software Developer Guide
DateFilterArgs..::..WithBounds Field
DateFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Flag which indicates if boundaries should be accepted (=true) or rejected (=false)

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public bool WithBounds
Visual Basic
Public WithBounds As Boolean
Visual C++
public:
bool WithBounds

See Also

DateFilterArgs Class
DateFilterArgs Members
Parameters Namespace


DateFilterForm Class

[image]

MADCAT Software Developer Guide
DateFilterForm Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Form used to edit the Date/Time Filter's arguments. See DateFilterArgs.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public class DateFilterForm : Form
Visual Basic
Public Class DateFilterForm _
    Inherits Form
Visual C++
public ref class DateFilterForm : public Form

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
Parameters..::..DateFilterForm

See Also

DateFilterForm Members
Parameters Namespace


DateFilterForm Members

[image] [image]

MADCAT Software Developer Guide
DateFilterForm Members
DateFilterForm Class Constructors See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The DateFilterForm type exposes the following members.

Constructors

 | Name | Description
Public method | DateFilterForm | Constructor

See Also

DateFilterForm Class
Parameters Namespace


DateFilterForm Constructor

[image]

MADCAT Software Developer Guide
DateFilterForm Constructor
DateFilterForm Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public DateFilterForm(
    DateFilterArgs filter
)
Visual Basic
Public Sub New ( _
    filter As DateFilterArgs _
)
Visual C++
public:
DateFilterForm(
    DateFilterArgs^ filter
)

Parameters

filter
Type: Parameters..::..DateFilterArgs
Arguments of the filter

See Also

DateFilterForm Class
DateFilterForm Members
Parameters Namespace


DateFilterMode Enumeration

[image]

MADCAT Software Developer Guide
DateFilterMode Enumeration
See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Modes of the date/time filter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
[SerializableAttribute]
public enum DateFilterMode
Visual Basic
<SerializableAttribute> _
Public Enumeration DateFilterMode
Visual C++
[SerializableAttribute]
public enum class DateFilterMode

Members

Member name | Value | Description
Deactivated | 15 | Filter accepts all dates
LastDays | 14 | Filter accepts only values which are in the last N days. N is a parameter of the filter.
NextDays | 13 | Filter accepts only values which are in the next N days. N is a parameter of the filter.
InRange | 12 | Filter accepts only values which are between two given dates
LastYear | 11 | Filter accepts only values which are in the previous year
ThisYear | 10 | Filter accepts only values which are in the current year
NextYear | 9 | Filter accepts only values which are in the next year
LastMonth | 8 | Filter accepts only values which are in the previous month
ThisMonth | 7 | Filter accepts only values which are in the current month
NextMonth | 6 | Filter accepts only values which are in the next month
LastWeek | 5 | Filter accepts only values which are in the previous week
ThisWeek | 4 | Filter accepts only values which are in the current week
NextWeek | 3 | Filter accepts only values which are in the next week
Yesterday | 2 | Filter accepts only values which are equal to the date of yesterday
Today | 1 | Filter accepts only values which are equal to the date of tomorrow
Tomorrow | 0 | Filter accepts only values which are equal to the date of tomorrow

See Also

Parameters Namespace


DateInput Class

[image]

MADCAT Software Developer Guide
DateInput Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Used to manage date/time values in MADCAT.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
[SerializableAttribute]
public class DateInput : BaseParameter
Visual Basic
<SerializableAttribute> _
Public Class DateInput _
    Inherits BaseParameter
Visual C++
[SerializableAttribute]
public ref class DateInput : public BaseParameter

Inheritance Hierarchy

System..::..Object
Parameters..::..BaseParameter
Parameters..::..DateInput

See Also

DateInput Members
Parameters Namespace


DateInput Members

[image] [image]

MADCAT Software Developer Guide
DateInput Members
DateInput Class Constructors Methods Properties Events See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The DateInput type exposes the following members.

Constructors

 | Name | Description
Public method | DateInput | Constructor

Methods

 | Name | Description
Public method | BuildHTMLString | Gives the HTML code used to render the input field in HTML instead of Windows form control (Overrides BaseParameter..::..BuildHTMLString()()()().)
Public method | BuildLabel | Gives the Windows Form control for the label of the input field of the parameter (Inherited from BaseParameter.)
Public method | Clone | Clones the parameter object into a new parameter object (Overrides BaseParameter..::..Clone()()()().)
Public method | RestoreValueFromItem | Gets the value of the parameter from a given project's Item (Overrides BaseParameter..::..RestoreValueFromItem(XmlNode).)
Public method | SaveValueInItem | Saves the value of the parameter into a given project's Item (Overrides BaseParameter..::..SaveValueInItem(XmlNode).)

Properties

Name Description
Public property ContextMenu
Property used by MADCAT to get the context menu of the parameter
(Inherited from BaseParameter.)
Public property Description
Property used by MADCAT to get/set the description of the parameter
(Inherited from BaseParameter.)
Public property DisplayOnly
Property used by MADCAT to set the access mode of the parameter
(Overrides BaseParameter..::..DisplayOnly.)
Public property DrawHandler
Property used by MADCAT to get the Bitmap handler of the parameter
(Inherited from BaseParameter.)
Public property FormControl
Control used to change the date/time. Offers a calendar to pick a date
(Overrides BaseParameter..::..FormControl.)
Public property HasChanged
Property used by MADCAT to check if the parameter has changed
(Inherited from BaseParameter.)
Public property Hint
Property used by MADCAT to get/set the tip of the parameter. The tip contains a short help which popups when the user moves his mouse cursor over the parameter's name
(Inherited from BaseParameter.)
Public property IsMandatory
Property used by MADCAT to indicate if the parameter is mandatory or not. When mandatory, the user must give a value to the parameter to continue his current operation.
(Inherited from BaseParameter.)
Public property IsUndefined
Property used by MADCAT to check if the parameter has been set by the user or not
(Inherited from BaseParameter.)
Public property MaxNumberOfChars
Gets/sets the maximum number of characters of the parameter's value
(Inherited from BaseParameter.)
Public property Name
Property used by MADCAT to get/set the name of the parameter
(Inherited from BaseParameter.)
Public property NumberOfLines
Gets/sets the number of lines visible in the text box of the parameter
(Inherited from BaseParameter.)
Public property Options
Property used by MADCAT to get/set the options of the parameter. Common options are (applicable to all parameters):
    • mandatory=b : where b is 'yes' or 'no'. Indicates if the parameter must be filled by the user
      readonly=b : where b is 'yes' or 'no'. Indicates if the parameter can be modified by the user
    • (Overrides BaseParameter..::..Options.)
    Public property Tag
    Gets/sets the Tag property of the parameter's control object
    (Overrides BaseParameter..::..Tag.)
    Public property TextHandler
    Property used by MADCAT to get the String handler of the parameter
    (Inherited from BaseParameter.)
    Public property Tip
    Property used by MADCAT to get/set the ToolTip object for the Form Control of the parameter
    (Inherited from BaseParameter.)
    Public property Type
    Gets the base type of the parameter. For date/time, it is CMN_DateTime.
    (Overrides BaseParameter..::..Type.)
    Public property TypeName
    Gets the name of the type of the parameter as it is coded in the attribute TYPE of the parameter's Xml definition (ATTRIBUTE element definition) It is the core type's name of the parameter
    (Inherited from BaseParameter.)
    Public property UserSettings
    Property used by MADCAT to get/set the user settings of the parameter
    (Inherited from BaseParameter.)
    Public property Value
    Property used by MADCAT to get/set the value of the parameter. Date/time is stored with the following format : dd/MM/yyyy HH:mm:ss
    (Overrides BaseParameter..::..Value.)
    Public property XmlDefinition
    Property used by MADCAT to get/set the XML definition of the parameter. Definition must be compliant with the schema MODELS.XSD
    (Inherited from BaseParameter.)
    Public property XmlNodeHandler
    Property used by MADCAT to get the XML handler of the parameter
    (Inherited from BaseParameter.)

    Events

     | Name | Description
Public event | ValueChanged | Fired when the value of the parameter changes (Inherited from BaseParameter.)

    See Also

    DateInput Class
    Parameters Namespace


DateInput Constructor

[image]

MADCAT Software Developer Guide
DateInput Constructor
DateInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public DateInput()
Visual Basic
Public Sub New
Visual C++
public:
DateInput()

See Also

DateInput Class
DateInput Members
Parameters Namespace


DateInput Methods

[image] [image]

MADCAT Software Developer Guide
DateInput Methods
DateInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The DateInput type exposes the following members.

Methods

 | Name | Description
Public method | BuildHTMLString | Gives the HTML code used to render the input field in HTML instead of Windows form control (Overrides BaseParameter..::..BuildHTMLString()()()().)
Public method | BuildLabel | Gives the Windows Form control for the label of the input field of the parameter (Inherited from BaseParameter.)
Public method | Clone | Clones the parameter object into a new parameter object (Overrides BaseParameter..::..Clone()()()().)
Public method | RestoreValueFromItem | Gets the value of the parameter from a given project's Item (Overrides BaseParameter..::..RestoreValueFromItem(XmlNode).)
Public method | SaveValueInItem | Saves the value of the parameter into a given project's Item (Overrides BaseParameter..::..SaveValueInItem(XmlNode).)

See Also

DateInput Class
Parameters Namespace


BuildHTMLString Method

[image]

MADCAT Software Developer Guide
DateInput..::..BuildHTMLString Method
DateInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gives the HTML code used to render the input field in HTML instead of Windows form control

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override string BuildHTMLString()
Visual Basic
Public Overrides Function BuildHTMLString As String
Visual C++
public:
virtual String^ BuildHTMLString() override

Return Value

The HTML code equivalent to the Windows Form Control

Implements

IParameter..::..BuildHTMLString()()()()

See Also

DateInput Class
DateInput Members
Parameters Namespace


Clone Method

[image]

MADCAT Software Developer Guide
DateInput..::..Clone Method
DateInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Clones the parameter object into a new parameter object

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

A clone of the current object

See Also

DateInput Class
DateInput Members
Parameters Namespace


RestoreValueFromItem Method

[image]

MADCAT Software Developer Guide
DateInput..::..RestoreValueFromItem Method
DateInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the value of the parameter from a given project's Item

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override void RestoreValueFromItem(
    XmlNode item
)
Visual Basic
Public Overrides Sub RestoreValueFromItem ( _
    item As XmlNode _
)
Visual C++
public:
virtual void RestoreValueFromItem(
    XmlNode^ item
) override

Parameters

item
Type: System.Xml..::..XmlNode
XML node where the attribute's value shall be used to set the parameter's value

Implements

IParameter..::..RestoreValueFromItem(XmlNode)

See Also

DateInput Class
DateInput Members
Parameters Namespace


SaveValueInItem Method

[image]

MADCAT Software Developer Guide
DateInput..::..SaveValueInItem Method
DateInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Saves the value of the parameter into a given project's Item

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override void SaveValueInItem(
    XmlNode item
)
Visual Basic
Public Overrides Sub SaveValueInItem ( _
    item As XmlNode _
)
Visual C++
public:
virtual void SaveValueInItem(
    XmlNode^ item
) override

Parameters

item
Type: System.Xml..::..XmlNode
XML node where the parameter's value shall be stored into as an attribute's value

Implements

IParameter..::..SaveValueInItem(XmlNode)

See Also

DateInput Class
DateInput Members
Parameters Namespace


DateInput Properties

[image] [image]

MADCAT Software Developer Guide
DateInput Properties
DateInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The DateInput type exposes the following members.

Properties

Name Description
Public property ContextMenu
Property used by MADCAT to get the context menu of the parameter
(Inherited from BaseParameter.)
Public property Description
Property used by MADCAT to get/set the description of the parameter
(Inherited from BaseParameter.)
Public property DisplayOnly
Property used by MADCAT to set the access mode of the parameter
(Overrides BaseParameter..::..DisplayOnly.)
Public property DrawHandler
Property used by MADCAT to get the Bitmap handler of the parameter
(Inherited from BaseParameter.)
Public property FormControl
Control used to change the date/time. Offers a calendar to pick a date
(Overrides BaseParameter..::..FormControl.)
Public property HasChanged
Property used by MADCAT to check if the parameter has changed
(Inherited from BaseParameter.)
Public property Hint
Property used by MADCAT to get/set the tip of the parameter. The tip contains a short help which popups when the user moves his mouse cursor over the parameter's name
(Inherited from BaseParameter.)
Public property IsMandatory
Property used by MADCAT to indicate if the parameter is mandatory or not. When mandatory, the user must give a value to the parameter to continue his current operation.
(Inherited from BaseParameter.)
Public property IsUndefined
Property used by MADCAT to check if the parameter has been set by the user or not
(Inherited from BaseParameter.)
Public property MaxNumberOfChars
Gets/sets the maximum number of characters of the parameter's value
(Inherited from BaseParameter.)
Public property Name
Property used by MADCAT to get/set the name of the parameter
(Inherited from BaseParameter.)
Public property NumberOfLines
Gets/sets the number of lines visible in the text box of the parameter
(Inherited from BaseParameter.)
Public property Options
Property used by MADCAT to get/set the options of the parameter. Common options are (applicable to all parameters):
    • mandatory=b : where b is 'yes' or 'no'. Indicates if the parameter must be filled by the user
      readonly=b : where b is 'yes' or 'no'. Indicates if the parameter can be modified by the user
    • (Overrides BaseParameter..::..Options.)
    Public property Tag
    Gets/sets the Tag property of the parameter's control object
    (Overrides BaseParameter..::..Tag.)
    Public property TextHandler
    Property used by MADCAT to get the String handler of the parameter
    (Inherited from BaseParameter.)
    Public property Tip
    Property used by MADCAT to get/set the ToolTip object for the Form Control of the parameter
    (Inherited from BaseParameter.)
    Public property Type
    Gets the base type of the parameter. For date/time, it is CMN_DateTime.
    (Overrides BaseParameter..::..Type.)
    Public property TypeName
    Gets the name of the type of the parameter as it is coded in the attribute TYPE of the parameter's Xml definition (ATTRIBUTE element definition) It is the core type's name of the parameter
    (Inherited from BaseParameter.)
    Public property UserSettings
    Property used by MADCAT to get/set the user settings of the parameter
    (Inherited from BaseParameter.)
    Public property Value
    Property used by MADCAT to get/set the value of the parameter. Date/time is stored with the following format : dd/MM/yyyy HH:mm:ss
    (Overrides BaseParameter..::..Value.)
    Public property XmlDefinition
    Property used by MADCAT to get/set the XML definition of the parameter. Definition must be compliant with the schema MODELS.XSD
    (Inherited from BaseParameter.)
    Public property XmlNodeHandler
    Property used by MADCAT to get the XML handler of the parameter
    (Inherited from BaseParameter.)

    See Also

    DateInput Class
    Parameters Namespace


DisplayOnly Property

[image]

MADCAT Software Developer Guide
DateInput..::..DisplayOnly Property
DateInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to set the access mode of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override bool DisplayOnly { get; set; }
Visual Basic
Public Overrides Property DisplayOnly As Boolean
    Get
    Set
Visual C++
public:
virtual property bool DisplayOnly {
    bool get () override;
    void set (bool value) override;
}

Implements

IParameter..::..DisplayOnly

See Also

DateInput Class
DateInput Members
Parameters Namespace


FormControl Property

[image]

MADCAT Software Developer Guide
DateInput..::..FormControl Property
DateInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Control used to change the date/time. Offers a calendar to pick a date

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Control FormControl { get; }
Visual Basic
Public Overrides ReadOnly Property FormControl As Control
    Get
Visual C++
public:
virtual property Control^ FormControl {
    Control^ get () override;
}

Implements

IParameter..::..FormControl

See Also

DateInput Class
DateInput Members
Parameters Namespace


Options Property

[image]

MADCAT Software Developer Guide
DateInput..::..Options Property
DateInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the options of the parameter. Common options are (applicable to all parameters):
    • mandatory=b : where b is 'yes' or 'no'. Indicates if the parameter must be filled by the user
      readonly=b : where b is 'yes' or 'no'. Indicates if the parameter can be modified by the user

    • Namespace: Parameters
    Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

    Syntax

    C#
    public override Hashtable Options { set; }
    Visual Basic
    Public Overrides WriteOnly Property Options As Hashtable
    Set
    Visual C++
    public:
virtual property Hashtable^ Options {
    void set (Hashtable^ value) override;
}

    Implements

    IParameter..::..Options

    See Also

    DateInput Class
    DateInput Members
    Parameters Namespace


Tag Property

[image]

MADCAT Software Developer Guide
DateInput..::..Tag Property
DateInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/sets the Tag property of the parameter's control object

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Object Tag { get; set; }
Visual Basic
Public Overrides Property Tag As Object
    Get
    Set
Visual C++
public:
virtual property Object^ Tag {
    Object^ get () override;
    void set (Object^ value) override;
}

See Also

DateInput Class
DateInput Members
Parameters Namespace


Type Property

[image]

MADCAT Software Developer Guide
DateInput..::..Type Property
DateInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the base type of the parameter. For date/time, it is CMN_DateTime.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override DataToolTypes Type { get; }
Visual Basic
Public Overrides ReadOnly Property Type As DataToolTypes
    Get
Visual C++
public:
virtual property DataToolTypes Type {
    DataToolTypes get () override;
}

Implements

IParameter..::..Type

See Also

DateInput Class
DateInput Members
Parameters Namespace


Value Property

[image]

MADCAT Software Developer Guide
DateInput..::..Value Property
DateInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the value of the parameter. Date/time is stored with the following format : dd/MM/yyyy HH:mm:ss

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override string Value { get; set; }
Visual Basic
Public Overrides Property Value As String
    Get
    Set
Visual C++
public:
virtual property String^ Value {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IParameter..::..Value

See Also

DateInput Class
DateInput Members
Parameters Namespace


DateInput Events

[image] [image]

MADCAT Software Developer Guide
DateInput Events
DateInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The DateInput type exposes the following members.

Events

 | Name | Description
Public event | ValueChanged | Fired when the value of the parameter changes (Inherited from BaseParameter.)

See Also

DateInput Class
Parameters Namespace


DateSorter Class

[image]

MADCAT Software Developer Guide
DateSorter Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Used to compare 2 date/time values.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public class DateSorter : IComparer
Visual Basic
Public Class DateSorter _
    Implements IComparer
Visual C++
public ref class DateSorter : IComparer

Inheritance Hierarchy

System..::..Object
Parameters..::..DateSorter

See Also

DateSorter Members
Parameters Namespace


DateSorter Members

[image] [image]

MADCAT Software Developer Guide
DateSorter Members
DateSorter Class Constructors Methods See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The DateSorter type exposes the following members.

Constructors

 | Name | Description
Public method | DateSorter | Constructor

Methods

 | Name | Description
Public method | Compare | Compare two different date/time values

See Also

DateSorter Class
Parameters Namespace


DateSorter Constructor

[image]

MADCAT Software Developer Guide
DateSorter Constructor
DateSorter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public DateSorter()
Visual Basic
Public Sub New
Visual C++
public:
DateSorter()

See Also

DateSorter Class
DateSorter Members
Parameters Namespace


DateSorter Methods

[image] [image]

MADCAT Software Developer Guide
DateSorter Methods
DateSorter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The DateSorter type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compare two different date/time values

See Also

DateSorter Class
Parameters Namespace


Compare Method

[image]

MADCAT Software Developer Guide
DateSorter..::..Compare Method
DateSorter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Compare two different date/time values

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual int Compare(
    Object x,
    Object y
)
Visual Basic
Public Overridable Function Compare ( _
    x As Object, _
    y As Object _
) As Integer
Visual C++
public:
virtual int Compare(
    Object^ x,
    Object^ y
)

Parameters

x
Type: System..::..Object
String of the 1st formatted date/time
y
Type: System..::..Object
String of the 2nd formatted date/time

Return Value

The comparison results coded as follow:
  • equal to 0 : Values are equal
  • less than 0 : 1st value is lower than 2nd value
  • greater than 0 : 1st value is greater than 2nd value

Implements

IComparer..::..Compare(Object, Object)

See Also

DateSorter Class
DateSorter Members
Parameters Namespace


DirectoryInput Class

[image]

MADCAT Software Developer Guide
DirectoryInput Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Used to manage paths of directories of the host's filesystem.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
[SerializableAttribute]
public class DirectoryInput : BaseParameter
Visual Basic
<SerializableAttribute> _
Public Class DirectoryInput _
    Inherits BaseParameter
Visual C++
[SerializableAttribute]
public ref class DirectoryInput : public BaseParameter

Inheritance Hierarchy

System..::..Object
Parameters..::..BaseParameter
Parameters..::..DirectoryInput

See Also

DirectoryInput Members
Parameters Namespace


DirectoryInput Members

[image] [image]

MADCAT Software Developer Guide
DirectoryInput Members
DirectoryInput Class Constructors Methods Properties Events See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The DirectoryInput type exposes the following members.

Constructors

 | Name | Description
Public method | DirectoryInput | Constructor

Methods

 | Name | Description
Public method | BuildHTMLString | Gives the HTML code used to render the input field in HTML instead of Windows form control (Inherited from BaseParameter.)
Public method | BuildLabel | Gives the Windows Form control for the label of the input field of the parameter (Inherited from BaseParameter.)
Public method | Clone | Clones the parameter object into a new parameter object (Overrides BaseParameter..::..Clone()()()().)
Public method | RestoreValueFromItem | Gets the value of the parameter from a given project's Item (Overrides BaseParameter..::..RestoreValueFromItem(XmlNode).)
Public method | SaveValueInItem | Saves the value of the parameter into a given project's Item (Overrides BaseParameter..::..SaveValueInItem(XmlNode).)

Properties

Name Description
Public property ContextMenu
Property used by MADCAT to get the context menu of the parameter
(Inherited from BaseParameter.)
Public property Description
Property used by MADCAT to get/set the description of the parameter
(Inherited from BaseParameter.)
Public property DisplayOnly
Set to true if the value can't be changed
(Overrides BaseParameter..::..DisplayOnly.)
Public property DrawHandler
Property used by MADCAT to get the Bitmap handler of the parameter
(Inherited from BaseParameter.)
Public property FormControl
Gets the control used to change the parameter's value. For directories, it is a text box with a button which opens the common Windows' directory dialog box.
(Overrides BaseParameter..::..FormControl.)
Public property ForOutput
Gets/sets the purpose of the directory. If it is equal to true, the directory is used to store files and will be accessed for writing. Otherwise, it is used to read files and is accessed for reading.
Public property HasChanged
Property used by MADCAT to check if the parameter has changed
(Inherited from BaseParameter.)
Public property Hint
Property used by MADCAT to get/set the tip of the parameter. The tip contains a short help which popups when the user moves his mouse cursor over the parameter's name
(Inherited from BaseParameter.)
Public property IsMandatory
Property used by MADCAT to indicate if the parameter is mandatory or not. When mandatory, the user must give a value to the parameter to continue his current operation.
(Inherited from BaseParameter.)
Public property IsUndefined
Property used by MADCAT to check if the parameter has been set by the user or not
(Inherited from BaseParameter.)
Public property MaxNumberOfChars
Gets/sets the maximum number of characters of the parameter's value
(Inherited from BaseParameter.)
Public property Name
Property used by MADCAT to get/set the name of the parameter
(Inherited from BaseParameter.)
Public property NumberOfLines
Gets/sets the number of lines visible in the text box of the parameter
(Inherited from BaseParameter.)
Public property Options
Sets the options for the parameter. Directory parameters accept the following options :
  • foroutput=yes|no : Flag which indicates if the parameters manage input directories (=false) or output directories (=true). This has a direct impact on the dialog box which will be used to let the user select a directory in his system.
(Overrides BaseParameter..::..Options.)
Public property Tag
Gets/sets the Tag property of the parameter's control object
(Inherited from BaseParameter.)
Public property TextHandler
Property used by MADCAT to get the String handler of the parameter
(Inherited from BaseParameter.)
Public property Tip
Property used by MADCAT to get/set the ToolTip object for the Form Control of the parameter
(Inherited from BaseParameter.)
Public property Type
Gets the base type of the parameter. For directories, it is CMN_Directory.
(Overrides BaseParameter..::..Type.)
Public property TypeName
Gets the name of the type of the parameter as it is coded in the attribute TYPE of the parameter's Xml definition (ATTRIBUTE element definition) It is the core type's name of the parameter
(Inherited from BaseParameter.)
Public property UserSettings
Property used by MADCAT to get/set the user settings of the parameter
(Inherited from BaseParameter.)
Public property Value
Gets/sets the value of the parameter. Paths are always absolute values. If relative values are set, they are considered relative to the current workspace's root path.
(Overrides BaseParameter..::..Value.)
Public property XmlDefinition
Property used by MADCAT to get/set the XML definition of the parameter. Definition must be compliant with the schema MODELS.XSD
(Overrides BaseParameter..::..XmlDefinition.)
Public property XmlNodeHandler
Property used by MADCAT to get the XML handler of the parameter
(Inherited from BaseParameter.)

Events

 | Name | Description
Public event | ValueChanged | Fired when the value of the parameter changes (Inherited from BaseParameter.)

See Also

DirectoryInput Class
Parameters Namespace


DirectoryInput Constructor

[image]

MADCAT Software Developer Guide
DirectoryInput Constructor
DirectoryInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public DirectoryInput()
Visual Basic
Public Sub New
Visual C++
public:
DirectoryInput()

See Also

DirectoryInput Class
DirectoryInput Members
Parameters Namespace


DirectoryInput Methods

[image] [image]

MADCAT Software Developer Guide
DirectoryInput Methods
DirectoryInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The DirectoryInput type exposes the following members.

Methods

 | Name | Description
Public method | BuildHTMLString | Gives the HTML code used to render the input field in HTML instead of Windows form control (Inherited from BaseParameter.)
Public method | BuildLabel | Gives the Windows Form control for the label of the input field of the parameter (Inherited from BaseParameter.)
Public method | Clone | Clones the parameter object into a new parameter object (Overrides BaseParameter..::..Clone()()()().)
Public method | RestoreValueFromItem | Gets the value of the parameter from a given project's Item (Overrides BaseParameter..::..RestoreValueFromItem(XmlNode).)
Public method | SaveValueInItem | Saves the value of the parameter into a given project's Item (Overrides BaseParameter..::..SaveValueInItem(XmlNode).)

See Also

DirectoryInput Class
Parameters Namespace


Clone Method

[image]

MADCAT Software Developer Guide
DirectoryInput..::..Clone Method
DirectoryInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Clones the parameter object into a new parameter object

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

A clone of the current object

See Also

DirectoryInput Class
DirectoryInput Members
Parameters Namespace


RestoreValueFromItem Method

[image]

MADCAT Software Developer Guide
DirectoryInput..::..RestoreValueFromItem Method
DirectoryInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the value of the parameter from a given project's Item

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override void RestoreValueFromItem(
    XmlNode item
)
Visual Basic
Public Overrides Sub RestoreValueFromItem ( _
    item As XmlNode _
)
Visual C++
public:
virtual void RestoreValueFromItem(
    XmlNode^ item
) override

Parameters

item
Type: System.Xml..::..XmlNode
XML node where the attribute's value shall be used to set the parameter's value

Implements

IParameter..::..RestoreValueFromItem(XmlNode)

See Also

DirectoryInput Class
DirectoryInput Members
Parameters Namespace


SaveValueInItem Method

[image]

MADCAT Software Developer Guide
DirectoryInput..::..SaveValueInItem Method
DirectoryInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Saves the value of the parameter into a given project's Item

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override void SaveValueInItem(
    XmlNode item
)
Visual Basic
Public Overrides Sub SaveValueInItem ( _
    item As XmlNode _
)
Visual C++
public:
virtual void SaveValueInItem(
    XmlNode^ item
) override

Parameters

item
Type: System.Xml..::..XmlNode
XML node where the parameter's value shall be stored into as an attribute's value

Implements

IParameter..::..SaveValueInItem(XmlNode)

See Also

DirectoryInput Class
DirectoryInput Members
Parameters Namespace


DirectoryInput Properties

[image] [image]

MADCAT Software Developer Guide
DirectoryInput Properties
DirectoryInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The DirectoryInput type exposes the following members.

Properties

Name Description
Public property ContextMenu
Property used by MADCAT to get the context menu of the parameter
(Inherited from BaseParameter.)
Public property Description
Property used by MADCAT to get/set the description of the parameter
(Inherited from BaseParameter.)
Public property DisplayOnly
Set to true if the value can't be changed
(Overrides BaseParameter..::..DisplayOnly.)
Public property DrawHandler
Property used by MADCAT to get the Bitmap handler of the parameter
(Inherited from BaseParameter.)
Public property FormControl
Gets the control used to change the parameter's value. For directories, it is a text box with a button which opens the common Windows' directory dialog box.
(Overrides BaseParameter..::..FormControl.)
Public property ForOutput
Gets/sets the purpose of the directory. If it is equal to true, the directory is used to store files and will be accessed for writing. Otherwise, it is used to read files and is accessed for reading.
Public property HasChanged
Property used by MADCAT to check if the parameter has changed
(Inherited from BaseParameter.)
Public property Hint
Property used by MADCAT to get/set the tip of the parameter. The tip contains a short help which popups when the user moves his mouse cursor over the parameter's name
(Inherited from BaseParameter.)
Public property IsMandatory
Property used by MADCAT to indicate if the parameter is mandatory or not. When mandatory, the user must give a value to the parameter to continue his current operation.
(Inherited from BaseParameter.)
Public property IsUndefined
Property used by MADCAT to check if the parameter has been set by the user or not
(Inherited from BaseParameter.)
Public property MaxNumberOfChars
Gets/sets the maximum number of characters of the parameter's value
(Inherited from BaseParameter.)
Public property Name
Property used by MADCAT to get/set the name of the parameter
(Inherited from BaseParameter.)
Public property NumberOfLines
Gets/sets the number of lines visible in the text box of the parameter
(Inherited from BaseParameter.)
Public property Options
Sets the options for the parameter. Directory parameters accept the following options :
  • foroutput=yes|no : Flag which indicates if the parameters manage input directories (=false) or output directories (=true). This has a direct impact on the dialog box which will be used to let the user select a directory in his system.
(Overrides BaseParameter..::..Options.)
Public property Tag
Gets/sets the Tag property of the parameter's control object
(Inherited from BaseParameter.)
Public property TextHandler
Property used by MADCAT to get the String handler of the parameter
(Inherited from BaseParameter.)
Public property Tip
Property used by MADCAT to get/set the ToolTip object for the Form Control of the parameter
(Inherited from BaseParameter.)
Public property Type
Gets the base type of the parameter. For directories, it is CMN_Directory.
(Overrides BaseParameter..::..Type.)
Public property TypeName
Gets the name of the type of the parameter as it is coded in the attribute TYPE of the parameter's Xml definition (ATTRIBUTE element definition) It is the core type's name of the parameter
(Inherited from BaseParameter.)
Public property UserSettings
Property used by MADCAT to get/set the user settings of the parameter
(Inherited from BaseParameter.)
Public property Value
Gets/sets the value of the parameter. Paths are always absolute values. If relative values are set, they are considered relative to the current workspace's root path.
(Overrides BaseParameter..::..Value.)
Public property XmlDefinition
Property used by MADCAT to get/set the XML definition of the parameter. Definition must be compliant with the schema MODELS.XSD
(Overrides BaseParameter..::..XmlDefinition.)
Public property XmlNodeHandler
Property used by MADCAT to get the XML handler of the parameter
(Inherited from BaseParameter.)

See Also

DirectoryInput Class
Parameters Namespace


DisplayOnly Property

[image]

MADCAT Software Developer Guide
DirectoryInput..::..DisplayOnly Property
DirectoryInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Set to true if the value can't be changed

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override bool DisplayOnly { set; }
Visual Basic
Public Overrides WriteOnly Property DisplayOnly As Boolean
    Set
Visual C++
public:
virtual property bool DisplayOnly {
    void set (bool value) override;
}

Implements

IParameter..::..DisplayOnly

See Also

DirectoryInput Class
DirectoryInput Members
Parameters Namespace


FormControl Property

[image]

MADCAT Software Developer Guide
DirectoryInput..::..FormControl Property
DirectoryInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the control used to change the parameter's value. For directories, it is a text box with a button which opens the common Windows' directory dialog box.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Control FormControl { get; }
Visual Basic
Public Overrides ReadOnly Property FormControl As Control
    Get
Visual C++
public:
virtual property Control^ FormControl {
    Control^ get () override;
}

Implements

IParameter..::..FormControl

See Also

DirectoryInput Class
DirectoryInput Members
Parameters Namespace


ForOutput Property

[image]

MADCAT Software Developer Guide
DirectoryInput..::..ForOutput Property
DirectoryInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/sets the purpose of the directory. If it is equal to true, the directory is used to store files and will be accessed for writing. Otherwise, it is used to read files and is accessed for reading.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public bool ForOutput { get; set; }
Visual Basic
Public Property ForOutput As Boolean
    Get
    Set
Visual C++
public:
property bool ForOutput {
    bool get ();
    void set (bool value);
}

See Also

DirectoryInput Class
DirectoryInput Members
Parameters Namespace


Options Property

[image]

MADCAT Software Developer Guide
DirectoryInput..::..Options Property
DirectoryInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Sets the options for the parameter. Directory parameters accept the following options :
  • foroutput=yes|no : Flag which indicates if the parameters manage input directories (=false) or output directories (=true). This has a direct impact on the dialog box which will be used to let the user select a directory in his system.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Hashtable Options { set; }
Visual Basic
Public Overrides WriteOnly Property Options As Hashtable
    Set
Visual C++
public:
virtual property Hashtable^ Options {
    void set (Hashtable^ value) override;
}

Implements

IParameter..::..Options

See Also

DirectoryInput Class
DirectoryInput Members
Parameters Namespace


Type Property

[image]

MADCAT Software Developer Guide
DirectoryInput..::..Type Property
DirectoryInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the base type of the parameter. For directories, it is CMN_Directory.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override DataToolTypes Type { get; }
Visual Basic
Public Overrides ReadOnly Property Type As DataToolTypes
    Get
Visual C++
public:
virtual property DataToolTypes Type {
    DataToolTypes get () override;
}

Implements

IParameter..::..Type

See Also

DirectoryInput Class
DirectoryInput Members
Parameters Namespace


Value Property

[image]

MADCAT Software Developer Guide
DirectoryInput..::..Value Property
DirectoryInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/sets the value of the parameter. Paths are always absolute values. If relative values are set, they are considered relative to the current workspace's root path.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override string Value { get; set; }
Visual Basic
Public Overrides Property Value As String
    Get
    Set
Visual C++
public:
virtual property String^ Value {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IParameter..::..Value

See Also

DirectoryInput Class
DirectoryInput Members
Parameters Namespace


XmlDefinition Property

[image]

MADCAT Software Developer Guide
DirectoryInput..::..XmlDefinition Property
DirectoryInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the XML definition of the parameter. Definition must be compliant with the schema MODELS.XSD

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override XmlNode XmlDefinition { set; }
Visual Basic
Public Overrides WriteOnly Property XmlDefinition As XmlNode
    Set
Visual C++
public:
virtual property XmlNode^ XmlDefinition {
    void set (XmlNode^ value) override;
}

Implements

IParameter..::..XmlDefinition

See Also

DirectoryInput Class
DirectoryInput Members
Parameters Namespace


DirectoryInput Events

[image] [image]

MADCAT Software Developer Guide
DirectoryInput Events
DirectoryInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The DirectoryInput type exposes the following members.

Events

 | Name | Description
Public event | ValueChanged | Fired when the value of the parameter changes (Inherited from BaseParameter.)

See Also

DirectoryInput Class
Parameters Namespace


EnumControlTypes Enumeration

[image]

MADCAT Software Developer Guide
EnumControlTypes Enumeration
See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Type of controls available for the Enumerate Input

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public enum EnumControlTypes
Visual Basic
Public Enumeration EnumControlTypes
Visual C++
public enum class EnumControlTypes

Members

Member name | Value | Description
Buttons | 2 | Enumerated values appear in a list of buttons
CheckBoxes | 1 | Enumerated values appear in a list of check boxes
ListBox | 0 | Enumerated values appear in a list box (if multiselection is on) or a combo box

See Also

Parameters Namespace


EnumFilter Class

[image]

MADCAT Software Developer Guide
EnumFilter Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Filter for enumeration parameters.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public class EnumFilter : IFilter
Visual Basic
Public Class EnumFilter _
    Implements IFilter
Visual C++
public ref class EnumFilter : IFilter

Inheritance Hierarchy

System..::..Object
Parameters..::..EnumFilter

See Also

EnumFilter Members
Parameters Namespace


EnumFilter Members

[image] [image]

MADCAT Software Developer Guide
EnumFilter Members
EnumFilter Class Constructors Methods Properties See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The EnumFilter type exposes the following members.

Constructors

 | Name | Description
Public method | EnumFilter | Constructor

Methods

 | Name | Description
Public method | GetTypeOptions | Not implemented. Reserved.
Public method | IsMatch | The filter function.

Properties

 | Name | Description
Public property | Args | Gets/sets the filter's arguments. Can be safely casted into EnumFilterArgs object. See EnumFilterArgs.
Public property | Form | Gets the filter's configuration form. See EnumFilterForm.
Public property | IsActive | Indicates if the filter is active or not.
Public property | Type | Gets the base type of the filter. Always CMN_Enumerate.
Public property | Values | Gets/sets the list of reference values for the filter
Public property | XPathCondition | Not used for Enumeration filters. Always null.

See Also

EnumFilter Class
Parameters Namespace


EnumFilter Constructor

[image]

MADCAT Software Developer Guide
EnumFilter Constructor
EnumFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public EnumFilter(
    DataToolTypes type
)
Visual Basic
Public Sub New ( _
    type As DataToolTypes _
)
Visual C++
public:
EnumFilter(
    DataToolTypes type
)

Parameters

type
Type: Parameters..::..DataToolTypes
Sets the base type of the filter. Shall be CMN_Enumerate.

See Also

EnumFilter Class
EnumFilter Members
Parameters Namespace


EnumFilter Methods

[image] [image]

MADCAT Software Developer Guide
EnumFilter Methods
EnumFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The EnumFilter type exposes the following members.

Methods

 | Name | Description
Public method | GetTypeOptions | Not implemented. Reserved.
Public method | IsMatch | The filter function.

See Also

EnumFilter Class
Parameters Namespace


GetTypeOptions Method

[image]

MADCAT Software Developer Guide
EnumFilter..::..GetTypeOptions Method
EnumFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Not implemented. Reserved.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual void GetTypeOptions(
    Hashtable opt
)
Visual Basic
Public Overridable Sub GetTypeOptions ( _
    opt As Hashtable _
)
Visual C++
public:
virtual void GetTypeOptions(
    Hashtable^ opt
)

Parameters

opt
Type: System.Collections..::..Hashtable
Not implemented

Implements

IFilter..::..GetTypeOptions(Hashtable)

See Also

EnumFilter Class
EnumFilter Members
Parameters Namespace


IsMatch Method

[image]

MADCAT Software Developer Guide
EnumFilter..::..IsMatch Method
EnumFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
The filter function.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual bool IsMatch(
    string value
)
Visual Basic
Public Overridable Function IsMatch ( _
    value As String _
) As Boolean
Visual C++
public:
virtual bool IsMatch(
    String^ value
)

Parameters

value
Type: System..::..String
Value to test

Return Value

True if the given string matches the filter's arguments.

Implements

IFilter..::..IsMatch(String)

See Also

EnumFilter Class
EnumFilter Members
Parameters Namespace


EnumFilter Properties

[image] [image]

MADCAT Software Developer Guide
EnumFilter Properties
EnumFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The EnumFilter type exposes the following members.

Properties

 | Name | Description
Public property | Args | Gets/sets the filter's arguments. Can be safely casted into EnumFilterArgs object. See EnumFilterArgs.
Public property | Form | Gets the filter's configuration form. See EnumFilterForm.
Public property | IsActive | Indicates if the filter is active or not.
Public property | Type | Gets the base type of the filter. Always CMN_Enumerate.
Public property | Values | Gets/sets the list of reference values for the filter
Public property | XPathCondition | Not used for Enumeration filters. Always null.

See Also

EnumFilter Class
Parameters Namespace


Args Property

[image]

MADCAT Software Developer Guide
EnumFilter..::..Args Property
EnumFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/sets the filter's arguments. Can be safely casted into EnumFilterArgs object. See EnumFilterArgs.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual Object Args { get; set; }
Visual Basic
Public Overridable Property Args As Object
    Get
    Set
Visual C++
public:
virtual property Object^ Args {
    Object^ get ();
    void set (Object^ value);
}

Implements

IFilter..::..Args

See Also

EnumFilter Class
EnumFilter Members
Parameters Namespace


Form Property

[image]

MADCAT Software Developer Guide
EnumFilter..::..Form Property
EnumFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the filter's configuration form. See EnumFilterForm.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual Control Form { get; }
Visual Basic
Public Overridable ReadOnly Property Form As Control
    Get
Visual C++
public:
virtual property Control^ Form {
    Control^ get ();
}

Implements

IFilter..::..Form

See Also

EnumFilter Class
EnumFilter Members
Parameters Namespace


IsActive Property

[image]

MADCAT Software Developer Guide
EnumFilter..::..IsActive Property
EnumFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Indicates if the filter is active or not.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual bool IsActive { get; }
Visual Basic
Public Overridable ReadOnly Property IsActive As Boolean
    Get
Visual C++
public:
virtual property bool IsActive {
    bool get ();
}

Implements

IFilter..::..IsActive

See Also

EnumFilter Class
EnumFilter Members
Parameters Namespace


Type Property

[image]

MADCAT Software Developer Guide
EnumFilter..::..Type Property
EnumFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the base type of the filter. Always CMN_Enumerate.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual DataToolTypes Type { get; }
Visual Basic
Public Overridable ReadOnly Property Type As DataToolTypes
    Get
Visual C++
public:
virtual property DataToolTypes Type {
    DataToolTypes get ();
}

Implements

IFilter..::..Type

See Also

EnumFilter Class
EnumFilter Members
Parameters Namespace


Values Property

[image]

MADCAT Software Developer Guide
EnumFilter..::..Values Property
EnumFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/sets the list of reference values for the filter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public ArrayList Values { get; set; }
Visual Basic
Public Property Values As ArrayList
    Get
    Set
Visual C++
public:
property ArrayList^ Values {
    ArrayList^ get ();
    void set (ArrayList^ value);
}

See Also

EnumFilter Class
EnumFilter Members
Parameters Namespace


XPathCondition Property

[image]

MADCAT Software Developer Guide
EnumFilter..::..XPathCondition Property
EnumFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Not used for Enumeration filters. Always null.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual string XPathCondition { get; }
Visual Basic
Public Overridable ReadOnly Property XPathCondition As String
    Get
Visual C++
public:
virtual property String^ XPathCondition {
    String^ get ();
}

Implements

IFilter..::..XPathCondition

See Also

EnumFilter Class
EnumFilter Members
Parameters Namespace


EnumFilterArgs Class

[image]

MADCAT Software Developer Guide
EnumFilterArgs Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Arguments of the filter for enumerate values

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
[SerializableAttribute]
public class EnumFilterArgs
Visual Basic
<SerializableAttribute> _
Public Class EnumFilterArgs
Visual C++
[SerializableAttribute]
public ref class EnumFilterArgs

Inheritance Hierarchy

System..::..Object
Parameters..::..EnumFilterArgs

See Also

EnumFilterArgs Members
Parameters Namespace


EnumFilterArgs Members

[image] [image]

MADCAT Software Developer Guide
EnumFilterArgs Members
EnumFilterArgs Class Constructors Fields See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The EnumFilterArgs type exposes the following members.

Constructors

 | Name | Description
Public method | EnumFilterArgs | Constructor

Fields

 | Name | Description
Public field | Mode | Mode of the filter
Public field | Values | Collection of values to accept/reject when filter is active. Array is filled with EnumValue objects. Content of the array can be changed.

See Also

EnumFilterArgs Class
Parameters Namespace


EnumFilterArgs Constructor

[image]

MADCAT Software Developer Guide
EnumFilterArgs Constructor
EnumFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public EnumFilterArgs()
Visual Basic
Public Sub New
Visual C++
public:
EnumFilterArgs()

See Also

EnumFilterArgs Class
EnumFilterArgs Members
Parameters Namespace


EnumFilterArgs Fields

[image] [image]

MADCAT Software Developer Guide
EnumFilterArgs Fields
EnumFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The EnumFilterArgs type exposes the following members.

Fields

 | Name | Description
Public field | Mode | Mode of the filter
Public field | Values | Collection of values to accept/reject when filter is active. Array is filled with EnumValue objects. Content of the array can be changed.

See Also

EnumFilterArgs Class
Parameters Namespace


Mode Field

[image]

MADCAT Software Developer Guide
EnumFilterArgs..::..Mode Field
EnumFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Mode of the filter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public EnumFilterMode Mode
Visual Basic
Public Mode As EnumFilterMode
Visual C++
public:
EnumFilterMode Mode

See Also

EnumFilterArgs Class
EnumFilterArgs Members
Parameters Namespace


Values Field

[image]

MADCAT Software Developer Guide
EnumFilterArgs..::..Values Field
EnumFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Collection of values to accept/reject when filter is active. Array is filled with EnumValue objects. Content of the array can be changed.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public ArrayList Values
Visual Basic
Public Values As ArrayList
Visual C++
public:
ArrayList^ Values

See Also

EnumFilterArgs Class
EnumFilterArgs Members
Parameters Namespace


EnumFilterForm Class

[image]

MADCAT Software Developer Guide
EnumFilterForm Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Form used to edit the Enumeration Filter's arguments. See EnumFilterArgs.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public class EnumFilterForm : Form
Visual Basic
Public Class EnumFilterForm _
    Inherits Form
Visual C++
public ref class EnumFilterForm : public Form

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
Parameters..::..EnumFilterForm

See Also

EnumFilterForm Members
Parameters Namespace


EnumFilterForm Members

[image] [image]

MADCAT Software Developer Guide
EnumFilterForm Members
EnumFilterForm Class Constructors See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The EnumFilterForm type exposes the following members.

Constructors

 | Name | Description
Public method | EnumFilterForm | Constructor

See Also

EnumFilterForm Class
Parameters Namespace


EnumFilterForm Constructor

[image]

MADCAT Software Developer Guide
EnumFilterForm Constructor
EnumFilterForm Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public EnumFilterForm(
    EnumFilterArgs filter
)
Visual Basic
Public Sub New ( _
    filter As EnumFilterArgs _
)
Visual C++
public:
EnumFilterForm(
    EnumFilterArgs^ filter
)

Parameters

filter
Type: Parameters..::..EnumFilterArgs
Arguments of the filter

See Also

EnumFilterForm Class
EnumFilterForm Members
Parameters Namespace


EnumFilterMode Enumeration

[image]

MADCAT Software Developer Guide
EnumFilterMode Enumeration
See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Modes of the filter for enumerate values

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
[SerializableAttribute]
public enum EnumFilterMode
Visual Basic
<SerializableAttribute> _
Public Enumeration EnumFilterMode
Visual C++
[SerializableAttribute]
public enum class EnumFilterMode

Members

Member name | Value | Description
Exclusive | 1 | Values attached to the filter are the ones which are discarded
Inclusive | 0 | Values attached to the filter are the ones which are accepted
Deactivated | 2 | All values are accepted

See Also

Parameters Namespace


EnumInput Class

[image]

MADCAT Software Developer Guide
EnumInput Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Manages parameters which handle enumerate values

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public class EnumInput : BaseParameter
Visual Basic
Public Class EnumInput _
    Inherits BaseParameter
Visual C++
public ref class EnumInput : public BaseParameter

Inheritance Hierarchy

System..::..Object
Parameters..::..BaseParameter
Parameters..::..EnumInput

See Also

EnumInput Members
Parameters Namespace


EnumInput Members

[image] [image]

MADCAT Software Developer Guide
EnumInput Members
EnumInput Class Constructors Methods Properties Events See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The EnumInput type exposes the following members.

Constructors

 | Name | Description
Public method | EnumInput | Constructor

Methods

 | Name | Description
Public method | AddEnumerateValue | Add a new value in the list of the possible values for the parameter
Public method | BuildHTMLString | Gives the HTML code used to render the input field in HTML instead of Windows form control (Overrides BaseParameter..::..BuildHTMLString()()()().)
Public method | BuildLabel | Gives the Windows Form control for the label of the input field of the parameter (Inherited from BaseParameter.)
Public method | Clone | Clones the parameter object into a new parameter object (Overrides BaseParameter..::..Clone()()()().)
Public method | RestoreValueFromItem | Gets the value of the parameter from a given project's Item (Overrides BaseParameter..::..RestoreValueFromItem(XmlNode).)
Public method | SaveValueInItem | Saves the value of the parameter into a given project's Item (Overrides BaseParameter..::..SaveValueInItem(XmlNode).)

Properties

Name Description
Public property ContextMenu
Property used by MADCAT to get the context menu of the parameter
(Inherited from BaseParameter.)
Public property ControlType
Gets the base type of the parameter. For directories, it is CMN_Enumerate.
Public property Description
Property used by MADCAT to get/set the description of the parameter
(Inherited from BaseParameter.)
Public property DisplayOnly
Property used by MADCAT to set the access mode of the parameter
(Overrides BaseParameter..::..DisplayOnly.)
Public property DrawHandler
Property used by MADCAT to get the Bitmap handler of the parameter
(Inherited from BaseParameter.)
Public property FormControl
Gets the control used to change the parameter's value. For enum, it is a drop-down box, a group of check box or a list box. This depends on the option named "showas".
(Overrides BaseParameter..::..FormControl.)
Public property HasChanged
Property used by MADCAT to check if the parameter has changed
(Inherited from BaseParameter.)
Public property Hint
Property used by MADCAT to get/set the tip of the parameter. The tip contains a short help which popups when the user moves his mouse cursor over the parameter's name
(Inherited from BaseParameter.)
Public property IsMandatory
Property used by MADCAT to indicate if the parameter is mandatory or not. When mandatory, the user must give a value to the parameter to continue his current operation.
(Inherited from BaseParameter.)
Public property IsUndefined
Property used by MADCAT to check if the parameter has been set by the user or not
(Overrides BaseParameter..::..IsUndefined.)
Public property MaxNumberOfChars
Gets/sets the maximum number of characters of the parameter's value
(Inherited from BaseParameter.)
Public property MultiSelection
Gets the base type of the parameter. For directories, it is CMN_Enumerate.
Public property Name
Property used by MADCAT to get/set the name of the parameter
(Inherited from BaseParameter.)
Public property NumberOfLines
Gets/sets the number of lines visible in the text box of the parameter
(Inherited from BaseParameter.)
Public property Options
Property used by MADCAT to get/set the options of the parameter. Common options are (applicable to all parameters):
  • mandatory=b : where b is 'yes' or 'no'. Indicates if the parameter must be filled by the user
  • readonly=b : where b is 'yes' or 'no'. Indicates if the parameter can be modified by the user
Additional options are :
  • multiselect=yes|no : indicates if the user can select more than one value or not
  • showas=xxx : Selects the kind of control to use. xxx can be : checkbox or button
(Overrides BaseParameter..::..Options.)
Public property Tag
Gets/sets the Tag property of the parameter's control object
(Inherited from BaseParameter.)
Public property TextHandler
Property used by MADCAT to get the String handler of the parameter
(Overrides BaseParameter..::..TextHandler.)
Public property Tip
Property used by MADCAT to get/set the ToolTip object for the Form Control of the parameter
(Inherited from BaseParameter.)
Public property Type
Gets the base type of the parameter. For directories, it is CMN_Enumerate.
(Overrides BaseParameter..::..Type.)
Public property TypeName
Gets the name of the type of the parameter as it is coded in the attribute TYPE of the parameter's Xml definition (ATTRIBUTE element definition) It is the core type's name of the parameter
(Inherited from BaseParameter.)
Public property UserSettings
Property used by MADCAT to get/set the user settings of the parameter
(Inherited from BaseParameter.)
Public property Value
Property used by MADCAT to get/set the value of the parameter. If mutliple values are selected, they are merged in the same string and separated with comas.
(Overrides BaseParameter..::..Value.)
Public property ValuesCollection
Gets the list of possible values. The array contains EnumValue objects. The array can be modified to add/remove values.
Public property XmlDefinition
Property used by MADCAT to get/set the XML definition of the parameter. Definition must be compliant with the schema MODELS.XSD
(Overrides BaseParameter..::..XmlDefinition.)
Public property XmlNodeHandler
Property used by MADCAT to get the XML handler of the parameter
(Inherited from BaseParameter.)

Events

 | Name | Description
Public event | ValueChanged | Fired when the value of the parameter changes (Inherited from BaseParameter.)

See Also

EnumInput Class
Parameters Namespace


EnumInput Constructor

[image]

MADCAT Software Developer Guide
EnumInput Constructor
EnumInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public EnumInput()
Visual Basic
Public Sub New
Visual C++
public:
EnumInput()

See Also

EnumInput Class
EnumInput Members
Parameters Namespace


EnumInput Methods

[image] [image]

MADCAT Software Developer Guide
EnumInput Methods
EnumInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The EnumInput type exposes the following members.

Methods

 | Name | Description
Public method | AddEnumerateValue | Add a new value in the list of the possible values for the parameter
Public method | BuildHTMLString | Gives the HTML code used to render the input field in HTML instead of Windows form control (Overrides BaseParameter..::..BuildHTMLString()()()().)
Public method | BuildLabel | Gives the Windows Form control for the label of the input field of the parameter (Inherited from BaseParameter.)
Public method | Clone | Clones the parameter object into a new parameter object (Overrides BaseParameter..::..Clone()()()().)
Public method | RestoreValueFromItem | Gets the value of the parameter from a given project's Item (Overrides BaseParameter..::..RestoreValueFromItem(XmlNode).)
Public method | SaveValueInItem | Saves the value of the parameter into a given project's Item (Overrides BaseParameter..::..SaveValueInItem(XmlNode).)

See Also

EnumInput Class
Parameters Namespace


AddEnumerateValue Method

[image]

MADCAT Software Developer Guide
EnumInput..::..AddEnumerateValue Method
EnumInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Add a new value in the list of the possible values for the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public void AddEnumerateValue(
    EnumValue new_val
)
Visual Basic
Public Sub AddEnumerateValue ( _
    new_val As EnumValue _
)
Visual C++
public:
void AddEnumerateValue(
    EnumValue^ new_val
)

Parameters

new_val
Type: Parameters..::..EnumValue
Object of class EnumValue to add to the enumeration

See Also

EnumInput Class
EnumInput Members
Parameters Namespace


BuildHTMLString Method

[image]

MADCAT Software Developer Guide
EnumInput..::..BuildHTMLString Method
EnumInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gives the HTML code used to render the input field in HTML instead of Windows form control

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override string BuildHTMLString()
Visual Basic
Public Overrides Function BuildHTMLString As String
Visual C++
public:
virtual String^ BuildHTMLString() override

Return Value

The HTML code equivalent to the Windows Form Control

Implements

IParameter..::..BuildHTMLString()()()()

See Also

EnumInput Class
EnumInput Members
Parameters Namespace


Clone Method

[image]

MADCAT Software Developer Guide
EnumInput..::..Clone Method
EnumInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Clones the parameter object into a new parameter object

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

A clone of the current object

See Also

EnumInput Class
EnumInput Members
Parameters Namespace


RestoreValueFromItem Method

[image]

MADCAT Software Developer Guide
EnumInput..::..RestoreValueFromItem Method
EnumInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the value of the parameter from a given project's Item

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override void RestoreValueFromItem(
    XmlNode item
)
Visual Basic
Public Overrides Sub RestoreValueFromItem ( _
    item As XmlNode _
)
Visual C++
public:
virtual void RestoreValueFromItem(
    XmlNode^ item
) override

Parameters

item
Type: System.Xml..::..XmlNode
XML node where the attribute's value shall be used to set the parameter's value

Implements

IParameter..::..RestoreValueFromItem(XmlNode)

See Also

EnumInput Class
EnumInput Members
Parameters Namespace


SaveValueInItem Method

[image]

MADCAT Software Developer Guide
EnumInput..::..SaveValueInItem Method
EnumInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Saves the value of the parameter into a given project's Item

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override void SaveValueInItem(
    XmlNode item
)
Visual Basic
Public Overrides Sub SaveValueInItem ( _
    item As XmlNode _
)
Visual C++
public:
virtual void SaveValueInItem(
    XmlNode^ item
) override

Parameters

item
Type: System.Xml..::..XmlNode
XML node where the parameter's value shall be stored into as an attribute's value

Implements

IParameter..::..SaveValueInItem(XmlNode)

See Also

EnumInput Class
EnumInput Members
Parameters Namespace


EnumInput Properties

[image] [image]

MADCAT Software Developer Guide
EnumInput Properties
EnumInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The EnumInput type exposes the following members.

Properties

Name Description
Public property ContextMenu
Property used by MADCAT to get the context menu of the parameter
(Inherited from BaseParameter.)
Public property ControlType
Gets the base type of the parameter. For directories, it is CMN_Enumerate.
Public property Description
Property used by MADCAT to get/set the description of the parameter
(Inherited from BaseParameter.)
Public property DisplayOnly
Property used by MADCAT to set the access mode of the parameter
(Overrides BaseParameter..::..DisplayOnly.)
Public property DrawHandler
Property used by MADCAT to get the Bitmap handler of the parameter
(Inherited from BaseParameter.)
Public property FormControl
Gets the control used to change the parameter's value. For enum, it is a drop-down box, a group of check box or a list box. This depends on the option named "showas".
(Overrides BaseParameter..::..FormControl.)
Public property HasChanged
Property used by MADCAT to check if the parameter has changed
(Inherited from BaseParameter.)
Public property Hint
Property used by MADCAT to get/set the tip of the parameter. The tip contains a short help which popups when the user moves his mouse cursor over the parameter's name
(Inherited from BaseParameter.)
Public property IsMandatory
Property used by MADCAT to indicate if the parameter is mandatory or not. When mandatory, the user must give a value to the parameter to continue his current operation.
(Inherited from BaseParameter.)
Public property IsUndefined
Property used by MADCAT to check if the parameter has been set by the user or not
(Overrides BaseParameter..::..IsUndefined.)
Public property MaxNumberOfChars
Gets/sets the maximum number of characters of the parameter's value
(Inherited from BaseParameter.)
Public property MultiSelection
Gets the base type of the parameter. For directories, it is CMN_Enumerate.
Public property Name
Property used by MADCAT to get/set the name of the parameter
(Inherited from BaseParameter.)
Public property NumberOfLines
Gets/sets the number of lines visible in the text box of the parameter
(Inherited from BaseParameter.)
Public property Options
Property used by MADCAT to get/set the options of the parameter. Common options are (applicable to all parameters):
  • mandatory=b : where b is 'yes' or 'no'. Indicates if the parameter must be filled by the user
  • readonly=b : where b is 'yes' or 'no'. Indicates if the parameter can be modified by the user
Additional options are :
  • multiselect=yes|no : indicates if the user can select more than one value or not
  • showas=xxx : Selects the kind of control to use. xxx can be : checkbox or button
(Overrides BaseParameter..::..Options.)
Public property Tag
Gets/sets the Tag property of the parameter's control object
(Inherited from BaseParameter.)
Public property TextHandler
Property used by MADCAT to get the String handler of the parameter
(Overrides BaseParameter..::..TextHandler.)
Public property Tip
Property used by MADCAT to get/set the ToolTip object for the Form Control of the parameter
(Inherited from BaseParameter.)
Public property Type
Gets the base type of the parameter. For directories, it is CMN_Enumerate.
(Overrides BaseParameter..::..Type.)
Public property TypeName
Gets the name of the type of the parameter as it is coded in the attribute TYPE of the parameter's Xml definition (ATTRIBUTE element definition) It is the core type's name of the parameter
(Inherited from BaseParameter.)
Public property UserSettings
Property used by MADCAT to get/set the user settings of the parameter
(Inherited from BaseParameter.)
Public property Value
Property used by MADCAT to get/set the value of the parameter. If mutliple values are selected, they are merged in the same string and separated with comas.
(Overrides BaseParameter..::..Value.)
Public property ValuesCollection
Gets the list of possible values. The array contains EnumValue objects. The array can be modified to add/remove values.
Public property XmlDefinition
Property used by MADCAT to get/set the XML definition of the parameter. Definition must be compliant with the schema MODELS.XSD
(Overrides BaseParameter..::..XmlDefinition.)
Public property XmlNodeHandler
Property used by MADCAT to get the XML handler of the parameter
(Inherited from BaseParameter.)

See Also

EnumInput Class
Parameters Namespace


ControlType Property

[image]

MADCAT Software Developer Guide
EnumInput..::..ControlType Property
EnumInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the base type of the parameter. For directories, it is CMN_Enumerate.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public EnumControlTypes ControlType { get; set; }
Visual Basic
Public Property ControlType As EnumControlTypes
    Get
    Set
Visual C++
public:
property EnumControlTypes ControlType {
    EnumControlTypes get ();
    void set (EnumControlTypes value);
}

See Also

EnumInput Class
EnumInput Members
Parameters Namespace


DisplayOnly Property

[image]

MADCAT Software Developer Guide
EnumInput..::..DisplayOnly Property
EnumInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to set the access mode of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override bool DisplayOnly { set; }
Visual Basic
Public Overrides WriteOnly Property DisplayOnly As Boolean
    Set
Visual C++
public:
virtual property bool DisplayOnly {
    void set (bool value) override;
}

Implements

IParameter..::..DisplayOnly

See Also

EnumInput Class
EnumInput Members
Parameters Namespace


FormControl Property

[image]

MADCAT Software Developer Guide
EnumInput..::..FormControl Property
EnumInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the control used to change the parameter's value. For enum, it is a drop-down box, a group of check box or a list box. This depends on the option named "showas".

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Control FormControl { get; }
Visual Basic
Public Overrides ReadOnly Property FormControl As Control
    Get
Visual C++
public:
virtual property Control^ FormControl {
    Control^ get () override;
}

Implements

IParameter..::..FormControl

See Also

EnumInput Class
EnumInput Members
Parameters Namespace


IsUndefined Property

[image]

MADCAT Software Developer Guide
EnumInput..::..IsUndefined Property
EnumInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to check if the parameter has been set by the user or not

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override bool IsUndefined { get; }
Visual Basic
Public Overrides ReadOnly Property IsUndefined As Boolean
    Get
Visual C++
public:
virtual property bool IsUndefined {
    bool get () override;
}

Implements

IParameter..::..IsUndefined

See Also

EnumInput Class
EnumInput Members
Parameters Namespace


MultiSelection Property

[image]

MADCAT Software Developer Guide
EnumInput..::..MultiSelection Property
EnumInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the base type of the parameter. For directories, it is CMN_Enumerate.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public bool MultiSelection { get; set; }
Visual Basic
Public Property MultiSelection As Boolean
    Get
    Set
Visual C++
public:
property bool MultiSelection {
    bool get ();
    void set (bool value);
}

See Also

EnumInput Class
EnumInput Members
Parameters Namespace


Options Property

[image]

MADCAT Software Developer Guide
EnumInput..::..Options Property
EnumInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the options of the parameter. Common options are (applicable to all parameters):
  • mandatory=b : where b is 'yes' or 'no'. Indicates if the parameter must be filled by the user
  • readonly=b : where b is 'yes' or 'no'. Indicates if the parameter can be modified by the user
Additional options are :
  • multiselect=yes|no : indicates if the user can select more than one value or not
  • showas=xxx : Selects the kind of control to use. xxx can be : checkbox or button

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Hashtable Options { set; }
Visual Basic
Public Overrides WriteOnly Property Options As Hashtable
    Set
Visual C++
public:
virtual property Hashtable^ Options {
    void set (Hashtable^ value) override;
}

Implements

IParameter..::..Options

See Also

EnumInput Class
EnumInput Members
Parameters Namespace


TextHandler Property

[image]

MADCAT Software Developer Guide
EnumInput..::..TextHandler Property
EnumInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get the String handler of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override StringHandler TextHandler { get; }
Visual Basic
Public Overrides ReadOnly Property TextHandler As StringHandler
    Get
Visual C++
public:
virtual property StringHandler^ TextHandler {
    StringHandler^ get () override;
}

Implements

IParameter..::..TextHandler

See Also

EnumInput Class
EnumInput Members
Parameters Namespace


Type Property

[image]

MADCAT Software Developer Guide
EnumInput..::..Type Property
EnumInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the base type of the parameter. For directories, it is CMN_Enumerate.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override DataToolTypes Type { get; }
Visual Basic
Public Overrides ReadOnly Property Type As DataToolTypes
    Get
Visual C++
public:
virtual property DataToolTypes Type {
    DataToolTypes get () override;
}

Implements

IParameter..::..Type

See Also

EnumInput Class
EnumInput Members
Parameters Namespace


Value Property

[image]

MADCAT Software Developer Guide
EnumInput..::..Value Property
EnumInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the value of the parameter. If mutliple values are selected, they are merged in the same string and separated with comas.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override string Value { get; set; }
Visual Basic
Public Overrides Property Value As String
    Get
    Set
Visual C++
public:
virtual property String^ Value {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IParameter..::..Value

See Also

EnumInput Class
EnumInput Members
Parameters Namespace


ValuesCollection Property

[image]

MADCAT Software Developer Guide
EnumInput..::..ValuesCollection Property
EnumInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the list of possible values. The array contains EnumValue objects. The array can be modified to add/remove values.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public ArrayList ValuesCollection { get; }
Visual Basic
Public ReadOnly Property ValuesCollection As ArrayList
    Get
Visual C++
public:
property ArrayList^ ValuesCollection {
    ArrayList^ get ();
}

See Also

EnumInput Class
EnumInput Members
Parameters Namespace


XmlDefinition Property

[image]

MADCAT Software Developer Guide
EnumInput..::..XmlDefinition Property
EnumInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the XML definition of the parameter. Definition must be compliant with the schema MODELS.XSD

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override XmlNode XmlDefinition { set; }
Visual Basic
Public Overrides WriteOnly Property XmlDefinition As XmlNode
    Set
Visual C++
public:
virtual property XmlNode^ XmlDefinition {
    void set (XmlNode^ value) override;
}

Implements

IParameter..::..XmlDefinition

See Also

EnumInput Class
EnumInput Members
Parameters Namespace


EnumInput Events

[image] [image]

MADCAT Software Developer Guide
EnumInput Events
EnumInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The EnumInput type exposes the following members.

Events

 | Name | Description
Public event | ValueChanged | Fired when the value of the parameter changes (Inherited from BaseParameter.)

See Also

EnumInput Class
Parameters Namespace


EnumValue Class

[image]

MADCAT Software Developer Guide
EnumValue Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
One possible value of a enumerated parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
[SerializableAttribute]
public class EnumValue
Visual Basic
<SerializableAttribute> _
Public Class EnumValue
Visual C++
[SerializableAttribute]
public ref class EnumValue

Inheritance Hierarchy

System..::..Object
Parameters..::..EnumValue

See Also

EnumValue Members
Parameters Namespace


EnumValue Members

[image] [image]

MADCAT Software Developer Guide
EnumValue Members
EnumValue Class Constructors Fields See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The EnumValue type exposes the following members.

Constructors

 | Name | Description
Public method | EnumValue | Constructor. Instanciates one object having a label and a value.

Fields

 | Name | Description
Public field | Checked | Indicates of the value is checked or not (available only if multiselection is activated for the parameter)
Public field | Label | Label to use to display the value in the user interface
Public field | Value | Value to store in the parameter

See Also

EnumValue Class
Parameters Namespace


EnumValue Constructor

[image]

MADCAT Software Developer Guide
EnumValue Constructor
EnumValue Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor. Instanciates one object having a label and a value.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public EnumValue(
    string value,
    string label
)
Visual Basic
Public Sub New ( _
    value As String, _
    label As String _
)
Visual C++
public:
EnumValue(
    String^ value,
    String^ label
)

Parameters

value
Type: System..::..String
Value
label
Type: System..::..String
Label

See Also

EnumValue Class
EnumValue Members
Parameters Namespace


EnumValue Fields

[image] [image]

MADCAT Software Developer Guide
EnumValue Fields
EnumValue Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The EnumValue type exposes the following members.

Fields

 | Name | Description
Public field | Checked | Indicates of the value is checked or not (available only if multiselection is activated for the parameter)
Public field | Label | Label to use to display the value in the user interface
Public field | Value | Value to store in the parameter

See Also

EnumValue Class
Parameters Namespace


Checked Field

[image]

MADCAT Software Developer Guide
EnumValue..::..Checked Field
EnumValue Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Indicates of the value is checked or not (available only if multiselection is activated for the parameter)

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public bool Checked
Visual Basic
Public Checked As Boolean
Visual C++
public:
bool Checked

See Also

EnumValue Class
EnumValue Members
Parameters Namespace


Label Field

[image]

MADCAT Software Developer Guide
EnumValue..::..Label Field
EnumValue Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Label to use to display the value in the user interface

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public string Label
Visual Basic
Public Label As String
Visual C++
public:
String^ Label

See Also

EnumValue Class
EnumValue Members
Parameters Namespace


Value Field

[image]

MADCAT Software Developer Guide
EnumValue..::..Value Field
EnumValue Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Value to store in the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public string Value
Visual Basic
Public Value As String
Visual C++
public:
String^ Value

See Also

EnumValue Class
EnumValue Members
Parameters Namespace


FileInput Class

[image]

MADCAT Software Developer Guide
FileInput Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Class used to create parameters which manage files

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
[SerializableAttribute]
public class FileInput : BaseParameter
Visual Basic
<SerializableAttribute> _
Public Class FileInput _
    Inherits BaseParameter
Visual C++
[SerializableAttribute]
public ref class FileInput : public BaseParameter

Inheritance Hierarchy

System..::..Object
Parameters..::..BaseParameter
Parameters..::..FileInput

See Also

FileInput Members
Parameters Namespace


FileInput Members

[image] [image]

MADCAT Software Developer Guide
FileInput Members
FileInput Class Constructors Methods Fields Properties Events See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The FileInput type exposes the following members.

Constructors

 | Name | Description
Public method | FileInput | Constructor

Methods

 | Name | Description
 | AbsoluteToRelativePath | Converts an absolute path string to a workspace-relative path string
Public method | BuildHTMLString | Gives the HTML code used to render the input field in HTML instead of Windows form control (Inherited from BaseParameter.)
Public method | BuildLabel | Gives the Windows Form control for the label of the input field of the parameter (Inherited from BaseParameter.)
Public method | Clone | Clones the parameter object into a new parameter object (Overrides BaseParameter..::..Clone()()()().)
 | RelativeToAbsolutePath | Converts a workspace-relative path string to an absolute path string
Public method | RestoreValueFromItem | Gets the value of the parameter from a given project's Item (Overrides BaseParameter..::..RestoreValueFromItem(XmlNode).)
Public method | SaveValueInItem | Saves the value of the parameter into a given project's Item (Overrides BaseParameter..::..SaveValueInItem(XmlNode).)

Fields

Name | Description
WorkspaceDirectory | Gives the root directory of the current workspace.

Properties

Name Description
Public property ContextMenu
Property used by MADCAT to get the context menu of the parameter
(Inherited from BaseParameter.)
Public property DefaultExtension
Default extension for the files managed by the parameter
Public property Description
Property used by MADCAT to get/set the description of the parameter
(Inherited from BaseParameter.)
Public property DisplayOnly
Set to true if the value can't be changed
(Overrides BaseParameter..::..DisplayOnly.)
Public property DrawHandler
Property used by MADCAT to get the Bitmap handler of the parameter
(Inherited from BaseParameter.)
Public property Filters
Gets or sets the filters available in the file dialog box. Filters are written in accordance with the format used by the property Filter of the class FileDialog of the namespace System::Windows::Forms. See Filter. Example : Image Files(*.BMP;*.JPG;*.GIF)|*.BMP;*.JPG;*.GIF|All files (*.*)|*.*
Public property FormControl
Gets the control used to change the parameter's value. For files, it is a text box with a button which opens the common Windows' file dialog box.
(Overrides BaseParameter..::..FormControl.)
Public property ForOutput
Flag which indicates if the parameters manage input files (=false) or output files (=true). This has a direct impact on the dialog box which will be used to let the user select a file in his system.
Public property HasChanged
Property used by MADCAT to check if the parameter has changed
(Inherited from BaseParameter.)
Public property Hint
Property used by MADCAT to get/set the tip of the parameter. The tip contains a short help which popups when the user moves his mouse cursor over the parameter's name
(Inherited from BaseParameter.)
Public property IsMandatory
Property used by MADCAT to indicate if the parameter is mandatory or not. When mandatory, the user must give a value to the parameter to continue his current operation.
(Inherited from BaseParameter.)
Public property IsUndefined
Property used by MADCAT to check if the parameter has been set by the user or not
(Inherited from BaseParameter.)
Public property MaxNumberOfChars
Gets/sets the maximum number of characters of the parameter's value
(Inherited from BaseParameter.)
Public property Name
Property used by MADCAT to get/set the name of the parameter
(Inherited from BaseParameter.)
Public property NumberOfLines
Gets/sets the number of lines visible in the text box of the parameter
(Inherited from BaseParameter.)
Public property Options
Sets the options for the parameter. File parameters accept the following options :
  • foroutput=yes|no : Flag which indicates if the parameters manage input files (=false) or output files (=true). This has a direct impact on the dialog box which will be used to let the user select a file in his system.
  • filters=filters' list : Sets the filters of the dialog box. See Filters.
  • extension=xxx : Sets the default extension of the file. xxx is the extension.
(Overrides BaseParameter..::..Options.)
Public property Tag
Gets/sets the Tag property of the parameter's control object
(Inherited from BaseParameter.)
Public property TextHandler
Property used by MADCAT to get the String handler of the parameter
(Inherited from BaseParameter.)
Public property Tip
Property used by MADCAT to get/set the ToolTip object for the Form Control of the parameter
(Inherited from BaseParameter.)
Public property Type
Gets the base type of the parameter. For files, it is CMN_File.
(Overrides BaseParameter..::..Type.)
Public property TypeName
Gets the name of the type of the parameter as it is coded in the attribute TYPE of the parameter's Xml definition (ATTRIBUTE element definition) It is the core type's name of the parameter
(Inherited from BaseParameter.)
Public property UserSettings
Property used by MADCAT to get/set the user settings of the parameter
(Inherited from BaseParameter.)
Public property Value
Gets/sets the value of the parameter. Paths are always absolute values. If relative values are set, they are considered relative to the current workspace's root path.
(Overrides BaseParameter..::..Value.)
Public property XmlDefinition
Property used by MADCAT to get/set the XML definition of the parameter. Definition must be compliant with the schema MODELS.XSD
(Overrides BaseParameter..::..XmlDefinition.)
Public property XmlNodeHandler
Property used by MADCAT to get the XML handler of the parameter
(Inherited from BaseParameter.)

Events

 | Name | Description
Public event | ValueChanged | Fired when the value of the parameter changes (Inherited from BaseParameter.)

See Also

FileInput Class
Parameters Namespace


FileInput Constructor

[image]

MADCAT Software Developer Guide
FileInput Constructor
FileInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public FileInput()
Visual Basic
Public Sub New
Visual C++
public:
FileInput()

See Also

FileInput Class
FileInput Members
Parameters Namespace


FileInput Fields

[image] [image]

MADCAT Software Developer Guide
FileInput Fields
FileInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The FileInput type exposes the following members.

Fields

Name | Description
WorkspaceDirectory | Gives the root directory of the current workspace.

See Also

FileInput Class
Parameters Namespace


WorkspaceDirectory Field

[image]

MADCAT Software Developer Guide
FileInput..::..WorkspaceDirectory Field
FileInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gives the root directory of the current workspace.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public static string WorkspaceDirectory
Visual Basic
Public Shared WorkspaceDirectory As String
Visual C++
public:
static String^ WorkspaceDirectory

See Also

FileInput Class
FileInput Members
Parameters Namespace


FileInput Methods

[image] [image]

MADCAT Software Developer Guide
FileInput Methods
FileInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The FileInput type exposes the following members.

Methods

 | Name | Description
 | AbsoluteToRelativePath | Converts an absolute path string to a workspace-relative path string
Public method | BuildHTMLString | Gives the HTML code used to render the input field in HTML instead of Windows form control (Inherited from BaseParameter.)
Public method | BuildLabel | Gives the Windows Form control for the label of the input field of the parameter (Inherited from BaseParameter.)
Public method | Clone | Clones the parameter object into a new parameter object (Overrides BaseParameter..::..Clone()()()().)
 | RelativeToAbsolutePath | Converts a workspace-relative path string to an absolute path string
Public method | RestoreValueFromItem | Gets the value of the parameter from a given project's Item (Overrides BaseParameter..::..RestoreValueFromItem(XmlNode).)
Public method | SaveValueInItem | Saves the value of the parameter into a given project's Item (Overrides BaseParameter..::..SaveValueInItem(XmlNode).)

See Also

FileInput Class
Parameters Namespace


AbsoluteToRelativePath Method

[image]

MADCAT Software Developer Guide
FileInput..::..AbsoluteToRelativePath Method
FileInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Converts an absolute path string to a workspace-relative path string

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public static string AbsoluteToRelativePath(
    string p
)
Visual Basic
Public Shared Function AbsoluteToRelativePath ( _
    p As String _
) As String
Visual C++
public:
static String^ AbsoluteToRelativePath(
    String^ p
)

Parameters

p
Type: System..::..String
Absolute path

Return Value

Relative path. Example : if workspace is located in 'C:\TEST', the absolute path 'C:\TEST\bitmap' will be converted into 'bitmap'.

See Also

FileInput Class
FileInput Members
Parameters Namespace


Clone Method

[image]

MADCAT Software Developer Guide
FileInput..::..Clone Method
FileInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Clones the parameter object into a new parameter object

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

A clone of the current object

See Also

FileInput Class
FileInput Members
Parameters Namespace


RelativeToAbsolutePath Method

[image]

MADCAT Software Developer Guide
FileInput..::..RelativeToAbsolutePath Method
FileInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Converts a workspace-relative path string to an absolute path string

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public static string RelativeToAbsolutePath(
    string p
)
Visual Basic
Public Shared Function RelativeToAbsolutePath ( _
    p As String _
) As String
Visual C++
public:
static String^ RelativeToAbsolutePath(
    String^ p
)

Parameters

p
Type: System..::..String
Relative path

Return Value

Absolute path. Example : if workspace is located in 'C:\TEST', the relative path 'bitmap' will be converted into 'C:\TEST\bitmap'. Note that '\bitmap' is considered as an absolute path. Relative paths shall never start with a backslash.

See Also

FileInput Class
FileInput Members
Parameters Namespace


RestoreValueFromItem Method

[image]

MADCAT Software Developer Guide
FileInput..::..RestoreValueFromItem Method
FileInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the value of the parameter from a given project's Item

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override void RestoreValueFromItem(
    XmlNode item
)
Visual Basic
Public Overrides Sub RestoreValueFromItem ( _
    item As XmlNode _
)
Visual C++
public:
virtual void RestoreValueFromItem(
    XmlNode^ item
) override

Parameters

item
Type: System.Xml..::..XmlNode
XML node where the attribute's value shall be used to set the parameter's value

Implements

IParameter..::..RestoreValueFromItem(XmlNode)

See Also

FileInput Class
FileInput Members
Parameters Namespace


SaveValueInItem Method

[image]

MADCAT Software Developer Guide
FileInput..::..SaveValueInItem Method
FileInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Saves the value of the parameter into a given project's Item

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override void SaveValueInItem(
    XmlNode item
)
Visual Basic
Public Overrides Sub SaveValueInItem ( _
    item As XmlNode _
)
Visual C++
public:
virtual void SaveValueInItem(
    XmlNode^ item
) override

Parameters

item
Type: System.Xml..::..XmlNode
XML node where the parameter's value shall be stored into as an attribute's value

Implements

IParameter..::..SaveValueInItem(XmlNode)

See Also

FileInput Class
FileInput Members
Parameters Namespace


FileInput Properties

[image] [image]

MADCAT Software Developer Guide
FileInput Properties
FileInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The FileInput type exposes the following members.

Properties

Name Description
Public property ContextMenu
Property used by MADCAT to get the context menu of the parameter
(Inherited from BaseParameter.)
Public property DefaultExtension
Default extension for the files managed by the parameter
Public property Description
Property used by MADCAT to get/set the description of the parameter
(Inherited from BaseParameter.)
Public property DisplayOnly
Set to true if the value can't be changed
(Overrides BaseParameter..::..DisplayOnly.)
Public property DrawHandler
Property used by MADCAT to get the Bitmap handler of the parameter
(Inherited from BaseParameter.)
Public property Filters
Gets or sets the filters available in the file dialog box. Filters are written in accordance with the format used by the property Filter of the class FileDialog of the namespace System::Windows::Forms. See Filter. Example : Image Files(*.BMP;*.JPG;*.GIF)|*.BMP;*.JPG;*.GIF|All files (*.*)|*.*
Public property FormControl
Gets the control used to change the parameter's value. For files, it is a text box with a button which opens the common Windows' file dialog box.
(Overrides BaseParameter..::..FormControl.)
Public property ForOutput
Flag which indicates if the parameters manage input files (=false) or output files (=true). This has a direct impact on the dialog box which will be used to let the user select a file in his system.
Public property HasChanged
Property used by MADCAT to check if the parameter has changed
(Inherited from BaseParameter.)
Public property Hint
Property used by MADCAT to get/set the tip of the parameter. The tip contains a short help which popups when the user moves his mouse cursor over the parameter's name
(Inherited from BaseParameter.)
Public property IsMandatory
Property used by MADCAT to indicate if the parameter is mandatory or not. When mandatory, the user must give a value to the parameter to continue his current operation.
(Inherited from BaseParameter.)
Public property IsUndefined
Property used by MADCAT to check if the parameter has been set by the user or not
(Inherited from BaseParameter.)
Public property MaxNumberOfChars
Gets/sets the maximum number of characters of the parameter's value
(Inherited from BaseParameter.)
Public property Name
Property used by MADCAT to get/set the name of the parameter
(Inherited from BaseParameter.)
Public property NumberOfLines
Gets/sets the number of lines visible in the text box of the parameter
(Inherited from BaseParameter.)
Public property Options
Sets the options for the parameter. File parameters accept the following options :
  • foroutput=yes|no : Flag which indicates if the parameters manage input files (=false) or output files (=true). This has a direct impact on the dialog box which will be used to let the user select a file in his system.
  • filters=filters' list : Sets the filters of the dialog box. See Filters.
  • extension=xxx : Sets the default extension of the file. xxx is the extension.
(Overrides BaseParameter..::..Options.)
Public property Tag
Gets/sets the Tag property of the parameter's control object
(Inherited from BaseParameter.)
Public property TextHandler
Property used by MADCAT to get the String handler of the parameter
(Inherited from BaseParameter.)
Public property Tip
Property used by MADCAT to get/set the ToolTip object for the Form Control of the parameter
(Inherited from BaseParameter.)
Public property Type
Gets the base type of the parameter. For files, it is CMN_File.
(Overrides BaseParameter..::..Type.)
Public property TypeName
Gets the name of the type of the parameter as it is coded in the attribute TYPE of the parameter's Xml definition (ATTRIBUTE element definition) It is the core type's name of the parameter
(Inherited from BaseParameter.)
Public property UserSettings
Property used by MADCAT to get/set the user settings of the parameter
(Inherited from BaseParameter.)
Public property Value
Gets/sets the value of the parameter. Paths are always absolute values. If relative values are set, they are considered relative to the current workspace's root path.
(Overrides BaseParameter..::..Value.)
Public property XmlDefinition
Property used by MADCAT to get/set the XML definition of the parameter. Definition must be compliant with the schema MODELS.XSD
(Overrides BaseParameter..::..XmlDefinition.)
Public property XmlNodeHandler
Property used by MADCAT to get the XML handler of the parameter
(Inherited from BaseParameter.)

See Also

FileInput Class
Parameters Namespace


DefaultExtension Property

[image]

MADCAT Software Developer Guide
FileInput..::..DefaultExtension Property
FileInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Default extension for the files managed by the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public string DefaultExtension { get; set; }
Visual Basic
Public Property DefaultExtension As String
    Get
    Set
Visual C++
public:
property String^ DefaultExtension {
    String^ get ();
    void set (String^ value);
}

See Also

FileInput Class
FileInput Members
Parameters Namespace


DisplayOnly Property

[image]

MADCAT Software Developer Guide
FileInput..::..DisplayOnly Property
FileInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Set to true if the value can't be changed

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override bool DisplayOnly { set; }
Visual Basic
Public Overrides WriteOnly Property DisplayOnly As Boolean
    Set
Visual C++
public:
virtual property bool DisplayOnly {
    void set (bool value) override;
}

Implements

IParameter..::..DisplayOnly

See Also

FileInput Class
FileInput Members
Parameters Namespace


Filters Property

[image]

MADCAT Software Developer Guide
FileInput..::..Filters Property
FileInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets or sets the filters available in the file dialog box. Filters are written in accordance with the format used by the property Filter of the class FileDialog of the namespace System::Windows::Forms. See Filter. Example : Image Files(*.BMP;*.JPG;*.GIF)|*.BMP;*.JPG;*.GIF|All files (*.*)|*.*

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public string Filters { get; set; }
Visual Basic
Public Property Filters As String
    Get
    Set
Visual C++
public:
property String^ Filters {
    String^ get ();
    void set (String^ value);
}

See Also

FileInput Class
FileInput Members
Parameters Namespace


FormControl Property

[image]

MADCAT Software Developer Guide
FileInput..::..FormControl Property
FileInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the control used to change the parameter's value. For files, it is a text box with a button which opens the common Windows' file dialog box.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Control FormControl { get; }
Visual Basic
Public Overrides ReadOnly Property FormControl As Control
    Get
Visual C++
public:
virtual property Control^ FormControl {
    Control^ get () override;
}

Implements

IParameter..::..FormControl

See Also

FileInput Class
FileInput Members
Parameters Namespace


ForOutput Property

[image]

MADCAT Software Developer Guide
FileInput..::..ForOutput Property
FileInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Flag which indicates if the parameters manage input files (=false) or output files (=true). This has a direct impact on the dialog box which will be used to let the user select a file in his system.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public bool ForOutput { get; set; }
Visual Basic
Public Property ForOutput As Boolean
    Get
    Set
Visual C++
public:
property bool ForOutput {
    bool get ();
    void set (bool value);
}

See Also

FileInput Class
FileInput Members
Parameters Namespace


Options Property

[image]

MADCAT Software Developer Guide
FileInput..::..Options Property
FileInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Sets the options for the parameter. File parameters accept the following options :
  • foroutput=yes|no : Flag which indicates if the parameters manage input files (=false) or output files (=true). This has a direct impact on the dialog box which will be used to let the user select a file in his system.
  • filters=filters' list : Sets the filters of the dialog box. See Filters.
  • extension=xxx : Sets the default extension of the file. xxx is the extension.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Hashtable Options { set; }
Visual Basic
Public Overrides WriteOnly Property Options As Hashtable
    Set
Visual C++
public:
virtual property Hashtable^ Options {
    void set (Hashtable^ value) override;
}

Implements

IParameter..::..Options

See Also

FileInput Class
FileInput Members
Parameters Namespace


Type Property

[image]

MADCAT Software Developer Guide
FileInput..::..Type Property
FileInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the base type of the parameter. For files, it is CMN_File.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override DataToolTypes Type { get; }
Visual Basic
Public Overrides ReadOnly Property Type As DataToolTypes
    Get
Visual C++
public:
virtual property DataToolTypes Type {
    DataToolTypes get () override;
}

Implements

IParameter..::..Type

See Also

FileInput Class
FileInput Members
Parameters Namespace


Value Property

[image]

MADCAT Software Developer Guide
FileInput..::..Value Property
FileInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/sets the value of the parameter. Paths are always absolute values. If relative values are set, they are considered relative to the current workspace's root path.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override string Value { get; set; }
Visual Basic
Public Overrides Property Value As String
    Get
    Set
Visual C++
public:
virtual property String^ Value {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IParameter..::..Value

See Also

FileInput Class
FileInput Members
Parameters Namespace


XmlDefinition Property

[image]

MADCAT Software Developer Guide
FileInput..::..XmlDefinition Property
FileInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the XML definition of the parameter. Definition must be compliant with the schema MODELS.XSD

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override XmlNode XmlDefinition { set; }
Visual Basic
Public Overrides WriteOnly Property XmlDefinition As XmlNode
    Set
Visual C++
public:
virtual property XmlNode^ XmlDefinition {
    void set (XmlNode^ value) override;
}

Implements

IParameter..::..XmlDefinition

See Also

FileInput Class
FileInput Members
Parameters Namespace


FileInput Events

[image] [image]

MADCAT Software Developer Guide
FileInput Events
FileInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The FileInput type exposes the following members.

Events

 | Name | Description
Public event | ValueChanged | Fired when the value of the parameter changes (Inherited from BaseParameter.)

See Also

FileInput Class
Parameters Namespace


GaugeType Enumeration

[image]

MADCAT Software Developer Guide
GaugeType Enumeration
See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Types of gauge when display mode of a parameter is Gauge. See NumericDisplay.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
[SerializableAttribute]
public enum GaugeType
Visual Basic
<SerializableAttribute> _
Public Enumeration GaugeType
Visual C++
[SerializableAttribute]
public enum class GaugeType

Members

Member name | Value | Description
Circular | 2 | Gauge is a circular area with one background color
GradientLinear | 1 | Gauge is a straight line with a gradient composed of 2 or more colors.
Linear | 0 | Gauge is a straight line with one background color

See Also

Parameters Namespace


GroupOfFields Class

[image]

MADCAT Software Developer Guide
GroupOfFields Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Manages group of parameters. This parameter doesn't actually store any value but can manage the display of several parameters inside a specific panel

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
[SerializableAttribute]
public class GroupOfFields : BaseParameter
Visual Basic
<SerializableAttribute> _
Public Class GroupOfFields _
    Inherits BaseParameter
Visual C++
[SerializableAttribute]
public ref class GroupOfFields : public BaseParameter

Inheritance Hierarchy

System..::..Object
Parameters..::..BaseParameter
Parameters..::..GroupOfFields

See Also

GroupOfFields Members
Parameters Namespace


GroupOfFields Members

[image] [image]

MADCAT Software Developer Guide
GroupOfFields Members
GroupOfFields Class Constructors Methods Properties Events See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The GroupOfFields type exposes the following members.

Constructors

 | Name | Description
Public method | GroupOfFields | Constructor

Methods

 | Name | Description
Public method | BuildHTMLString | Gives the HTML code used to render the input field in HTML instead of Windows form control (Overrides BaseParameter..::..BuildHTMLString()()()().)
Public method | BuildLabel | Gives the Windows Form control for the label of the input field of the parameter (Overrides BaseParameter..::..BuildLabel(String, FontStyle, UInt16).)
Public method | Clone | Clones the parameter object into a new parameter object (Overrides BaseParameter..::..Clone()()()().)
Public method | RestoreValueFromItem | Gets the value of the parameter from a given project's Item (Overrides BaseParameter..::..RestoreValueFromItem(XmlNode).)
Public method | SaveValueInItem | Saves the value of the parameter into a given project's Item (Overrides BaseParameter..::..SaveValueInItem(XmlNode).)

Properties

Name Description
Public property ContextMenu
Property used by MADCAT to get the context menu of the parameter
(Inherited from BaseParameter.)
Public property Description
Property used by MADCAT to get/set the description of the parameter
(Inherited from BaseParameter.)
Public property DisplayOnly
Property used by MADCAT to set the access mode of the parameter
(Overrides BaseParameter..::..DisplayOnly.)
Public property DrawHandler
Property used by MADCAT to get the Bitmap handler of the parameter
(Inherited from BaseParameter.)
Public property FormControl
Gets the panel used to embed all the parameters of the group. The panel has a title placed on top. When it is expandable, this title can be clicked to show/hide the content of the panel.
(Overrides BaseParameter..::..FormControl.)
Public property HasChanged
Property used by MADCAT to check if the parameter has changed
(Inherited from BaseParameter.)
Public property Hint
Property used by MADCAT to get/set the tip of the parameter. The tip contains a short help which popups when the user moves his mouse cursor over the parameter's name
(Inherited from BaseParameter.)
Public property IsExpandable
Indicates if the panel can be collapsed/expanded dynamically by the user. When set to true, the panel can be collapsed/expanded.
Public property IsHorizontal
Sets the orientation of the parameters inside the panel. When set to true, the parameters are placed on the same line, one beside another. They are top aligned. When set to false, the parameters are placed one over another in the same column. They are left aligned.
Public property IsMandatory
Not applicable.
(Overrides BaseParameter..::..IsMandatory.)
Public property IsUndefined
Not applicable.
(Overrides BaseParameter..::..IsUndefined.)
Public property MaxNumberOfChars
Gets/sets the maximum number of characters of the parameter's value
(Inherited from BaseParameter.)
Public property Name
Property used by MADCAT to get/set the name of the parameter
(Inherited from BaseParameter.)
Public property NumberOfLines
Gets/sets the number of lines visible in the text box of the parameter
(Inherited from BaseParameter.)
Public property Options
Property used by MADCAT to get/set the options of the parameter. Common options are (applicable to all parameters):
  • mandatory=b : where b is 'yes' or 'no'. Indicates if the parameter must be filled by the user
  • readonly=b : where b is 'yes' or 'no'. Indicates if the parameter can be modified by the user
Additional options are :
  • orientation=horizontal|vertical : this option sets the alignment of the fields in the group. Horizontal : all fields are in the same line. Vertical : all fields are in the same column.
  • expandable=yes|no : Indicates if the user can show/hide the content of the group. If set to false, content is always visible.
  • height=xxx : Height in pixels of the group.
  • separator=x : Character to use in the value of the parameter to separate values of the child parameters
(Overrides BaseParameter..::..Options.)
Public property Parameters
Collection of parameters object. All these parameters will be displayed inside the same panel
Public property Tag
Gets/sets the Tag property of the parameter's control object
(Inherited from BaseParameter.)
Public property TextHandler
Property used by MADCAT to get the String handler of the parameter
(Inherited from BaseParameter.)
Public property Tip
Property used by MADCAT to get/set the ToolTip object for the Form Control of the parameter
(Overrides BaseParameter..::..Tip.)
Public property Type
Gets the base type of the parameter. For groups of fields, it is CMN_Group.
(Overrides BaseParameter..::..Type.)
Public property TypeName
Gets the name of the type of the parameter as it is coded in the attribute TYPE of the parameter's Xml definition (ATTRIBUTE element definition) It is the core type's name of the parameter
(Inherited from BaseParameter.)
Public property UserSettings
Property used by MADCAT to get/set the user settings of the parameter
(Inherited from BaseParameter.)
Public property Value
Property used by MADCAT to get/set the value of the parameter
(Overrides BaseParameter..::..Value.)
Public property XmlDefinition
Property used by MADCAT to get/set the XML definition of the parameter. Definition must be compliant with the schema MODELS.XSD
(Overrides BaseParameter..::..XmlDefinition.)
Public property XmlNodeHandler
Property used by MADCAT to get the XML handler of the parameter
(Inherited from BaseParameter.)

Events

 | Name | Description
Public event | ValueChanged | Fired when the value of the parameter changes (Inherited from BaseParameter.)

See Also

GroupOfFields Class
Parameters Namespace


GroupOfFields Constructor

[image]

MADCAT Software Developer Guide
GroupOfFields Constructor
GroupOfFields Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public GroupOfFields()
Visual Basic
Public Sub New
Visual C++
public:
GroupOfFields()

See Also

GroupOfFields Class
GroupOfFields Members
Parameters Namespace


GroupOfFields Methods

[image] [image]

MADCAT Software Developer Guide
GroupOfFields Methods
GroupOfFields Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The GroupOfFields type exposes the following members.

Methods

 | Name | Description
Public method | BuildHTMLString | Gives the HTML code used to render the input field in HTML instead of Windows form control (Overrides BaseParameter..::..BuildHTMLString()()()().)
Public method | BuildLabel | Gives the Windows Form control for the label of the input field of the parameter (Overrides BaseParameter..::..BuildLabel(String, FontStyle, UInt16).)
Public method | Clone | Clones the parameter object into a new parameter object (Overrides BaseParameter..::..Clone()()()().)
Public method | RestoreValueFromItem | Gets the value of the parameter from a given project's Item (Overrides BaseParameter..::..RestoreValueFromItem(XmlNode).)
Public method | SaveValueInItem | Saves the value of the parameter into a given project's Item (Overrides BaseParameter..::..SaveValueInItem(XmlNode).)

See Also

GroupOfFields Class
Parameters Namespace


BuildHTMLString Method

[image]

MADCAT Software Developer Guide
GroupOfFields..::..BuildHTMLString Method
GroupOfFields Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gives the HTML code used to render the input field in HTML instead of Windows form control

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override string BuildHTMLString()
Visual Basic
Public Overrides Function BuildHTMLString As String
Visual C++
public:
virtual String^ BuildHTMLString() override

Return Value

The HTML code equivalent to the Windows Form Control

Implements

IParameter..::..BuildHTMLString()()()()

See Also

GroupOfFields Class
GroupOfFields Members
Parameters Namespace


BuildLabel Method

[image]

MADCAT Software Developer Guide
GroupOfFields..::..BuildLabel Method
GroupOfFields Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gives the Windows Form control for the label of the input field of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Control BuildLabel(
    string TypeFace,
    FontStyle Style,
    ushort Size
)
Visual Basic
Public Overrides Function BuildLabel ( _
    TypeFace As String, _
    Style As FontStyle, _
    Size As UShort _
) As Control
Visual C++
public:
virtual Control^ BuildLabel(
    String^ TypeFace,
    FontStyle Style,
    unsigned short Size
) override

Parameters

TypeFace
Type: System..::..String
Font to use to build the label
Style
Type: System.Drawing..::..FontStyle
Font style to use to build the label
Size
Type: System..::..UInt16
Font size to use to build the label

Return Value

A Label object which contains the name of the parameter

Implements

IParameter..::..BuildLabel(String, FontStyle, UInt16)

See Also

GroupOfFields Class
GroupOfFields Members
Parameters Namespace


Clone Method

[image]

MADCAT Software Developer Guide
GroupOfFields..::..Clone Method
GroupOfFields Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Clones the parameter object into a new parameter object

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

A clone of the current object

See Also

GroupOfFields Class
GroupOfFields Members
Parameters Namespace


RestoreValueFromItem Method

[image]

MADCAT Software Developer Guide
GroupOfFields..::..RestoreValueFromItem Method
GroupOfFields Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the value of the parameter from a given project's Item

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override void RestoreValueFromItem(
    XmlNode item
)
Visual Basic
Public Overrides Sub RestoreValueFromItem ( _
    item As XmlNode _
)
Visual C++
public:
virtual void RestoreValueFromItem(
    XmlNode^ item
) override

Parameters

item
Type: System.Xml..::..XmlNode
XML node where the attribute's value shall be used to set the parameter's value

Implements

IParameter..::..RestoreValueFromItem(XmlNode)

See Also

GroupOfFields Class
GroupOfFields Members
Parameters Namespace


SaveValueInItem Method

[image]

MADCAT Software Developer Guide
GroupOfFields..::..SaveValueInItem Method
GroupOfFields Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Saves the value of the parameter into a given project's Item

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override void SaveValueInItem(
    XmlNode item
)
Visual Basic
Public Overrides Sub SaveValueInItem ( _
    item As XmlNode _
)
Visual C++
public:
virtual void SaveValueInItem(
    XmlNode^ item
) override

Parameters

item
Type: System.Xml..::..XmlNode
XML node where the parameter's value shall be stored into as an attribute's value

Implements

IParameter..::..SaveValueInItem(XmlNode)

See Also

GroupOfFields Class
GroupOfFields Members
Parameters Namespace


GroupOfFields Properties

[image] [image]

MADCAT Software Developer Guide
GroupOfFields Properties
GroupOfFields Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The GroupOfFields type exposes the following members.

Properties

Name Description
Public property ContextMenu
Property used by MADCAT to get the context menu of the parameter
(Inherited from BaseParameter.)
Public property Description
Property used by MADCAT to get/set the description of the parameter
(Inherited from BaseParameter.)
Public property DisplayOnly
Property used by MADCAT to set the access mode of the parameter
(Overrides BaseParameter..::..DisplayOnly.)
Public property DrawHandler
Property used by MADCAT to get the Bitmap handler of the parameter
(Inherited from BaseParameter.)
Public property FormControl
Gets the panel used to embed all the parameters of the group. The panel has a title placed on top. When it is expandable, this title can be clicked to show/hide the content of the panel.
(Overrides BaseParameter..::..FormControl.)
Public property HasChanged
Property used by MADCAT to check if the parameter has changed
(Inherited from BaseParameter.)
Public property Hint
Property used by MADCAT to get/set the tip of the parameter. The tip contains a short help which popups when the user moves his mouse cursor over the parameter's name
(Inherited from BaseParameter.)
Public property IsExpandable
Indicates if the panel can be collapsed/expanded dynamically by the user. When set to true, the panel can be collapsed/expanded.
Public property IsHorizontal
Sets the orientation of the parameters inside the panel. When set to true, the parameters are placed on the same line, one beside another. They are top aligned. When set to false, the parameters are placed one over another in the same column. They are left aligned.
Public property IsMandatory
Not applicable.
(Overrides BaseParameter..::..IsMandatory.)
Public property IsUndefined
Not applicable.
(Overrides BaseParameter..::..IsUndefined.)
Public property MaxNumberOfChars
Gets/sets the maximum number of characters of the parameter's value
(Inherited from BaseParameter.)
Public property Name
Property used by MADCAT to get/set the name of the parameter
(Inherited from BaseParameter.)
Public property NumberOfLines
Gets/sets the number of lines visible in the text box of the parameter
(Inherited from BaseParameter.)
Public property Options
Property used by MADCAT to get/set the options of the parameter. Common options are (applicable to all parameters):
  • mandatory=b : where b is 'yes' or 'no'. Indicates if the parameter must be filled by the user
  • readonly=b : where b is 'yes' or 'no'. Indicates if the parameter can be modified by the user
Additional options are :
  • orientation=horizontal|vertical : this option sets the alignment of the fields in the group. Horizontal : all fields are in the same line. Vertical : all fields are in the same column.
  • expandable=yes|no : Indicates if the user can show/hide the content of the group. If set to false, content is always visible.
  • height=xxx : Height in pixels of the group.
  • separator=x : Character to use in the value of the parameter to separate values of the child parameters
(Overrides BaseParameter..::..Options.)
Public property Parameters
Collection of parameters object. All these parameters will be displayed inside the same panel
Public property Tag
Gets/sets the Tag property of the parameter's control object
(Inherited from BaseParameter.)
Public property TextHandler
Property used by MADCAT to get the String handler of the parameter
(Inherited from BaseParameter.)
Public property Tip
Property used by MADCAT to get/set the ToolTip object for the Form Control of the parameter
(Overrides BaseParameter..::..Tip.)
Public property Type
Gets the base type of the parameter. For groups of fields, it is CMN_Group.
(Overrides BaseParameter..::..Type.)
Public property TypeName
Gets the name of the type of the parameter as it is coded in the attribute TYPE of the parameter's Xml definition (ATTRIBUTE element definition) It is the core type's name of the parameter
(Inherited from BaseParameter.)
Public property UserSettings
Property used by MADCAT to get/set the user settings of the parameter
(Inherited from BaseParameter.)
Public property Value
Property used by MADCAT to get/set the value of the parameter
(Overrides BaseParameter..::..Value.)
Public property XmlDefinition
Property used by MADCAT to get/set the XML definition of the parameter. Definition must be compliant with the schema MODELS.XSD
(Overrides BaseParameter..::..XmlDefinition.)
Public property XmlNodeHandler
Property used by MADCAT to get the XML handler of the parameter
(Inherited from BaseParameter.)

See Also

GroupOfFields Class
Parameters Namespace


DisplayOnly Property

[image]

MADCAT Software Developer Guide
GroupOfFields..::..DisplayOnly Property
GroupOfFields Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to set the access mode of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override bool DisplayOnly { set; }
Visual Basic
Public Overrides WriteOnly Property DisplayOnly As Boolean
    Set
Visual C++
public:
virtual property bool DisplayOnly {
    void set (bool value) override;
}

Implements

IParameter..::..DisplayOnly

See Also

GroupOfFields Class
GroupOfFields Members
Parameters Namespace


FormControl Property

[image]

MADCAT Software Developer Guide
GroupOfFields..::..FormControl Property
GroupOfFields Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the panel used to embed all the parameters of the group. The panel has a title placed on top. When it is expandable, this title can be clicked to show/hide the content of the panel.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Control FormControl { get; }
Visual Basic
Public Overrides ReadOnly Property FormControl As Control
    Get
Visual C++
public:
virtual property Control^ FormControl {
    Control^ get () override;
}

Implements

IParameter..::..FormControl

See Also

GroupOfFields Class
GroupOfFields Members
Parameters Namespace


IsExpandable Property

[image]

MADCAT Software Developer Guide
GroupOfFields..::..IsExpandable Property
GroupOfFields Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Indicates if the panel can be collapsed/expanded dynamically by the user. When set to true, the panel can be collapsed/expanded.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public bool IsExpandable { get; set; }
Visual Basic
Public Property IsExpandable As Boolean
    Get
    Set
Visual C++
public:
property bool IsExpandable {
    bool get ();
    void set (bool value);
}

See Also

GroupOfFields Class
GroupOfFields Members
Parameters Namespace


IsHorizontal Property

[image]

MADCAT Software Developer Guide
GroupOfFields..::..IsHorizontal Property
GroupOfFields Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Sets the orientation of the parameters inside the panel. When set to true, the parameters are placed on the same line, one beside another. They are top aligned. When set to false, the parameters are placed one over another in the same column. They are left aligned.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public bool IsHorizontal { get; set; }
Visual Basic
Public Property IsHorizontal As Boolean
    Get
    Set
Visual C++
public:
property bool IsHorizontal {
    bool get ();
    void set (bool value);
}

See Also

GroupOfFields Class
GroupOfFields Members
Parameters Namespace


IsMandatory Property

[image]

MADCAT Software Developer Guide
GroupOfFields..::..IsMandatory Property
GroupOfFields Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Not applicable.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override bool IsMandatory { get; }
Visual Basic
Public Overrides ReadOnly Property IsMandatory As Boolean
    Get
Visual C++
public:
virtual property bool IsMandatory {
    bool get () override;
}

Implements

IParameter..::..IsMandatory

See Also

GroupOfFields Class
GroupOfFields Members
Parameters Namespace


IsUndefined Property

[image]

MADCAT Software Developer Guide
GroupOfFields..::..IsUndefined Property
GroupOfFields Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Not applicable.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override bool IsUndefined { get; }
Visual Basic
Public Overrides ReadOnly Property IsUndefined As Boolean
    Get
Visual C++
public:
virtual property bool IsUndefined {
    bool get () override;
}

Implements

IParameter..::..IsUndefined

See Also

GroupOfFields Class
GroupOfFields Members
Parameters Namespace


Options Property

[image]

MADCAT Software Developer Guide
GroupOfFields..::..Options Property
GroupOfFields Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the options of the parameter. Common options are (applicable to all parameters):
  • mandatory=b : where b is 'yes' or 'no'. Indicates if the parameter must be filled by the user
  • readonly=b : where b is 'yes' or 'no'. Indicates if the parameter can be modified by the user
Additional options are :
  • orientation=horizontal|vertical : this option sets the alignment of the fields in the group. Horizontal : all fields are in the same line. Vertical : all fields are in the same column.
  • expandable=yes|no : Indicates if the user can show/hide the content of the group. If set to false, content is always visible.
  • height=xxx : Height in pixels of the group.
  • separator=x : Character to use in the value of the parameter to separate values of the child parameters

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Hashtable Options { set; }
Visual Basic
Public Overrides WriteOnly Property Options As Hashtable
    Set
Visual C++
public:
virtual property Hashtable^ Options {
    void set (Hashtable^ value) override;
}

Implements

IParameter..::..Options

See Also

GroupOfFields Class
GroupOfFields Members
Parameters Namespace


Parameters Property

[image]

MADCAT Software Developer Guide
GroupOfFields..::..Parameters Property
GroupOfFields Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Collection of parameters object. All these parameters will be displayed inside the same panel

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public IParameter[] Parameters { get; set; }
Visual Basic
Public Property Parameters As IParameter()
    Get
    Set
Visual C++
public:
property array<IParameter^>^ Parameters {
    array<IParameter^>^ get ();
    void set (array<IParameter^>^ value);
}

See Also

GroupOfFields Class
GroupOfFields Members
Parameters Namespace


Tip Property

[image]

MADCAT Software Developer Guide
GroupOfFields..::..Tip Property
GroupOfFields Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the ToolTip object for the Form Control of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override ToolTip Tip { set; }
Visual Basic
Public Overrides WriteOnly Property Tip As ToolTip
    Set
Visual C++
public:
virtual property ToolTip^ Tip {
    void set (ToolTip^ value) override;
}

Implements

IParameter..::..Tip

See Also

GroupOfFields Class
GroupOfFields Members
Parameters Namespace


Type Property

[image]

MADCAT Software Developer Guide
GroupOfFields..::..Type Property
GroupOfFields Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the base type of the parameter. For groups of fields, it is CMN_Group.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override DataToolTypes Type { get; }
Visual Basic
Public Overrides ReadOnly Property Type As DataToolTypes
    Get
Visual C++
public:
virtual property DataToolTypes Type {
    DataToolTypes get () override;
}

Implements

IParameter..::..Type

See Also

GroupOfFields Class
GroupOfFields Members
Parameters Namespace


Value Property

[image]

MADCAT Software Developer Guide
GroupOfFields..::..Value Property
GroupOfFields Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the value of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override string Value { get; set; }
Visual Basic
Public Overrides Property Value As String
    Get
    Set
Visual C++
public:
virtual property String^ Value {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IParameter..::..Value

See Also

GroupOfFields Class
GroupOfFields Members
Parameters Namespace


XmlDefinition Property

[image]

MADCAT Software Developer Guide
GroupOfFields..::..XmlDefinition Property
GroupOfFields Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the XML definition of the parameter. Definition must be compliant with the schema MODELS.XSD

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override XmlNode XmlDefinition { set; }
Visual Basic
Public Overrides WriteOnly Property XmlDefinition As XmlNode
    Set
Visual C++
public:
virtual property XmlNode^ XmlDefinition {
    void set (XmlNode^ value) override;
}

Implements

IParameter..::..XmlDefinition

See Also

GroupOfFields Class
GroupOfFields Members
Parameters Namespace


GroupOfFields Events

[image] [image]

MADCAT Software Developer Guide
GroupOfFields Events
GroupOfFields Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The GroupOfFields type exposes the following members.

Events

 | Name | Description
Public event | ValueChanged | Fired when the value of the parameter changes (Inherited from BaseParameter.)

See Also

GroupOfFields Class
Parameters Namespace


IFilter Interface

[image]

MADCAT Software Developer Guide
IFilter Interface
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Interface which shall be exposed by any parameter not using the standard string filter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public interface IFilter
Visual Basic
Public Interface IFilter
Visual C++
public interface class IFilter

See Also

IFilter Members
Parameters Namespace


IFilter Members

[image] [image]

MADCAT Software Developer Guide
IFilter Members
IFilter Interface Methods Properties See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IFilter type exposes the following members.

Methods

 | Name | Description
Public method | GetTypeOptions | Invoked by MADCAT to get the type options
Public method | IsMatch | Invoked by MADCAT to check if a given string matches filter's properties

Properties

 | Name | Description
Public property | Args | Invoked by MADCAT to get or set the properties of the filter
Public property | Form | Invoked by MADCAT to get the Windows form which is used to set the filter properties
Public property | IsActive | Invoked by MADCAT to detect if the filter is active
Public property | Type | Invoked by MADCAT to the core type of the filter
Public property | XPathCondition | Invoked by MADCAT to get the XQuery expression to be used to select items from the database

See Also

IFilter Interface
Parameters Namespace


IFilter Methods

[image] [image]

MADCAT Software Developer Guide
IFilter Methods
IFilter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IFilter type exposes the following members.

Methods

 | Name | Description
Public method | GetTypeOptions | Invoked by MADCAT to get the type options
Public method | IsMatch | Invoked by MADCAT to check if a given string matches filter's properties

See Also

IFilter Interface
Parameters Namespace


GetTypeOptions Method

[image]

MADCAT Software Developer Guide
IFilter..::..GetTypeOptions Method
IFilter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Invoked by MADCAT to get the type options

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
void GetTypeOptions(
    Hashtable opt
)
Visual Basic
Sub GetTypeOptions ( _
    opt As Hashtable _
)
Visual C++
void GetTypeOptions(
    Hashtable^ opt
)

Parameters

opt
Type: System.Collections..::..Hashtable
Hashtable which shall be filled by the filter with the type options (key=option name, value=value of the option)

See Also

IFilter Interface
IFilter Members
Parameters Namespace


IsMatch Method

[image]

MADCAT Software Developer Guide
IFilter..::..IsMatch Method
IFilter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Invoked by MADCAT to check if a given string matches filter's properties

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
bool IsMatch(
    string value
)
Visual Basic
Function IsMatch ( _
    value As String _
) As Boolean
Visual C++
bool IsMatch(
    String^ value
)

Parameters

value
Type: System..::..String
A value of a parameter exposing the filter

Return Value

True means the item should be displayed because the value matches the filter's criterias

See Also

IFilter Interface
IFilter Members
Parameters Namespace


IFilter Properties

[image] [image]

MADCAT Software Developer Guide
IFilter Properties
IFilter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IFilter type exposes the following members.

Properties

 | Name | Description
Public property | Args | Invoked by MADCAT to get or set the properties of the filter
Public property | Form | Invoked by MADCAT to get the Windows form which is used to set the filter properties
Public property | IsActive | Invoked by MADCAT to detect if the filter is active
Public property | Type | Invoked by MADCAT to the core type of the filter
Public property | XPathCondition | Invoked by MADCAT to get the XQuery expression to be used to select items from the database

See Also

IFilter Interface
Parameters Namespace


Args Property

[image]

MADCAT Software Developer Guide
IFilter..::..Args Property
IFilter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Invoked by MADCAT to get or set the properties of the filter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
Object Args { get; set; }
Visual Basic
Property Args As Object
    Get
    Set
Visual C++
property Object^ Args {
    Object^ get ();
    void set (Object^ value);
}

See Also

IFilter Interface
IFilter Members
Parameters Namespace


Form Property

[image]

MADCAT Software Developer Guide
IFilter..::..Form Property
IFilter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Invoked by MADCAT to get the Windows form which is used to set the filter properties

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
Control Form { get; }
Visual Basic
ReadOnly Property Form As Control
    Get
Visual C++
property Control^ Form {
    Control^ get ();
}

See Also

IFilter Interface
IFilter Members
Parameters Namespace


IsActive Property

[image]

MADCAT Software Developer Guide
IFilter..::..IsActive Property
IFilter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Invoked by MADCAT to detect if the filter is active

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
bool IsActive { get; }
Visual Basic
ReadOnly Property IsActive As Boolean
    Get
Visual C++
property bool IsActive {
    bool get ();
}

See Also

IFilter Interface
IFilter Members
Parameters Namespace


Type Property

[image]

MADCAT Software Developer Guide
IFilter..::..Type Property
IFilter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Invoked by MADCAT to the core type of the filter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
DataToolTypes Type { get; }
Visual Basic
ReadOnly Property Type As DataToolTypes
    Get
Visual C++
property DataToolTypes Type {
    DataToolTypes get ();
}

See Also

IFilter Interface
IFilter Members
Parameters Namespace


XPathCondition Property

[image]

MADCAT Software Developer Guide
IFilter..::..XPathCondition Property
IFilter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Invoked by MADCAT to get the XQuery expression to be used to select items from the database

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
string XPathCondition { get; }
Visual Basic
ReadOnly Property XPathCondition As String
    Get
Visual C++
property String^ XPathCondition {
    String^ get ();
}

See Also

IFilter Interface
IFilter Members
Parameters Namespace


IPAddrInput Class

[image]

MADCAT Software Developer Guide
IPAddrInput Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Used to managed parameters which handle IP addresses

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
[SerializableAttribute]
public class IPAddrInput : BaseParameter
Visual Basic
<SerializableAttribute> _
Public Class IPAddrInput _
    Inherits BaseParameter
Visual C++
[SerializableAttribute]
public ref class IPAddrInput : public BaseParameter

Inheritance Hierarchy

System..::..Object
Parameters..::..BaseParameter
Parameters..::..IPAddrInput

See Also

IPAddrInput Members
Parameters Namespace


IPAddrInput Members

[image] [image]

MADCAT Software Developer Guide
IPAddrInput Members
IPAddrInput Class Constructors Methods Properties Events See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IPAddrInput type exposes the following members.

Constructors

 | Name | Description
Public method | IPAddrInput | Constructor

Methods

 | Name | Description
Public method | BuildHTMLString | Gives the HTML code used to render the input field in HTML instead of Windows form control (Inherited from BaseParameter.)
Public method | BuildLabel | Gives the Windows Form control for the label of the input field of the parameter (Inherited from BaseParameter.)
Public method | Clone | Clones the parameter object into a new parameter object (Overrides BaseParameter..::..Clone()()()().)
Public method | RestoreValueFromItem | Gets the value of the parameter from a given project's Item (Inherited from BaseParameter.)
Public method | SaveValueInItem | Saves the value of the parameter into a given project's Item (Inherited from BaseParameter.)

Properties

Name Description
Public property ContextMenu
Property used by MADCAT to get the context menu of the parameter
(Inherited from BaseParameter.)
Public property Description
Property used by MADCAT to get/set the description of the parameter
(Inherited from BaseParameter.)
Public property DisplayOnly
Set to true if the value can't be changed
(Overrides BaseParameter..::..DisplayOnly.)
Public property DrawHandler
Property used by MADCAT to get the Bitmap handler of the parameter
(Inherited from BaseParameter.)
Public property FormControl
Gets the panel which contains the 4 text boxes used to enter the 4 digits of the IP address. Each box has its own up/down buttons to easily increase/decrease the value. Pressing the space bar in any field makes the cursor goes to the next field.
(Overrides BaseParameter..::..FormControl.)
Public property HasChanged
Property used by MADCAT to check if the parameter has changed
(Inherited from BaseParameter.)
Public property Hint
Property used by MADCAT to get/set the tip of the parameter. The tip contains a short help which popups when the user moves his mouse cursor over the parameter's name
(Inherited from BaseParameter.)
Public property IsMandatory
Property used by MADCAT to indicate if the parameter is mandatory or not. When mandatory, the user must give a value to the parameter to continue his current operation.
(Inherited from BaseParameter.)
Public property IsUndefined
Property used by MADCAT to check if the parameter has been set by the user or not
(Inherited from BaseParameter.)
Public property MaxNumberOfChars
Gets/sets the maximum number of characters of the parameter's value
(Inherited from BaseParameter.)
Public property Name
Property used by MADCAT to get/set the name of the parameter
(Inherited from BaseParameter.)
Public property NumberOfLines
Gets/sets the number of lines visible in the text box of the parameter
(Inherited from BaseParameter.)
Public property Options
Property used by MADCAT to get/set the options of the parameter. Common options are (applicable to all parameters):
    • mandatory=b : where b is 'yes' or 'no'. Indicates if the parameter must be filled by the user
      readonly=b : where b is 'yes' or 'no'. Indicates if the parameter can be modified by the user
    • (Overrides BaseParameter..::..Options.)
    Public property Tag
    Gets/sets the Tag property of the parameter's control object
    (Inherited from BaseParameter.)
    Public property TextHandler
    Property used by MADCAT to get the String handler of the parameter
    (Inherited from BaseParameter.)
    Public property Tip
    Property used by MADCAT to get/set the ToolTip object for the Form Control of the parameter
    (Inherited from BaseParameter.)
    Public property Type
    Gets the base type of the parameter. For IP addresses parameters, it is CMN_IPAddress
    (Overrides BaseParameter..::..Type.)
    Public property TypeName
    Gets the name of the type of the parameter as it is coded in the attribute TYPE of the parameter's Xml definition (ATTRIBUTE element definition) It is the core type's name of the parameter
    (Inherited from BaseParameter.)
    Public property UserSettings
    Property used by MADCAT to get/set the user settings of the parameter
    (Inherited from BaseParameter.)
    Public property Value
    Gets/sets the IP address of the parameter. IP address shall be compliant with IP v4 standard : xxx.xxx.xxx.xxx
    (Overrides BaseParameter..::..Value.)
    Public property XmlDefinition
    Property used by MADCAT to get/set the XML definition of the parameter. Definition must be compliant with the schema MODELS.XSD
    (Overrides BaseParameter..::..XmlDefinition.)
    Public property XmlNodeHandler
    Property used by MADCAT to get the XML handler of the parameter
    (Inherited from BaseParameter.)

    Events

     | Name | Description
Public event | ValueChanged | Fired when the value of the parameter changes (Inherited from BaseParameter.)

    See Also

    IPAddrInput Class
    Parameters Namespace


IPAddrInput Constructor

[image]

MADCAT Software Developer Guide
IPAddrInput Constructor
IPAddrInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public IPAddrInput()
Visual Basic
Public Sub New
Visual C++
public:
IPAddrInput()

See Also

IPAddrInput Class
IPAddrInput Members
Parameters Namespace


IPAddrInput Methods

[image] [image]

MADCAT Software Developer Guide
IPAddrInput Methods
IPAddrInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IPAddrInput type exposes the following members.

Methods

 | Name | Description
Public method | BuildHTMLString | Gives the HTML code used to render the input field in HTML instead of Windows form control (Inherited from BaseParameter.)
Public method | BuildLabel | Gives the Windows Form control for the label of the input field of the parameter (Inherited from BaseParameter.)
Public method | Clone | Clones the parameter object into a new parameter object (Overrides BaseParameter..::..Clone()()()().)
Public method | RestoreValueFromItem | Gets the value of the parameter from a given project's Item (Inherited from BaseParameter.)
Public method | SaveValueInItem | Saves the value of the parameter into a given project's Item (Inherited from BaseParameter.)

See Also

IPAddrInput Class
Parameters Namespace


Clone Method

[image]

MADCAT Software Developer Guide
IPAddrInput..::..Clone Method
IPAddrInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Clones the parameter object into a new parameter object

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

A clone of the current object

See Also

IPAddrInput Class
IPAddrInput Members
Parameters Namespace


IPAddrInput Properties

[image] [image]

MADCAT Software Developer Guide
IPAddrInput Properties
IPAddrInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IPAddrInput type exposes the following members.

Properties

Name Description
Public property ContextMenu
Property used by MADCAT to get the context menu of the parameter
(Inherited from BaseParameter.)
Public property Description
Property used by MADCAT to get/set the description of the parameter
(Inherited from BaseParameter.)
Public property DisplayOnly
Set to true if the value can't be changed
(Overrides BaseParameter..::..DisplayOnly.)
Public property DrawHandler
Property used by MADCAT to get the Bitmap handler of the parameter
(Inherited from BaseParameter.)
Public property FormControl
Gets the panel which contains the 4 text boxes used to enter the 4 digits of the IP address. Each box has its own up/down buttons to easily increase/decrease the value. Pressing the space bar in any field makes the cursor goes to the next field.
(Overrides BaseParameter..::..FormControl.)
Public property HasChanged
Property used by MADCAT to check if the parameter has changed
(Inherited from BaseParameter.)
Public property Hint
Property used by MADCAT to get/set the tip of the parameter. The tip contains a short help which popups when the user moves his mouse cursor over the parameter's name
(Inherited from BaseParameter.)
Public property IsMandatory
Property used by MADCAT to indicate if the parameter is mandatory or not. When mandatory, the user must give a value to the parameter to continue his current operation.
(Inherited from BaseParameter.)
Public property IsUndefined
Property used by MADCAT to check if the parameter has been set by the user or not
(Inherited from BaseParameter.)
Public property MaxNumberOfChars
Gets/sets the maximum number of characters of the parameter's value
(Inherited from BaseParameter.)
Public property Name
Property used by MADCAT to get/set the name of the parameter
(Inherited from BaseParameter.)
Public property NumberOfLines
Gets/sets the number of lines visible in the text box of the parameter
(Inherited from BaseParameter.)
Public property Options
Property used by MADCAT to get/set the options of the parameter. Common options are (applicable to all parameters):
    • mandatory=b : where b is 'yes' or 'no'. Indicates if the parameter must be filled by the user
      readonly=b : where b is 'yes' or 'no'. Indicates if the parameter can be modified by the user
    • (Overrides BaseParameter..::..Options.)
    Public property Tag
    Gets/sets the Tag property of the parameter's control object
    (Inherited from BaseParameter.)
    Public property TextHandler
    Property used by MADCAT to get the String handler of the parameter
    (Inherited from BaseParameter.)
    Public property Tip
    Property used by MADCAT to get/set the ToolTip object for the Form Control of the parameter
    (Inherited from BaseParameter.)
    Public property Type
    Gets the base type of the parameter. For IP addresses parameters, it is CMN_IPAddress
    (Overrides BaseParameter..::..Type.)
    Public property TypeName
    Gets the name of the type of the parameter as it is coded in the attribute TYPE of the parameter's Xml definition (ATTRIBUTE element definition) It is the core type's name of the parameter
    (Inherited from BaseParameter.)
    Public property UserSettings
    Property used by MADCAT to get/set the user settings of the parameter
    (Inherited from BaseParameter.)
    Public property Value
    Gets/sets the IP address of the parameter. IP address shall be compliant with IP v4 standard : xxx.xxx.xxx.xxx
    (Overrides BaseParameter..::..Value.)
    Public property XmlDefinition
    Property used by MADCAT to get/set the XML definition of the parameter. Definition must be compliant with the schema MODELS.XSD
    (Overrides BaseParameter..::..XmlDefinition.)
    Public property XmlNodeHandler
    Property used by MADCAT to get the XML handler of the parameter
    (Inherited from BaseParameter.)

    See Also

    IPAddrInput Class
    Parameters Namespace


DisplayOnly Property

[image]

MADCAT Software Developer Guide
IPAddrInput..::..DisplayOnly Property
IPAddrInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Set to true if the value can't be changed

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override bool DisplayOnly { get; set; }
Visual Basic
Public Overrides Property DisplayOnly As Boolean
    Get
    Set
Visual C++
public:
virtual property bool DisplayOnly {
    bool get () override;
    void set (bool value) override;
}

Implements

IParameter..::..DisplayOnly

See Also

IPAddrInput Class
IPAddrInput Members
Parameters Namespace


FormControl Property

[image]

MADCAT Software Developer Guide
IPAddrInput..::..FormControl Property
IPAddrInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the panel which contains the 4 text boxes used to enter the 4 digits of the IP address. Each box has its own up/down buttons to easily increase/decrease the value. Pressing the space bar in any field makes the cursor goes to the next field.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Control FormControl { get; }
Visual Basic
Public Overrides ReadOnly Property FormControl As Control
    Get
Visual C++
public:
virtual property Control^ FormControl {
    Control^ get () override;
}

Implements

IParameter..::..FormControl

See Also

IPAddrInput Class
IPAddrInput Members
Parameters Namespace


Options Property

[image]

MADCAT Software Developer Guide
IPAddrInput..::..Options Property
IPAddrInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the options of the parameter. Common options are (applicable to all parameters):
    • mandatory=b : where b is 'yes' or 'no'. Indicates if the parameter must be filled by the user
      readonly=b : where b is 'yes' or 'no'. Indicates if the parameter can be modified by the user

    • Namespace: Parameters
    Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

    Syntax

    C#
    public override Hashtable Options { set; }
    Visual Basic
    Public Overrides WriteOnly Property Options As Hashtable
    Set
    Visual C++
    public:
virtual property Hashtable^ Options {
    void set (Hashtable^ value) override;
}

    Implements

    IParameter..::..Options

    See Also

    IPAddrInput Class
    IPAddrInput Members
    Parameters Namespace


Type Property

[image]

MADCAT Software Developer Guide
IPAddrInput..::..Type Property
IPAddrInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the base type of the parameter. For IP addresses parameters, it is CMN_IPAddress

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override DataToolTypes Type { get; }
Visual Basic
Public Overrides ReadOnly Property Type As DataToolTypes
    Get
Visual C++
public:
virtual property DataToolTypes Type {
    DataToolTypes get () override;
}

Implements

IParameter..::..Type

See Also

IPAddrInput Class
IPAddrInput Members
Parameters Namespace


Value Property

[image]

MADCAT Software Developer Guide
IPAddrInput..::..Value Property
IPAddrInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/sets the IP address of the parameter. IP address shall be compliant with IP v4 standard : xxx.xxx.xxx.xxx

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override string Value { get; set; }
Visual Basic
Public Overrides Property Value As String
    Get
    Set
Visual C++
public:
virtual property String^ Value {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IParameter..::..Value

See Also

IPAddrInput Class
IPAddrInput Members
Parameters Namespace


XmlDefinition Property

[image]

MADCAT Software Developer Guide
IPAddrInput..::..XmlDefinition Property
IPAddrInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the XML definition of the parameter. Definition must be compliant with the schema MODELS.XSD

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override XmlNode XmlDefinition { set; }
Visual Basic
Public Overrides WriteOnly Property XmlDefinition As XmlNode
    Set
Visual C++
public:
virtual property XmlNode^ XmlDefinition {
    void set (XmlNode^ value) override;
}

Implements

IParameter..::..XmlDefinition

See Also

IPAddrInput Class
IPAddrInput Members
Parameters Namespace


IPAddrInput Events

[image] [image]

MADCAT Software Developer Guide
IPAddrInput Events
IPAddrInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IPAddrInput type exposes the following members.

Events

 | Name | Description
Public event | ValueChanged | Fired when the value of the parameter changes (Inherited from BaseParameter.)

See Also

IPAddrInput Class
Parameters Namespace


IParameter Interface

[image]

MADCAT Software Developer Guide
IParameter Interface
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Interface exposed by any type handler of MADCAT. A type handler is used to manage one parameter in MADCAT GUI.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public interface IParameter : ICloneable
Visual Basic
Public Interface IParameter _
    Inherits ICloneable
Visual C++
public interface class IParameter : ICloneable

See Also

IParameter Members
Parameters Namespace


IParameter Members

[image] [image]

MADCAT Software Developer Guide
IParameter Members
IParameter Interface Methods Properties Events See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IParameter type exposes the following members.

Methods

 | Name | Description
Public method | BuildHTMLString | Gives the HTML code used to render the input field in HTML instead of Windows form control
Public method | BuildLabel | Gives the Windows Form control for the label of the input field of the parameter
Public method | RestoreValueFromItem | Gets the value of the parameter from a given project's Item
Public method | SaveValueInItem | Saves the value of the parameter into a given project's Item

Properties

Name Description
Public property ContextMenu
Property used by MADCAT to get the context menu of the parameter
Public property Description
Property used by MADCAT to get/set the description of the parameter
Public property DisplayOnly
Property used by MADCAT to set the access mode of the parameter
Public property DrawHandler
Property used by MADCAT to get the Bitmap handler of the parameter
Public property FormControl
Property used by MADCAT to get Form Control of the parameter. The Form Control shall take into account dynamically the values provided by MADCAT through the following properties :
  • IsMandatory
  • DisplayOnly
  • UserSettings
  • Options
  • Value
Public property HasChanged
Property used by MADCAT to check if the parameter has changed
Public property Hint
Property used by MADCAT to get/set the tip of the parameter. The tip contains a short help which popups when the user moves his mouse cursor over the parameter's name
Public property IsMandatory
Property used by MADCAT to indicate if the parameter is mandatory or not. When mandatory, the user must give a value to the parameter to continue his current operation.
Public property IsUndefined
Property used by MADCAT to check if the parameter has been set by the user or not
Public property Name
Property used by MADCAT to get/set the name of the parameter
Public property Options
Property used by MADCAT to get/set the options of the parameter
Public property TextHandler
Property used by MADCAT to get the String handler of the parameter
Public property Tip
Property used by MADCAT to get/set the ToolTip object for the Form Control of the parameter
Public property Type
Property used by MADCAT to get the core type of the parameter
Public property TypeName
Property used by MADCAT to get the core type's name of the parameter
Public property UserSettings
Property used by MADCAT to get/set the user settings of the parameter
Public property Value
Property used by MADCAT to get/set the value of the parameter
Public property XmlDefinition
Property used by MADCAT to get/set the XML definition of the parameter
Public property XmlNodeHandler
Property used by MADCAT to get the XML handler of the parameter

Events

 | Name | Description
Public event | ValueChanged | Fired when the value of the parameter changes because of an user action (not fired when Value property is set)

See Also

IParameter Interface
Parameters Namespace


IParameter Methods

[image] [image]

MADCAT Software Developer Guide
IParameter Methods
IParameter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IParameter type exposes the following members.

Methods

 | Name | Description
Public method | BuildHTMLString | Gives the HTML code used to render the input field in HTML instead of Windows form control
Public method | BuildLabel | Gives the Windows Form control for the label of the input field of the parameter
Public method | RestoreValueFromItem | Gets the value of the parameter from a given project's Item
Public method | SaveValueInItem | Saves the value of the parameter into a given project's Item

See Also

IParameter Interface
Parameters Namespace


BuildHTMLString Method

[image]

MADCAT Software Developer Guide
IParameter..::..BuildHTMLString Method
IParameter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gives the HTML code used to render the input field in HTML instead of Windows form control

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
string BuildHTMLString()
Visual Basic
Function BuildHTMLString As String
Visual C++
String^ BuildHTMLString()

Return Value

The HTML code equivalent to the Windows Form Control

See Also

IParameter Interface
IParameter Members
Parameters Namespace


BuildLabel Method

[image]

MADCAT Software Developer Guide
IParameter..::..BuildLabel Method
IParameter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gives the Windows Form control for the label of the input field of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
Control BuildLabel(
    string TypeFace,
    FontStyle Style,
    ushort Size
)
Visual Basic
Function BuildLabel ( _
    TypeFace As String, _
    Style As FontStyle, _
    Size As UShort _
) As Control
Visual C++
Control^ BuildLabel(
    String^ TypeFace,
    FontStyle Style,
    unsigned short Size
)

Parameters

TypeFace
Type: System..::..String
Font to use to build the label
Style
Type: System.Drawing..::..FontStyle
Font style to use to build the label
Size
Type: System..::..UInt16
Font size to use to build the label

Return Value

A Label object which contains the name of the parameter

See Also

IParameter Interface
IParameter Members
Parameters Namespace


RestoreValueFromItem Method

[image]

MADCAT Software Developer Guide
IParameter..::..RestoreValueFromItem Method
IParameter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the value of the parameter from a given project's Item

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
void RestoreValueFromItem(
    XmlNode item
)
Visual Basic
Sub RestoreValueFromItem ( _
    item As XmlNode _
)
Visual C++
void RestoreValueFromItem(
    XmlNode^ item
)

Parameters

item
Type: System.Xml..::..XmlNode
XML node where the attribute's value shall be used to set the parameter's value

See Also

IParameter Interface
IParameter Members
Parameters Namespace


SaveValueInItem Method

[image]

MADCAT Software Developer Guide
IParameter..::..SaveValueInItem Method
IParameter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Saves the value of the parameter into a given project's Item

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
void SaveValueInItem(
    XmlNode item
)
Visual Basic
Sub SaveValueInItem ( _
    item As XmlNode _
)
Visual C++
void SaveValueInItem(
    XmlNode^ item
)

Parameters

item
Type: System.Xml..::..XmlNode
XML node where the parameter's value shall be stored into as an attribute's value

See Also

IParameter Interface
IParameter Members
Parameters Namespace


IParameter Properties

[image] [image]

MADCAT Software Developer Guide
IParameter Properties
IParameter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IParameter type exposes the following members.

Properties

Name Description
Public property ContextMenu
Property used by MADCAT to get the context menu of the parameter
Public property Description
Property used by MADCAT to get/set the description of the parameter
Public property DisplayOnly
Property used by MADCAT to set the access mode of the parameter
Public property DrawHandler
Property used by MADCAT to get the Bitmap handler of the parameter
Public property FormControl
Property used by MADCAT to get Form Control of the parameter. The Form Control shall take into account dynamically the values provided by MADCAT through the following properties :
  • IsMandatory
  • DisplayOnly
  • UserSettings
  • Options
  • Value
Public property HasChanged
Property used by MADCAT to check if the parameter has changed
Public property Hint
Property used by MADCAT to get/set the tip of the parameter. The tip contains a short help which popups when the user moves his mouse cursor over the parameter's name
Public property IsMandatory
Property used by MADCAT to indicate if the parameter is mandatory or not. When mandatory, the user must give a value to the parameter to continue his current operation.
Public property IsUndefined
Property used by MADCAT to check if the parameter has been set by the user or not
Public property Name
Property used by MADCAT to get/set the name of the parameter
Public property Options
Property used by MADCAT to get/set the options of the parameter
Public property TextHandler
Property used by MADCAT to get the String handler of the parameter
Public property Tip
Property used by MADCAT to get/set the ToolTip object for the Form Control of the parameter
Public property Type
Property used by MADCAT to get the core type of the parameter
Public property TypeName
Property used by MADCAT to get the core type's name of the parameter
Public property UserSettings
Property used by MADCAT to get/set the user settings of the parameter
Public property Value
Property used by MADCAT to get/set the value of the parameter
Public property XmlDefinition
Property used by MADCAT to get/set the XML definition of the parameter
Public property XmlNodeHandler
Property used by MADCAT to get the XML handler of the parameter

See Also

IParameter Interface
Parameters Namespace


ContextMenu Property

[image]

MADCAT Software Developer Guide
IParameter..::..ContextMenu Property
IParameter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get the context menu of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
ContextMenuStrip ContextMenu { get; }
Visual Basic
ReadOnly Property ContextMenu As ContextMenuStrip
    Get
Visual C++
property ContextMenuStrip^ ContextMenu {
    ContextMenuStrip^ get ();
}

See Also

IParameter Interface
IParameter Members
Parameters Namespace


Description Property

[image]

MADCAT Software Developer Guide
IParameter..::..Description Property
IParameter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the description of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
string Description { get; set; }
Visual Basic
Property Description As String
    Get
    Set
Visual C++
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

IParameter Interface
IParameter Members
Parameters Namespace


DisplayOnly Property

[image]

MADCAT Software Developer Guide
IParameter..::..DisplayOnly Property
IParameter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to set the access mode of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
bool DisplayOnly { get; set; }
Visual Basic
Property DisplayOnly As Boolean
    Get
    Set
Visual C++
property bool DisplayOnly {
    bool get ();
    void set (bool value);
}

See Also

IParameter Interface
IParameter Members
Parameters Namespace


DrawHandler Property

[image]

MADCAT Software Developer Guide
IParameter..::..DrawHandler Property
IParameter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get the Bitmap handler of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
BitmapHandler DrawHandler { get; }
Visual Basic
ReadOnly Property DrawHandler As BitmapHandler
    Get
Visual C++
property BitmapHandler^ DrawHandler {
    BitmapHandler^ get ();
}

See Also

IParameter Interface
IParameter Members
Parameters Namespace


FormControl Property

[image]

MADCAT Software Developer Guide
IParameter..::..FormControl Property
IParameter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get Form Control of the parameter. The Form Control shall take into account dynamically the values provided by MADCAT through the following properties :
  • IsMandatory
  • DisplayOnly
  • UserSettings
  • Options
  • Value

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
Control FormControl { get; }
Visual Basic
ReadOnly Property FormControl As Control
    Get
Visual C++
property Control^ FormControl {
    Control^ get ();
}

See Also

IParameter Interface
IParameter Members
Parameters Namespace


HasChanged Property

[image]

MADCAT Software Developer Guide
IParameter..::..HasChanged Property
IParameter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to check if the parameter has changed

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
bool HasChanged { get; }
Visual Basic
ReadOnly Property HasChanged As Boolean
    Get
Visual C++
property bool HasChanged {
    bool get ();
}

See Also

IParameter Interface
IParameter Members
Parameters Namespace


Hint Property

[image]

MADCAT Software Developer Guide
IParameter..::..Hint Property
IParameter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the tip of the parameter. The tip contains a short help which popups when the user moves his mouse cursor over the parameter's name

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
string Hint { get; set; }
Visual Basic
Property Hint As String
    Get
    Set
Visual C++
property String^ Hint {
    String^ get ();
    void set (String^ value);
}

See Also

IParameter Interface
IParameter Members
Parameters Namespace


IsMandatory Property

[image]

MADCAT Software Developer Guide
IParameter..::..IsMandatory Property
IParameter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to indicate if the parameter is mandatory or not. When mandatory, the user must give a value to the parameter to continue his current operation.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
bool IsMandatory { get; set; }
Visual Basic
Property IsMandatory As Boolean
    Get
    Set
Visual C++
property bool IsMandatory {
    bool get ();
    void set (bool value);
}

See Also

IParameter Interface
IParameter Members
Parameters Namespace


IsUndefined Property

[image]

MADCAT Software Developer Guide
IParameter..::..IsUndefined Property
IParameter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to check if the parameter has been set by the user or not

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
bool IsUndefined { get; }
Visual Basic
ReadOnly Property IsUndefined As Boolean
    Get
Visual C++
property bool IsUndefined {
    bool get ();
}

See Also

IParameter Interface
IParameter Members
Parameters Namespace


Name Property

[image]

MADCAT Software Developer Guide
IParameter..::..Name Property
IParameter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the name of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
string Name { get; set; }
Visual Basic
Property Name As String
    Get
    Set
Visual C++
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

IParameter Interface
IParameter Members
Parameters Namespace


Options Property

[image]

MADCAT Software Developer Guide
IParameter..::..Options Property
IParameter Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the options of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
Hashtable Options { get; set; }
Visual Basic
Property Options As Hashtable
    Get
    Set
Visual C++
property Hashtable^ Options {
    Hashtable^ get ();
    void set (Hashtable^ value);
}

Examples

This example shows how to use this property to change the options of a numeric parameter
CopyC++
NumericInput ^refreshRate = gcnew NumericInput();
refreshRate->Name = L"RATE";
refreshRate->Description = L"Refresh rate (sec)";
refreshRate->Hint = L"Set the period in seconds";

Hashtable ^opts = gcnew Hashtable();
opts[L"showas"] = L"button";
opts[L"mini"] = L"1";
opts[L"maxi"] = L"60";
opts[L"step"] = L"1";
refreshRate->Options = opts;

Control ^ctrl = refreshRate->FormControl;

See Also

IParameter Interface
IParameter Members
Parameters Namespace


TextHandler Property

[image]

MADCAT Software Developer Guide
IParameter..::..TextHandler Property
IParameter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get the String handler of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
StringHandler TextHandler { get; }
Visual Basic
ReadOnly Property TextHandler As StringHandler
    Get
Visual C++
property StringHandler^ TextHandler {
    StringHandler^ get ();
}

See Also

IParameter Interface
IParameter Members
Parameters Namespace


Tip Property

[image]

MADCAT Software Developer Guide
IParameter..::..Tip Property
IParameter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the ToolTip object for the Form Control of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
ToolTip Tip { get; set; }
Visual Basic
Property Tip As ToolTip
    Get
    Set
Visual C++
property ToolTip^ Tip {
    ToolTip^ get ();
    void set (ToolTip^ value);
}

See Also

IParameter Interface
IParameter Members
Parameters Namespace


Type Property

[image]

MADCAT Software Developer Guide
IParameter..::..Type Property
IParameter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get the core type of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
DataToolTypes Type { get; }
Visual Basic
ReadOnly Property Type As DataToolTypes
    Get
Visual C++
property DataToolTypes Type {
    DataToolTypes get ();
}

See Also

IParameter Interface
IParameter Members
Parameters Namespace


TypeName Property

[image]

MADCAT Software Developer Guide
IParameter..::..TypeName Property
IParameter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get the core type's name of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
string TypeName { get; }
Visual Basic
ReadOnly Property TypeName As String
    Get
Visual C++
property String^ TypeName {
    String^ get ();
}

See Also

IParameter Interface
IParameter Members
Parameters Namespace


UserSettings Property

[image]

MADCAT Software Developer Guide
IParameter..::..UserSettings Property
IParameter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the user settings of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
Object UserSettings { get; set; }
Visual Basic
Property UserSettings As Object
    Get
    Set
Visual C++
property Object^ UserSettings {
    Object^ get ();
    void set (Object^ value);
}

See Also

IParameter Interface
IParameter Members
Parameters Namespace


Value Property

[image]

MADCAT Software Developer Guide
IParameter..::..Value Property
IParameter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the value of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
string Value { get; set; }
Visual Basic
Property Value As String
    Get
    Set
Visual C++
property String^ Value {
    String^ get ();
    void set (String^ value);
}

See Also

IParameter Interface
IParameter Members
Parameters Namespace


XmlDefinition Property

[image]

MADCAT Software Developer Guide
IParameter..::..XmlDefinition Property
IParameter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the XML definition of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
XmlNode XmlDefinition { get; set; }
Visual Basic
Property XmlDefinition As XmlNode
    Get
    Set
Visual C++
property XmlNode^ XmlDefinition {
    XmlNode^ get ();
    void set (XmlNode^ value);
}

See Also

IParameter Interface
IParameter Members
Parameters Namespace


XmlNodeHandler Property

[image]

MADCAT Software Developer Guide
IParameter..::..XmlNodeHandler Property
IParameter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get the XML handler of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
XmlHandler XmlNodeHandler { get; }
Visual Basic
ReadOnly Property XmlNodeHandler As XmlHandler
    Get
Visual C++
property XmlHandler^ XmlNodeHandler {
    XmlHandler^ get ();
}

See Also

IParameter Interface
IParameter Members
Parameters Namespace


IParameter Events

[image] [image]

MADCAT Software Developer Guide
IParameter Events
IParameter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IParameter type exposes the following members.

Events

 | Name | Description
Public event | ValueChanged | Fired when the value of the parameter changes because of an user action (not fired when Value property is set)

See Also

IParameter Interface
Parameters Namespace


ValueChanged Event

[image]

MADCAT Software Developer Guide
IParameter..::..ValueChanged Event
IParameter Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Fired when the value of the parameter changes because of an user action (not fired when Value property is set)

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
event ParameterValueChangedEventHandler ValueChanged
Visual Basic
Event ValueChanged As ParameterValueChangedEventHandler
Visual C++
 event ParameterValueChangedEventHandler^ ValueChanged {
    void add (ParameterValueChangedEventHandler^ value);
    void remove (ParameterValueChangedEventHandler^ value);
}

See Also

IParameter Interface
IParameter Members
Parameters Namespace


IPlottingServices Interface

[image]

MADCAT Software Developer Guide
IPlottingServices Interface
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Interface for plotting services of the parameters. Parameters which can be plotted in charts (graphical series) shall expose this interface to provide conversion methods between parameter's values and global float coordinates.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public interface IPlottingServices
Visual Basic
Public Interface IPlottingServices
Visual C++
public interface class IPlottingServices

See Also

IPlottingServices Members
Parameters Namespace


IPlottingServices Members

[image] [image]

MADCAT Software Developer Guide
IPlottingServices Members
IPlottingServices Interface Methods Properties See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IPlottingServices type exposes the following members.

Methods

 | Name | Description
Public method | GetDistance | This method computes the distance between two different values. Values are provided with strings. Distance is a float value.
Public method | GetNextValue(String, Single) | This method computes the value expressed in the parameter's string format located at a certain distance of a given value.
Public method | GetNextValue(String, Single, Int32) | This method computes the value expressed in the parameter's string format located at a certain distance of a given value. The precision controls the format of the output value. For example, in case of a Date/Time parameter, precision can be : Days, Months, Years or Hours, Minutes, Seconds.
Public method | GetZero | The method returns the official 'zero' value for the parameter. The 'zero' is the value located on the axis of the charts.

Properties

 | Name | Description
Public property | DataType | Property used to get the core type of the parameter

See Also

IPlottingServices Interface
Parameters Namespace


IPlottingServices Methods

[image] [image]

MADCAT Software Developer Guide
IPlottingServices Methods
IPlottingServices Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IPlottingServices type exposes the following members.

Methods

 | Name | Description
Public method | GetDistance | This method computes the distance between two different values. Values are provided with strings. Distance is a float value.
Public method | GetNextValue(String, Single) | This method computes the value expressed in the parameter's string format located at a certain distance of a given value.
Public method | GetNextValue(String, Single, Int32) | This method computes the value expressed in the parameter's string format located at a certain distance of a given value. The precision controls the format of the output value. For example, in case of a Date/Time parameter, precision can be : Days, Months, Years or Hours, Minutes, Seconds.
Public method | GetZero | The method returns the official 'zero' value for the parameter. The 'zero' is the value located on the axis of the charts.

See Also

IPlottingServices Interface
Parameters Namespace


GetDistance Method

[image]

MADCAT Software Developer Guide
IPlottingServices..::..GetDistance Method
IPlottingServices Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This method computes the distance between two different values. Values are provided with strings. Distance is a float value.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
float GetDistance(
    string v1,
    string v2
)
Visual Basic
Function GetDistance ( _
    v1 As String, _
    v2 As String _
) As Single
Visual C++
float GetDistance(
    String^ v1,
    String^ v2
)

Parameters

v1
Type: System..::..String
First value expressed in the parameter's string format
v2
Type: System..::..String
Second value expressed in the parameter's string format

Return Value

Float value which is the distance expressed with no specific unit.

See Also

IPlottingServices Interface
IPlottingServices Members
Parameters Namespace


GetNextValue Method

[image] [image]

MADCAT Software Developer Guide
IPlottingServices..::..GetNextValue Method
IPlottingServices Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | GetNextValue(String, Single) | This method computes the value expressed in the parameter's string format located at a certain distance of a given value.
Public method | GetNextValue(String, Single, Int32) | This method computes the value expressed in the parameter's string format located at a certain distance of a given value. The precision controls the format of the output value. For example, in case of a Date/Time parameter, precision can be : Days, Months, Years or Hours, Minutes, Seconds.

See Also

IPlottingServices Interface
IPlottingServices Members
Parameters Namespace


GetNextValue Method (String, Single)

[image]

MADCAT Software Developer Guide
IPlottingServices..::..GetNextValue Method (String, Single)
IPlottingServices Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This method computes the value expressed in the parameter's string format located at a certain distance of a given value.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
string GetNextValue(
    string orig,
    float distance
)
Visual Basic
Function GetNextValue ( _
    orig As String, _
    distance As Single _
) As String
Visual C++
String^ GetNextValue(
    String^ orig,
    float distance
)

Parameters

orig
Type: System..::..String
Value of the origin of the computation expressed in the parameter's string format
distance
Type: System..::..Single
Distance expressed in float value.

Return Value

The value located at the specified distance of the 'orig' value. The returned value and the 'orig' value shall return the same distance value with the method GetDistance(String, String).

See Also

IPlottingServices Interface
IPlottingServices Members
GetNextValue Overload
Parameters Namespace


GetNextValue Method (String, Single, Int32)

[image]

MADCAT Software Developer Guide
IPlottingServices..::..GetNextValue Method (String, Single, Int32)
IPlottingServices Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This method computes the value expressed in the parameter's string format located at a certain distance of a given value. The precision controls the format of the output value. For example, in case of a Date/Time parameter, precision can be : Days, Months, Years or Hours, Minutes, Seconds.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
string GetNextValue(
    string orig,
    float distance,
    int precision
)
Visual Basic
Function GetNextValue ( _
    orig As String, _
    distance As Single, _
    precision As Integer _
) As String
Visual C++
String^ GetNextValue(
    String^ orig,
    float distance,
    int precision
)

Parameters

orig
Type: System..::..String
Value of the origin of the computation expressed in the parameter's string format
distance
Type: System..::..Single
Distance expressed in float value.
precision
Type: System..::..Int32
Precision of the output value. Positive value starting from zero. 0 is the lowest precision. Precision values depends on the parameter. For Numeric parameter, precisions are in range [0:4]. For Date/Time parameter, precisions are in range [0:5]. Giving an unknown precision value will return a raw value (i.e. maximum precision with no format).

Return Value

The value located at the specified distance of the 'orig' value. The returned value and the 'orig' value may not return the same distance value as the method GetDistance(String, String) (it depends on the precision used).

See Also

IPlottingServices Interface
IPlottingServices Members
GetNextValue Overload
Parameters Namespace


GetZero Method

[image]

MADCAT Software Developer Guide
IPlottingServices..::..GetZero Method
IPlottingServices Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
The method returns the official 'zero' value for the parameter. The 'zero' is the value located on the axis of the charts.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
string GetZero()
Visual Basic
Function GetZero As String
Visual C++
String^ GetZero()

Return Value

String with the 'zero' value for the parameter.

See Also

IPlottingServices Interface
IPlottingServices Members
Parameters Namespace


IPlottingServices Properties

[image] [image]

MADCAT Software Developer Guide
IPlottingServices Properties
IPlottingServices Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IPlottingServices type exposes the following members.

Properties

 | Name | Description
Public property | DataType | Property used to get the core type of the parameter

See Also

IPlottingServices Interface
Parameters Namespace


DataType Property

[image]

MADCAT Software Developer Guide
IPlottingServices..::..DataType Property
IPlottingServices Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used to get the core type of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
DataToolTypes DataType { get; }
Visual Basic
ReadOnly Property DataType As DataToolTypes
    Get
Visual C++
property DataToolTypes DataType {
    DataToolTypes get ();
}

See Also

IPlottingServices Interface
IPlottingServices Members
Parameters Namespace


LedColors Enumeration

[image]

MADCAT Software Developer Guide
LedColors Enumeration
See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Available colors for the led of the Boolean Input

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public enum LedColors
Visual Basic
Public Enumeration LedColors
Visual C++
public enum class LedColors

Members

Member name | Value | Description
Green | 2 | Green led
Yellow | 1 | Yellow led
Red | 0 | Red led

See Also

Parameters Namespace


NumericButtonCursor Enumeration

[image]

MADCAT Software Developer Guide
NumericButtonCursor Enumeration
See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Types of cursors to point the value of the button for numeric parameters

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
[SerializableAttribute]
public enum NumericButtonCursor
Visual Basic
<SerializableAttribute> _
Public Enumeration NumericButtonCursor
Visual C++
[SerializableAttribute]
public enum class NumericButtonCursor

Members

Member name | Value | Description
Switch | 1 | Switch over the button
Dot | 0 | Dot on the button

See Also

Parameters Namespace


NumericButtonType Enumeration

[image]

MADCAT Software Developer Guide
NumericButtonType Enumeration
See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Types of button for numeric parameters

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
[SerializableAttribute]
public enum NumericButtonType
Visual Basic
<SerializableAttribute> _
Public Enumeration NumericButtonType
Visual C++
[SerializableAttribute]
public enum class NumericButtonType

Members

Member name | Value | Description
Normal | 0 | Normal grey button
Metal | 1 | Metal button

See Also

Parameters Namespace


NumericDisplay Enumeration

[image]

MADCAT Software Developer Guide
NumericDisplay Enumeration
See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Display modes for numeric parameters

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
[SerializableAttribute]
public enum NumericDisplay
Visual Basic
<SerializableAttribute> _
Public Enumeration NumericDisplay
Visual C++
[SerializableAttribute]
public enum class NumericDisplay

Members

Member name | Value | Description
Button | 3 | Number is entered using a rotary button. Works only when min and max values exist.
Field | 0 | Number is entered with a normal textbox
Hexadecimal | 2 | Number is entered using the hexadecimal format '0x....'. Value is entered with a textbox.
Gauge | 4 | Number is entered using a gauge. Works only when min and max values exist.
Slider | 1 | Number is entered using a sliding control. Works only when min and max values exist.

See Also

Parameters Namespace


NumericFilter Class

[image]

MADCAT Software Developer Guide
NumericFilter Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Class used to filter items on numeric parameters

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public class NumericFilter : IFilter
Visual Basic
Public Class NumericFilter _
    Implements IFilter
Visual C++
public ref class NumericFilter : IFilter

Inheritance Hierarchy

System..::..Object
Parameters..::..NumericFilter

See Also

NumericFilter Members
Parameters Namespace


NumericFilter Members

[image] [image]

MADCAT Software Developer Guide
NumericFilter Members
NumericFilter Class Constructors Methods Properties See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The NumericFilter type exposes the following members.

Constructors

 | Name | Description
Public method | NumericFilter | Constructor

Methods

 | Name | Description
Public method | GetTypeOptions | Invoked by MADCAT to get the type options
Public method | IsMatch | Invoked by MADCAT to check if a given string matches filter's properties
Public method | SetRange | Sets the range used by the filter to accept/reject items by changing both RangeStart and RangeEnd properties.

Properties

 | Name | Description
Public property | Args | Invoked by MADCAT to get or set the properties of the filter. Can be safely casted to NumericFilterArgs object. See NumericFilterArgs.
Public property | Exclusive | Gets/sets the filter to exclusive mode. If true, values which are not in the range [RangeStart:RangeEnd] will be accepted by the filter.
Public property | Form | Invoked by MADCAT to get the Windows form which is used to set the filter properties. See NumericFilterForm.
Public property | IsActive | Invoked by MADCAT to detect if the filter is active
Public property | Maximum | Gets/sets the absolute maximum value the parameters can have
Public property | Minimum | Gets/sets the absolute minimum value the parameters can have
Public property | Step | Gets/sets the minimum gap between 2 different parameters' values
Public property | Type | Invoked by MADCAT to the core type of the filter
Public property | WithBounds | Accepts/Denies the range boundaries in the filter. If true, values which are equal to RangeStart or RangeEnd will be accepted by the filter.
Public property | XPathCondition | Not used for Numeric filters. Always null.

See Also

NumericFilter Class
Parameters Namespace


NumericFilter Constructor

[image]

MADCAT Software Developer Guide
NumericFilter Constructor
NumericFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public NumericFilter(
    DataToolTypes type
)
Visual Basic
Public Sub New ( _
    type As DataToolTypes _
)
Visual C++
public:
NumericFilter(
    DataToolTypes type
)

Parameters

type
Type: Parameters..::..DataToolTypes
Sets the base type of the filter. Shall be CMN_Numeric.

See Also

NumericFilter Class
NumericFilter Members
Parameters Namespace


NumericFilter Methods

[image] [image]

MADCAT Software Developer Guide
NumericFilter Methods
NumericFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The NumericFilter type exposes the following members.

Methods

 | Name | Description
Public method | GetTypeOptions | Invoked by MADCAT to get the type options
Public method | IsMatch | Invoked by MADCAT to check if a given string matches filter's properties
Public method | SetRange | Sets the range used by the filter to accept/reject items by changing both RangeStart and RangeEnd properties.

See Also

NumericFilter Class
Parameters Namespace


GetTypeOptions Method

[image]

MADCAT Software Developer Guide
NumericFilter..::..GetTypeOptions Method
NumericFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Invoked by MADCAT to get the type options

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual void GetTypeOptions(
    Hashtable opt
)
Visual Basic
Public Overridable Sub GetTypeOptions ( _
    opt As Hashtable _
)
Visual C++
public:
virtual void GetTypeOptions(
    Hashtable^ opt
)

Parameters

opt
Type: System.Collections..::..Hashtable
Hashtable which shall be filled by the filter with the type options (key=option name, value=value of the option)

Implements

IFilter..::..GetTypeOptions(Hashtable)

See Also

NumericFilter Class
NumericFilter Members
Parameters Namespace


IsMatch Method

[image]

MADCAT Software Developer Guide
NumericFilter..::..IsMatch Method
NumericFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Invoked by MADCAT to check if a given string matches filter's properties

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual bool IsMatch(
    string value
)
Visual Basic
Public Overridable Function IsMatch ( _
    value As String _
) As Boolean
Visual C++
public:
virtual bool IsMatch(
    String^ value
)

Parameters

value
Type: System..::..String
A value of a parameter exposing the filter

Return Value

True means the item should be displayed because the value matches the filter's criterias

Implements

IFilter..::..IsMatch(String)

See Also

NumericFilter Class
NumericFilter Members
Parameters Namespace


SetRange Method

[image]

MADCAT Software Developer Guide
NumericFilter..::..SetRange Method
NumericFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Sets the range used by the filter to accept/reject items by changing both RangeStart and RangeEnd properties.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public void SetRange(
    decimal start,
    decimal end
)
Visual Basic
Public Sub SetRange ( _
    start As Decimal, _
    end As Decimal _
)
Visual C++
public:
void SetRange(
    Decimal start,
    Decimal end
)

Parameters

start
Type: System..::..Decimal
Value for RangeStart
end
Type: System..::..Decimal
Value for RangeEnd

See Also

NumericFilter Class
NumericFilter Members
Parameters Namespace


NumericFilter Properties

[image] [image]

MADCAT Software Developer Guide
NumericFilter Properties
NumericFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The NumericFilter type exposes the following members.

Properties

 | Name | Description
Public property | Args | Invoked by MADCAT to get or set the properties of the filter. Can be safely casted to NumericFilterArgs object. See NumericFilterArgs.
Public property | Exclusive | Gets/sets the filter to exclusive mode. If true, values which are not in the range [RangeStart:RangeEnd] will be accepted by the filter.
Public property | Form | Invoked by MADCAT to get the Windows form which is used to set the filter properties. See NumericFilterForm.
Public property | IsActive | Invoked by MADCAT to detect if the filter is active
Public property | Maximum | Gets/sets the absolute maximum value the parameters can have
Public property | Minimum | Gets/sets the absolute minimum value the parameters can have
Public property | Step | Gets/sets the minimum gap between 2 different parameters' values
Public property | Type | Invoked by MADCAT to the core type of the filter
Public property | WithBounds | Accepts/Denies the range boundaries in the filter. If true, values which are equal to RangeStart or RangeEnd will be accepted by the filter.
Public property | XPathCondition | Not used for Numeric filters. Always null.

See Also

NumericFilter Class
Parameters Namespace


Args Property

[image]

MADCAT Software Developer Guide
NumericFilter..::..Args Property
NumericFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Invoked by MADCAT to get or set the properties of the filter. Can be safely casted to NumericFilterArgs object. See NumericFilterArgs.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual Object Args { get; set; }
Visual Basic
Public Overridable Property Args As Object
    Get
    Set
Visual C++
public:
virtual property Object^ Args {
    Object^ get ();
    void set (Object^ value);
}

Implements

IFilter..::..Args

See Also

NumericFilter Class
NumericFilter Members
Parameters Namespace


Exclusive Property

[image]

MADCAT Software Developer Guide
NumericFilter..::..Exclusive Property
NumericFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/sets the filter to exclusive mode. If true, values which are not in the range [RangeStart:RangeEnd] will be accepted by the filter.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public bool Exclusive { get; set; }
Visual Basic
Public Property Exclusive As Boolean
    Get
    Set
Visual C++
public:
property bool Exclusive {
    bool get ();
    void set (bool value);
}

See Also

NumericFilter Class
NumericFilter Members
Parameters Namespace


Form Property

[image]

MADCAT Software Developer Guide
NumericFilter..::..Form Property
NumericFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Invoked by MADCAT to get the Windows form which is used to set the filter properties. See NumericFilterForm.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual Control Form { get; }
Visual Basic
Public Overridable ReadOnly Property Form As Control
    Get
Visual C++
public:
virtual property Control^ Form {
    Control^ get ();
}

Implements

IFilter..::..Form

See Also

NumericFilter Class
NumericFilter Members
Parameters Namespace


IsActive Property

[image]

MADCAT Software Developer Guide
NumericFilter..::..IsActive Property
NumericFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Invoked by MADCAT to detect if the filter is active

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual bool IsActive { get; }
Visual Basic
Public Overridable ReadOnly Property IsActive As Boolean
    Get
Visual C++
public:
virtual property bool IsActive {
    bool get ();
}

Implements

IFilter..::..IsActive

See Also

NumericFilter Class
NumericFilter Members
Parameters Namespace


Maximum Property

[image]

MADCAT Software Developer Guide
NumericFilter..::..Maximum Property
NumericFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/sets the absolute maximum value the parameters can have

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public decimal Maximum { get; set; }
Visual Basic
Public Property Maximum As Decimal
    Get
    Set
Visual C++
public:
property Decimal Maximum {
    Decimal get ();
    void set (Decimal value);
}

See Also

NumericFilter Class
NumericFilter Members
Parameters Namespace


Minimum Property

[image]

MADCAT Software Developer Guide
NumericFilter..::..Minimum Property
NumericFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/sets the absolute minimum value the parameters can have

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public decimal Minimum { get; set; }
Visual Basic
Public Property Minimum As Decimal
    Get
    Set
Visual C++
public:
property Decimal Minimum {
    Decimal get ();
    void set (Decimal value);
}

See Also

NumericFilter Class
NumericFilter Members
Parameters Namespace


Step Property

[image]

MADCAT Software Developer Guide
NumericFilter..::..Step Property
NumericFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/sets the minimum gap between 2 different parameters' values

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public decimal Step { get; set; }
Visual Basic
Public Property Step As Decimal
    Get
    Set
Visual C++
public:
property Decimal Step {
    Decimal get ();
    void set (Decimal value);
}

See Also

NumericFilter Class
NumericFilter Members
Parameters Namespace


Type Property

[image]

MADCAT Software Developer Guide
NumericFilter..::..Type Property
NumericFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Invoked by MADCAT to the core type of the filter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual DataToolTypes Type { get; }
Visual Basic
Public Overridable ReadOnly Property Type As DataToolTypes
    Get
Visual C++
public:
virtual property DataToolTypes Type {
    DataToolTypes get ();
}

Implements

IFilter..::..Type

See Also

NumericFilter Class
NumericFilter Members
Parameters Namespace


WithBounds Property

[image]

MADCAT Software Developer Guide
NumericFilter..::..WithBounds Property
NumericFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Accepts/Denies the range boundaries in the filter. If true, values which are equal to RangeStart or RangeEnd will be accepted by the filter.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public bool WithBounds { get; set; }
Visual Basic
Public Property WithBounds As Boolean
    Get
    Set
Visual C++
public:
property bool WithBounds {
    bool get ();
    void set (bool value);
}

See Also

NumericFilter Class
NumericFilter Members
Parameters Namespace


XPathCondition Property

[image]

MADCAT Software Developer Guide
NumericFilter..::..XPathCondition Property
NumericFilter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Not used for Numeric filters. Always null.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual string XPathCondition { get; }
Visual Basic
Public Overridable ReadOnly Property XPathCondition As String
    Get
Visual C++
public:
virtual property String^ XPathCondition {
    String^ get ();
}

Implements

IFilter..::..XPathCondition

See Also

NumericFilter Class
NumericFilter Members
Parameters Namespace


NumericFilterArgs Class

[image]

MADCAT Software Developer Guide
NumericFilterArgs Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Arguments for the NumericFilter objects

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
[SerializableAttribute]
public class NumericFilterArgs
Visual Basic
<SerializableAttribute> _
Public Class NumericFilterArgs
Visual C++
[SerializableAttribute]
public ref class NumericFilterArgs

Inheritance Hierarchy

System..::..Object
Parameters..::..NumericFilterArgs

See Also

NumericFilterArgs Members
Parameters Namespace


NumericFilterArgs Members

[image] [image]

MADCAT Software Developer Guide
NumericFilterArgs Members
NumericFilterArgs Class Constructors Fields See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The NumericFilterArgs type exposes the following members.

Constructors

 | Name | Description
Public method | NumericFilterArgs | Constructor

Fields

 | Name | Description
Public field | Maximum | Maximum value which can be taken by the values
Public field | Minimum | Minimum value which can be taken by the values
Public field | Mode | Mode of the filter
Public field | RangeEnd | Higher boundary of the filter's range
Public field | RangeStart | Lower boundary of the filter's range
Public field | Step | Minimum gap between two values
Public field | WithBounds | Flag indicating if boundaries are accepted (=true) or rejected (=false) by the filter.

See Also

NumericFilterArgs Class
Parameters Namespace


NumericFilterArgs Constructor

[image]

MADCAT Software Developer Guide
NumericFilterArgs Constructor
NumericFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public NumericFilterArgs()
Visual Basic
Public Sub New
Visual C++
public:
NumericFilterArgs()

See Also

NumericFilterArgs Class
NumericFilterArgs Members
Parameters Namespace


NumericFilterArgs Fields

[image] [image]

MADCAT Software Developer Guide
NumericFilterArgs Fields
NumericFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The NumericFilterArgs type exposes the following members.

Fields

 | Name | Description
Public field | Maximum | Maximum value which can be taken by the values
Public field | Minimum | Minimum value which can be taken by the values
Public field | Mode | Mode of the filter
Public field | RangeEnd | Higher boundary of the filter's range
Public field | RangeStart | Lower boundary of the filter's range
Public field | Step | Minimum gap between two values
Public field | WithBounds | Flag indicating if boundaries are accepted (=true) or rejected (=false) by the filter.

See Also

NumericFilterArgs Class
Parameters Namespace


Maximum Field

[image]

MADCAT Software Developer Guide
NumericFilterArgs..::..Maximum Field
NumericFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Maximum value which can be taken by the values

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public decimal Maximum
Visual Basic
Public Maximum As Decimal
Visual C++
public:
Decimal Maximum

See Also

NumericFilterArgs Class
NumericFilterArgs Members
Parameters Namespace


Minimum Field

[image]

MADCAT Software Developer Guide
NumericFilterArgs..::..Minimum Field
NumericFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Minimum value which can be taken by the values

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public decimal Minimum
Visual Basic
Public Minimum As Decimal
Visual C++
public:
Decimal Minimum

See Also

NumericFilterArgs Class
NumericFilterArgs Members
Parameters Namespace


Mode Field

[image]

MADCAT Software Developer Guide
NumericFilterArgs..::..Mode Field
NumericFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Mode of the filter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public NumericFilterMode Mode
Visual Basic
Public Mode As NumericFilterMode
Visual C++
public:
NumericFilterMode Mode

See Also

NumericFilterArgs Class
NumericFilterArgs Members
Parameters Namespace


RangeEnd Field

[image]

MADCAT Software Developer Guide
NumericFilterArgs..::..RangeEnd Field
NumericFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Higher boundary of the filter's range

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public decimal RangeEnd
Visual Basic
Public RangeEnd As Decimal
Visual C++
public:
Decimal RangeEnd

See Also

NumericFilterArgs Class
NumericFilterArgs Members
Parameters Namespace


RangeStart Field

[image]

MADCAT Software Developer Guide
NumericFilterArgs..::..RangeStart Field
NumericFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Lower boundary of the filter's range

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public decimal RangeStart
Visual Basic
Public RangeStart As Decimal
Visual C++
public:
Decimal RangeStart

See Also

NumericFilterArgs Class
NumericFilterArgs Members
Parameters Namespace


Step Field

[image]

MADCAT Software Developer Guide
NumericFilterArgs..::..Step Field
NumericFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Minimum gap between two values

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public decimal Step
Visual Basic
Public Step As Decimal
Visual C++
public:
Decimal Step

See Also

NumericFilterArgs Class
NumericFilterArgs Members
Parameters Namespace


WithBounds Field

[image]

MADCAT Software Developer Guide
NumericFilterArgs..::..WithBounds Field
NumericFilterArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Flag indicating if boundaries are accepted (=true) or rejected (=false) by the filter.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public bool WithBounds
Visual Basic
Public WithBounds As Boolean
Visual C++
public:
bool WithBounds

See Also

NumericFilterArgs Class
NumericFilterArgs Members
Parameters Namespace


NumericFilterForm Class

[image]

MADCAT Software Developer Guide
NumericFilterForm Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Form used to edit the Numeric Filter's arguments. See NumericFilterArgs.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public class NumericFilterForm : Form
Visual Basic
Public Class NumericFilterForm _
    Inherits Form
Visual C++
public ref class NumericFilterForm : public Form

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
Parameters..::..NumericFilterForm

See Also

NumericFilterForm Members
Parameters Namespace


NumericFilterForm Members

[image] [image]

MADCAT Software Developer Guide
NumericFilterForm Members
NumericFilterForm Class Constructors See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The NumericFilterForm type exposes the following members.

Constructors

 | Name | Description
Public method | NumericFilterForm | Constructor

See Also

NumericFilterForm Class
Parameters Namespace


NumericFilterForm Constructor

[image]

MADCAT Software Developer Guide
NumericFilterForm Constructor
NumericFilterForm Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public NumericFilterForm(
    NumericFilterArgs filter
)
Visual Basic
Public Sub New ( _
    filter As NumericFilterArgs _
)
Visual C++
public:
NumericFilterForm(
    NumericFilterArgs^ filter
)

Parameters

filter
Type: Parameters..::..NumericFilterArgs
Arguments of the filter

See Also

NumericFilterForm Class
NumericFilterForm Members
Parameters Namespace


NumericFilterMode Enumeration

[image]

MADCAT Software Developer Guide
NumericFilterMode Enumeration
See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Modes of the filter for numeric values

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
[SerializableAttribute]
public enum NumericFilterMode
Visual Basic
<SerializableAttribute> _
Public Enumeration NumericFilterMode
Visual C++
[SerializableAttribute]
public enum class NumericFilterMode

Members

Member name | Value | Description
LessThan | 3 | Filter accepts all values lower than RangeStart
GreaterThan | 2 | Filter accepts all values greater than RangeStart
Exclusive | 1 | Filter accepts all values lower than RangeStart or greater than RangeEnd
Inclusive | 0 | Filter accepts all values between RangeStart and RangeEnd.
Deactivated | 4 | Filter accepts all values

See Also

Parameters Namespace


NumericInput Class

[image]

MADCAT Software Developer Guide
NumericInput Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Class used to manage numeric values in MADCAT. Numeric values may be integers or floats

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public class NumericInput : BaseParameter
Visual Basic
Public Class NumericInput _
    Inherits BaseParameter
Visual C++
public ref class NumericInput : public BaseParameter

Inheritance Hierarchy

System..::..Object
Parameters..::..BaseParameter
Parameters..::..NumericInput

See Also

NumericInput Members
Parameters Namespace


NumericInput Members

[image] [image]

MADCAT Software Developer Guide
NumericInput Members
NumericInput Class Constructors Methods Fields Properties Events See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The NumericInput type exposes the following members.

Constructors

 | Name | Description
Public method | NumericInput | Constructor of the parameter

Methods

 | Name | Description
Public method | BuildHTMLString | Gives the HTML code used to render the input field in HTML instead of Windows form control (Inherited from BaseParameter.)
Public method | BuildLabel | Gives the Windows Form control for the label of the input field of the parameter (Inherited from BaseParameter.)
Public method | Clone | Clones the parameter object into a new parameter object (Overrides BaseParameter..::..Clone()()()().)
Public method | RestoreValueFromItem | Gets the value of the parameter from a given project's Item (Overrides BaseParameter..::..RestoreValueFromItem(XmlNode).)
Public method | SaveValueInItem | Saves the value of the parameter into a given project's Item (Inherited from BaseParameter.)

Fields

Name | Description
FormatInfo | Definition of the format used for the numeric value of the parameter

Properties

Name Description
Public property ButtonCursor
Gets/Sets the type of the cursor of the button.
Public property ButtonDisplayType
Gets/Sets the display style of the button.
Public property ContextMenu
Property used by MADCAT to get the context menu of the parameter
(Inherited from BaseParameter.)
Public property Description
Property used by MADCAT to get/set the description of the parameter
(Inherited from BaseParameter.)
Public property Display
Gets/Sets the display style of the numeric value. This controls the way the number is displayed on screen.
Public property DisplayOnly
Property used by MADCAT to set the access mode of the parameter
(Overrides BaseParameter..::..DisplayOnly.)
Public property DrawHandler
Property used by MADCAT to get the Bitmap handler of the parameter
(Overrides BaseParameter..::..DrawHandler.)
Public property FormControl
Gets the control corresponding to the display options set with the Options property.
(Overrides BaseParameter..::..FormControl.)
Public property GaugeCursorVisible
Shows/Hides the cursor of the gauge.
Public property GaugeDisplayType
Gets/Sets the display style of the gauge.
Public property GaugeHeight
Height of the gauge in pixel
Public property GaugeOrientation
Orientation of the gauge.
Public property GaugeRedZone
Gets/sets the gauge red zone (values over this threshold are highlighted)
Public property GradientColors
Gets/Sets the list of colors of the gradient used for the linear gauge. Colors are coded in HTML and are separated by a pipe '|'.
Public property HasChanged
Property used by MADCAT to check if the parameter has changed
(Inherited from BaseParameter.)
Public property Hint
Property used by MADCAT to get/set the tip of the parameter. The tip contains a short help which popups when the user moves his mouse cursor over the parameter's name
(Inherited from BaseParameter.)
Public property IsMandatory
Property used by MADCAT to indicate if the parameter is mandatory or not. When mandatory, the user must give a value to the parameter to continue his current operation.
(Inherited from BaseParameter.)
Public property IsUndefined
Property used by MADCAT to check if the parameter has been set by the user or not
(Inherited from BaseParameter.)
Public property MaxNumberOfChars
Gets/sets the maximum number of characters of the parameter's value
(Inherited from BaseParameter.)
Public property MaxValue
Gets/Sets the maximum value of the numeric parameter
Public property MinValue
Gets/Sets the minimum value of the numeric parameter
Public property Name
Property used by MADCAT to get/set the name of the parameter
(Inherited from BaseParameter.)
Public property NumberOfLines
Gets/sets the number of lines visible in the text box of the parameter
(Inherited from BaseParameter.)
Public property Options
Sets the options of the numeric parameter. In addition to the common options (Options), numeric parameters have the following ones :
  • showas=xxx : sets the display mode of the numeric value. Where xxx is one of the following modes :
    • slider : Value is set by moving a cursor on a horizontal or vertical bar.
    • hexadecimal : Value is set by editing a text box field. Number is written in hexadecimal format '0x...'
    • button : Value is set by turning a graphic button.
    • metalbutton : Value is set by turning a graphic button. Button has a metallic rendering.
    • gauge : Value is set by clicking on a gauge which can be horizontal or vertical.
    By default, the value is set by editing a classic text box.
  • gaugetype=xxx : When display mode is 'gauge', this option sets the way the gauge is displayed :
    • circular : The gauge is an arc
    • gradientlinear : The gauge is linear and its background is a gradient filled with several colors
    By default, the gauge is linear and is filled with green.
  • withcursor=yes|no : when display mode is 'gauge' and gauge is not circular, indicates if the value shall be marked with a cursor. If it is set to 'no', the value is displayed by the filling of the gauge.
  • orientation=horizontal|vertical : when display mode is 'gauge' and gauge is not circular, this option sets the orientation of the gauge.
  • cursor=dot|switch : when display mode is 'button', this option indicates if the value is marked with a dot or a dedicated switch.
  • mini=xxx : Sets the minimum value authorized by the parameter. xxx is the value. Doesn't work with hexadecimal values.
  • maxi=xxx : Sets the maximum value authorized by the parameter. xxx is the value. Doesn't work with hexadecimal values.
  • step=xxx : Sets the step value of the parameter. xxx is the value. Doesn't work with hexadecimal values. When used, values are incremented or decremented with this step.
  • colors=c1|c2|c3... : When the display mode is 'gauge' and gauge type is 'gradientlinear', sets the gradient colors c1, c2, etc... Colors are written in the HTML format and separated by '|'. Supports 2 or more color codes.
  • redzone=xxx : Sets the position of the red zone of the background of the gauge. Used only if display mode is 'gauge' and type is not 'gradientlinear'. Values greater than xxx will be displayed over a red solid background color.
(Overrides BaseParameter..::..Options.)
Public property StepValue
Gets/Sets the step value of the numeric parameter
Public property Tag
Gets/sets the Tag property of the parameter's control object
(Inherited from BaseParameter.)
Public property TextHandler
Property used by MADCAT to get the String handler of the parameter
(Inherited from BaseParameter.)
Public property Tip
Property used by MADCAT to get/set the ToolTip object for the Form Control of the parameter
(Inherited from BaseParameter.)
Public property Type
Gets the base type of the parameter. For numeric parameters, it is CMN_Numeric
(Overrides BaseParameter..::..Type.)
Public property TypeName
Gets the name of the type of the parameter as it is coded in the attribute TYPE of the parameter's Xml definition (ATTRIBUTE element definition) It is the core type's name of the parameter
(Inherited from BaseParameter.)
Public property UseLimits
Gets/sets the flag which activates/deactivates the control of the boundaries of the numeric value.
Public property UserSettings
Property used by MADCAT to get/set the user settings of the parameter
(Inherited from BaseParameter.)
Public property Value
Property used by MADCAT to get/set the value of the parameter.
(Overrides BaseParameter..::..Value.)
Public property XmlDefinition
Property used by MADCAT to get/set the XML definition of the parameter. Definition must be compliant with the schema MODELS.XSD
(Overrides BaseParameter..::..XmlDefinition.)
Public property XmlNodeHandler
Property used by MADCAT to get the XML handler of the parameter
(Inherited from BaseParameter.)

Events

 | Name | Description
Public event | ValueChanged | Fired when the value of the parameter changes (Inherited from BaseParameter.)

See Also

NumericInput Class
Parameters Namespace


NumericInput Constructor

[image]

MADCAT Software Developer Guide
NumericInput Constructor
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public NumericInput()
Visual Basic
Public Sub New
Visual C++
public:
NumericInput()

See Also

NumericInput Class
NumericInput Members
Parameters Namespace


NumericInput Fields

[image] [image]

MADCAT Software Developer Guide
NumericInput Fields
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The NumericInput type exposes the following members.

Fields

Name | Description
FormatInfo | Definition of the format used for the numeric value of the parameter

See Also

NumericInput Class
Parameters Namespace


FormatInfo Field

[image]

MADCAT Software Developer Guide
NumericInput..::..FormatInfo Field
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Definition of the format used for the numeric value of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public static NumberFormatInfo FormatInfo
Visual Basic
Public Shared FormatInfo As NumberFormatInfo
Visual C++
public:
static NumberFormatInfo^ FormatInfo

See Also

NumericInput Class
NumericInput Members
Parameters Namespace


NumericInput Methods

[image] [image]

MADCAT Software Developer Guide
NumericInput Methods
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The NumericInput type exposes the following members.

Methods

 | Name | Description
Public method | BuildHTMLString | Gives the HTML code used to render the input field in HTML instead of Windows form control (Inherited from BaseParameter.)
Public method | BuildLabel | Gives the Windows Form control for the label of the input field of the parameter (Inherited from BaseParameter.)
Public method | Clone | Clones the parameter object into a new parameter object (Overrides BaseParameter..::..Clone()()()().)
Public method | RestoreValueFromItem | Gets the value of the parameter from a given project's Item (Overrides BaseParameter..::..RestoreValueFromItem(XmlNode).)
Public method | SaveValueInItem | Saves the value of the parameter into a given project's Item (Inherited from BaseParameter.)

See Also

NumericInput Class
Parameters Namespace


Clone Method

[image]

MADCAT Software Developer Guide
NumericInput..::..Clone Method
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Clones the parameter object into a new parameter object

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object
Visual C++
public:
virtual Object^ Clone() override

Return Value

A clone of the current object

See Also

NumericInput Class
NumericInput Members
Parameters Namespace


RestoreValueFromItem Method

[image]

MADCAT Software Developer Guide
NumericInput..::..RestoreValueFromItem Method
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the value of the parameter from a given project's Item

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override void RestoreValueFromItem(
    XmlNode item
)
Visual Basic
Public Overrides Sub RestoreValueFromItem ( _
    item As XmlNode _
)
Visual C++
public:
virtual void RestoreValueFromItem(
    XmlNode^ item
) override

Parameters

item
Type: System.Xml..::..XmlNode
XML node where the attribute's value shall be used to set the parameter's value

Implements

IParameter..::..RestoreValueFromItem(XmlNode)

See Also

NumericInput Class
NumericInput Members
Parameters Namespace


NumericInput Properties

[image] [image]

MADCAT Software Developer Guide
NumericInput Properties
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The NumericInput type exposes the following members.

Properties

Name Description
Public property ButtonCursor
Gets/Sets the type of the cursor of the button.
Public property ButtonDisplayType
Gets/Sets the display style of the button.
Public property ContextMenu
Property used by MADCAT to get the context menu of the parameter
(Inherited from BaseParameter.)
Public property Description
Property used by MADCAT to get/set the description of the parameter
(Inherited from BaseParameter.)
Public property Display
Gets/Sets the display style of the numeric value. This controls the way the number is displayed on screen.
Public property DisplayOnly
Property used by MADCAT to set the access mode of the parameter
(Overrides BaseParameter..::..DisplayOnly.)
Public property DrawHandler
Property used by MADCAT to get the Bitmap handler of the parameter
(Overrides BaseParameter..::..DrawHandler.)
Public property FormControl
Gets the control corresponding to the display options set with the Options property.
(Overrides BaseParameter..::..FormControl.)
Public property GaugeCursorVisible
Shows/Hides the cursor of the gauge.
Public property GaugeDisplayType
Gets/Sets the display style of the gauge.
Public property GaugeHeight
Height of the gauge in pixel
Public property GaugeOrientation
Orientation of the gauge.
Public property GaugeRedZone
Gets/sets the gauge red zone (values over this threshold are highlighted)
Public property GradientColors
Gets/Sets the list of colors of the gradient used for the linear gauge. Colors are coded in HTML and are separated by a pipe '|'.
Public property HasChanged
Property used by MADCAT to check if the parameter has changed
(Inherited from BaseParameter.)
Public property Hint
Property used by MADCAT to get/set the tip of the parameter. The tip contains a short help which popups when the user moves his mouse cursor over the parameter's name
(Inherited from BaseParameter.)
Public property IsMandatory
Property used by MADCAT to indicate if the parameter is mandatory or not. When mandatory, the user must give a value to the parameter to continue his current operation.
(Inherited from BaseParameter.)
Public property IsUndefined
Property used by MADCAT to check if the parameter has been set by the user or not
(Inherited from BaseParameter.)
Public property MaxNumberOfChars
Gets/sets the maximum number of characters of the parameter's value
(Inherited from BaseParameter.)
Public property MaxValue
Gets/Sets the maximum value of the numeric parameter
Public property MinValue
Gets/Sets the minimum value of the numeric parameter
Public property Name
Property used by MADCAT to get/set the name of the parameter
(Inherited from BaseParameter.)
Public property NumberOfLines
Gets/sets the number of lines visible in the text box of the parameter
(Inherited from BaseParameter.)
Public property Options
Sets the options of the numeric parameter. In addition to the common options (Options), numeric parameters have the following ones :
  • showas=xxx : sets the display mode of the numeric value. Where xxx is one of the following modes :
    • slider : Value is set by moving a cursor on a horizontal or vertical bar.
    • hexadecimal : Value is set by editing a text box field. Number is written in hexadecimal format '0x...'
    • button : Value is set by turning a graphic button.
    • metalbutton : Value is set by turning a graphic button. Button has a metallic rendering.
    • gauge : Value is set by clicking on a gauge which can be horizontal or vertical.
    By default, the value is set by editing a classic text box.
  • gaugetype=xxx : When display mode is 'gauge', this option sets the way the gauge is displayed :
    • circular : The gauge is an arc
    • gradientlinear : The gauge is linear and its background is a gradient filled with several colors
    By default, the gauge is linear and is filled with green.
  • withcursor=yes|no : when display mode is 'gauge' and gauge is not circular, indicates if the value shall be marked with a cursor. If it is set to 'no', the value is displayed by the filling of the gauge.
  • orientation=horizontal|vertical : when display mode is 'gauge' and gauge is not circular, this option sets the orientation of the gauge.
  • cursor=dot|switch : when display mode is 'button', this option indicates if the value is marked with a dot or a dedicated switch.
  • mini=xxx : Sets the minimum value authorized by the parameter. xxx is the value. Doesn't work with hexadecimal values.
  • maxi=xxx : Sets the maximum value authorized by the parameter. xxx is the value. Doesn't work with hexadecimal values.
  • step=xxx : Sets the step value of the parameter. xxx is the value. Doesn't work with hexadecimal values. When used, values are incremented or decremented with this step.
  • colors=c1|c2|c3... : When the display mode is 'gauge' and gauge type is 'gradientlinear', sets the gradient colors c1, c2, etc... Colors are written in the HTML format and separated by '|'. Supports 2 or more color codes.
  • redzone=xxx : Sets the position of the red zone of the background of the gauge. Used only if display mode is 'gauge' and type is not 'gradientlinear'. Values greater than xxx will be displayed over a red solid background color.
(Overrides BaseParameter..::..Options.)
Public property StepValue
Gets/Sets the step value of the numeric parameter
Public property Tag
Gets/sets the Tag property of the parameter's control object
(Inherited from BaseParameter.)
Public property TextHandler
Property used by MADCAT to get the String handler of the parameter
(Inherited from BaseParameter.)
Public property Tip
Property used by MADCAT to get/set the ToolTip object for the Form Control of the parameter
(Inherited from BaseParameter.)
Public property Type
Gets the base type of the parameter. For numeric parameters, it is CMN_Numeric
(Overrides BaseParameter..::..Type.)
Public property TypeName
Gets the name of the type of the parameter as it is coded in the attribute TYPE of the parameter's Xml definition (ATTRIBUTE element definition) It is the core type's name of the parameter
(Inherited from BaseParameter.)
Public property UseLimits
Gets/sets the flag which activates/deactivates the control of the boundaries of the numeric value.
Public property UserSettings
Property used by MADCAT to get/set the user settings of the parameter
(Inherited from BaseParameter.)
Public property Value
Property used by MADCAT to get/set the value of the parameter.
(Overrides BaseParameter..::..Value.)
Public property XmlDefinition
Property used by MADCAT to get/set the XML definition of the parameter. Definition must be compliant with the schema MODELS.XSD
(Overrides BaseParameter..::..XmlDefinition.)
Public property XmlNodeHandler
Property used by MADCAT to get the XML handler of the parameter
(Inherited from BaseParameter.)

See Also

NumericInput Class
Parameters Namespace


ButtonCursor Property

[image]

MADCAT Software Developer Guide
NumericInput..::..ButtonCursor Property
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/Sets the type of the cursor of the button.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public NumericButtonCursor ButtonCursor { get; set; }
Visual Basic
Public Property ButtonCursor As NumericButtonCursor
    Get
    Set
Visual C++
public:
property NumericButtonCursor ButtonCursor {
    NumericButtonCursor get ();
    void set (NumericButtonCursor value);
}

See Also

NumericInput Class
NumericInput Members
Parameters Namespace


ButtonDisplayType Property

[image]

MADCAT Software Developer Guide
NumericInput..::..ButtonDisplayType Property
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/Sets the display style of the button.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public NumericButtonType ButtonDisplayType { get; set; }
Visual Basic
Public Property ButtonDisplayType As NumericButtonType
    Get
    Set
Visual C++
public:
property NumericButtonType ButtonDisplayType {
    NumericButtonType get ();
    void set (NumericButtonType value);
}

See Also

NumericInput Class
NumericInput Members
Parameters Namespace


Display Property

[image]

MADCAT Software Developer Guide
NumericInput..::..Display Property
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/Sets the display style of the numeric value. This controls the way the number is displayed on screen.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public NumericDisplay Display { get; set; }
Visual Basic
Public Property Display As NumericDisplay
    Get
    Set
Visual C++
public:
property NumericDisplay Display {
    NumericDisplay get ();
    void set (NumericDisplay value);
}

See Also

NumericInput Class
NumericInput Members
Parameters Namespace


DisplayOnly Property

[image]

MADCAT Software Developer Guide
NumericInput..::..DisplayOnly Property
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to set the access mode of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override bool DisplayOnly { set; }
Visual Basic
Public Overrides WriteOnly Property DisplayOnly As Boolean
    Set
Visual C++
public:
virtual property bool DisplayOnly {
    void set (bool value) override;
}

Implements

IParameter..::..DisplayOnly

See Also

NumericInput Class
NumericInput Members
Parameters Namespace


DrawHandler Property

[image]

MADCAT Software Developer Guide
NumericInput..::..DrawHandler Property
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get the Bitmap handler of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override BitmapHandler DrawHandler { get; }
Visual Basic
Public Overrides ReadOnly Property DrawHandler As BitmapHandler
    Get
Visual C++
public:
virtual property BitmapHandler^ DrawHandler {
    BitmapHandler^ get () override;
}

Implements

IParameter..::..DrawHandler

See Also

NumericInput Class
NumericInput Members
Parameters Namespace


FormControl Property

[image]

MADCAT Software Developer Guide
NumericInput..::..FormControl Property
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the control corresponding to the display options set with the Options property.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Control FormControl { get; }
Visual Basic
Public Overrides ReadOnly Property FormControl As Control
    Get
Visual C++
public:
virtual property Control^ FormControl {
    Control^ get () override;
}

Implements

IParameter..::..FormControl

See Also

NumericInput Class
NumericInput Members
Parameters Namespace


GaugeCursorVisible Property

[image]

MADCAT Software Developer Guide
NumericInput..::..GaugeCursorVisible Property
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Shows/Hides the cursor of the gauge.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public bool GaugeCursorVisible { get; set; }
Visual Basic
Public Property GaugeCursorVisible As Boolean
    Get
    Set
Visual C++
public:
property bool GaugeCursorVisible {
    bool get ();
    void set (bool value);
}

See Also

NumericInput Class
NumericInput Members
Parameters Namespace


GaugeDisplayType Property

[image]

MADCAT Software Developer Guide
NumericInput..::..GaugeDisplayType Property
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/Sets the display style of the gauge.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public GaugeType GaugeDisplayType { get; set; }
Visual Basic
Public Property GaugeDisplayType As GaugeType
    Get
    Set
Visual C++
public:
property GaugeType GaugeDisplayType {
    GaugeType get ();
    void set (GaugeType value);
}

See Also

NumericInput Class
NumericInput Members
Parameters Namespace


GaugeHeight Property

[image]

MADCAT Software Developer Guide
NumericInput..::..GaugeHeight Property
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Height of the gauge in pixel

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public int GaugeHeight { get; set; }
Visual Basic
Public Property GaugeHeight As Integer
    Get
    Set
Visual C++
public:
property int GaugeHeight {
    int get ();
    void set (int value);
}

See Also

NumericInput Class
NumericInput Members
Parameters Namespace


GaugeOrientation Property

[image]

MADCAT Software Developer Guide
NumericInput..::..GaugeOrientation Property
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Orientation of the gauge.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public Orientation GaugeOrientation { get; set; }
Visual Basic
Public Property GaugeOrientation As Orientation
    Get
    Set
Visual C++
public:
property Orientation GaugeOrientation {
    Orientation get ();
    void set (Orientation value);
}

See Also

NumericInput Class
NumericInput Members
Parameters Namespace


GaugeRedZone Property

[image]

MADCAT Software Developer Guide
NumericInput..::..GaugeRedZone Property
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/sets the gauge red zone (values over this threshold are highlighted)

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public decimal GaugeRedZone { get; set; }
Visual Basic
Public Property GaugeRedZone As Decimal
    Get
    Set
Visual C++
public:
property Decimal GaugeRedZone {
    Decimal get ();
    void set (Decimal value);
}

See Also

NumericInput Class
NumericInput Members
Parameters Namespace


GradientColors Property

[image]

MADCAT Software Developer Guide
NumericInput..::..GradientColors Property
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/Sets the list of colors of the gradient used for the linear gauge. Colors are coded in HTML and are separated by a pipe '|'.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public string GradientColors { get; set; }
Visual Basic
Public Property GradientColors As String
    Get
    Set
Visual C++
public:
property String^ GradientColors {
    String^ get ();
    void set (String^ value);
}

See Also

NumericInput Class
NumericInput Members
Parameters Namespace


MaxValue Property

[image]

MADCAT Software Developer Guide
NumericInput..::..MaxValue Property
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/Sets the maximum value of the numeric parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public decimal MaxValue { get; set; }
Visual Basic
Public Property MaxValue As Decimal
    Get
    Set
Visual C++
public:
property Decimal MaxValue {
    Decimal get ();
    void set (Decimal value);
}

See Also

NumericInput Class
NumericInput Members
Parameters Namespace


MinValue Property

[image]

MADCAT Software Developer Guide
NumericInput..::..MinValue Property
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/Sets the minimum value of the numeric parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public decimal MinValue { get; set; }
Visual Basic
Public Property MinValue As Decimal
    Get
    Set
Visual C++
public:
property Decimal MinValue {
    Decimal get ();
    void set (Decimal value);
}

See Also

NumericInput Class
NumericInput Members
Parameters Namespace


Options Property

[image]

MADCAT Software Developer Guide
NumericInput..::..Options Property
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Sets the options of the numeric parameter. In addition to the common options (Options), numeric parameters have the following ones :
  • showas=xxx : sets the display mode of the numeric value. Where xxx is one of the following modes :
    • slider : Value is set by moving a cursor on a horizontal or vertical bar.
    • hexadecimal : Value is set by editing a text box field. Number is written in hexadecimal format '0x...'
    • button : Value is set by turning a graphic button.
    • metalbutton : Value is set by turning a graphic button. Button has a metallic rendering.
    • gauge : Value is set by clicking on a gauge which can be horizontal or vertical.
    By default, the value is set by editing a classic text box.
  • gaugetype=xxx : When display mode is 'gauge', this option sets the way the gauge is displayed :
    • circular : The gauge is an arc
    • gradientlinear : The gauge is linear and its background is a gradient filled with several colors
    By default, the gauge is linear and is filled with green.
  • withcursor=yes|no : when display mode is 'gauge' and gauge is not circular, indicates if the value shall be marked with a cursor. If it is set to 'no', the value is displayed by the filling of the gauge.
  • orientation=horizontal|vertical : when display mode is 'gauge' and gauge is not circular, this option sets the orientation of the gauge.
  • cursor=dot|switch : when display mode is 'button', this option indicates if the value is marked with a dot or a dedicated switch.
  • mini=xxx : Sets the minimum value authorized by the parameter. xxx is the value. Doesn't work with hexadecimal values.
  • maxi=xxx : Sets the maximum value authorized by the parameter. xxx is the value. Doesn't work with hexadecimal values.
  • step=xxx : Sets the step value of the parameter. xxx is the value. Doesn't work with hexadecimal values. When used, values are incremented or decremented with this step.
  • colors=c1|c2|c3... : When the display mode is 'gauge' and gauge type is 'gradientlinear', sets the gradient colors c1, c2, etc... Colors are written in the HTML format and separated by '|'. Supports 2 or more color codes.
  • redzone=xxx : Sets the position of the red zone of the background of the gauge. Used only if display mode is 'gauge' and type is not 'gradientlinear'. Values greater than xxx will be displayed over a red solid background color.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override Hashtable Options { set; }
Visual Basic
Public Overrides WriteOnly Property Options As Hashtable
    Set
Visual C++
public:
virtual property Hashtable^ Options {
    void set (Hashtable^ value) override;
}

Implements

IParameter..::..Options

See Also

NumericInput Class
NumericInput Members
Parameters Namespace


StepValue Property

[image]

MADCAT Software Developer Guide
NumericInput..::..StepValue Property
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/Sets the step value of the numeric parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public decimal StepValue { get; set; }
Visual Basic
Public Property StepValue As Decimal
    Get
    Set
Visual C++
public:
property Decimal StepValue {
    Decimal get ();
    void set (Decimal value);
}

See Also

NumericInput Class
NumericInput Members
Parameters Namespace


Type Property

[image]

MADCAT Software Developer Guide
NumericInput..::..Type Property
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the base type of the parameter. For numeric parameters, it is CMN_Numeric

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override DataToolTypes Type { get; }
Visual Basic
Public Overrides ReadOnly Property Type As DataToolTypes
    Get
Visual C++
public:
virtual property DataToolTypes Type {
    DataToolTypes get () override;
}

Implements

IParameter..::..Type

See Also

NumericInput Class
NumericInput Members
Parameters Namespace


UseLimits Property

[image]

MADCAT Software Developer Guide
NumericInput..::..UseLimits Property
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets/sets the flag which activates/deactivates the control of the boundaries of the numeric value.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public bool UseLimits { get; set; }
Visual Basic
Public Property UseLimits As Boolean
    Get
    Set
Visual C++
public:
property bool UseLimits {
    bool get ();
    void set (bool value);
}

See Also

NumericInput Class
NumericInput Members
Parameters Namespace


Value Property

[image]

MADCAT Software Developer Guide
NumericInput..::..Value Property
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the value of the parameter.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override string Value { get; set; }
Visual Basic
Public Overrides Property Value As String
    Get
    Set
Visual C++
public:
virtual property String^ Value {
    String^ get () override;
    void set (String^ value) override;
}

Implements

IParameter..::..Value

See Also

NumericInput Class
NumericInput Members
Parameters Namespace


XmlDefinition Property

[image]

MADCAT Software Developer Guide
NumericInput..::..XmlDefinition Property
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Property used by MADCAT to get/set the XML definition of the parameter. Definition must be compliant with the schema MODELS.XSD

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public override XmlNode XmlDefinition { set; }
Visual Basic
Public Overrides WriteOnly Property XmlDefinition As XmlNode
    Set
Visual C++
public:
virtual property XmlNode^ XmlDefinition {
    void set (XmlNode^ value) override;
}

Implements

IParameter..::..XmlDefinition

See Also

NumericInput Class
NumericInput Members
Parameters Namespace


NumericInput Events

[image] [image]

MADCAT Software Developer Guide
NumericInput Events
NumericInput Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The NumericInput type exposes the following members.

Events

 | Name | Description
Public event | ValueChanged | Fired when the value of the parameter changes (Inherited from BaseParameter.)

See Also

NumericInput Class
Parameters Namespace


NumericSorter Class

[image]

MADCAT Software Developer Guide
NumericSorter Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Class used to sort numeric values of NumericInput parameters

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public class NumericSorter : IComparer
Visual Basic
Public Class NumericSorter _
    Implements IComparer
Visual C++
public ref class NumericSorter : IComparer

Inheritance Hierarchy

System..::..Object
Parameters..::..NumericSorter

See Also

NumericSorter Members
Parameters Namespace


NumericSorter Members

[image] [image]

MADCAT Software Developer Guide
NumericSorter Members
NumericSorter Class Constructors Methods Fields See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The NumericSorter type exposes the following members.

Constructors

 | Name | Description
Public method | NumericSorter | Constructor

Methods

 | Name | Description
Public method | Compare | Compares two numeric values coded into Strings objects

Fields

 | Name | Description
Public field | decimaldef | Format used to encode the numeric value into a string

See Also

NumericSorter Class
Parameters Namespace


NumericSorter Constructor

[image]

MADCAT Software Developer Guide
NumericSorter Constructor
NumericSorter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public NumericSorter()
Visual Basic
Public Sub New
Visual C++
public:
NumericSorter()

See Also

NumericSorter Class
NumericSorter Members
Parameters Namespace


NumericSorter Fields

[image] [image]

MADCAT Software Developer Guide
NumericSorter Fields
NumericSorter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The NumericSorter type exposes the following members.

Fields

 | Name | Description
Public field | decimaldef | Format used to encode the numeric value into a string

See Also

NumericSorter Class
Parameters Namespace


decimaldef Field

[image]

MADCAT Software Developer Guide
NumericSorter..::..decimaldef Field
NumericSorter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Format used to encode the numeric value into a string

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public NumberFormatInfo decimaldef
Visual Basic
Public decimaldef As NumberFormatInfo
Visual C++
public:
NumberFormatInfo^ decimaldef

See Also

NumericSorter Class
NumericSorter Members
Parameters Namespace


NumericSorter Methods

[image] [image]

MADCAT Software Developer Guide
NumericSorter Methods
NumericSorter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The NumericSorter type exposes the following members.

Methods

 | Name | Description
Public method | Compare | Compares two numeric values coded into Strings objects

See Also

NumericSorter Class
Parameters Namespace


Compare Method

[image]

MADCAT Software Developer Guide
NumericSorter..::..Compare Method
NumericSorter Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Compares two numeric values coded into Strings objects

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public virtual int Compare(
    Object x,
    Object y
)
Visual Basic
Public Overridable Function Compare ( _
    x As Object, _
    y As Object _
) As Integer
Visual C++
public:
virtual int Compare(
    Object^ x,
    Object^ y
)

Parameters

x
Type: System..::..Object
1st numeric value
y
Type: System..::..Object
2nd numeric value

Return Value

The comparison results coded as follow:
  • equal to 0 : Values are equal
  • less than 0 : 1st value is lower than 2nd value
  • greater than 0 : 1st value is greater than 2nd value

Implements

IComparer..::..Compare(Object, Object)

See Also

NumericSorter Class
NumericSorter Members
Parameters Namespace


ParametersManager Class

[image]

MADCAT Software Developer Guide
ParametersManager Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Main class to use to manage parameters. It has methods which can build any parameter for MADCAT, use filters and sorters and also manage parameters' values. This is the main entry point for parameters.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public class ParametersManager
Visual Basic
Public Class ParametersManager
Visual C++
public ref class ParametersManager

Inheritance Hierarchy

System..::..Object
Parameters..::..ParametersManager

See Also

ParametersManager Members
Parameters Namespace


ParametersManager Members

[image] [image]

MADCAT Software Developer Guide
ParametersManager Members
ParametersManager Class Constructors Methods Fields See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The ParametersManager type exposes the following members.

Constructors

 | Name | Description
Public method | ParametersManager | Constructor

Methods

Name | Description
BackupParameterValue | Save the parameters' values. Backup can be restored with the method RestoreParameterValue(array<IParameter>[]()[][], Hashtable)
BuildAllParameters | Builds all the parameters objects corresponding to the attributes of the given item.
BuildParameter | Builds a parameter object exposing the interface IParameter using a Xml definition compliant with MADCAT's schema.
GetFilter | Builds a filter object exposing the interface IFilter corresponding to the type given by its name
GetPlottingServices | Builds a plotting manager object exposing the interface IPlottingServices corresponding to the type given by its XML definition
GetSorter | Builds a comparer object exposing the interface IComparer corresponding to the type given by its name
LoadExternalTypes | Loads the external types stored in a given list of paths
RestoreParameterValue | Restore the parameters' values saved previously with the method BackupParameterValue(array<IParameter>[]()[][], Hashtable)
SetParameterOptions | Changes the options of a parameter

Fields

Name | Description
CurrentTabIndex | MADCAT uses this variable to set the tab index of the controls. Set it to zero before you build controls in a form.
NumberOfExternalTypes | Gives the number of external types loaded by MADCAT for the current workspace.

See Also

ParametersManager Class
Parameters Namespace


ParametersManager Constructor

[image]

MADCAT Software Developer Guide
ParametersManager Constructor
ParametersManager Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public ParametersManager()
Visual Basic
Public Sub New
Visual C++
public:
ParametersManager()

See Also

ParametersManager Class
ParametersManager Members
Parameters Namespace


ParametersManager Fields

[image] [image]

MADCAT Software Developer Guide
ParametersManager Fields
ParametersManager Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The ParametersManager type exposes the following members.

Fields

Name | Description
CurrentTabIndex | MADCAT uses this variable to set the tab index of the controls. Set it to zero before you build controls in a form.
NumberOfExternalTypes | Gives the number of external types loaded by MADCAT for the current workspace.

See Also

ParametersManager Class
Parameters Namespace


CurrentTabIndex Field

[image]

MADCAT Software Developer Guide
ParametersManager..::..CurrentTabIndex Field
ParametersManager Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
MADCAT uses this variable to set the tab index of the controls. Set it to zero before you build controls in a form.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public static int CurrentTabIndex
Visual Basic
Public Shared CurrentTabIndex As Integer
Visual C++
public:
static int CurrentTabIndex

See Also

ParametersManager Class
ParametersManager Members
Parameters Namespace


NumberOfExternalTypes Field

[image]

MADCAT Software Developer Guide
ParametersManager..::..NumberOfExternalTypes Field
ParametersManager Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gives the number of external types loaded by MADCAT for the current workspace.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public static int NumberOfExternalTypes
Visual Basic
Public Shared NumberOfExternalTypes As Integer
Visual C++
public:
static int NumberOfExternalTypes

See Also

ParametersManager Class
ParametersManager Members
Parameters Namespace


ParametersManager Methods

[image] [image]

MADCAT Software Developer Guide
ParametersManager Methods
ParametersManager Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The ParametersManager type exposes the following members.

Methods

Name | Description
BackupParameterValue | Save the parameters' values. Backup can be restored with the method RestoreParameterValue(array<IParameter>[]()[][], Hashtable)
BuildAllParameters | Builds all the parameters objects corresponding to the attributes of the given item.
BuildParameter | Builds a parameter object exposing the interface IParameter using a Xml definition compliant with MADCAT's schema.
GetFilter | Builds a filter object exposing the interface IFilter corresponding to the type given by its name
GetPlottingServices | Builds a plotting manager object exposing the interface IPlottingServices corresponding to the type given by its XML definition
GetSorter | Builds a comparer object exposing the interface IComparer corresponding to the type given by its name
LoadExternalTypes | Loads the external types stored in a given list of paths
RestoreParameterValue | Restore the parameters' values saved previously with the method BackupParameterValue(array<IParameter>[]()[][], Hashtable)
SetParameterOptions | Changes the options of a parameter

See Also

ParametersManager Class
Parameters Namespace


BackupParameterValue Method

[image]

MADCAT Software Developer Guide
ParametersManager..::..BackupParameterValue Method
ParametersManager Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Save the parameters' values. Backup can be restored with the method RestoreParameterValue(array<IParameter>[]()[][], Hashtable)

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public static void BackupParameterValue(
    IParameter[] Parameters,
    Hashtable cfg
)
Visual Basic
Public Shared Sub BackupParameterValue ( _
    Parameters As IParameter(), _
    cfg As Hashtable _
)
Visual C++
public:
static void BackupParameterValue(
    array<IParameter^>^ Parameters,
    Hashtable^ cfg
)

Parameters

Parameters
Type: array< Parameters..::..IParameter >[]()[][]
Array of parameters
cfg
Type: System.Collections..::..Hashtable
Hashtable where the values shall be saved

See Also

ParametersManager Class
ParametersManager Members
Parameters Namespace


BuildAllParameters Method

[image]

MADCAT Software Developer Guide
ParametersManager..::..BuildAllParameters Method
ParametersManager Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Builds all the parameters objects corresponding to the attributes of the given item.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public static IParameter[] BuildAllParameters(
    XmlNode Item
)
Visual Basic
Public Shared Function BuildAllParameters ( _
    Item As XmlNode _
) As IParameter()
Visual C++
public:
static array<IParameter^>^ BuildAllParameters(
    XmlNode^ Item
)

Parameters

Item
Type: System.Xml..::..XmlNode
Xml Item

Return Value

Array of IParameter interfaces. One for each attribute found in the given item.

See Also

ParametersManager Class
ParametersManager Members
Parameters Namespace


BuildParameter Method

[image]

MADCAT Software Developer Guide
ParametersManager..::..BuildParameter Method
ParametersManager Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Builds a parameter object exposing the interface IParameter using a Xml definition compliant with MADCAT's schema.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public static IParameter BuildParameter(
    XmlNode Attr
)
Visual Basic
Public Shared Function BuildParameter ( _
    Attr As XmlNode _
) As IParameter
Visual C++
public:
static IParameter^ BuildParameter(
    XmlNode^ Attr
)

Parameters

Attr
Type: System.Xml..::..XmlNode
Xml data which contains the definition of the parameter

Return Value

IParameter interface to use to control the parameter

See Also

ParametersManager Class
ParametersManager Members
Parameters Namespace


GetFilter Method

[image]

MADCAT Software Developer Guide
ParametersManager..::..GetFilter Method
ParametersManager Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Builds a filter object exposing the interface IFilter corresponding to the type given by its name

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public static IFilter GetFilter(
    string TypeName
)
Visual Basic
Public Shared Function GetFilter ( _
    TypeName As String _
) As IFilter
Visual C++
public:
static IFilter^ GetFilter(
    String^ TypeName
)

Parameters

TypeName
Type: System..::..String
Name of the type

Return Value

IFilter interface to use to configure and use the filter of the type

See Also

ParametersManager Class
ParametersManager Members
Parameters Namespace


GetPlottingServices Method

[image]

MADCAT Software Developer Guide
ParametersManager..::..GetPlottingServices Method
ParametersManager Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Builds a plotting manager object exposing the interface IPlottingServices corresponding to the type given by its XML definition

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public static IPlottingServices GetPlottingServices(
    XmlNode attr_def
)
Visual Basic
Public Shared Function GetPlottingServices ( _
    attr_def As XmlNode _
) As IPlottingServices
Visual C++
public:
static IPlottingServices^ GetPlottingServices(
    XmlNode^ attr_def
)

Parameters

attr_def
Type: System.Xml..::..XmlNode
XML Definition of the type

Return Value

IPlottingServices interface to use to draw values of the type on charts

See Also

ParametersManager Class
ParametersManager Members
Parameters Namespace


GetSorter Method

[image]

MADCAT Software Developer Guide
ParametersManager..::..GetSorter Method
ParametersManager Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Builds a comparer object exposing the interface IComparer corresponding to the type given by its name

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public static IComparer GetSorter(
    string TypeName
)
Visual Basic
Public Shared Function GetSorter ( _
    TypeName As String _
) As IComparer
Visual C++
public:
static IComparer^ GetSorter(
    String^ TypeName
)

Parameters

TypeName
Type: System..::..String
Name of the type

Return Value

IComparer interface to use to configure and use the comparer of the type

See Also

ParametersManager Class
ParametersManager Members
Parameters Namespace


LoadExternalTypes Method

[image]

MADCAT Software Developer Guide
ParametersManager..::..LoadExternalTypes Method
ParametersManager Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Loads the external types stored in a given list of paths

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public static void LoadExternalTypes(
    ArrayList Path
)
Visual Basic
Public Shared Sub LoadExternalTypes ( _
    Path As ArrayList _
)
Visual C++
public:
static void LoadExternalTypes(
    ArrayList^ Path
)

Parameters

Path
Type: System.Collections..::..ArrayList
Array of String objects. Each object contains the location of the types in the host filesystem

See Also

ParametersManager Class
ParametersManager Members
Parameters Namespace


RestoreParameterValue Method

[image]

MADCAT Software Developer Guide
ParametersManager..::..RestoreParameterValue Method
ParametersManager Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Restore the parameters' values saved previously with the method BackupParameterValue(array<IParameter>[]()[][], Hashtable)

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public static void RestoreParameterValue(
    IParameter[] Parameters,
    Hashtable cfg
)
Visual Basic
Public Shared Sub RestoreParameterValue ( _
    Parameters As IParameter(), _
    cfg As Hashtable _
)
Visual C++
public:
static void RestoreParameterValue(
    array<IParameter^>^ Parameters,
    Hashtable^ cfg
)

Parameters

Parameters
Type: array< Parameters..::..IParameter >[]()[][]
Array of parameters
cfg
Type: System.Collections..::..Hashtable
Hashtable where the values shall be read from

See Also

ParametersManager Class
ParametersManager Members
Parameters Namespace


SetParameterOptions Method

[image]

MADCAT Software Developer Guide
ParametersManager..::..SetParameterOptions Method
ParametersManager Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Changes the options of a parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public static void SetParameterOptions(
    IParameter Param,
    string options
)
Visual Basic
Public Shared Sub SetParameterOptions ( _
    Param As IParameter, _
    options As String _
)
Visual C++
public:
static void SetParameterOptions(
    IParameter^ Param,
    String^ options
)

Parameters

Param
Type: Parameters..::..IParameter
The parameter
options
Type: System..::..String
A string object which contains the options written in the following format : option=value,option=value,...

See Also

ParametersManager Class
ParametersManager Members
Parameters Namespace


ParameterValueChangedEventArgs Class

[image]

MADCAT Software Developer Guide
ParameterValueChangedEventArgs Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Arguments of the event ParameterValueChanged.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public class ParameterValueChangedEventArgs
Visual Basic
Public Class ParameterValueChangedEventArgs
Visual C++
public ref class ParameterValueChangedEventArgs

Inheritance Hierarchy

System..::..Object
Parameters..::..ParameterValueChangedEventArgs

See Also

ParameterValueChangedEventArgs Members
Parameters Namespace


ParameterValueChangedEventArgs Members

[image] [image]

MADCAT Software Developer Guide
ParameterValueChangedEventArgs Members
ParameterValueChangedEventArgs Class Constructors Fields See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The ParameterValueChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ParameterValueChangedEventArgs | Constructor to initialize public members of the class

Fields

 | Name | Description
Public field | NewValue | New value of the parameter
Public field | PreviousValue | Previous value of the parameter

See Also

ParameterValueChangedEventArgs Class
Parameters Namespace


ParameterValueChangedEventArgs Constructor

[image]

MADCAT Software Developer Guide
ParameterValueChangedEventArgs Constructor
ParameterValueChangedEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor to initialize public members of the class

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public ParameterValueChangedEventArgs(
    string Old,
    string New
)
Visual Basic
Public Sub New ( _
    Old As String, _
    New As String _
)
Visual C++
public:
ParameterValueChangedEventArgs(
    String^ Old,
    String^ New
)

Parameters

Old
Type: System..::..String
Previous value of the parameter
New
Type: System..::..String
New value of the parameter

See Also

ParameterValueChangedEventArgs Class
ParameterValueChangedEventArgs Members
Parameters Namespace


ParameterValueChangedEventArgs Fields

[image] [image]

MADCAT Software Developer Guide
ParameterValueChangedEventArgs Fields
ParameterValueChangedEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The ParameterValueChangedEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | NewValue | New value of the parameter
Public field | PreviousValue | Previous value of the parameter

See Also

ParameterValueChangedEventArgs Class
Parameters Namespace


NewValue Field

[image]

MADCAT Software Developer Guide
ParameterValueChangedEventArgs..::..NewValue Field
ParameterValueChangedEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
New value of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public string NewValue
Visual Basic
Public NewValue As String
Visual C++
public:
String^ NewValue

See Also

ParameterValueChangedEventArgs Class
ParameterValueChangedEventArgs Members
Parameters Namespace


PreviousValue Field

[image]

MADCAT Software Developer Guide
ParameterValueChangedEventArgs..::..PreviousValue Field
ParameterValueChangedEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Previous value of the parameter

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public string PreviousValue
Visual Basic
Public PreviousValue As String
Visual C++
public:
String^ PreviousValue

See Also

ParameterValueChangedEventArgs Class
ParameterValueChangedEventArgs Members
Parameters Namespace


ParameterValueChangedEventHandler Delegate

[image]

MADCAT Software Developer Guide
ParameterValueChangedEventHandler Delegate
See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Delegate used to invoke handlers for the ParameterValueChanged event fired when a parameter value changes.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public delegate void ParameterValueChangedEventHandler(
    Object sender,
    ParameterValueChangedEventArgs args
)
Visual Basic
Public Delegate Sub ParameterValueChangedEventHandler ( _
    sender As Object, _
    args As ParameterValueChangedEventArgs _
)
Visual C++
public delegate void ParameterValueChangedEventHandler(
    Object^ sender,
    ParameterValueChangedEventArgs^ args
)

Parameters

sender
Type: System..::..Object
args
Type: Parameters..::..ParameterValueChangedEventArgs

See Also

Parameters Namespace


StringHandler Delegate

[image]

MADCAT Software Developer Guide
StringHandler Delegate
See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Delegate used to invoke String handlers. String handlers produce human-readable strings which are placed inside the cells of the listview renderer of MADCAT in details mode. to be used when the value stored in the database is not human-readable.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public delegate string StringHandler(
    string val
)
Visual Basic
Public Delegate Function StringHandler ( _
    val As String _
) As String
Visual C++
public delegate String^ StringHandler(
    String^ val
)

Parameters

val
Type: System..::..String

See Also

Parameters Namespace


XmlHandler Delegate

[image]

MADCAT Software Developer Guide
XmlHandler Delegate
See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Delegate used to invoke XML handlers. XML handlers produce XML strings which are placed inside the XML reports of MADCAT.

Namespace: Parameters
Assembly: Parameters (in Parameters.dll) Version: 1.0.4787.39861

Syntax

C#
public delegate void XmlHandler(
    XmlNode node
)
Visual Basic
Public Delegate Sub XmlHandler ( _
    node As XmlNode _
)
Visual C++
public delegate void XmlHandler(
    XmlNode^ node
)

Parameters

node
Type: System.Xml..::..XmlNode

See Also

Parameters Namespace


RendererInterfaces Namespace

[image]

MADCAT Software Developer Guide
RendererInterfaces Namespace
Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Interfaces for Renderers This namespace gathers all the interfaces used by the Renderers to access data and by MADCAT to capture user events from Renderers.

Classes

 | Class | Description
Public class | RenderersToolBox | This class contains static functions which can be used by renderers' coders to perform frequent operations easily

Interfaces

 | Interface | Description
Public interface | IRenderer | Interface which shall be exposed by any renderer of MADCAT. Used by MADCAT to control the renderer modes and to retrieve user actions from it (only the renderer can know what the user does inside the renderer's space)
Public interface | IRendererContext | Interface used by Renderers to retrieve all relevant information about their context Most important, it provides services to get items which has to be rendered.


IRenderer Interface

[image]

MADCAT Software Developer Guide
IRenderer Interface
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Interface which shall be exposed by any renderer of MADCAT. Used by MADCAT to control the renderer modes and to retrieve user actions from it (only the renderer can know what the user does inside the renderer's space)

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
public interface IRenderer
Visual Basic
Public Interface IRenderer
Visual C++
public interface class IRenderer

See Also

IRenderer Members
RendererInterfaces Namespace


IRenderer Members

[image] [image]

MADCAT Software Developer Guide
IRenderer Members
IRenderer Interface Methods Properties Events See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IRenderer type exposes the following members.

Methods

 | Name | Description
Public method | ApplyUserSettings | Invoked by MADCAT to pass the user settings of the renderer coming from the user profile
Public method | GetUserSettings | Invoked by MADCAT to get the user settings of the renderer which must be saved in the user profile
Public method | Init | Invoked by MADCAT to initialize the renderer by giving it its context
Public method | RenderHTML | Invoked by MADCAT to get the HTML code which can be used to display the items in a Web browser (not used for the moment)
Public method | SetMode(String) | Invoked by MADCAT to change the mode of the renderer with no options
Public method | SetMode(String, String) | Invoked by MADCAT to change the mode of the renderer and give mode's options
Public method | ShowOptionDialog | Invoked by MADCAT when the user wants to open the configuration panel of the renderer (optional)
Public method | Terminate | Invoked by MADCAT before killing the renderer. The renderer shall release all the allocated objects, events, ....

Properties

 | Name | Description
Public property | Items | Invoked by MADCAT to get the list of items actually displayed by the renderer
Public property | Mode | Invoked by MADCAT to get the current display mode of the renderer
Public property | ParentItem | Invoked by MADCAT to get the parent Item of the renderer's listed items
Public property | SelectedItems | Invoked by MADCAT to get the list of items the user has selected using the renderer interface

Events

 | Name | Description
Public event | DragOver | Fired by the renderer when the user moves his mouse over the renderer during a drag'n'drop operation
Public event | Drop | Fired by the renderer when the user dropped an object on the renderer area
Public event | ItemDrag | Fired by the renderer when the user initiates a drag'n'drop operation from an item displayed by the renderer
Public event | ItemSelectionChanged | Fired by the renderer when the user performed an action which changes the selection of items
Public event | RootItemChanged | Fired by the renderer when the user performed an action which requires a new root item

See Also

IRenderer Interface
RendererInterfaces Namespace


IRenderer Methods

[image] [image]

MADCAT Software Developer Guide
IRenderer Methods
IRenderer Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IRenderer type exposes the following members.

Methods

 | Name | Description
Public method | ApplyUserSettings | Invoked by MADCAT to pass the user settings of the renderer coming from the user profile
Public method | GetUserSettings | Invoked by MADCAT to get the user settings of the renderer which must be saved in the user profile
Public method | Init | Invoked by MADCAT to initialize the renderer by giving it its context
Public method | RenderHTML | Invoked by MADCAT to get the HTML code which can be used to display the items in a Web browser (not used for the moment)
Public method | SetMode(String) | Invoked by MADCAT to change the mode of the renderer with no options
Public method | SetMode(String, String) | Invoked by MADCAT to change the mode of the renderer and give mode's options
Public method | ShowOptionDialog | Invoked by MADCAT when the user wants to open the configuration panel of the renderer (optional)
Public method | Terminate | Invoked by MADCAT before killing the renderer. The renderer shall release all the allocated objects, events, ....

See Also

IRenderer Interface
RendererInterfaces Namespace


ApplyUserSettings Method

[image]

MADCAT Software Developer Guide
IRenderer..::..ApplyUserSettings Method
IRenderer Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Invoked by MADCAT to pass the user settings of the renderer coming from the user profile

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
void ApplyUserSettings(
    Object Settings
)
Visual Basic
Sub ApplyUserSettings ( _
    Settings As Object _
)
Visual C++
void ApplyUserSettings(
    Object^ Settings
)

Parameters

Settings
Type: System..::..Object
Object which contains the renderer configuration attached to the current user profile. This object is the one returned by the renderer with the method GetUserSettings()()()() the last time the renderer was invoked.

Examples

This example shows how to implement this method.
CopyC++
void Renderer::ApplyUserSettings(Object ^Settings)
{
   Hashtable ^opt;
   if(Settings)
   {
       // The content of this table has been set previously by the renderer with the method GetUserSettings.
       opt = (Hashtable ^)Settings;
       try
       {
           this->is_recursive->Value = (String ^)opt[L"recursive"];
           this->refreshRate->Value = (String ^)opt[L"refreshrate"];
           this->targetName->Value = (String ^)opt[L"target"];
       }
       catch(Exception ^)
       {
       }
   }
};

See Also

IRenderer Interface
IRenderer Members
RendererInterfaces Namespace


GetUserSettings Method

[image]

MADCAT Software Developer Guide
IRenderer..::..GetUserSettings Method
IRenderer Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Invoked by MADCAT to get the user settings of the renderer which must be saved in the user profile

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
Object GetUserSettings()
Visual Basic
Function GetUserSettings As Object
Visual C++
Object^ GetUserSettings()

Return Value

Object which contains the renderer configuration attached to the current user profile. This object is the one built by the renderer and will be returned with the method ApplyUserSettings(Object) the next time the renderer will be invoked.

Examples

This example shows how to implement this method.
CopyC++
Object ^Renderer::GetUserSettings()
{
   Hashtable   ^opt = gcnew Hashtable();

   // Build a table to save the settings we want. It will be used later by the method ApplyUserSettings.
   opt[L"recursive"] = this->is_recursive->Value;
   opt[L"refreshrate"] = this->refreshRate->Value;
   opt[L"target"] = this->targetName->Value;
   return opt;
};

See Also

IRenderer Interface
IRenderer Members
RendererInterfaces Namespace


Init Method

[image]

MADCAT Software Developer Guide
IRenderer..::..Init Method
IRenderer Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Invoked by MADCAT to initialize the renderer by giving it its context

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
void Init(
    IRendererContext Context
)
Visual Basic
Sub Init ( _
    Context As IRendererContext _
)
Visual C++
void Init(
    IRendererContext^ Context
)

Parameters

Context
Type: RendererInterfaces..::..IRendererContext
Context of the renderer. Contains all informations and interfaces needed by the renderer to display the items.

See Also

IRenderer Interface
IRenderer Members
RendererInterfaces Namespace


RenderHTML Method

[image]

MADCAT Software Developer Guide
IRenderer..::..RenderHTML Method
IRenderer Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Invoked by MADCAT to get the HTML code which can be used to display the items in a Web browser (not used for the moment)

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
string RenderHTML()
Visual Basic
Function RenderHTML As String
Visual C++
String^ RenderHTML()

Return Value

HTML code (not implemented)

See Also

IRenderer Interface
IRenderer Members
RendererInterfaces Namespace


SetMode Method

[image] [image]

MADCAT Software Developer Guide
IRenderer..::..SetMode Method
IRenderer Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | SetMode(String) | Invoked by MADCAT to change the mode of the renderer with no options
Public method | SetMode(String, String) | Invoked by MADCAT to change the mode of the renderer and give mode's options

See Also

IRenderer Interface
IRenderer Members
RendererInterfaces Namespace


SetMode Method (String)

[image]

MADCAT Software Developer Guide
IRenderer..::..SetMode Method (String)
IRenderer Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Invoked by MADCAT to change the mode of the renderer with no options

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
void SetMode(
    string Name
)
Visual Basic
Sub SetMode ( _
    Name As String _
)
Visual C++
void SetMode(
    String^ Name
)

Parameters

Name
Type: System..::..String
Mode name

See Also

IRenderer Interface
IRenderer Members
SetMode Overload
RendererInterfaces Namespace


SetMode Method (String, String)

[image]

MADCAT Software Developer Guide
IRenderer..::..SetMode Method (String, String)
IRenderer Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Invoked by MADCAT to change the mode of the renderer and give mode's options

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
void SetMode(
    string Name,
    string Options
)
Visual Basic
Sub SetMode ( _
    Name As String, _
    Options As String _
)
Visual C++
void SetMode(
    String^ Name,
    String^ Options
)

Parameters

Name
Type: System..::..String
Mode name
Options
Type: System..::..String
String with mode's options. Options are written this way : option=value,option=value,...

See Also

IRenderer Interface
IRenderer Members
SetMode Overload
RendererInterfaces Namespace


ShowOptionDialog Method

[image]

MADCAT Software Developer Guide
IRenderer..::..ShowOptionDialog Method
IRenderer Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Invoked by MADCAT when the user wants to open the configuration panel of the renderer (optional)

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
void ShowOptionDialog()
Visual Basic
Sub ShowOptionDialog
Visual C++
void ShowOptionDialog()

See Also

IRenderer Interface
IRenderer Members
RendererInterfaces Namespace


Terminate Method

[image]

MADCAT Software Developer Guide
IRenderer..::..Terminate Method
IRenderer Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Invoked by MADCAT before killing the renderer. The renderer shall release all the allocated objects, events, ....

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
void Terminate()
Visual Basic
Sub Terminate
Visual C++
void Terminate()

Examples

This example shows how to implement this method. It is important to unsuscribe all the events of the explorer window. Otherwise, exceptions will occur when events will be fired because your object won't exist anymore.
CopyC++
void Renderer::Init(IRendererContext ^Context)
{
   // Create 2 delegates to handle explorer window events.
   this->RICHdl = gcnew IWorkspaceForm::DisplayEventHandler(this, &Renderer::RootItemChangedHandler);
   this->ItmHdl = gcnew IWorkspaceForm::ItemEventHandler(this, &Renderer::ItemHandler);

   // Suscribe to all explorer window events
   Context->ParentForm->RootItemChanged += this->RICHdl;
   Context->ParentForm->ItemAdded += this->ItmHdl;
   Context->ParentForm->ItemChanged += this->ItmHdl;
   Context->ParentForm->ItemDeleted += this->ItmHdl;
   Context->ParentForm->ItemUnDeleted += this->ItmHdl;
}

void Renderer::Terminate()
{
   // Unsuscribe from all events. All the delegates have been previously saved into private variables
   this->myContext->ParentForm->RootItemChanged -= this->RICHdl;
   this->myContext->ParentForm->ItemAdded -= this->ItmHdl;
   this->myContext->ParentForm->ItemChanged -= this->ItmHdl;
   this->myContext->ParentForm->ItemDeleted -= this->ItmHdl;
   this->myContext->ParentForm->ItemUnDeleted -= this->ItmHdl;
};

See Also

IRenderer Interface
IRenderer Members
RendererInterfaces Namespace


IRenderer Properties

[image] [image]

MADCAT Software Developer Guide
IRenderer Properties
IRenderer Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IRenderer type exposes the following members.

Properties

 | Name | Description
Public property | Items | Invoked by MADCAT to get the list of items actually displayed by the renderer
Public property | Mode | Invoked by MADCAT to get the current display mode of the renderer
Public property | ParentItem | Invoked by MADCAT to get the parent Item of the renderer's listed items
Public property | SelectedItems | Invoked by MADCAT to get the list of items the user has selected using the renderer interface

See Also

IRenderer Interface
RendererInterfaces Namespace


Items Property

[image]

MADCAT Software Developer Guide
IRenderer..::..Items Property
IRenderer Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Invoked by MADCAT to get the list of items actually displayed by the renderer

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
ArrayList Items { get; }
Visual Basic
ReadOnly Property Items As ArrayList
    Get
Visual C++
property ArrayList^ Items {
    ArrayList^ get ();
}

See Also

IRenderer Interface
IRenderer Members
RendererInterfaces Namespace


Mode Property

[image]

MADCAT Software Developer Guide
IRenderer..::..Mode Property
IRenderer Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Invoked by MADCAT to get the current display mode of the renderer

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
string Mode { get; }
Visual Basic
ReadOnly Property Mode As String
    Get
Visual C++
property String^ Mode {
    String^ get ();
}

See Also

IRenderer Interface
IRenderer Members
RendererInterfaces Namespace


ParentItem Property

[image]

MADCAT Software Developer Guide
IRenderer..::..ParentItem Property
IRenderer Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Invoked by MADCAT to get the parent Item of the renderer's listed items

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
XmlNode ParentItem { get; }
Visual Basic
ReadOnly Property ParentItem As XmlNode
    Get
Visual C++
property XmlNode^ ParentItem {
    XmlNode^ get ();
}

See Also

IRenderer Interface
IRenderer Members
RendererInterfaces Namespace


SelectedItems Property

[image]

MADCAT Software Developer Guide
IRenderer..::..SelectedItems Property
IRenderer Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Invoked by MADCAT to get the list of items the user has selected using the renderer interface

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
ArrayList SelectedItems { get; }
Visual Basic
ReadOnly Property SelectedItems As ArrayList
    Get
Visual C++
property ArrayList^ SelectedItems {
    ArrayList^ get ();
}

See Also

IRenderer Interface
IRenderer Members
RendererInterfaces Namespace


IRenderer Events

[image] [image]

MADCAT Software Developer Guide
IRenderer Events
IRenderer Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IRenderer type exposes the following members.

Events

 | Name | Description
Public event | DragOver | Fired by the renderer when the user moves his mouse over the renderer during a drag'n'drop operation
Public event | Drop | Fired by the renderer when the user dropped an object on the renderer area
Public event | ItemDrag | Fired by the renderer when the user initiates a drag'n'drop operation from an item displayed by the renderer
Public event | ItemSelectionChanged | Fired by the renderer when the user performed an action which changes the selection of items
Public event | RootItemChanged | Fired by the renderer when the user performed an action which requires a new root item

See Also

IRenderer Interface
RendererInterfaces Namespace


DragOver Event

[image]

MADCAT Software Developer Guide
IRenderer..::..DragOver Event
IRenderer Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Fired by the renderer when the user moves his mouse over the renderer during a drag'n'drop operation

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
event IWorkspaceForm..::..DragDropEventHandler DragOver
Visual Basic
Event DragOver As IWorkspaceForm..::..DragDropEventHandler
Visual C++
 event IWorkspaceForm..::..DragDropEventHandler^ DragOver {
    void add (IWorkspaceForm..::..DragDropEventHandler^ value);
    void remove (IWorkspaceForm..::..DragDropEventHandler^ value);
}

See Also

IRenderer Interface
IRenderer Members
RendererInterfaces Namespace


Drop Event

[image]

MADCAT Software Developer Guide
IRenderer..::..Drop Event
IRenderer Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Fired by the renderer when the user dropped an object on the renderer area

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
event IWorkspaceForm..::..DragDropEventHandler Drop
Visual Basic
Event Drop As IWorkspaceForm..::..DragDropEventHandler
Visual C++
 event IWorkspaceForm..::..DragDropEventHandler^ Drop {
    void add (IWorkspaceForm..::..DragDropEventHandler^ value);
    void remove (IWorkspaceForm..::..DragDropEventHandler^ value);
}

See Also

IRenderer Interface
IRenderer Members
RendererInterfaces Namespace


ItemDrag Event

[image]

MADCAT Software Developer Guide
IRenderer..::..ItemDrag Event
IRenderer Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Fired by the renderer when the user initiates a drag'n'drop operation from an item displayed by the renderer

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
event IWorkspaceForm..::..DragDropEventHandler ItemDrag
Visual Basic
Event ItemDrag As IWorkspaceForm..::..DragDropEventHandler
Visual C++
 event IWorkspaceForm..::..DragDropEventHandler^ ItemDrag {
    void add (IWorkspaceForm..::..DragDropEventHandler^ value);
    void remove (IWorkspaceForm..::..DragDropEventHandler^ value);
}

See Also

IRenderer Interface
IRenderer Members
RendererInterfaces Namespace


ItemSelectionChanged Event

[image]

MADCAT Software Developer Guide
IRenderer..::..ItemSelectionChanged Event
IRenderer Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Fired by the renderer when the user performed an action which changes the selection of items

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
event IWorkspaceForm..::..SelectionEventHandler ItemSelectionChanged
Visual Basic
Event ItemSelectionChanged As IWorkspaceForm..::..SelectionEventHandler
Visual C++
 event IWorkspaceForm..::..SelectionEventHandler^ ItemSelectionChanged {
    void add (IWorkspaceForm..::..SelectionEventHandler^ value);
    void remove (IWorkspaceForm..::..SelectionEventHandler^ value);
}

See Also

IRenderer Interface
IRenderer Members
RendererInterfaces Namespace


RootItemChanged Event

[image]

MADCAT Software Developer Guide
IRenderer..::..RootItemChanged Event
IRenderer Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Fired by the renderer when the user performed an action which requires a new root item

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
event IWorkspaceForm..::..DisplayEventHandler RootItemChanged
Visual Basic
Event RootItemChanged As IWorkspaceForm..::..DisplayEventHandler
Visual C++
 event IWorkspaceForm..::..DisplayEventHandler^ RootItemChanged {
    void add (IWorkspaceForm..::..DisplayEventHandler^ value);
    void remove (IWorkspaceForm..::..DisplayEventHandler^ value);
}

See Also

IRenderer Interface
IRenderer Members
RendererInterfaces Namespace


IRendererContext Interface

[image]

MADCAT Software Developer Guide
IRendererContext Interface
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Interface used by Renderers to retrieve all relevant information about their context Most important, it provides services to get items which has to be rendered.

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
public interface IRendererContext
Visual Basic
Public Interface IRendererContext
Visual C++
public interface class IRendererContext

See Also

IRendererContext Members
RendererInterfaces Namespace


IRendererContext Members

[image] [image]

MADCAT Software Developer Guide
IRendererContext Members
IRendererContext Interface Methods Properties See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IRendererContext type exposes the following members.

Methods

 | Name | Description
Public method | GetUserConfig | This method returns the list of global parameters and their values for a renderer. Values are taken from the user profile. These parameters are modified by the user when he activates the configuration panel with the command "Options" of the menu of the main window of MADCAT.
Public method | SetUserConfig | This method saves in the user profile the list of global parameters and their values for a renderer. These parameters are modified by the user when he activates the configuration panel with the command "Options" of the menu of the main window of MADCAT.

Properties

 | Name | Description
Public property | DataContext | DataPacket object which contains the items to render
Public property | Log | Provides the interface the renderer must use to log messages in MADCAT logbooks if needed. See example for tools in IProcessContext
Public property | Menu | Provides the menu strip where the renderer can add its own buttons
Public property | ParentControl | Provides the parent control the renderer shall place its controls into
Public property | ParentForm | Provides the IWorkspaceForm interface which can be used by the renderer to invoke services provided by the database explorer

See Also

IRendererContext Interface
RendererInterfaces Namespace


IRendererContext Methods

[image] [image]

MADCAT Software Developer Guide
IRendererContext Methods
IRendererContext Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IRendererContext type exposes the following members.

Methods

 | Name | Description
Public method | GetUserConfig | This method returns the list of global parameters and their values for a renderer. Values are taken from the user profile. These parameters are modified by the user when he activates the configuration panel with the command "Options" of the menu of the main window of MADCAT.
Public method | SetUserConfig | This method saves in the user profile the list of global parameters and their values for a renderer. These parameters are modified by the user when he activates the configuration panel with the command "Options" of the menu of the main window of MADCAT.

See Also

IRendererContext Interface
RendererInterfaces Namespace


GetUserConfig Method

[image]

MADCAT Software Developer Guide
IRendererContext..::..GetUserConfig Method
IRendererContext Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This method returns the list of global parameters and their values for a renderer. Values are taken from the user profile. These parameters are modified by the user when he activates the configuration panel with the command "Options" of the menu of the main window of MADCAT.

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
void GetUserConfig(
    IParameter[] Parameters
)
Visual Basic
Sub GetUserConfig ( _
    Parameters As IParameter() _
)
Visual C++
void GetUserConfig(
    array<IParameter^>^ Parameters
)

Parameters

Parameters
Type: array< Parameters..::..IParameter >[]()[][]
Array of parameters. Empty when calling the method, it is filled with the parameters by the method. It remains empty if no parameters are found in the user profile.

See Also

IRendererContext Interface
IRendererContext Members
RendererInterfaces Namespace
IRendererContext..::..SetUserConfig(array<IParameter>[]()[][])


SetUserConfig Method

[image]

MADCAT Software Developer Guide
IRendererContext..::..SetUserConfig Method
IRendererContext Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This method saves in the user profile the list of global parameters and their values for a renderer. These parameters are modified by the user when he activates the configuration panel with the command "Options" of the menu of the main window of MADCAT.

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
void SetUserConfig(
    IParameter[] Parameters
)
Visual Basic
Sub SetUserConfig ( _
    Parameters As IParameter() _
)
Visual C++
void SetUserConfig(
    array<IParameter^>^ Parameters
)

Parameters

Parameters
Type: array< Parameters..::..IParameter >[]()[][]
Array of parameters filled with the parameters and their values.

See Also

IRendererContext Interface
IRendererContext Members
RendererInterfaces Namespace
IRendererContext..::..GetUserConfig(array<IParameter>[]()[][])


IRendererContext Properties

[image] [image]

MADCAT Software Developer Guide
IRendererContext Properties
IRendererContext Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IRendererContext type exposes the following members.

Properties

 | Name | Description
Public property | DataContext | DataPacket object which contains the items to render
Public property | Log | Provides the interface the renderer must use to log messages in MADCAT logbooks if needed. See example for tools in IProcessContext
Public property | Menu | Provides the menu strip where the renderer can add its own buttons
Public property | ParentControl | Provides the parent control the renderer shall place its controls into
Public property | ParentForm | Provides the IWorkspaceForm interface which can be used by the renderer to invoke services provided by the database explorer

See Also

IRendererContext Interface
RendererInterfaces Namespace


DataContext Property

[image]

MADCAT Software Developer Guide
IRendererContext..::..DataContext Property
IRendererContext Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
DataPacket object which contains the items to render

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
DataPacket DataContext { get; }
Visual Basic
ReadOnly Property DataContext As DataPacket
    Get
Visual C++
property DataPacket^ DataContext {
    DataPacket^ get ();
}

See Also

IRendererContext Interface
IRendererContext Members
RendererInterfaces Namespace


Log Property

[image]

MADCAT Software Developer Guide
IRendererContext..::..Log Property
IRendererContext Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Provides the interface the renderer must use to log messages in MADCAT logbooks if needed. See example for tools in IProcessContext

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
ILogbookWriter Log { get; }
Visual Basic
ReadOnly Property Log As ILogbookWriter
    Get
Visual C++
property ILogbookWriter^ Log {
    ILogbookWriter^ get ();
}

See Also

IRendererContext Interface
IRendererContext Members
RendererInterfaces Namespace


Menu Property

[image]

MADCAT Software Developer Guide
IRendererContext..::..Menu Property
IRendererContext Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Provides the menu strip where the renderer can add its own buttons

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
ContextMenuStrip Menu { get; }
Visual Basic
ReadOnly Property Menu As ContextMenuStrip
    Get
Visual C++
property ContextMenuStrip^ Menu {
    ContextMenuStrip^ get ();
}

See Also

IRendererContext Interface
IRendererContext Members
RendererInterfaces Namespace


ParentControl Property

[image]

MADCAT Software Developer Guide
IRendererContext..::..ParentControl Property
IRendererContext Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Provides the parent control the renderer shall place its controls into

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
Panel ParentControl { get; }
Visual Basic
ReadOnly Property ParentControl As Panel
    Get
Visual C++
property Panel^ ParentControl {
    Panel^ get ();
}

Examples

This example shows how to add new controls into the explorer's rendering panel (the panel which is on the right of the explorer tree). We use the parameter "Group of fields" to display informations using a list of parameters which will be embedded inside dynamically each time the user will change the current item with the explorer tree.
CopyC++
void Renderer::Init(IRendererContext ^Context)
{
   Hashtable   ^opts;
   Control     ^ctrl;
   ToolTip     ^tip;

   // Init the group of fields and add it to the parent control
   GroupOfFields ^myFields = gcnew GroupOfFields();
   myFields->Name = L"MYFIELDS";
   myFields->Description = L"Item properties";
   myFields->Tip = gcnew ToolTip();
   opts = gcnew Hashtable();
   opts[L"expandable"] = L"no";
   opts[L"orientation"] = L"vertical";
   myFields->Options = opts;

   // Gets the control associated to the group of fields
   ctrl = myFields->FormControl;
   ctrl->Dock = DockStyle::Fill;

   // Now add this control into the explorer panel
   Context->ParentControl->Controls->Add(ctrl);
}

See Also

IRendererContext Interface
IRendererContext Members
RendererInterfaces Namespace


ParentForm Property

[image]

MADCAT Software Developer Guide
IRendererContext..::..ParentForm Property
IRendererContext Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Provides the IWorkspaceForm interface which can be used by the renderer to invoke services provided by the database explorer

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
IWorkspaceForm ParentForm { get; }
Visual Basic
ReadOnly Property ParentForm As IWorkspaceForm
    Get
Visual C++
property IWorkspaceForm^ ParentForm {
    IWorkspaceForm^ get ();
}

See Also

IRendererContext Interface
IRendererContext Members
RendererInterfaces Namespace


RenderersToolBox Class

[image]

MADCAT Software Developer Guide
RenderersToolBox Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This class contains static functions which can be used by renderers' coders to perform frequent operations easily

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
public class RenderersToolBox
Visual Basic
Public Class RenderersToolBox
Visual C++
public ref class RenderersToolBox

Inheritance Hierarchy

System..::..Object
RendererInterfaces..::..RenderersToolBox

See Also

RenderersToolBox Members
RendererInterfaces Namespace


RenderersToolBox Members

[image] [image]

MADCAT Software Developer Guide
RenderersToolBox Members
RenderersToolBox Class Constructors Methods See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The RenderersToolBox type exposes the following members.

Constructors

 | Name | Description
Public method | RenderersToolBox | Constructor

Methods

Name | Description
DecodeOptions | Function used to decode an option string coming from a model

See Also

RenderersToolBox Class
RendererInterfaces Namespace


RenderersToolBox Constructor

[image]

MADCAT Software Developer Guide
RenderersToolBox Constructor
RenderersToolBox Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
public RenderersToolBox()
Visual Basic
Public Sub New
Visual C++
public:
RenderersToolBox()

See Also

RenderersToolBox Class
RenderersToolBox Members
RendererInterfaces Namespace


RenderersToolBox Methods

[image] [image]

MADCAT Software Developer Guide
RenderersToolBox Methods
RenderersToolBox Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The RenderersToolBox type exposes the following members.

Methods

Name | Description
DecodeOptions | Function used to decode an option string coming from a model

See Also

RenderersToolBox Class
RendererInterfaces Namespace


DecodeOptions Method

[image]

MADCAT Software Developer Guide
RenderersToolBox..::..DecodeOptions Method
RenderersToolBox Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Function used to decode an option string coming from a model

Namespace: RendererInterfaces
Assembly: RendererInterfaces (in RendererInterfaces.dll) Version: 1.0.4787.39866

Syntax

C#
public static Hashtable DecodeOptions(
    string Options
)
Visual Basic
Public Shared Function DecodeOptions ( _
    Options As String _
) As Hashtable
Visual C++
public:
static Hashtable^ DecodeOptions(
    String^ Options
)

Parameters

Options
Type: System..::..String
String which contains the options' values

Return Value

Hashtable where keys are options' names and values are the values of the options

See Also

RenderersToolBox Class
RenderersToolBox Members
RendererInterfaces Namespace


ToolInterfaces Namespace

[image]

MADCAT Software Developer Guide
ToolInterfaces Namespace
Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Interfaces for Tools This namespace gathers all the interfaces used by the Tools to access data and models of a workspace.

Classes

Class Description
Public class BaselineEventArgs
Arguments sent to the handler of baseline's events
Public class DataPacket
This class is used by MADCAT to share with external components such as tools, renderers and other MADCAT instances This class provides methods and properties to :
  • read/modify/delete data in projects
  • read data from any baseline of a project
  • get informations about items' definition from models
Public class IWorkspaceForm..::..DisplayEventArgs
This class is used to pass arguments to event handlers. This is used for the following events : RootItemChanged by the delegate DisplayEventHandler.
Public class IWorkspaceForm..::..DragDropEventArgs
This class is used to pass arguments to event handlers. This is used for the following events : TBD by the delegate DragDropEventHandler.
Public class IWorkspaceForm..::..ItemEventArgs
This class is used to pass arguments to event handlers. This is used for the following events : ItemAdded, ItemChanged, ItemDeleted and ItemUndeleted by the delegate ItemEventHandler.
Public class IWorkspaceForm..::..SelectionEventArgs
This class is used to pass arguments to event handlers. This is used for the following events : SelectionChanged, ClipboardChanged and SelectionPaste by the delegate SelectionEventHandler.
Public class IWorkspaceForm..::..ToolBarItemCollection
This class manages the ToolStripItems which appears in the explorer form. Renderers should use this class to add new tool bars to explorers.
Public class ProjectHandler
Handler that defines the location of a data repository which can be loaded in a workspace

Interfaces

Interface Description
Public interface IBaseline
This interfaces provides methods to get informations about a baseline This interface must be used to get useful informations about a baseline. Baselines are snapshots of all the project's data. They are created by the end-user. They can be used to trace modifications performed on critical data. User can recall any baseline to read/compare data. This interface can be retrieved by using objects exposing the IBaselineManager interface.
Public interface IBaselineManager
This interface shall be used to switch from one baseline to another This interface is exposed by DataPacket objects. With this interface, you can change the baseline of the data packet and get all the data related to the packet at different moment of the project.
Public interface IDatabase
This interfaces provides methods to get the source of data and the related model. This interface must be used to get and handle data of a database.
Public interface IDataManager
This interfaces provides methods to manage models and data of a workspace This interface must be used to get models of a workspace and to find/create/edit items in your project.
Public interface IDataModel
This interfaces provides methods to get models data This interface must be used to get detailed informations about models of a workspace. Methods can give definitions of any element of the model which exposes this interface.
Public interface IDataSource
This interfaces provides methods to manage raw Xml data of a database.
Public interface IProcessContext
Main interface between a tool and MADCAT. Gives access to all the functionalities of MADCAT and to the data which should be processed by the tool. This interface gathers all the data and methods needed by a tool to perform any actions. It provides access to all the functionalities of MADCAT such as :
  • Logbook manager : used to log informations, warnings, errors. See interface ILogbookWriter
  • Progress management : used to indicate the progress of an action.
  • Workspace : used to control display, read/write user preferences, activate wizards, start other workspaces. See interface IWorkspace
  • Data management : used to create/modify/delete data with baselines, models. See class DataPacket.
Public interface ITool
Interface which must be implemented by tools of MADCAT. This is the entry point of the tool for MADCAT; the interface used by MADCAT to control the tool and perform actions with it.
Public interface IWorkspace
Interface exposed by any workspace in MADCAT Any workspace exposes this interface. It can be used to control the user interface and access any element of the workspace such as : actions, items, user preferences, forms layouts, ...
Public interface IWorkspaceForm
Use this interface to control database explorer forms or capture events generated by them. All database explorer forms expose this interface. It is mainly used by renderers for integration with MADCAT.

Delegates

 | Delegate | Description
Public delegate | IProcessContext..::..EventHandler | Prototype for handlers for the user events Cancel/Pause/Resume
Public delegate | IWorkspace..::..AccessRightsEventHandler | Delegate for handlers for User access rights changes
Public delegate | IWorkspace..::..BaselineEventHandler | Delegate for handlers for Baseline's events
Public delegate | IWorkspace..::..DatabaseEventHandler | Delegate for handlers for Database's events
Public delegate | IWorkspace..::..ProjectReloadedEventHandler | Use this delegate to subscribe to the ProjectReloaded event fired by the DataManager when one XML file of the project of the current workspace has been modified by an external program and XML data has been entirely reloaded by the user.
Public delegate | IWorkspaceForm..::..DisplayEventHandler | Delegate used for the following events : RootItemChanged
Public delegate | IWorkspaceForm..::..DragDropEventHandler | Delegate used for the following events : TBD
Public delegate | IWorkspaceForm..::..EventHandler | Delegate used for the following events : Refresh
Public delegate | IWorkspaceForm..::..ItemEventHandler | Delegate used for the following events : ItemAdded, ItemChanged, ItemDeleted and ItemUnDeleted
Public delegate | IWorkspaceForm..::..SelectionEventHandler | Delegate used for the following events : SelectionChanged, ClipboardChanged and SelectionPaste

Enumerations

 | Enumeration | Description
Public enumeration | BaselineEventType | Enumerates the events which can occur on a baseline
Public enumeration | BaselineState | Enumerates the states of a baseline
Public enumeration | ExecutionResult | Enumerate used by the tools to indicate the result of the execution of an action.
Public enumeration | InitResult | Enumerate used by the tools to indicate if an action has been successfully initialized and then can be executed by MADCAT. Actions are a 2-steps process : Init and Run. During "Init", the tool checks the execution context, prepare some data for the requested action or ask the user for additional data using Wizards. If any prerequisite is missing, execution can be avoided by returning an error during the "Init phase". Another possibility is too schedule the action later. For example, if a shared resource is not available when action is requested and this resource is mandatory, the tool can asked MADCAT to schedule the action when the current action using the resource will be over.


BaselineEventArgs Class

[image]

MADCAT Software Developer Guide
BaselineEventArgs Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Arguments sent to the handler of baseline's events

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public class BaselineEventArgs
Visual Basic
Public Class BaselineEventArgs
Visual C++
public ref class BaselineEventArgs

Inheritance Hierarchy

System..::..Object
ToolInterfaces..::..BaselineEventArgs

See Also

BaselineEventArgs Members
ToolInterfaces Namespace


BaselineEventArgs Members

[image] [image]

MADCAT Software Developer Guide
BaselineEventArgs Members
BaselineEventArgs Class Constructors Fields See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BaselineEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | BaselineEventArgs | Constructor

Fields

 | Name | Description
Public field | Item | XML Node related to the event
Public field | Type | Indicates the event which has invoked the handler

See Also

BaselineEventArgs Class
ToolInterfaces Namespace


BaselineEventArgs Constructor

[image]

MADCAT Software Developer Guide
BaselineEventArgs Constructor
BaselineEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public BaselineEventArgs(
    BaselineEventType t,
    XmlNode n
)
Visual Basic
Public Sub New ( _
    t As BaselineEventType, _
    n As XmlNode _
)
Visual C++
public:
BaselineEventArgs(
    BaselineEventType t,
    XmlNode^ n
)

Parameters

t
Type: ToolInterfaces..::..BaselineEventType
Type of baseline event. See BaselineEventType.
n
Type: System.Xml..::..XmlNode
Xml data of the item on which the event occured

See Also

BaselineEventArgs Class
BaselineEventArgs Members
ToolInterfaces Namespace


BaselineEventArgs Fields

[image] [image]

MADCAT Software Developer Guide
BaselineEventArgs Fields
BaselineEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The BaselineEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | Item | XML Node related to the event
Public field | Type | Indicates the event which has invoked the handler

See Also

BaselineEventArgs Class
ToolInterfaces Namespace


Item Field

[image]

MADCAT Software Developer Guide
BaselineEventArgs..::..Item Field
BaselineEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
XML Node related to the event

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public XmlNode Item
Visual Basic
Public Item As XmlNode
Visual C++
public:
XmlNode^ Item

See Also

BaselineEventArgs Class
BaselineEventArgs Members
ToolInterfaces Namespace


Type Field

[image]

MADCAT Software Developer Guide
BaselineEventArgs..::..Type Field
BaselineEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Indicates the event which has invoked the handler

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public BaselineEventType Type
Visual Basic
Public Type As BaselineEventType
Visual C++
public:
BaselineEventType Type

See Also

BaselineEventArgs Class
BaselineEventArgs Members
ToolInterfaces Namespace


BaselineEventType Enumeration

[image]

MADCAT Software Developer Guide
BaselineEventType Enumeration
See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Enumerates the events which can occur on a baseline

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public enum BaselineEventType
Visual Basic
Public Enumeration BaselineEventType
Visual C++
public enum class BaselineEventType

Members

Member name | Value | Description
ChangeReference | 7 | The reference of the baseline indicators has changed
Save | 5 | Content of a baseline has been saved
Open | 4 | A baseline is opened
UndeleteChild | 3 | A deleted child has been undeleted
DeleteChild | 2 | A child has been deleted
Edit | 1 | The value of an attribute of a node has been modified
AddChild | 0 | A child has been added to a node
Close | 6 | A baseline has been closed. Data is now read-only

See Also

ToolInterfaces Namespace


BaselineState Enumeration

[image]

MADCAT Software Developer Guide
BaselineState Enumeration
See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Enumerates the states of a baseline

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public enum BaselineState
Visual Basic
Public Enumeration BaselineState
Visual C++
public enum class BaselineState

Members

Member name | Value | Description
Closed | 1 | Baseline is closed. Data is read-only
Open | 0 | Baseline is opened. Data can be changed

See Also

ToolInterfaces Namespace


DataPacket Class

[image]

MADCAT Software Developer Guide
DataPacket Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This class is used by MADCAT to share with external components such as tools, renderers and other MADCAT instances This class provides methods and properties to :
  • read/modify/delete data in projects
  • read data from any baseline of a project
  • get informations about items' definition from models

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
[SerializableAttribute]
public class DataPacket : ICloneable, IDataManager,
    IBaselineManager
Visual Basic
<SerializableAttribute> _
Public Class DataPacket _
    Implements ICloneable, IDataManager, IBaselineManager
Visual C++
[SerializableAttribute]
public ref class DataPacket : ICloneable,
    IDataManager, IBaselineManager

Inheritance Hierarchy

System..::..Object
ToolInterfaces..::..DataPacket

See Also

DataPacket Members
ToolInterfaces Namespace


DataPacket Members

[image] [image]

MADCAT Software Developer Guide
DataPacket Members
DataPacket Class Constructors Methods Fields Properties See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The DataPacket type exposes the following members.

Constructors

 | Name | Description
Public method | DataPacket()()()() | Constructor
Public method | DataPacket(IDataManager, ArrayList) | Constructor Creates a DataPacket object filled with items

Methods

Name Description
Public method AddItemInSeries
Creates a XML node in a given series. This method creates a XML node in the project document related to the model. The XML node will be a child of the XML series node if Series is not null.
Public method Clone
Clones the DataPacket object. Creates a new instance of the DataPacket with the exact same properties
Public method CreateItem
Creates a XML node This method creates a XML node in the project document related to the model. The XML node will be a child of the XML parent node if Parent is not null. Otherwise, the node will be the root node of the project XML document.
Public method CreateLink
Creates a XML link node This method creates a XML link node which will refer to the given target XML node. The XML link node will be a child of the XML parent node if Parent is not null. Otherwise, link will be the root node of a XML document.
Public method CreateSeries
Creates a XML node for series This method creates a XML node in the project document related to the model. The XML node will be a child of the XML parent node if Parent is not null. Otherwise, the node will be the root node of the project XML document. This node is the parent of all the items that will be added in the series.
Public method EditItem
Signals the modification of a XML node This method signals an XML node modification to MADCAT. Modification will be recorded in baseline history (if workspace has activated baselines) or the undo/redo stack of MADCAT.
Public method GetAllItemsOrdered
Retrieves all the XML nodes of a given series. This method sorts the items by index value and returns the list of items in an ArrayList object.
Public method GetBaseline
Gets the IBaseline interface of the baseline of the given XML node Use this interface to get more informations about the item such as :
  • the name of the current baseline
  • the parent baselines
Public method GetDatabase
Gets the IDatabase interface of the given XML node The IDatabase interface is needed to browse the database where the given item is stored.
Public method GetDatabaseByTitle
Gets the IDatabase interface which has the given title The IDatabase interface is needed to browse the database.
Public method GetItemInSeries
Retrieves a XML node from a given series. This method finds the XML node having the given index in the series and returns it.
Public method GetModel(String)
Gets the IDataModel interface of a model This method returns the IDataModel interface of the model
Public method GetModel(XmlNode)
Gets the IDataModel interface of the model of a given XML node This method returns the IDataModel interface of the model which defines the given XML node. Use this interface to get more informations about the item such as :
  • its attributes
  • its actions
  • its graphical properties (icons, description)
  • ...
Public method GetNodeById
Finds a XML node by its ID Use this method to find a XML node in the active project with its ID. ID shall be compliant with the following format : 99,MODEL where :
  • 99 : is a digit
  • MODEL : is the name of the model of the XML node
Public method PerformSearch
Executes a query using a XPath expression from a given XML node Use this method to find XML nodes matching a given XPath expression. Query is executed within the given root node so results are child nodes of root.
Public method RemoveItemFromSeries
Retrieves a XML node from a given series. This method finds the given XML node in the series and deletes it.
Public method RemoveItemFromSeriesByIndex
Removes a XML node from a given series. This method finds the XML node having the given index in the series and deletes it.
Public method ResolveDataLink
Finds the XML node referenced by a given link node Use this method to get the XML node referenced by a XML link node.
Public method SwitchToBaseline
Change the baseline of the DataPacket object When this method returns true, the DataPacket shows the data saved in the requested baseline. Otherwise, nothing is changed. This method doesn't change the baseline seen by the user in MADCAT. It can be used in tools to access the data of any baseline. Data is always read-only when the baseline is not the current.
Public method SwitchToCurrentBaseline
Sets the baseline of the DataPacket object to the current baseline When this method returns true, the DataPacket shows the current data of the project. Otherwise, nothing is changed. This method doesn't change the baseline seen by the user in MADCAT. It can be used in tools to return to the current data of the project after a baseline change. Data can be modified when returning to current baseline.
ToByte
Serializes the DataPacket into a stream of Bytes
ToObject
DeSerializes a stream of Bytes into a DataPacket instance

Fields

 | Name | Description
Public field | Items | Main data container : Array of XmlNode objects which are representing the XML data of the packet
Public field | StrItems | Secondary data container : Array of String objects which are representing the XML data of the packet. Used for serialization.

Properties

 | Name | Description
Public property | Baseline | Interface of the working baseline of the current data packet.
Public property | Databases | Array of interfaces to all the databases of the current workspace (Read-only) This property gives an array of IDatabase interfaces. Use them to get data items.
Public property | Manager | IDataManager interface of the source workspace. Use this interface to search/create/edit/delete items or links in the packet
Public property | Models | Array of IDataModel interfaces. All the models of the source workspace are exposed here. Use this array to get informations about items' definition
Public property | ProjectPath | Absolute path of the project where the data comes from
Public property | Projects | Not used

See Also

DataPacket Class
ToolInterfaces Namespace


DataPacket Constructor

[image] [image]

MADCAT Software Developer Guide
DataPacket Constructor
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | DataPacket()()()() | Constructor
Public method | DataPacket(IDataManager, ArrayList) | Constructor Creates a DataPacket object filled with items

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


DataPacket Constructor

[image]

MADCAT Software Developer Guide
DataPacket Constructor
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public DataPacket()
Visual Basic
Public Sub New
Visual C++
public:
DataPacket()

See Also

DataPacket Class
DataPacket Members
DataPacket Overload
ToolInterfaces Namespace


DataPacket Constructor (IDataManager, ArrayList)

[image]

MADCAT Software Developer Guide
DataPacket Constructor (IDataManager, ArrayList)
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor Creates a DataPacket object filled with items

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public DataPacket(
    IDataManager Source,
    ArrayList Nodes
)
Visual Basic
Public Sub New ( _
    Source As IDataManager, _
    Nodes As ArrayList _
)
Visual C++
public:
DataPacket(
    IDataManager^ Source,
    ArrayList^ Nodes
)

Parameters

Source
Type: ToolInterfaces..::..IDataManager
Data manager which owns the items put in the data packet
Nodes
Type: System.Collections..::..ArrayList
Array of items to place in the data packet

See Also

DataPacket Class
DataPacket Members
DataPacket Overload
ToolInterfaces Namespace


DataPacket Fields

[image] [image]

MADCAT Software Developer Guide
DataPacket Fields
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The DataPacket type exposes the following members.

Fields

 | Name | Description
Public field | Items | Main data container : Array of XmlNode objects which are representing the XML data of the packet
Public field | StrItems | Secondary data container : Array of String objects which are representing the XML data of the packet. Used for serialization.

See Also

DataPacket Class
ToolInterfaces Namespace


Items Field

[image]

MADCAT Software Developer Guide
DataPacket..::..Items Field
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Main data container : Array of XmlNode objects which are representing the XML data of the packet

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
[NonSerializedAttribute]
public ArrayList Items
Visual Basic
<NonSerializedAttribute> _
Public Items As ArrayList
Visual C++
public:
[NonSerializedAttribute]
ArrayList^ Items

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


StrItems Field

[image]

MADCAT Software Developer Guide
DataPacket..::..StrItems Field
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Secondary data container : Array of String objects which are representing the XML data of the packet. Used for serialization.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public ArrayList StrItems
Visual Basic
Public StrItems As ArrayList
Visual C++
public:
ArrayList^ StrItems

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


DataPacket Methods

[image] [image]

MADCAT Software Developer Guide
DataPacket Methods
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The DataPacket type exposes the following members.

Methods

Name Description
Public method AddItemInSeries
Creates a XML node in a given series. This method creates a XML node in the project document related to the model. The XML node will be a child of the XML series node if Series is not null.
Public method Clone
Clones the DataPacket object. Creates a new instance of the DataPacket with the exact same properties
Public method CreateItem
Creates a XML node This method creates a XML node in the project document related to the model. The XML node will be a child of the XML parent node if Parent is not null. Otherwise, the node will be the root node of the project XML document.
Public method CreateLink
Creates a XML link node This method creates a XML link node which will refer to the given target XML node. The XML link node will be a child of the XML parent node if Parent is not null. Otherwise, link will be the root node of a XML document.
Public method CreateSeries
Creates a XML node for series This method creates a XML node in the project document related to the model. The XML node will be a child of the XML parent node if Parent is not null. Otherwise, the node will be the root node of the project XML document. This node is the parent of all the items that will be added in the series.
Public method EditItem
Signals the modification of a XML node This method signals an XML node modification to MADCAT. Modification will be recorded in baseline history (if workspace has activated baselines) or the undo/redo stack of MADCAT.
Public method GetAllItemsOrdered
Retrieves all the XML nodes of a given series. This method sorts the items by index value and returns the list of items in an ArrayList object.
Public method GetBaseline
Gets the IBaseline interface of the baseline of the given XML node Use this interface to get more informations about the item such as :
  • the name of the current baseline
  • the parent baselines
Public method GetDatabase
Gets the IDatabase interface of the given XML node The IDatabase interface is needed to browse the database where the given item is stored.
Public method GetDatabaseByTitle
Gets the IDatabase interface which has the given title The IDatabase interface is needed to browse the database.
Public method GetItemInSeries
Retrieves a XML node from a given series. This method finds the XML node having the given index in the series and returns it.
Public method GetModel(String)
Gets the IDataModel interface of a model This method returns the IDataModel interface of the model
Public method GetModel(XmlNode)
Gets the IDataModel interface of the model of a given XML node This method returns the IDataModel interface of the model which defines the given XML node. Use this interface to get more informations about the item such as :
  • its attributes
  • its actions
  • its graphical properties (icons, description)
  • ...
Public method GetNodeById
Finds a XML node by its ID Use this method to find a XML node in the active project with its ID. ID shall be compliant with the following format : 99,MODEL where :
  • 99 : is a digit
  • MODEL : is the name of the model of the XML node
Public method PerformSearch
Executes a query using a XPath expression from a given XML node Use this method to find XML nodes matching a given XPath expression. Query is executed within the given root node so results are child nodes of root.
Public method RemoveItemFromSeries
Retrieves a XML node from a given series. This method finds the given XML node in the series and deletes it.
Public method RemoveItemFromSeriesByIndex
Removes a XML node from a given series. This method finds the XML node having the given index in the series and deletes it.
Public method ResolveDataLink
Finds the XML node referenced by a given link node Use this method to get the XML node referenced by a XML link node.
Public method SwitchToBaseline
Change the baseline of the DataPacket object When this method returns true, the DataPacket shows the data saved in the requested baseline. Otherwise, nothing is changed. This method doesn't change the baseline seen by the user in MADCAT. It can be used in tools to access the data of any baseline. Data is always read-only when the baseline is not the current.
Public method SwitchToCurrentBaseline
Sets the baseline of the DataPacket object to the current baseline When this method returns true, the DataPacket shows the current data of the project. Otherwise, nothing is changed. This method doesn't change the baseline seen by the user in MADCAT. It can be used in tools to return to the current data of the project after a baseline change. Data can be modified when returning to current baseline.
ToByte
Serializes the DataPacket into a stream of Bytes
ToObject
DeSerializes a stream of Bytes into a DataPacket instance

See Also

DataPacket Class
ToolInterfaces Namespace


AddItemInSeries Method

[image]

MADCAT Software Developer Guide
DataPacket..::..AddItemInSeries Method
DataPacket Class Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Creates a XML node in a given series. This method creates a XML node in the project document related to the model. The XML node will be a child of the XML series node if Series is not null.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public virtual XmlNode AddItemInSeries(
    XmlNode Series,
    string IndexValue
)
Visual Basic
Public Overridable Function AddItemInSeries ( _
    Series As XmlNode, _
    IndexValue As String _
) As XmlNode
Visual C++
public:
virtual XmlNode^ AddItemInSeries(
    XmlNode^ Series,
    String^ IndexValue
)

Parameters

Series
Type: System.Xml..::..XmlNode
XML node of the series. Can't be null.
IndexValue
Type: System..::..String
Value of the index attached to the new item. Must be compatible with the type of the index of the series. This type can be obtained using the method GetIndexDef of the IDataModel interface.

Return Value

XML node created. nullptr if operation fails.

Implements

IDataManager..::..AddItemInSeries(XmlNode, String)

Examples

This example shows how to use this method in a tool to create a series in the database using the workspace given by MADCAT when tool is initialized.
CopyC++
IDataManager ^dm = wrk->DatabaseManager;

XmlNode ^series = dm->CreateSeries(null,L"OBJECTIVE");

if(series)
{
  // Series has been created so the required database is certainly available and the series is correctly initialized.
  // We can fill it safely by adding items.
  dm->AddItemInSeries(series,L"1");
  dm->AddItemInSeries(series,L"2");
  dm->AddItemInSeries(series,L"3");
}

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


Clone Method

[image]

MADCAT Software Developer Guide
DataPacket..::..Clone Method
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Clones the DataPacket object. Creates a new instance of the DataPacket with the exact same properties

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public virtual Object Clone()
Visual Basic
Public Overridable Function Clone As Object
Visual C++
public:
virtual Object^ Clone()

Return Value

A clone of the current object

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


CreateItem Method

[image]

MADCAT Software Developer Guide
DataPacket..::..CreateItem Method
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Creates a XML node This method creates a XML node in the project document related to the model. The XML node will be a child of the XML parent node if Parent is not null. Otherwise, the node will be the root node of the project XML document.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public virtual XmlNode CreateItem(
    XmlNode Parent,
    string NodeName
)
Visual Basic
Public Overridable Function CreateItem ( _
    Parent As XmlNode, _
    NodeName As String _
) As XmlNode
Visual C++
public:
virtual XmlNode^ CreateItem(
    XmlNode^ Parent,
    String^ NodeName
)

Parameters

Parent
Type: System.Xml..::..XmlNode
XML node which will be the parent of the link. May be null.
NodeName
Type: System..::..String
Name of the model node used to build the XML node. Must correspond to a ITEM node in the model.

Return Value

XML node created. nullptr if operation fails (NodeName is unknown).

Implements

IDataManager..::..CreateItem(XmlNode, String)

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


CreateLink Method

[image]

MADCAT Software Developer Guide
DataPacket..::..CreateLink Method
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Creates a XML link node This method creates a XML link node which will refer to the given target XML node. The XML link node will be a child of the XML parent node if Parent is not null. Otherwise, link will be the root node of a XML document.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public virtual XmlNode CreateLink(
    XmlNode Parent,
    XmlNode Target
)
Visual Basic
Public Overridable Function CreateLink ( _
    Parent As XmlNode, _
    Target As XmlNode _
) As XmlNode
Visual C++
public:
virtual XmlNode^ CreateLink(
    XmlNode^ Parent,
    XmlNode^ Target
)

Parameters

Parent
Type: System.Xml..::..XmlNode
XML node which will be the parent of the link. May be null.
Target
Type: System.Xml..::..XmlNode
XML node which will be referenced by the link

Return Value

XML link node created. nullptr if operation fails.

Implements

IDataManager..::..CreateLink(XmlNode, XmlNode)

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


CreateSeries Method

[image]

MADCAT Software Developer Guide
DataPacket..::..CreateSeries Method
DataPacket Class Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Creates a XML node for series This method creates a XML node in the project document related to the model. The XML node will be a child of the XML parent node if Parent is not null. Otherwise, the node will be the root node of the project XML document. This node is the parent of all the items that will be added in the series.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public virtual XmlNode CreateSeries(
    XmlNode Parent,
    string NodeName
)
Visual Basic
Public Overridable Function CreateSeries ( _
    Parent As XmlNode, _
    NodeName As String _
) As XmlNode
Visual C++
public:
virtual XmlNode^ CreateSeries(
    XmlNode^ Parent,
    String^ NodeName
)

Parameters

Parent
Type: System.Xml..::..XmlNode
XML node which will be the parent of the series. May be null.
NodeName
Type: System..::..String
Name of the model node used to build the XML node for the series. Must correspond to a SERIES node in the model.

Return Value

XML node created. nullptr if operation fails (NodeName is unknown).

Implements

IDataManager..::..CreateSeries(XmlNode, String)

Examples

This example shows how to use this method in a tool to create a series in the database using the workspace given by MADCAT when tool is initialized.
CopyC++
IDataManager ^dm = wrk->DatabaseManager;

XmlNode ^series = dm->CreateSeries(null,L"OBJECTIVE");

if(series)
{
  // Series has been created so the required database is certainly available and the series is correctly initialized.
  // We can fill it safely by adding items.
  dm->AddItemInSeries(series,L"1");
  dm->AddItemInSeries(series,L"2");
  dm->AddItemInSeries(series,L"3");
}

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


EditItem Method

[image]

MADCAT Software Developer Guide
DataPacket..::..EditItem Method
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Signals the modification of a XML node This method signals an XML node modification to MADCAT. Modification will be recorded in baseline history (if workspace has activated baselines) or the undo/redo stack of MADCAT.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public virtual void EditItem(
    XmlNode NewItem,
    XmlNode OldItem
)
Visual Basic
Public Overridable Sub EditItem ( _
    NewItem As XmlNode, _
    OldItem As XmlNode _
)
Visual C++
public:
virtual void EditItem(
    XmlNode^ NewItem,
    XmlNode^ OldItem
)

Parameters

NewItem
Type: System.Xml..::..XmlNode
XML node after modifications.
OldItem
Type: System.Xml..::..XmlNode
XML node before modifications. Use the Clone method of XmlNode class to have a backup of the node before changing its attributes.

Implements

IDataManager..::..EditItem(XmlNode, XmlNode)

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


GetAllItemsOrdered Method

[image]

MADCAT Software Developer Guide
DataPacket..::..GetAllItemsOrdered Method
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Retrieves all the XML nodes of a given series. This method sorts the items by index value and returns the list of items in an ArrayList object.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public virtual ArrayList GetAllItemsOrdered(
    XmlNode Series
)
Visual Basic
Public Overridable Function GetAllItemsOrdered ( _
    Series As XmlNode _
) As ArrayList
Visual C++
public:
virtual ArrayList^ GetAllItemsOrdered(
    XmlNode^ Series
)

Parameters

Series
Type: System.Xml..::..XmlNode
XML node of the series. Can't be null.

Return Value

Array of XML nodes. Array is empty if series has no items. Can never be null.

Implements

IDataManager..::..GetAllItemsOrdered(XmlNode)

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


GetBaseline Method

[image]

MADCAT Software Developer Guide
DataPacket..::..GetBaseline Method
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the IBaseline interface of the baseline of the given XML node Use this interface to get more informations about the item such as :
  • the name of the current baseline
  • the parent baselines

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public virtual IBaseline GetBaseline(
    XmlNode Item
)
Visual Basic
Public Overridable Function GetBaseline ( _
    Item As XmlNode _
) As IBaseline
Visual C++
public:
virtual IBaseline^ GetBaseline(
    XmlNode^ Item
)

Parameters

Item
Type: System.Xml..::..XmlNode
XML node

Return Value

IBaseline interface of the baseline of the XML node

Implements

IBaselineManager..::..GetBaseline(XmlNode)

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


GetDatabase Method

[image]

MADCAT Software Developer Guide
DataPacket..::..GetDatabase Method
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the IDatabase interface of the given XML node The IDatabase interface is needed to browse the database where the given item is stored.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public virtual IDatabase GetDatabase(
    XmlNode Item
)
Visual Basic
Public Overridable Function GetDatabase ( _
    Item As XmlNode _
) As IDatabase
Visual C++
public:
virtual IDatabase^ GetDatabase(
    XmlNode^ Item
)

Parameters

Item
Type: System.Xml..::..XmlNode
XML node

Return Value

IDatabase interface of database where the XML node is

Implements

IDataManager..::..GetDatabase(XmlNode)

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


GetDatabaseByTitle Method

[image]

MADCAT Software Developer Guide
DataPacket..::..GetDatabaseByTitle Method
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the IDatabase interface which has the given title The IDatabase interface is needed to browse the database.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public virtual IDatabase GetDatabaseByTitle(
    string Title
)
Visual Basic
Public Overridable Function GetDatabaseByTitle ( _
    Title As String _
) As IDatabase
Visual C++
public:
virtual IDatabase^ GetDatabaseByTitle(
    String^ Title
)

Parameters

Title
Type: System..::..String
Title of the database to get

Return Value

IDatabase interface of requested database

Implements

IDataManager..::..GetDatabaseByTitle(String)

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


GetItemInSeries Method

[image]

MADCAT Software Developer Guide
DataPacket..::..GetItemInSeries Method
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Retrieves a XML node from a given series. This method finds the XML node having the given index in the series and returns it.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public virtual XmlNode GetItemInSeries(
    XmlNode Series,
    string IndexValue
)
Visual Basic
Public Overridable Function GetItemInSeries ( _
    Series As XmlNode, _
    IndexValue As String _
) As XmlNode
Visual C++
public:
virtual XmlNode^ GetItemInSeries(
    XmlNode^ Series,
    String^ IndexValue
)

Parameters

Series
Type: System.Xml..::..XmlNode
XML node of the series. Can't be null.
IndexValue
Type: System..::..String
Value of the index of the item. Must be compatible with the type of the index of the series. This type can be obtained using the method GetIndexDef of the IDataModel interface.

Return Value

XML node. nullptr if no items found with the given index value.

Implements

IDataManager..::..GetItemInSeries(XmlNode, String)

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


GetModel Method

[image] [image]

MADCAT Software Developer Guide
DataPacket..::..GetModel Method
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

Name Description
Public method GetModel(String)
Gets the IDataModel interface of a model This method returns the IDataModel interface of the model
Public method GetModel(XmlNode)
Gets the IDataModel interface of the model of a given XML node This method returns the IDataModel interface of the model which defines the given XML node. Use this interface to get more informations about the item such as :
  • its attributes
  • its actions
  • its graphical properties (icons, description)
  • ...

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


GetModel Method (String)

[image]

MADCAT Software Developer Guide
DataPacket..::..GetModel Method (String)
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the IDataModel interface of a model This method returns the IDataModel interface of the model

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public virtual IDataModel GetModel(
    string modelname
)
Visual Basic
Public Overridable Function GetModel ( _
    modelname As String _
) As IDataModel
Visual C++
public:
virtual IDataModel^ GetModel(
    String^ modelname
)

Parameters

modelname
Type: System..::..String
Name of the model

Return Value

IDataModel interface of the requested model. nullptr if model name is unknown.

Implements

IDataManager..::..GetModel(String)

See Also

DataPacket Class
DataPacket Members
GetModel Overload
ToolInterfaces Namespace


GetModel Method (XmlNode)

[image]

MADCAT Software Developer Guide
DataPacket..::..GetModel Method (XmlNode)
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the IDataModel interface of the model of a given XML node This method returns the IDataModel interface of the model which defines the given XML node. Use this interface to get more informations about the item such as :
  • its attributes
  • its actions
  • its graphical properties (icons, description)
  • ...

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public virtual IDataModel GetModel(
    XmlNode itm
)
Visual Basic
Public Overridable Function GetModel ( _
    itm As XmlNode _
) As IDataModel
Visual C++
public:
virtual IDataModel^ GetModel(
    XmlNode^ itm
)

Parameters

itm
Type: System.Xml..::..XmlNode
XML node

Return Value

IDataModel interface of the model of the XML node

Implements

IDataManager..::..GetModel(XmlNode)

See Also

DataPacket Class
DataPacket Members
GetModel Overload
ToolInterfaces Namespace


GetNodeById Method

[image]

MADCAT Software Developer Guide
DataPacket..::..GetNodeById Method
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Finds a XML node by its ID Use this method to find a XML node in the active project with its ID. ID shall be compliant with the following format : 99,MODEL where :
  • 99 : is a digit
  • MODEL : is the name of the model of the XML node

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public virtual XmlNode GetNodeById(
    string NodeID
)
Visual Basic
Public Overridable Function GetNodeById ( _
    NodeID As String _
) As XmlNode
Visual C++
public:
virtual XmlNode^ GetNodeById(
    String^ NodeID
)

Parameters

NodeID
Type: System..::..String
ID of the node

Return Value

XML node having this ID. nullptr if nothing found.

Implements

IDataManager..::..GetNodeById(String)

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


PerformSearch Method

[image]

MADCAT Software Developer Guide
DataPacket..::..PerformSearch Method
DataPacket Class Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Executes a query using a XPath expression from a given XML node Use this method to find XML nodes matching a given XPath expression. Query is executed within the given root node so results are child nodes of root.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public virtual ArrayList PerformSearch(
    XmlNode root,
    string XQuery
)
Visual Basic
Public Overridable Function PerformSearch ( _
    root As XmlNode, _
    XQuery As String _
) As ArrayList
Visual C++
public:
virtual ArrayList^ PerformSearch(
    XmlNode^ root,
    String^ XQuery
)

Parameters

root
Type: System.Xml..::..XmlNode
XML node from where the query shall be executed. If null, query is performed on all the project (all models).
XQuery
Type: System..::..String
XPath expression

Return Value

Instance of ArrayList class having all the nodes matching the XPath expression. nullptr if nothing has been found.

Implements

IDataManager..::..PerformSearch(XmlNode, String)

Examples

See PerformSearch(XmlNode, String).

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


RemoveItemFromSeries Method

[image]

MADCAT Software Developer Guide
DataPacket..::..RemoveItemFromSeries Method
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Retrieves a XML node from a given series. This method finds the given XML node in the series and deletes it.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public virtual void RemoveItemFromSeries(
    XmlNode Series,
    XmlNode Item
)
Visual Basic
Public Overridable Sub RemoveItemFromSeries ( _
    Series As XmlNode, _
    Item As XmlNode _
)
Visual C++
public:
virtual void RemoveItemFromSeries(
    XmlNode^ Series,
    XmlNode^ Item
)

Parameters

Series
Type: System.Xml..::..XmlNode
XML node of the series. Can't be null.
Item
Type: System.Xml..::..XmlNode
XML Node of the item. Must be a part of the given series.

Implements

IDataManager..::..RemoveItemFromSeries(XmlNode, XmlNode)

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


RemoveItemFromSeriesByIndex Method

[image]

MADCAT Software Developer Guide
DataPacket..::..RemoveItemFromSeriesByIndex Method
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Removes a XML node from a given series. This method finds the XML node having the given index in the series and deletes it.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public virtual void RemoveItemFromSeriesByIndex(
    XmlNode Series,
    string IndexValue
)
Visual Basic
Public Overridable Sub RemoveItemFromSeriesByIndex ( _
    Series As XmlNode, _
    IndexValue As String _
)
Visual C++
public:
virtual void RemoveItemFromSeriesByIndex(
    XmlNode^ Series,
    String^ IndexValue
)

Parameters

Series
Type: System.Xml..::..XmlNode
XML node of the series. Can't be null.
IndexValue
Type: System..::..String
Value of the index of the item. Must be compatible with the type of the index of the series. This type can be obtained using the method GetIndexDef of the IDataModel interface.

Implements

IDataManager..::..RemoveItemFromSeriesByIndex(XmlNode, String)

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


ResolveDataLink Method

[image]

MADCAT Software Developer Guide
DataPacket..::..ResolveDataLink Method
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Finds the XML node referenced by a given link node Use this method to get the XML node referenced by a XML link node.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public virtual XmlNode ResolveDataLink(
    XmlNode Link
)
Visual Basic
Public Overridable Function ResolveDataLink ( _
    Link As XmlNode _
) As XmlNode
Visual C++
public:
virtual XmlNode^ ResolveDataLink(
    XmlNode^ Link
)

Parameters

Link
Type: System.Xml..::..XmlNode
XML Link node

Return Value

XML node referenced by the link. nullptr if link refers to nothing.

Implements

IDataManager..::..ResolveDataLink(XmlNode)

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


SwitchToBaseline Method

[image]

MADCAT Software Developer Guide
DataPacket..::..SwitchToBaseline Method
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Change the baseline of the DataPacket object When this method returns true, the DataPacket shows the data saved in the requested baseline. Otherwise, nothing is changed. This method doesn't change the baseline seen by the user in MADCAT. It can be used in tools to access the data of any baseline. Data is always read-only when the baseline is not the current.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public virtual bool SwitchToBaseline(
    IBaseline NewBaseline
)
Visual Basic
Public Overridable Function SwitchToBaseline ( _
    NewBaseline As IBaseline _
) As Boolean
Visual C++
public:
virtual bool SwitchToBaseline(
    IBaseline^ NewBaseline
)

Parameters

NewBaseline
Type: ToolInterfaces..::..IBaseline
Baseline to switch to

Return Value

  • True : baseline is found and DataPacket content now reflects the baseline data.
  • False : baseline not found. DataPacket is unchanged.

Implements

IBaselineManager..::..SwitchToBaseline(IBaseline)

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


SwitchToCurrentBaseline Method

[image]

MADCAT Software Developer Guide
DataPacket..::..SwitchToCurrentBaseline Method
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Sets the baseline of the DataPacket object to the current baseline When this method returns true, the DataPacket shows the current data of the project. Otherwise, nothing is changed. This method doesn't change the baseline seen by the user in MADCAT. It can be used in tools to return to the current data of the project after a baseline change. Data can be modified when returning to current baseline.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public virtual bool SwitchToCurrentBaseline()
Visual Basic
Public Overridable Function SwitchToCurrentBaseline As Boolean
Visual C++
public:
virtual bool SwitchToCurrentBaseline()

Return Value

  • True : DataPacket content now reflects the current data.
  • False : Error. DataPacket is unchanged.

Implements

IBaselineManager..::..SwitchToCurrentBaseline()()()()

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


ToByte Method

[image]

MADCAT Software Developer Guide
DataPacket..::..ToByte Method
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Serializes the DataPacket into a stream of Bytes

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public static byte[] ToByte(
    Object obj
)
Visual Basic
Public Shared Function ToByte ( _
    obj As Object _
) As Byte()
Visual C++
public:
static array<unsigned char>^ ToByte(
    Object^ obj
)

Parameters

obj
Type: System..::..Object
Object to serialize into a stream of bytes

Return Value

Array of Bytes of the serialized stream of the given object

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


ToObject Method

[image]

MADCAT Software Developer Guide
DataPacket..::..ToObject Method
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
DeSerializes a stream of Bytes into a DataPacket instance

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public static Object ToObject(
    byte[] stream
)
Visual Basic
Public Shared Function ToObject ( _
    stream As Byte() _
) As Object
Visual C++
public:
static Object^ ToObject(
    array<unsigned char>^ stream
)

Parameters

stream
Type: array< System..::..Byte >[]()[][]
Stream of bytes of a serialized object (see ToByte(Object)).

Return Value

Object created from the stream

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


DataPacket Properties

[image] [image]

MADCAT Software Developer Guide
DataPacket Properties
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The DataPacket type exposes the following members.

Properties

 | Name | Description
Public property | Baseline | Interface of the working baseline of the current data packet.
Public property | Databases | Array of interfaces to all the databases of the current workspace (Read-only) This property gives an array of IDatabase interfaces. Use them to get data items.
Public property | Manager | IDataManager interface of the source workspace. Use this interface to search/create/edit/delete items or links in the packet
Public property | Models | Array of IDataModel interfaces. All the models of the source workspace are exposed here. Use this array to get informations about items' definition
Public property | ProjectPath | Absolute path of the project where the data comes from
Public property | Projects | Not used

See Also

DataPacket Class
ToolInterfaces Namespace


Baseline Property

[image]

MADCAT Software Developer Guide
DataPacket..::..Baseline Property
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Interface of the working baseline of the current data packet.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public virtual IBaseline Baseline { get; }
Visual Basic
Public Overridable ReadOnly Property Baseline As IBaseline
    Get
Visual C++
public:
virtual property IBaseline^ Baseline {
    IBaseline^ get ();
}

Implements

IDataManager..::..Baseline

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


Databases Property

[image]

MADCAT Software Developer Guide
DataPacket..::..Databases Property
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Array of interfaces to all the databases of the current workspace (Read-only) This property gives an array of IDatabase interfaces. Use them to get data items.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public virtual IDatabase[] Databases { get; }
Visual Basic
Public Overridable ReadOnly Property Databases As IDatabase()
    Get
Visual C++
public:
virtual property array<IDatabase^>^ Databases {
    array<IDatabase^>^ get ();
}

Implements

IDataManager..::..Databases

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace
interface class


Manager Property

[image]

MADCAT Software Developer Guide
DataPacket..::..Manager Property
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
IDataManager interface of the source workspace. Use this interface to search/create/edit/delete items or links in the packet

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public IDataManager Manager { get; }
Visual Basic
Public ReadOnly Property Manager As IDataManager
    Get
Visual C++
public:
property IDataManager^ Manager {
    IDataManager^ get ();
}

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


Models Property

[image]

MADCAT Software Developer Guide
DataPacket..::..Models Property
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Array of IDataModel interfaces. All the models of the source workspace are exposed here. Use this array to get informations about items' definition

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public virtual IDataModel[] Models { get; }
Visual Basic
Public Overridable ReadOnly Property Models As IDataModel()
    Get
Visual C++
public:
virtual property array<IDataModel^>^ Models {
    array<IDataModel^>^ get ();
}

Implements

IDataManager..::..Models

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


ProjectPath Property

[image]

MADCAT Software Developer Guide
DataPacket..::..ProjectPath Property
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Absolute path of the project where the data comes from

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public virtual string ProjectPath { get; }
Visual Basic
Public Overridable ReadOnly Property ProjectPath As String
    Get
Visual C++
public:
virtual property String^ ProjectPath {
    String^ get ();
}

Implements

IDataManager..::..ProjectPath

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


Projects Property

[image]

MADCAT Software Developer Guide
DataPacket..::..Projects Property
DataPacket Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Not used

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public virtual ArrayList Projects { get; }
Visual Basic
Public Overridable ReadOnly Property Projects As ArrayList
    Get
Visual C++
public:
virtual property ArrayList^ Projects {
    ArrayList^ get ();
}

Implements

IDataManager..::..Projects

See Also

DataPacket Class
DataPacket Members
ToolInterfaces Namespace


ExecutionResult Enumeration

[image]

MADCAT Software Developer Guide
ExecutionResult Enumeration
See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Enumerate used by the tools to indicate the result of the execution of an action.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public enum ExecutionResult
Visual Basic
Public Enumeration ExecutionResult
Visual C++
public enum class ExecutionResult

Members

Member name | Value | Description
Failed | 2 | A fatal error occured during the execution. Action has been stopped.
Cancelled | 1 | Action cancelled by the user.
Successfull | 0 | Action performed completly without any errors.

See Also

ToolInterfaces Namespace


IBaseline Interface

[image]

MADCAT Software Developer Guide
IBaseline Interface
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This interfaces provides methods to get informations about a baseline This interface must be used to get useful informations about a baseline. Baselines are snapshots of all the project's data. They are created by the end-user. They can be used to trace modifications performed on critical data. User can recall any baseline to read/compare data. This interface can be retrieved by using objects exposing the IBaselineManager interface.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public interface IBaseline
Visual Basic
Public Interface IBaseline
Visual C++
public interface class IBaseline

See Also

IBaseline Members
ToolInterfaces Namespace


IBaseline Members

[image] [image]

MADCAT Software Developer Guide
IBaseline Members
IBaseline Interface Methods Properties See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IBaseline type exposes the following members.

Methods

 | Name | Description
Public method | GetBaseline | Gets the IBaseline interface of a baseline of a project Use this method to get the IBaseline interface of any baseline of a project. Works only if baselines are activated by the workspace which owns the given source.

Properties

 | Name | Description
Public property | Description | This property gives the description of the baseline which exposes the interface
Public property | Icon | This property gives the icon of the baseline which exposes the interface
Public property | Name | This property gives the name of the baseline which exposes the interface
Public property | ParentBaseline | This property gives the IBaseline interface of the parent baseline of the baseline which exposes the interface. Null if baseline has no parent.

See Also

IBaseline Interface
ToolInterfaces Namespace


IBaseline Methods

[image] [image]

MADCAT Software Developer Guide
IBaseline Methods
IBaseline Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IBaseline type exposes the following members.

Methods

 | Name | Description
Public method | GetBaseline | Gets the IBaseline interface of a baseline of a project Use this method to get the IBaseline interface of any baseline of a project. Works only if baselines are activated by the workspace which owns the given source.

See Also

IBaseline Interface
ToolInterfaces Namespace


GetBaseline Method

[image]

MADCAT Software Developer Guide
IBaseline..::..GetBaseline Method
IBaseline Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the IBaseline interface of a baseline of a project Use this method to get the IBaseline interface of any baseline of a project. Works only if baselines are activated by the workspace which owns the given source.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
IBaseline GetBaseline(
    IDataManager Source,
    string BLName
)
Visual Basic
Function GetBaseline ( _
    Source As IDataManager, _
    BLName As String _
) As IBaseline
Visual C++
IBaseline^ GetBaseline(
    IDataManager^ Source,
    String^ BLName
)

Parameters

Source
Type: ToolInterfaces..::..IDataManager
Name of a model of a workspace
BLName
Type: System..::..String
Name of the baseline to get the interface from

Return Value

IBaseline interface of the requested baseline. nullptr if no baseline found with the given name.

See Also

IBaseline Interface
IBaseline Members
ToolInterfaces Namespace


IBaseline Properties

[image] [image]

MADCAT Software Developer Guide
IBaseline Properties
IBaseline Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IBaseline type exposes the following members.

Properties

 | Name | Description
Public property | Description | This property gives the description of the baseline which exposes the interface
Public property | Icon | This property gives the icon of the baseline which exposes the interface
Public property | Name | This property gives the name of the baseline which exposes the interface
Public property | ParentBaseline | This property gives the IBaseline interface of the parent baseline of the baseline which exposes the interface. Null if baseline has no parent.

See Also

IBaseline Interface
ToolInterfaces Namespace


Description Property

[image]

MADCAT Software Developer Guide
IBaseline..::..Description Property
IBaseline Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This property gives the description of the baseline which exposes the interface

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
string Description { get; }
Visual Basic
ReadOnly Property Description As String
    Get
Visual C++
property String^ Description {
    String^ get ();
}

See Also

IBaseline Interface
IBaseline Members
ToolInterfaces Namespace


Icon Property

[image]

MADCAT Software Developer Guide
IBaseline..::..Icon Property
IBaseline Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This property gives the icon of the baseline which exposes the interface

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
Image Icon { get; }
Visual Basic
ReadOnly Property Icon As Image
    Get
Visual C++
property Image^ Icon {
    Image^ get ();
}

See Also

IBaseline Interface
IBaseline Members
ToolInterfaces Namespace


Name Property

[image]

MADCAT Software Developer Guide
IBaseline..::..Name Property
IBaseline Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This property gives the name of the baseline which exposes the interface

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
string Name { get; }
Visual Basic
ReadOnly Property Name As String
    Get
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IBaseline Interface
IBaseline Members
ToolInterfaces Namespace


ParentBaseline Property

[image]

MADCAT Software Developer Guide
IBaseline..::..ParentBaseline Property
IBaseline Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This property gives the IBaseline interface of the parent baseline of the baseline which exposes the interface. Null if baseline has no parent.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
IBaseline ParentBaseline { get; }
Visual Basic
ReadOnly Property ParentBaseline As IBaseline
    Get
Visual C++
property IBaseline^ ParentBaseline {
    IBaseline^ get ();
}

See Also

IBaseline Interface
IBaseline Members
ToolInterfaces Namespace


IBaselineManager Interface

[image]

MADCAT Software Developer Guide
IBaselineManager Interface
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This interface shall be used to switch from one baseline to another This interface is exposed by DataPacket objects. With this interface, you can change the baseline of the data packet and get all the data related to the packet at different moment of the project.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public interface IBaselineManager
Visual Basic
Public Interface IBaselineManager
Visual C++
public interface class IBaselineManager

See Also

IBaselineManager Members
ToolInterfaces Namespace
ToolInterfaces..::..IBaseline


IBaselineManager Members

[image] [image]

MADCAT Software Developer Guide
IBaselineManager Members
IBaselineManager Interface Methods See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IBaselineManager type exposes the following members.

Methods

Name Description
Public method GetBaseline
Gets the IBaseline interface of the baseline of the given XML node Use this interface to get more informations about the item such as :
  • the name of the current baseline
  • the parent baselines
Public method SwitchToBaseline
Change the baseline of the object When this method returns true, the object which exposes this interface shows the data saved in the requested baseline. Otherwise, nothing is changed. This method doesn't change the baseline seen by the user in MADCAT. It can be used in tools to access the data of any baseline. Data is always read-only when the baseline is not the current.
Public method SwitchToCurrentBaseline
Sets the baseline of the object to the current baseline When this method returns true, the object refers to the current data of the project. Otherwise, nothing is changed. This method doesn't change the baseline seen by the user in MADCAT. It can be used in tools to return to the current data of the project after a baseline change. Data can be modified when returning to current baseline.

See Also

IBaselineManager Interface
ToolInterfaces Namespace


IBaselineManager Methods

[image] [image]

MADCAT Software Developer Guide
IBaselineManager Methods
IBaselineManager Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IBaselineManager type exposes the following members.

Methods

Name Description
Public method GetBaseline
Gets the IBaseline interface of the baseline of the given XML node Use this interface to get more informations about the item such as :
  • the name of the current baseline
  • the parent baselines
Public method SwitchToBaseline
Change the baseline of the object When this method returns true, the object which exposes this interface shows the data saved in the requested baseline. Otherwise, nothing is changed. This method doesn't change the baseline seen by the user in MADCAT. It can be used in tools to access the data of any baseline. Data is always read-only when the baseline is not the current.
Public method SwitchToCurrentBaseline
Sets the baseline of the object to the current baseline When this method returns true, the object refers to the current data of the project. Otherwise, nothing is changed. This method doesn't change the baseline seen by the user in MADCAT. It can be used in tools to return to the current data of the project after a baseline change. Data can be modified when returning to current baseline.

See Also

IBaselineManager Interface
ToolInterfaces Namespace


GetBaseline Method

[image]

MADCAT Software Developer Guide
IBaselineManager..::..GetBaseline Method
IBaselineManager Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the IBaseline interface of the baseline of the given XML node Use this interface to get more informations about the item such as :
  • the name of the current baseline
  • the parent baselines

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
IBaseline GetBaseline(
    XmlNode Item
)
Visual Basic
Function GetBaseline ( _
    Item As XmlNode _
) As IBaseline
Visual C++
IBaseline^ GetBaseline(
    XmlNode^ Item
)

Parameters

Item
Type: System.Xml..::..XmlNode
XML node

Return Value

IBaseline interface of the baseline of the XML node

See Also

IBaselineManager Interface
IBaselineManager Members
ToolInterfaces Namespace


SwitchToBaseline Method

[image]

MADCAT Software Developer Guide
IBaselineManager..::..SwitchToBaseline Method
IBaselineManager Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Change the baseline of the object When this method returns true, the object which exposes this interface shows the data saved in the requested baseline. Otherwise, nothing is changed. This method doesn't change the baseline seen by the user in MADCAT. It can be used in tools to access the data of any baseline. Data is always read-only when the baseline is not the current.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
bool SwitchToBaseline(
    IBaseline NewBaseline
)
Visual Basic
Function SwitchToBaseline ( _
    NewBaseline As IBaseline _
) As Boolean
Visual C++
bool SwitchToBaseline(
    IBaseline^ NewBaseline
)

Parameters

NewBaseline
Type: ToolInterfaces..::..IBaseline
Interface IBaseline of the baseline to switch to

Return Value

  • True : baseline is activated and object now refers to the baseline data.
  • False : baseline not found. Object reference is unchanged.

See Also

IBaselineManager Interface
IBaselineManager Members
ToolInterfaces Namespace


SwitchToCurrentBaseline Method

[image]

MADCAT Software Developer Guide
IBaselineManager..::..SwitchToCurrentBaseline Method
IBaselineManager Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Sets the baseline of the object to the current baseline When this method returns true, the object refers to the current data of the project. Otherwise, nothing is changed. This method doesn't change the baseline seen by the user in MADCAT. It can be used in tools to return to the current data of the project after a baseline change. Data can be modified when returning to current baseline.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
bool SwitchToCurrentBaseline()
Visual Basic
Function SwitchToCurrentBaseline As Boolean
Visual C++
bool SwitchToCurrentBaseline()

Return Value

  • True : Object now refers to the current data.
  • False : Error. Object reference is unchanged.

See Also

IBaselineManager Interface
IBaselineManager Members
ToolInterfaces Namespace


IDatabase Interface

[image]

MADCAT Software Developer Guide
IDatabase Interface
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This interfaces provides methods to get the source of data and the related model. This interface must be used to get and handle data of a database.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public interface IDatabase
Visual Basic
Public Interface IDatabase
Visual C++
public interface class IDatabase

See Also

IDatabase Members
ToolInterfaces Namespace


IDatabase Members

[image] [image]

MADCAT Software Developer Guide
IDatabase Members
IDatabase Interface Properties See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IDatabase type exposes the following members.

Properties

 | Name | Description
Public property | Manager | This property gives the IDataModel interface of the manager of the database.
Public property | Source | This property gives the IDataSource interface of the database.

See Also

IDatabase Interface
ToolInterfaces Namespace


IDatabase Properties

[image] [image]

MADCAT Software Developer Guide
IDatabase Properties
IDatabase Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IDatabase type exposes the following members.

Properties

 | Name | Description
Public property | Manager | This property gives the IDataModel interface of the manager of the database.
Public property | Source | This property gives the IDataSource interface of the database.

See Also

IDatabase Interface
ToolInterfaces Namespace


Manager Property

[image]

MADCAT Software Developer Guide
IDatabase..::..Manager Property
IDatabase Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This property gives the IDataModel interface of the manager of the database.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
IDataModel Manager { get; }
Visual Basic
ReadOnly Property Manager As IDataModel
    Get
Visual C++
property IDataModel^ Manager {
    IDataModel^ get ();
}

See Also

IDatabase Interface
IDatabase Members
ToolInterfaces Namespace


Source Property

[image]

MADCAT Software Developer Guide
IDatabase..::..Source Property
IDatabase Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This property gives the IDataSource interface of the database.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
IDataSource Source { get; }
Visual Basic
ReadOnly Property Source As IDataSource
    Get
Visual C++
property IDataSource^ Source {
    IDataSource^ get ();
}

See Also

IDatabase Interface
IDatabase Members
ToolInterfaces Namespace


IDataManager Interface

[image]

MADCAT Software Developer Guide
IDataManager Interface
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This interfaces provides methods to manage models and data of a workspace This interface must be used to get models of a workspace and to find/create/edit items in your project.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public interface IDataManager
Visual Basic
Public Interface IDataManager
Visual C++
public interface class IDataManager

See Also

IDataManager Members
ToolInterfaces Namespace


IDataManager Members

[image] [image]

MADCAT Software Developer Guide
IDataManager Members
IDataManager Interface Methods Properties See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IDataManager type exposes the following members.

Methods

Name Description
Public method AddItemInSeries
Creates a XML node in a given series. This method creates a XML node in the project document related to the model. The XML node will be a child of the XML series node if Series is not null.
Public method CreateItem
Creates a XML node This method creates a XML node in the project document related to the model. The XML node will be a child of the XML parent node if Parent is not null. Otherwise, the node will be the root node of the project XML document.
Public method CreateLink
Creates a XML link node This method creates a XML link node which will refer to the given target XML node. The XML link node will be a child of the XML parent node if Parent is not null. Otherwise, link will be the root node of a XML document.
Public method CreateSeries
Creates a XML node for series This method creates a XML node in the project document related to the model. The XML node will be a child of the XML parent node if Parent is not null. Otherwise, the node will be the root node of the project XML document. This node is the parent of all the items that will be added in the series.
Public method EditItem
Signals the modification of a XML node This method signals an XML node modification to MADCAT. Modification will be recorded in baseline history (if workspace has activated baselines) or the undo/redo stack of MADCAT.
Public method GetAllItemsOrdered
Retrieves all the XML nodes of a given series. This method sorts the items by index value and returns the list of items in an ArrayList object.
Public method GetDatabase
Gets the IDatabase interface of the given XML node The IDatabase interface is needed to browse the database where the given item is stored.
Public method GetDatabaseByTitle
Gets the IDatabase interface which has the given title The IDatabase interface is needed to browse the database.
Public method GetItemInSeries
Retrieves a XML node from a given series. This method finds the XML node having the given index in the series and returns it.
Public method GetModel(String)
Gets the IDataModel interface of a model This method returns the IDataModel interface of the model
Public method GetModel(XmlNode)
Gets the IDataModel interface of the model of a given XML node This method returns the IDataModel interface of the model which defines the given XML node. Use this interface to get more informations about the item such as :
  • its attributes
  • its actions
  • its graphical properties (icons, description)
  • ...
Public method GetNodeById
Finds a XML node by its ID Use this method to find a XML node in the active project with its ID. ID shall be compliant with the following format : 99,MODEL where :
  • 99 : is a digit
  • MODEL : is the name of the model of the XML node
Public method PerformSearch
Executes a query using a XPath expression from a given XML node Use this method to find XML nodes matching a given XPath expression. Query is executed within the given root node so results are child nodes of root.
Public method RemoveItemFromSeries
Retrieves a XML node from a given series. This method finds the given XML node in the series and deletes it.
Public method RemoveItemFromSeriesByIndex
Removes a XML node from a given series. This method finds the XML node having the given index in the series and deletes it.
Public method ResolveDataLink
Finds the XML node referenced by a given link node Use this method to get the XML node referenced by a XML link node.

Properties

 | Name | Description
Public property | Baseline | Interface of the working baseline of the current workspace.
Public property | Databases | Array of interfaces to all the databases of the current workspace (Read-only) This property gives an array of IDatabase interfaces. Use them to get data items.
Public property | Models | Array of interfaces to all the models of the current workspace (Read-only) This property gives an array of IDataModel interfaces. Use them to get model informations.
Public property | ProjectPath | Path of the active workspace (Read-only) This property gives the path of the current workspace.
Public property | Projects | Paths of the project data directories (Read-only) This property gives an array of project handlers ProjectHandler. Each handler gives the location of the data files and the baseline which shall be loaded if defined. The array is filled with ProjectHandler objects.

See Also

IDataManager Interface
ToolInterfaces Namespace


IDataManager Methods

[image] [image]

MADCAT Software Developer Guide
IDataManager Methods
IDataManager Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IDataManager type exposes the following members.

Methods

Name Description
Public method AddItemInSeries
Creates a XML node in a given series. This method creates a XML node in the project document related to the model. The XML node will be a child of the XML series node if Series is not null.
Public method CreateItem
Creates a XML node This method creates a XML node in the project document related to the model. The XML node will be a child of the XML parent node if Parent is not null. Otherwise, the node will be the root node of the project XML document.
Public method CreateLink
Creates a XML link node This method creates a XML link node which will refer to the given target XML node. The XML link node will be a child of the XML parent node if Parent is not null. Otherwise, link will be the root node of a XML document.
Public method CreateSeries
Creates a XML node for series This method creates a XML node in the project document related to the model. The XML node will be a child of the XML parent node if Parent is not null. Otherwise, the node will be the root node of the project XML document. This node is the parent of all the items that will be added in the series.
Public method EditItem
Signals the modification of a XML node This method signals an XML node modification to MADCAT. Modification will be recorded in baseline history (if workspace has activated baselines) or the undo/redo stack of MADCAT.
Public method GetAllItemsOrdered
Retrieves all the XML nodes of a given series. This method sorts the items by index value and returns the list of items in an ArrayList object.
Public method GetDatabase
Gets the IDatabase interface of the given XML node The IDatabase interface is needed to browse the database where the given item is stored.
Public method GetDatabaseByTitle
Gets the IDatabase interface which has the given title The IDatabase interface is needed to browse the database.
Public method GetItemInSeries
Retrieves a XML node from a given series. This method finds the XML node having the given index in the series and returns it.
Public method GetModel(String)
Gets the IDataModel interface of a model This method returns the IDataModel interface of the model
Public method GetModel(XmlNode)
Gets the IDataModel interface of the model of a given XML node This method returns the IDataModel interface of the model which defines the given XML node. Use this interface to get more informations about the item such as :
  • its attributes
  • its actions
  • its graphical properties (icons, description)
  • ...
Public method GetNodeById
Finds a XML node by its ID Use this method to find a XML node in the active project with its ID. ID shall be compliant with the following format : 99,MODEL where :
  • 99 : is a digit
  • MODEL : is the name of the model of the XML node
Public method PerformSearch
Executes a query using a XPath expression from a given XML node Use this method to find XML nodes matching a given XPath expression. Query is executed within the given root node so results are child nodes of root.
Public method RemoveItemFromSeries
Retrieves a XML node from a given series. This method finds the given XML node in the series and deletes it.
Public method RemoveItemFromSeriesByIndex
Removes a XML node from a given series. This method finds the XML node having the given index in the series and deletes it.
Public method ResolveDataLink
Finds the XML node referenced by a given link node Use this method to get the XML node referenced by a XML link node.

See Also

IDataManager Interface
ToolInterfaces Namespace


AddItemInSeries Method

[image]

MADCAT Software Developer Guide
IDataManager..::..AddItemInSeries Method
IDataManager Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Creates a XML node in a given series. This method creates a XML node in the project document related to the model. The XML node will be a child of the XML series node if Series is not null.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
XmlNode AddItemInSeries(
    XmlNode Series,
    string IndexValue
)
Visual Basic
Function AddItemInSeries ( _
    Series As XmlNode, _
    IndexValue As String _
) As XmlNode
Visual C++
XmlNode^ AddItemInSeries(
    XmlNode^ Series,
    String^ IndexValue
)

Parameters

Series
Type: System.Xml..::..XmlNode
XML node of the series. Can't be null.
IndexValue
Type: System..::..String
Value of the index attached to the new item. Must be compatible with the type of the index of the series. This type can be obtained using the method GetIndexDef of the IDataModel interface.

Return Value

XML node created. nullptr if operation fails.

Examples

This example shows how to use this method in a tool to create a series in the database using the workspace given by MADCAT when tool is initialized.
CopyC++
IDataManager ^dm = wrk->DatabaseManager;

XmlNode ^series = dm->CreateSeries(null,L"OBJECTIVE");

if(series)
{
  // Series has been created so the required database is certainly available and the series is correctly initialized.
  // We can fill it safely by adding items.
  dm->AddItemInSeries(series,L"1");
  dm->AddItemInSeries(series,L"2");
  dm->AddItemInSeries(series,L"3");
}

See Also

IDataManager Interface
IDataManager Members
ToolInterfaces Namespace


CreateItem Method

[image]

MADCAT Software Developer Guide
IDataManager..::..CreateItem Method
IDataManager Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Creates a XML node This method creates a XML node in the project document related to the model. The XML node will be a child of the XML parent node if Parent is not null. Otherwise, the node will be the root node of the project XML document.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
XmlNode CreateItem(
    XmlNode Parent,
    string NodeName
)
Visual Basic
Function CreateItem ( _
    Parent As XmlNode, _
    NodeName As String _
) As XmlNode
Visual C++
XmlNode^ CreateItem(
    XmlNode^ Parent,
    String^ NodeName
)

Parameters

Parent
Type: System.Xml..::..XmlNode
XML node which will be the parent of the link. May be null.
NodeName
Type: System..::..String
Name of the model node used to build the XML node. Must correspond to a ITEM node in the model.

Return Value

XML node created. nullptr if operation fails (NodeName is unknown).

Examples

This example shows how to use this method in a tool to create an item in the database using the workspace given by MADCAT when tool is initialized.
CopyC++
IDataManager ^dm = wrk->DatabaseManager;

XmlNode ^itm = dm->CreateItem(null,L"FILE");

if(itm)
{
  // Item has been created so the required database is certainly available and the item is correctly initialized.
  // We can fill it safely.
  itm->Attributes[L"NAME"]->Value = L"My first item";
}

See Also

IDataManager Interface
IDataManager Members
ToolInterfaces Namespace


CreateLink Method

[image]

MADCAT Software Developer Guide
IDataManager..::..CreateLink Method
IDataManager Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Creates a XML link node This method creates a XML link node which will refer to the given target XML node. The XML link node will be a child of the XML parent node if Parent is not null. Otherwise, link will be the root node of a XML document.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
XmlNode CreateLink(
    XmlNode Parent,
    XmlNode Target
)
Visual Basic
Function CreateLink ( _
    Parent As XmlNode, _
    Target As XmlNode _
) As XmlNode
Visual C++
XmlNode^ CreateLink(
    XmlNode^ Parent,
    XmlNode^ Target
)

Parameters

Parent
Type: System.Xml..::..XmlNode
XML node which will be the parent of the link. May be null.
Target
Type: System.Xml..::..XmlNode
XML node which will be referenced by the link

Return Value

XML link node created. nullptr if operation fails.

Examples

This example shows how to use this method in a tool to create a link in the database using the workspace given by MADCAT when tool is initialized.
CopyC++
IDataManager ^dm = wrk->DatabaseManager;

ArrayList ^list = dm->PerformSearch(nullptr,L"//ITEM[&NAME='My Target']");

if(list&&list->Count==1)
{
  XmlNode ^target = (XmlNode ^)list[0];
  // Now we create one link at the top level
  XmlNode ^link = dm->CreateLink(nullptr,target);
}

See Also

IDataManager Interface
IDataManager Members
ToolInterfaces Namespace


CreateSeries Method

[image]

MADCAT Software Developer Guide
IDataManager..::..CreateSeries Method
IDataManager Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Creates a XML node for series This method creates a XML node in the project document related to the model. The XML node will be a child of the XML parent node if Parent is not null. Otherwise, the node will be the root node of the project XML document. This node is the parent of all the items that will be added in the series.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
XmlNode CreateSeries(
    XmlNode Parent,
    string NodeName
)
Visual Basic
Function CreateSeries ( _
    Parent As XmlNode, _
    NodeName As String _
) As XmlNode
Visual C++
XmlNode^ CreateSeries(
    XmlNode^ Parent,
    String^ NodeName
)

Parameters

Parent
Type: System.Xml..::..XmlNode
XML node which will be the parent of the series. May be null.
NodeName
Type: System..::..String
Name of the model node used to build the XML node for the series. Must correspond to a SERIES node in the model.

Return Value

XML node created. nullptr if operation fails (NodeName is unknown).

Examples

This example shows how to use this method in a tool to create a series in the database using the workspace given by MADCAT when tool is initialized.
CopyC++
IDataManager ^dm = wrk->DatabaseManager;

XmlNode ^series = dm->CreateSeries(null,L"OBJECTIVE");

if(series)
{
  // Series has been created so the required database is certainly available and the series is correctly initialized.
  // We can fill it safely by adding items.
  dm->AddItemInSeries(series,L"1");
  dm->AddItemInSeries(series,L"2");
  dm->AddItemInSeries(series,L"3");
}

See Also

IDataManager Interface
IDataManager Members
ToolInterfaces Namespace


EditItem Method

[image]

MADCAT Software Developer Guide
IDataManager..::..EditItem Method
IDataManager Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Signals the modification of a XML node This method signals an XML node modification to MADCAT. Modification will be recorded in baseline history (if workspace has activated baselines) or the undo/redo stack of MADCAT.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void EditItem(
    XmlNode NewItem,
    XmlNode OldItem
)
Visual Basic
Sub EditItem ( _
    NewItem As XmlNode, _
    OldItem As XmlNode _
)
Visual C++
void EditItem(
    XmlNode^ NewItem,
    XmlNode^ OldItem
)

Parameters

NewItem
Type: System.Xml..::..XmlNode
XML node after modifications.
OldItem
Type: System.Xml..::..XmlNode
XML node before modifications. Use the Clone method of XmlNode class to have a backup of the node before changing its attributes.

See Also

IDataManager Interface
IDataManager Members
ToolInterfaces Namespace


GetAllItemsOrdered Method

[image]

MADCAT Software Developer Guide
IDataManager..::..GetAllItemsOrdered Method
IDataManager Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Retrieves all the XML nodes of a given series. This method sorts the items by index value and returns the list of items in an ArrayList object.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
ArrayList GetAllItemsOrdered(
    XmlNode Series
)
Visual Basic
Function GetAllItemsOrdered ( _
    Series As XmlNode _
) As ArrayList
Visual C++
ArrayList^ GetAllItemsOrdered(
    XmlNode^ Series
)

Parameters

Series
Type: System.Xml..::..XmlNode
XML node of the series. Can't be null.

Return Value

Array of XML nodes. Array is empty if series has no items. Can never be null.

See Also

IDataManager Interface
IDataManager Members
ToolInterfaces Namespace


GetDatabase Method

[image]

MADCAT Software Developer Guide
IDataManager..::..GetDatabase Method
IDataManager Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the IDatabase interface of the given XML node The IDatabase interface is needed to browse the database where the given item is stored.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
IDatabase GetDatabase(
    XmlNode Item
)
Visual Basic
Function GetDatabase ( _
    Item As XmlNode _
) As IDatabase
Visual C++
IDatabase^ GetDatabase(
    XmlNode^ Item
)

Parameters

Item
Type: System.Xml..::..XmlNode
XML node

Return Value

IDatabase interface of database where the XML node is

See Also

IDataManager Interface
IDataManager Members
ToolInterfaces Namespace


GetDatabaseByTitle Method

[image]

MADCAT Software Developer Guide
IDataManager..::..GetDatabaseByTitle Method
IDataManager Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the IDatabase interface which has the given title The IDatabase interface is needed to browse the database.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
IDatabase GetDatabaseByTitle(
    string Title
)
Visual Basic
Function GetDatabaseByTitle ( _
    Title As String _
) As IDatabase
Visual C++
IDatabase^ GetDatabaseByTitle(
    String^ Title
)

Parameters

Title
Type: System..::..String
Title of the database to get

Return Value

IDatabase interface of requested database

See Also

IDataManager Interface
IDataManager Members
ToolInterfaces Namespace


GetItemInSeries Method

[image]

MADCAT Software Developer Guide
IDataManager..::..GetItemInSeries Method
IDataManager Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Retrieves a XML node from a given series. This method finds the XML node having the given index in the series and returns it.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
XmlNode GetItemInSeries(
    XmlNode Series,
    string IndexValue
)
Visual Basic
Function GetItemInSeries ( _
    Series As XmlNode, _
    IndexValue As String _
) As XmlNode
Visual C++
XmlNode^ GetItemInSeries(
    XmlNode^ Series,
    String^ IndexValue
)

Parameters

Series
Type: System.Xml..::..XmlNode
XML node of the series. Can't be null.
IndexValue
Type: System..::..String
Value of the index of the item. Must be compatible with the type of the index of the series. This type can be obtained using the method GetIndexDef of the IDataModel interface.

Return Value

XML node. nullptr if no items found with the given index value.

See Also

IDataManager Interface
IDataManager Members
ToolInterfaces Namespace


GetModel Method

[image] [image]

MADCAT Software Developer Guide
IDataManager..::..GetModel Method
IDataManager Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

Name Description
Public method GetModel(String)
Gets the IDataModel interface of a model This method returns the IDataModel interface of the model
Public method GetModel(XmlNode)
Gets the IDataModel interface of the model of a given XML node This method returns the IDataModel interface of the model which defines the given XML node. Use this interface to get more informations about the item such as :
  • its attributes
  • its actions
  • its graphical properties (icons, description)
  • ...

See Also

IDataManager Interface
IDataManager Members
ToolInterfaces Namespace


GetModel Method (String)

[image]

MADCAT Software Developer Guide
IDataManager..::..GetModel Method (String)
IDataManager Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the IDataModel interface of a model This method returns the IDataModel interface of the model

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
IDataModel GetModel(
    string modelname
)
Visual Basic
Function GetModel ( _
    modelname As String _
) As IDataModel
Visual C++
IDataModel^ GetModel(
    String^ modelname
)

Parameters

modelname
Type: System..::..String
Name of the model

Return Value

IDataModel interface of the requested model. nullptr if model name is unknown.

See Also

IDataManager Interface
IDataManager Members
GetModel Overload
ToolInterfaces Namespace


GetModel Method (XmlNode)

[image]

MADCAT Software Developer Guide
IDataManager..::..GetModel Method (XmlNode)
IDataManager Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the IDataModel interface of the model of a given XML node This method returns the IDataModel interface of the model which defines the given XML node. Use this interface to get more informations about the item such as :
  • its attributes
  • its actions
  • its graphical properties (icons, description)
  • ...

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
IDataModel GetModel(
    XmlNode itm
)
Visual Basic
Function GetModel ( _
    itm As XmlNode _
) As IDataModel
Visual C++
IDataModel^ GetModel(
    XmlNode^ itm
)

Parameters

itm
Type: System.Xml..::..XmlNode
XML node

Return Value

IDataModel interface of the model of the XML node

See Also

IDataManager Interface
IDataManager Members
GetModel Overload
ToolInterfaces Namespace


GetNodeById Method

[image]

MADCAT Software Developer Guide
IDataManager..::..GetNodeById Method
IDataManager Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Finds a XML node by its ID Use this method to find a XML node in the active project with its ID. ID shall be compliant with the following format : 99,MODEL where :
  • 99 : is a digit
  • MODEL : is the name of the model of the XML node

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
XmlNode GetNodeById(
    string NodeID
)
Visual Basic
Function GetNodeById ( _
    NodeID As String _
) As XmlNode
Visual C++
XmlNode^ GetNodeById(
    String^ NodeID
)

Parameters

NodeID
Type: System..::..String
ID of the node

Return Value

XML node having this ID. nullptr if nothing found.

See Also

IDataManager Interface
IDataManager Members
ToolInterfaces Namespace


PerformSearch Method

[image]

MADCAT Software Developer Guide
IDataManager..::..PerformSearch Method
IDataManager Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Executes a query using a XPath expression from a given XML node Use this method to find XML nodes matching a given XPath expression. Query is executed within the given root node so results are child nodes of root.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
ArrayList PerformSearch(
    XmlNode root,
    string XQuery
)
Visual Basic
Function PerformSearch ( _
    root As XmlNode, _
    XQuery As String _
) As ArrayList
Visual C++
ArrayList^ PerformSearch(
    XmlNode^ root,
    String^ XQuery
)

Parameters

root
Type: System.Xml..::..XmlNode
XML node from where the query shall be executed. If null, query is performed on all the project (all models).
XQuery
Type: System..::..String
XPath expression

Return Value

Instance of ArrayList class having all the nodes matching the XPath expression. nullptr if nothing has been found.

Examples

This example shows how to use this method to find an item in the database using the data context of an action
CopyC++
ArrayList ^result;

result = Context->DataContext->PerformSearch(nullptr,L"//PROGRAM");
if(result&&(result->Count==1))
{
   // Do something with the item
}
else
{
   Context->Log->ShowError(L"Your database has no 'PROGRAM' folder");
}

See Also

IDataManager Interface
IDataManager Members
ToolInterfaces Namespace


RemoveItemFromSeries Method

[image]

MADCAT Software Developer Guide
IDataManager..::..RemoveItemFromSeries Method
IDataManager Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Retrieves a XML node from a given series. This method finds the given XML node in the series and deletes it.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void RemoveItemFromSeries(
    XmlNode Series,
    XmlNode Item
)
Visual Basic
Sub RemoveItemFromSeries ( _
    Series As XmlNode, _
    Item As XmlNode _
)
Visual C++
void RemoveItemFromSeries(
    XmlNode^ Series,
    XmlNode^ Item
)

Parameters

Series
Type: System.Xml..::..XmlNode
XML node of the series. Can't be null.
Item
Type: System.Xml..::..XmlNode
XML Node of the item. Must be a part of the given series.

See Also

IDataManager Interface
IDataManager Members
ToolInterfaces Namespace


RemoveItemFromSeriesByIndex Method

[image]

MADCAT Software Developer Guide
IDataManager..::..RemoveItemFromSeriesByIndex Method
IDataManager Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Removes a XML node from a given series. This method finds the XML node having the given index in the series and deletes it.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void RemoveItemFromSeriesByIndex(
    XmlNode Series,
    string IndexValue
)
Visual Basic
Sub RemoveItemFromSeriesByIndex ( _
    Series As XmlNode, _
    IndexValue As String _
)
Visual C++
void RemoveItemFromSeriesByIndex(
    XmlNode^ Series,
    String^ IndexValue
)

Parameters

Series
Type: System.Xml..::..XmlNode
XML node of the series. Can't be null.
IndexValue
Type: System..::..String
Value of the index of the item. Must be compatible with the type of the index of the series. This type can be obtained using the method GetIndexDef of the IDataModel interface.

See Also

IDataManager Interface
IDataManager Members
ToolInterfaces Namespace


ResolveDataLink Method

[image]

MADCAT Software Developer Guide
IDataManager..::..ResolveDataLink Method
IDataManager Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Finds the XML node referenced by a given link node Use this method to get the XML node referenced by a XML link node.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
XmlNode ResolveDataLink(
    XmlNode Link
)
Visual Basic
Function ResolveDataLink ( _
    Link As XmlNode _
) As XmlNode
Visual C++
XmlNode^ ResolveDataLink(
    XmlNode^ Link
)

Parameters

Link
Type: System.Xml..::..XmlNode
XML Link node

Return Value

XML node referenced by the link. nullptr if link refers to nothing.

See Also

IDataManager Interface
IDataManager Members
ToolInterfaces Namespace


IDataManager Properties

[image] [image]

MADCAT Software Developer Guide
IDataManager Properties
IDataManager Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IDataManager type exposes the following members.

Properties

 | Name | Description
Public property | Baseline | Interface of the working baseline of the current workspace.
Public property | Databases | Array of interfaces to all the databases of the current workspace (Read-only) This property gives an array of IDatabase interfaces. Use them to get data items.
Public property | Models | Array of interfaces to all the models of the current workspace (Read-only) This property gives an array of IDataModel interfaces. Use them to get model informations.
Public property | ProjectPath | Path of the active workspace (Read-only) This property gives the path of the current workspace.
Public property | Projects | Paths of the project data directories (Read-only) This property gives an array of project handlers ProjectHandler. Each handler gives the location of the data files and the baseline which shall be loaded if defined. The array is filled with ProjectHandler objects.

See Also

IDataManager Interface
ToolInterfaces Namespace


Baseline Property

[image]

MADCAT Software Developer Guide
IDataManager..::..Baseline Property
IDataManager Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Interface of the working baseline of the current workspace.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
IBaseline Baseline { get; }
Visual Basic
ReadOnly Property Baseline As IBaseline
    Get
Visual C++
property IBaseline^ Baseline {
    IBaseline^ get ();
}

See Also

IDataManager Interface
IDataManager Members
ToolInterfaces Namespace


Databases Property

[image]

MADCAT Software Developer Guide
IDataManager..::..Databases Property
IDataManager Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Array of interfaces to all the databases of the current workspace (Read-only) This property gives an array of IDatabase interfaces. Use them to get data items.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
IDatabase[] Databases { get; }
Visual Basic
ReadOnly Property Databases As IDatabase()
    Get
Visual C++
property array<IDatabase^>^ Databases {
    array<IDatabase^>^ get ();
}

See Also

IDataManager Interface
IDataManager Members
ToolInterfaces Namespace
interface class


Models Property

[image]

MADCAT Software Developer Guide
IDataManager..::..Models Property
IDataManager Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Array of interfaces to all the models of the current workspace (Read-only) This property gives an array of IDataModel interfaces. Use them to get model informations.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
IDataModel[] Models { get; }
Visual Basic
ReadOnly Property Models As IDataModel()
    Get
Visual C++
property array<IDataModel^>^ Models {
    array<IDataModel^>^ get ();
}

See Also

IDataManager Interface
IDataManager Members
ToolInterfaces Namespace
interface class


ProjectPath Property

[image]

MADCAT Software Developer Guide
IDataManager..::..ProjectPath Property
IDataManager Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Path of the active workspace (Read-only) This property gives the path of the current workspace.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
string ProjectPath { get; }
Visual Basic
ReadOnly Property ProjectPath As String
    Get
Visual C++
property String^ ProjectPath {
    String^ get ();
}

See Also

IDataManager Interface
IDataManager Members
ToolInterfaces Namespace


Projects Property

[image]

MADCAT Software Developer Guide
IDataManager..::..Projects Property
IDataManager Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Paths of the project data directories (Read-only) This property gives an array of project handlers ProjectHandler. Each handler gives the location of the data files and the baseline which shall be loaded if defined. The array is filled with ProjectHandler objects.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
ArrayList Projects { get; }
Visual Basic
ReadOnly Property Projects As ArrayList
    Get
Visual C++
property ArrayList^ Projects {
    ArrayList^ get ();
}

See Also

IDataManager Interface
IDataManager Members
ToolInterfaces Namespace


IDataModel Interface

[image]

MADCAT Software Developer Guide
IDataModel Interface
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This interfaces provides methods to get models data This interface must be used to get detailed informations about models of a workspace. Methods can give definitions of any element of the model which exposes this interface.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public interface IDataModel
Visual Basic
Public Interface IDataModel
Visual C++
public interface class IDataModel

See Also

IDataModel Members
ToolInterfaces Namespace


IDataModel Members

[image] [image]

MADCAT Software Developer Guide
IDataModel Members
IDataModel Interface Methods Properties See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IDataModel type exposes the following members.

Methods

Name Description
Public method CanOpenItem
Indicates if the XML node contains child nodes Use this method to check if a given node taken from the project's data has child nodes which can be displayed in the explorer of MADCAT (like folders or items having sub-items).
Public method GetAttributeDef(String, String)
Provides the XML attribute defining an attribute of a project's data XML node Use this method to get the XML node of the model which defines an attribute of a XML node of the model With the definition, you can access internal data related to the selected attribute such as its type, its options, its icons, etc...
Public method GetAttributeDef(XmlNode, String)
Provides the XML attribute defining an attribute of a project's data XML node Use this method to get the XML node of the model which defines the attribute of the given project's data XML node. With the definition, you can access internal data related to the selected attribute such as its type, its options, its icons, etc...
Public method GetAttributesColor
Provides the baseline colors attached to the attributes of an item Use this method to get a hashtable which contains the color attached to the attributes of a given item. The colors are related to the baseline status of the item :
  • Red : The value of the attribute has been changed but not saved
  • Yellow : The value of the attribute has changed since the reference baseline and is saved
  • Green : The value of the attribute never changed since the reference baseline
Public method GetAttributeType
Provides the type of an attribute/index of the model Use this method to get the type of an attribute (or index) of the model which exposes the interface.
Public method GetIndexDef
Provides the XML node definition of the index of the given series definition Use this method to get the definition of an index of a series.
Public method GetItemImageKey
Provides the key of the image used to display an item Use this method to get the key of the image used to display the item in MADCAT's GUI. The key is related to the image lists of the model. Use the key with these lists to get an Image object for the item.
Public method GetItemIndex
Provides the index value of a given item in a series.
Public method GetModelByName
Provides a XML node of the model Use this method to get a node of the model using its name
Public method GetModelNode
Provides the XML node of the model which is the definition of the given XML node Use this method to get the XML node of the model which corresponds to the definition used by MADCAT to manage the given XML node. When you have a XML definition of a node, you can access all the internal data related to this node such as : its XML name, its attributes definitions, its children's definitions, its icons...
Public method GetNodeDescription
Provides the description of a project's data XML node Use this method to get a description of a node which can be displayed on the GUI of MADCAT
Public method GetNodeType
Provides the type of an XML node of the model Use this method to get the type of an XML node of the model which exposes the interface.
Public method GetNodeTypeDescription
Provides the description of the type of an XML node of the model Use this method to get a textual description of an XML node of the model which exposes the interface.
Public method GetSeriesAttributes
Provides the list of XML node definitions of the attributes of the given series definition Use this method to get the definition of all the attributes of a series.
Public method IsReadOnly
Indicates if the XML node contain be edited or not. Items in baseline can't be edited.
Public method SyncItemWithModel
Updates an item using the model Use this method to add missing attributes or missing children in accordance with the definition of the item in the model. Existing data is kept unchanged.

Properties

 | Name | Description
Public property | Icons | Image list which contains normal icons of the model (Read-only)
Public property | LargeIcons | Image list which contains large icons of the model
Public property | ModelColor | Color attached to the model (Read-only). Use this color to display elements in relation with the model. This helps the user in finding informations quicker on the screen.
Public property | ModelName | Name of the model referenced by the interface (Read-only)

See Also

IDataModel Interface
ToolInterfaces Namespace


IDataModel Methods

[image] [image]

MADCAT Software Developer Guide
IDataModel Methods
IDataModel Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IDataModel type exposes the following members.

Methods

Name Description
Public method CanOpenItem
Indicates if the XML node contains child nodes Use this method to check if a given node taken from the project's data has child nodes which can be displayed in the explorer of MADCAT (like folders or items having sub-items).
Public method GetAttributeDef(String, String)
Provides the XML attribute defining an attribute of a project's data XML node Use this method to get the XML node of the model which defines an attribute of a XML node of the model With the definition, you can access internal data related to the selected attribute such as its type, its options, its icons, etc...
Public method GetAttributeDef(XmlNode, String)
Provides the XML attribute defining an attribute of a project's data XML node Use this method to get the XML node of the model which defines the attribute of the given project's data XML node. With the definition, you can access internal data related to the selected attribute such as its type, its options, its icons, etc...
Public method GetAttributesColor
Provides the baseline colors attached to the attributes of an item Use this method to get a hashtable which contains the color attached to the attributes of a given item. The colors are related to the baseline status of the item :
  • Red : The value of the attribute has been changed but not saved
  • Yellow : The value of the attribute has changed since the reference baseline and is saved
  • Green : The value of the attribute never changed since the reference baseline
Public method GetAttributeType
Provides the type of an attribute/index of the model Use this method to get the type of an attribute (or index) of the model which exposes the interface.
Public method GetIndexDef
Provides the XML node definition of the index of the given series definition Use this method to get the definition of an index of a series.
Public method GetItemImageKey
Provides the key of the image used to display an item Use this method to get the key of the image used to display the item in MADCAT's GUI. The key is related to the image lists of the model. Use the key with these lists to get an Image object for the item.
Public method GetItemIndex
Provides the index value of a given item in a series.
Public method GetModelByName
Provides a XML node of the model Use this method to get a node of the model using its name
Public method GetModelNode
Provides the XML node of the model which is the definition of the given XML node Use this method to get the XML node of the model which corresponds to the definition used by MADCAT to manage the given XML node. When you have a XML definition of a node, you can access all the internal data related to this node such as : its XML name, its attributes definitions, its children's definitions, its icons...
Public method GetNodeDescription
Provides the description of a project's data XML node Use this method to get a description of a node which can be displayed on the GUI of MADCAT
Public method GetNodeType
Provides the type of an XML node of the model Use this method to get the type of an XML node of the model which exposes the interface.
Public method GetNodeTypeDescription
Provides the description of the type of an XML node of the model Use this method to get a textual description of an XML node of the model which exposes the interface.
Public method GetSeriesAttributes
Provides the list of XML node definitions of the attributes of the given series definition Use this method to get the definition of all the attributes of a series.
Public method IsReadOnly
Indicates if the XML node contain be edited or not. Items in baseline can't be edited.
Public method SyncItemWithModel
Updates an item using the model Use this method to add missing attributes or missing children in accordance with the definition of the item in the model. Existing data is kept unchanged.

See Also

IDataModel Interface
ToolInterfaces Namespace


CanOpenItem Method

[image]

MADCAT Software Developer Guide
IDataModel..::..CanOpenItem Method
IDataModel Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Indicates if the XML node contains child nodes Use this method to check if a given node taken from the project's data has child nodes which can be displayed in the explorer of MADCAT (like folders or items having sub-items).

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
bool CanOpenItem(
    XmlNode Item
)
Visual Basic
Function CanOpenItem ( _
    Item As XmlNode _
) As Boolean
Visual C++
bool CanOpenItem(
    XmlNode^ Item
)

Parameters

Item
Type: System.Xml..::..XmlNode
XML node of the project's data

Return Value

True if the node can be opened like a folder in the explorer of MADCAT

See Also

IDataModel Interface
IDataModel Members
ToolInterfaces Namespace


GetAttributeDef Method

[image] [image]

MADCAT Software Developer Guide
IDataModel..::..GetAttributeDef Method
IDataModel Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | GetAttributeDef(String, String) | Provides the XML attribute defining an attribute of a project's data XML node Use this method to get the XML node of the model which defines an attribute of a XML node of the model With the definition, you can access internal data related to the selected attribute such as its type, its options, its icons, etc...
Public method | GetAttributeDef(XmlNode, String) | Provides the XML attribute defining an attribute of a project's data XML node Use this method to get the XML node of the model which defines the attribute of the given project's data XML node. With the definition, you can access internal data related to the selected attribute such as its type, its options, its icons, etc...

See Also

IDataModel Interface
IDataModel Members
ToolInterfaces Namespace


GetAttributeDef Method (String, String)

[image]

MADCAT Software Developer Guide
IDataModel..::..GetAttributeDef Method (String, String)
IDataModel Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Provides the XML attribute defining an attribute of a project's data XML node Use this method to get the XML node of the model which defines an attribute of a XML node of the model With the definition, you can access internal data related to the selected attribute such as its type, its options, its icons, etc...

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
XmlNode GetAttributeDef(
    string NodeName,
    string attrName
)
Visual Basic
Function GetAttributeDef ( _
    NodeName As String, _
    attrName As String _
) As XmlNode
Visual C++
XmlNode^ GetAttributeDef(
    String^ NodeName,
    String^ attrName
)

Parameters

NodeName
Type: System..::..String
Name of the XML node of the model
attrName
Type: System..::..String
Name of the attribute

Return Value

The XML node which is the definition of the selected attribute in the model

See Also

IDataModel Interface
IDataModel Members
GetAttributeDef Overload
ToolInterfaces Namespace


GetAttributeDef Method (XmlNode, String)

[image]

MADCAT Software Developer Guide
IDataModel..::..GetAttributeDef Method (XmlNode, String)
IDataModel Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Provides the XML attribute defining an attribute of a project's data XML node Use this method to get the XML node of the model which defines the attribute of the given project's data XML node. With the definition, you can access internal data related to the selected attribute such as its type, its options, its icons, etc...

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
XmlNode GetAttributeDef(
    XmlNode Node,
    string attrName
)
Visual Basic
Function GetAttributeDef ( _
    Node As XmlNode, _
    attrName As String _
) As XmlNode
Visual C++
XmlNode^ GetAttributeDef(
    XmlNode^ Node,
    String^ attrName
)

Parameters

Node
Type: System.Xml..::..XmlNode
XML node of the project's data
attrName
Type: System..::..String
Name of the attribute

Return Value

The XML node which is the definition of the attribute in the model

See Also

IDataModel Interface
IDataModel Members
GetAttributeDef Overload
ToolInterfaces Namespace


GetAttributesColor Method

[image]

MADCAT Software Developer Guide
IDataModel..::..GetAttributesColor Method
IDataModel Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Provides the baseline colors attached to the attributes of an item Use this method to get a hashtable which contains the color attached to the attributes of a given item. The colors are related to the baseline status of the item :
  • Red : The value of the attribute has been changed but not saved
  • Yellow : The value of the attribute has changed since the reference baseline and is saved
  • Green : The value of the attribute never changed since the reference baseline

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
Hashtable GetAttributesColor(
    XmlNode Item
)
Visual Basic
Function GetAttributesColor ( _
    Item As XmlNode _
) As Hashtable
Visual C++
Hashtable^ GetAttributesColor(
    XmlNode^ Item
)

Parameters

Item
Type: System.Xml..::..XmlNode
XML node of the projects' data

Return Value

A hashtable which contains the colors (Class Drawing::Color). The key is the attribute name.

See Also

IDataModel Interface
IDataModel Members
ToolInterfaces Namespace


GetAttributeType Method

[image]

MADCAT Software Developer Guide
IDataModel..::..GetAttributeType Method
IDataModel Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Provides the type of an attribute/index of the model Use this method to get the type of an attribute (or index) of the model which exposes the interface.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
DataToolTypes GetAttributeType(
    XmlNode AttrOrIndexDef
)
Visual Basic
Function GetAttributeType ( _
    AttrOrIndexDef As XmlNode _
) As DataToolTypes
Visual C++
DataToolTypes GetAttributeType(
    XmlNode^ AttrOrIndexDef
)

Parameters

AttrOrIndexDef
Type: System.Xml..::..XmlNode
XML definition of the attribute (or index) to get the type from

Return Value

The type of the attribute (or index). Can be any value of the enumerate DataToolTypes

See Also

IDataModel Interface
IDataModel Members
ToolInterfaces Namespace


GetIndexDef Method

[image]

MADCAT Software Developer Guide
IDataModel..::..GetIndexDef Method
IDataModel Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Provides the XML node definition of the index of the given series definition Use this method to get the definition of an index of a series.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
XmlNode GetIndexDef(
    XmlNode Series
)
Visual Basic
Function GetIndexDef ( _
    Series As XmlNode _
) As XmlNode
Visual C++
XmlNode^ GetIndexDef(
    XmlNode^ Series
)

Parameters

Series
Type: System.Xml..::..XmlNode
Series definition node to get the index from

Return Value

The Xml definition node

See Also

IDataModel Interface
IDataModel Members
ToolInterfaces Namespace


GetItemImageKey Method

[image]

MADCAT Software Developer Guide
IDataModel..::..GetItemImageKey Method
IDataModel Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Provides the key of the image used to display an item Use this method to get the key of the image used to display the item in MADCAT's GUI. The key is related to the image lists of the model. Use the key with these lists to get an Image object for the item.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
string GetItemImageKey(
    XmlNode Item
)
Visual Basic
Function GetItemImageKey ( _
    Item As XmlNode _
) As String
Visual C++
String^ GetItemImageKey(
    XmlNode^ Item
)

Parameters

Item
Type: System.Xml..::..XmlNode
XML node of the projects' data

Return Value

The key of the image

See Also

IDataModel Interface
IDataModel Members
ToolInterfaces Namespace


GetItemIndex Method

[image]

MADCAT Software Developer Guide
IDataModel..::..GetItemIndex Method
IDataModel Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Provides the index value of a given item in a series.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
string GetItemIndex(
    XmlNode ItemInSeries
)
Visual Basic
Function GetItemIndex ( _
    ItemInSeries As XmlNode _
) As String
Visual C++
String^ GetItemIndex(
    XmlNode^ ItemInSeries
)

Parameters

ItemInSeries
Type: System.Xml..::..XmlNode
Item node to get the index from. Must be an item of a series.

Return Value

The index value of the item in its series. Returns nullptr if item has no indexes

See Also

IDataModel Interface
IDataModel Members
ToolInterfaces Namespace


GetModelByName Method

[image]

MADCAT Software Developer Guide
IDataModel..::..GetModelByName Method
IDataModel Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Provides a XML node of the model Use this method to get a node of the model using its name

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
XmlNode GetModelByName(
    string name
)
Visual Basic
Function GetModelByName ( _
    name As String _
) As XmlNode
Visual C++
XmlNode^ GetModelByName(
    String^ name
)

Parameters

name
Type: System..::..String
Name of the XML node

Return Value

The XML node having the selected name in the model

See Also

IDataModel Interface
IDataModel Members
ToolInterfaces Namespace


GetModelNode Method

[image]

MADCAT Software Developer Guide
IDataModel..::..GetModelNode Method
IDataModel Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Provides the XML node of the model which is the definition of the given XML node Use this method to get the XML node of the model which corresponds to the definition used by MADCAT to manage the given XML node. When you have a XML definition of a node, you can access all the internal data related to this node such as : its XML name, its attributes definitions, its children's definitions, its icons...

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
XmlNode GetModelNode(
    XmlNode Node
)
Visual Basic
Function GetModelNode ( _
    Node As XmlNode _
) As XmlNode
Visual C++
XmlNode^ GetModelNode(
    XmlNode^ Node
)

Parameters

Node
Type: System.Xml..::..XmlNode
XML node of the project's data

Return Value

The XML node which is the definition of the project's data node in the model

See Also

IDataModel Interface
IDataModel Members
ToolInterfaces Namespace


GetNodeDescription Method

[image]

MADCAT Software Developer Guide
IDataModel..::..GetNodeDescription Method
IDataModel Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Provides the description of a project's data XML node Use this method to get a description of a node which can be displayed on the GUI of MADCAT

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
string GetNodeDescription(
    XmlNode Node
)
Visual Basic
Function GetNodeDescription ( _
    Node As XmlNode _
) As String
Visual C++
String^ GetNodeDescription(
    XmlNode^ Node
)

Parameters

Node
Type: System.Xml..::..XmlNode
XML node of the project's data

Return Value

The description of the node

See Also

IDataModel Interface
IDataModel Members
ToolInterfaces Namespace


GetNodeType Method

[image]

MADCAT Software Developer Guide
IDataModel..::..GetNodeType Method
IDataModel Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Provides the type of an XML node of the model Use this method to get the type of an XML node of the model which exposes the interface.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
DataToolTypes GetNodeType(
    XmlNode Node
)
Visual Basic
Function GetNodeType ( _
    Node As XmlNode _
) As DataToolTypes
Visual C++
DataToolTypes GetNodeType(
    XmlNode^ Node
)

Parameters

Node
Type: System.Xml..::..XmlNode
XML node to get the type from

Return Value

The type of the node. Can be any value of the enumerate DataToolTypes

See Also

IDataModel Interface
IDataModel Members
ToolInterfaces Namespace


GetNodeTypeDescription Method

[image]

MADCAT Software Developer Guide
IDataModel..::..GetNodeTypeDescription Method
IDataModel Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Provides the description of the type of an XML node of the model Use this method to get a textual description of an XML node of the model which exposes the interface.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
string GetNodeTypeDescription(
    XmlNode Node
)
Visual Basic
Function GetNodeTypeDescription ( _
    Node As XmlNode _
) As String
Visual C++
String^ GetNodeTypeDescription(
    XmlNode^ Node
)

Parameters

Node
Type: System.Xml..::..XmlNode
XML Node to get the type from

Return Value

The description of the type of the node

See Also

IDataModel Interface
IDataModel Members
ToolInterfaces Namespace


GetSeriesAttributes Method

[image]

MADCAT Software Developer Guide
IDataModel..::..GetSeriesAttributes Method
IDataModel Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Provides the list of XML node definitions of the attributes of the given series definition Use this method to get the definition of all the attributes of a series.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
XmlNodeList GetSeriesAttributes(
    XmlNode Series
)
Visual Basic
Function GetSeriesAttributes ( _
    Series As XmlNode _
) As XmlNodeList
Visual C++
XmlNodeList^ GetSeriesAttributes(
    XmlNode^ Series
)

Parameters

Series
Type: System.Xml..::..XmlNode
Series definition node to get the index from

Return Value

The list of Xml definition nodes

See Also

IDataModel Interface
IDataModel Members
ToolInterfaces Namespace


IsReadOnly Method

[image]

MADCAT Software Developer Guide
IDataModel..::..IsReadOnly Method
IDataModel Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Indicates if the XML node contain be edited or not. Items in baseline can't be edited.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
bool IsReadOnly(
    XmlNode Item
)
Visual Basic
Function IsReadOnly ( _
    Item As XmlNode _
) As Boolean
Visual C++
bool IsReadOnly(
    XmlNode^ Item
)

Parameters

Item
Type: System.Xml..::..XmlNode
XML node of the project's data

Return Value

True if the node can be edited

See Also

IDataModel Interface
IDataModel Members
ToolInterfaces Namespace


SyncItemWithModel Method

[image]

MADCAT Software Developer Guide
IDataModel..::..SyncItemWithModel Method
IDataModel Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Updates an item using the model Use this method to add missing attributes or missing children in accordance with the definition of the item in the model. Existing data is kept unchanged.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void SyncItemWithModel(
    XmlNode Item
)
Visual Basic
Sub SyncItemWithModel ( _
    Item As XmlNode _
)
Visual C++
void SyncItemWithModel(
    XmlNode^ Item
)

Parameters

Item
Type: System.Xml..::..XmlNode
XML node of the projects' data

See Also

IDataModel Interface
IDataModel Members
ToolInterfaces Namespace


IDataModel Properties

[image] [image]

MADCAT Software Developer Guide
IDataModel Properties
IDataModel Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IDataModel type exposes the following members.

Properties

 | Name | Description
Public property | Icons | Image list which contains normal icons of the model (Read-only)
Public property | LargeIcons | Image list which contains large icons of the model
Public property | ModelColor | Color attached to the model (Read-only). Use this color to display elements in relation with the model. This helps the user in finding informations quicker on the screen.
Public property | ModelName | Name of the model referenced by the interface (Read-only)

See Also

IDataModel Interface
ToolInterfaces Namespace


Icons Property

[image]

MADCAT Software Developer Guide
IDataModel..::..Icons Property
IDataModel Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Image list which contains normal icons of the model (Read-only)

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
ImageList Icons { get; }
Visual Basic
ReadOnly Property Icons As ImageList
    Get
Visual C++
property ImageList^ Icons {
    ImageList^ get ();
}

See Also

IDataModel Interface
IDataModel Members
ToolInterfaces Namespace


LargeIcons Property

[image]

MADCAT Software Developer Guide
IDataModel..::..LargeIcons Property
IDataModel Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Image list which contains large icons of the model

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
ImageList LargeIcons { get; }
Visual Basic
ReadOnly Property LargeIcons As ImageList
    Get
Visual C++
property ImageList^ LargeIcons {
    ImageList^ get ();
}

See Also

IDataModel Interface
IDataModel Members
ToolInterfaces Namespace


ModelColor Property

[image]

MADCAT Software Developer Guide
IDataModel..::..ModelColor Property
IDataModel Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Color attached to the model (Read-only). Use this color to display elements in relation with the model. This helps the user in finding informations quicker on the screen.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
Color ModelColor { get; }
Visual Basic
ReadOnly Property ModelColor As Color
    Get
Visual C++
property Color ModelColor {
    Color get ();
}

See Also

IDataModel Interface
IDataModel Members
ToolInterfaces Namespace


ModelName Property

[image]

MADCAT Software Developer Guide
IDataModel..::..ModelName Property
IDataModel Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Name of the model referenced by the interface (Read-only)

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
string ModelName { get; }
Visual Basic
ReadOnly Property ModelName As String
    Get
Visual C++
property String^ ModelName {
    String^ get ();
}

See Also

IDataModel Interface
IDataModel Members
ToolInterfaces Namespace


IDataSource Interface

[image]

MADCAT Software Developer Guide
IDataSource Interface
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This interfaces provides methods to manage raw Xml data of a database.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public interface IDataSource
Visual Basic
Public Interface IDataSource
Visual C++
public interface class IDataSource

See Also

IDataSource Members
ToolInterfaces Namespace


IDataSource Members

[image] [image]

MADCAT Software Developer Guide
IDataSource Members
IDataSource Interface Properties See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IDataSource type exposes the following members.

Properties

 | Name | Description
Public property | FileName | Full file name (path+name) of the XML source
Public property | Identifier | Identifier of the source
Public property | IsReadOnly | Flag that indicates if the source can be modified (=false) or not (=true)
Public property | Name | Name of the source

See Also

IDataSource Interface
ToolInterfaces Namespace


IDataSource Properties

[image] [image]

MADCAT Software Developer Guide
IDataSource Properties
IDataSource Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IDataSource type exposes the following members.

Properties

 | Name | Description
Public property | FileName | Full file name (path+name) of the XML source
Public property | Identifier | Identifier of the source
Public property | IsReadOnly | Flag that indicates if the source can be modified (=false) or not (=true)
Public property | Name | Name of the source

See Also

IDataSource Interface
ToolInterfaces Namespace


FileName Property

[image]

MADCAT Software Developer Guide
IDataSource..::..FileName Property
IDataSource Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Full file name (path+name) of the XML source

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
string FileName { get; }
Visual Basic
ReadOnly Property FileName As String
    Get
Visual C++
property String^ FileName {
    String^ get ();
}

See Also

IDataSource Interface
IDataSource Members
ToolInterfaces Namespace


Identifier Property

[image]

MADCAT Software Developer Guide
IDataSource..::..Identifier Property
IDataSource Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Identifier of the source

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
string Identifier { get; }
Visual Basic
ReadOnly Property Identifier As String
    Get
Visual C++
property String^ Identifier {
    String^ get ();
}

See Also

IDataSource Interface
IDataSource Members
ToolInterfaces Namespace


IsReadOnly Property

[image]

MADCAT Software Developer Guide
IDataSource..::..IsReadOnly Property
IDataSource Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Flag that indicates if the source can be modified (=false) or not (=true)

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
bool IsReadOnly { get; }
Visual Basic
ReadOnly Property IsReadOnly As Boolean
    Get
Visual C++
property bool IsReadOnly {
    bool get ();
}

See Also

IDataSource Interface
IDataSource Members
ToolInterfaces Namespace


Name Property

[image]

MADCAT Software Developer Guide
IDataSource..::..Name Property
IDataSource Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Name of the source

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
string Name { get; }
Visual Basic
ReadOnly Property Name As String
    Get
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IDataSource Interface
IDataSource Members
ToolInterfaces Namespace


InitResult Enumeration

[image]

MADCAT Software Developer Guide
InitResult Enumeration
See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Enumerate used by the tools to indicate if an action has been successfully initialized and then can be executed by MADCAT. Actions are a 2-steps process : Init and Run. During "Init", the tool checks the execution context, prepare some data for the requested action or ask the user for additional data using Wizards. If any prerequisite is missing, execution can be avoided by returning an error during the "Init phase". Another possibility is too schedule the action later. For example, if a shared resource is not available when action is requested and this resource is mandatory, the tool can asked MADCAT to schedule the action when the current action using the resource will be over.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public enum InitResult
Visual Basic
Public Enumeration InitResult
Visual C++
public enum class InitResult

Members

Member name | Value | Description
Schedule | 3 | Data is OK but action can't be executed now. It is postponed and placed after another action. The process context of this action shall be given by the property ITool::RunAfter
Abort | 2 | User has canceled the action.
Stop | 1 | Init has detected an error. Action can't be executed.
Continue | 0 | Init is done. Action can be executed

See Also

ToolInterfaces Namespace


IProcessContext Interface

[image]

MADCAT Software Developer Guide
IProcessContext Interface
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Main interface between a tool and MADCAT. Gives access to all the functionalities of MADCAT and to the data which should be processed by the tool. This interface gathers all the data and methods needed by a tool to perform any actions. It provides access to all the functionalities of MADCAT such as :
  • Logbook manager : used to log informations, warnings, errors. See interface ILogbookWriter
  • Progress management : used to indicate the progress of an action.
  • Workspace : used to control display, read/write user preferences, activate wizards, start other workspaces. See interface IWorkspace
  • Data management : used to create/modify/delete data with baselines, models. See class DataPacket.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public interface IProcessContext
Visual Basic
Public Interface IProcessContext
Visual C++
public interface class IProcessContext

See Also

IProcessContext Members
ToolInterfaces Namespace


IProcessContext Members

[image] [image]

MADCAT Software Developer Guide
IProcessContext Members
IProcessContext Interface Methods Properties See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IProcessContext type exposes the following members.

Methods

Name Description
Public method ActivateTransactions
Activates the transaction manager for a Data packet Tools must invoke this method every time they want to modify the XML data of a data packet which is not the initial Data context given by MADCAT through the interfaces InitializeAction and PerformAction. If this method is not called before modifying the XML data, all the changes will be lost. MADCAT protects user data in data packets. Modifications performed on data packets must be traced by a transaction manager in order to be reproduced on the real XML data of the project of the user. This system is safe as all modifications performed during a long period of time by the tool during the execution of an action will be performed very shortly by MADCAT only if execution is successfull and the tool invokes the method CommitTransactions. Data is always coherent even if action has crashed during the execution or the user canceled the operation. User can also see all the transactions performed on his data in the list of actions of MADCAT. Note that the Data context provided by the interface IProcessContext is automatically connected to a transaction manager if the action is not defined as "readonly" in the tool definition file (xtl).
Public method AddStep
Tools use this method to add a step to the current execution. Invoke this method to add a step in the progress window of the current action.
Public method AddSteps
Tools use this method to add a serie of short steps to the current execution. Invoke this method to add a serie of short steps in the progress window of the current action. Each step should be executed rapidly for the user as the duration of each step can't be specified with this method.
Public method CancelStep(Int32)
Indicates that a step has been canceled by the tool As a step is not automatically set to Canceled when the tool starts a new one, this method must be invoked any time a step is over with an error.
Public method CancelStep(Int32, Int32)
Indicates that a step has been canceled by the tool and that a new step is starting As a step is not automatically set to Canceled when the tool starts a new one, this method must be invoked any time a step is over with an error.
Public method CommitTransactions
Commits all the pending data transactions of an action Tools invoke this method if they want to commit all the transactions performed on data packets BEFORE the end of the execution of an action. Transactions can be Creation/Modification/Deletion of an XML node (item or attribute). After the commit, there will be no more pending transactions. If an action is not defined as "readonly" in the tool definition file, MADCAT always automatically invokes this method at the end of an action when it is successfull. Note that project data is only updated in RAM. The user has to perform a "Save" to write all the modifications on disk before leaving MADCAT.
Public method CompleteStep(Int32)
Indicates that a step has been completed by the tool As a step is not automatically set to Complete when the tool starts a new one, this method must be invoked any time a step is over. This is the only way to signal the end of a step. Setting the progress of a step to its maximum value with SetStepProgress doesn't change its status.
Public method CompleteStep(Int32, Int32)
Indicates that a step has been completed by the tool and that a new step is starting As a step is not automatically set to Complete when the tool starts a new one, this method must be invoked any time a step is over. This is the only way to signal the end of a step. Setting the progress of a step to its maximum value with SetStepProgress doesn't change its status.
Public method GetTemporaryPath
Returns a path in the temporary folder of the user Use this method to get a path to a temporary storage place on user's disk.
Public method GetUserConfig
This method returns the list of global parameters and their values for a tool. Values are taken from the user profile. These parameters are modified by the user when he activates the configuration panel with the command "Options" of the menu of the main window of MADCAT. MADCAT gets the parameters of the configuration set by using the method GetConfigSet of the interface ITool implemented by the tool.
Public method HeartBeat
Indicates a process is still alive Invoke this method periodically when your tool performs an endless action just to indicate that the action is still running.
Public method RunWizard
Method used to run a wizard to ask a serie of questions to the user for the requested action. It is recommended to invoke this method during the "Init" phase of an action. Data entered by the user is saved by MADCAT so that the same action can be run multiple times without asking the user the same questions. The values entered by the user in a wizard is a part of the context of an action along with the XML data coming from the project.
Public method SetStepProgress
Changes the progression of a step Invoke this method to indicate the progression of a step. Ticks is relative to the total number of Ticks attached to the step when it has been created with the method AddStep. So progress in percentage can be computed as follow : P = 100 x Ticks / (TotalTicks). Tools can perform several steps in parallel so this method can be invoked in separate threads with different step numbers.
Public method SetUserConfig
This method saves in the user profile the list of global parameters and their values for a tool. These parameters are modified by the user when he activates the configuration panel with the command "Options" of the menu of the main window of MADCAT.
Public method StartStep
Tools use this method to start a step Invoke this method to indicate in the progress window that a new step has started. Note that it doesn't change the status of the preceding step as a tool can start several steps and execute them in parallel. See methods CompleteStep and CancelStep if you want to indicate the end of a step to the user.

Properties

 | Name | Description
Public property | ActionToPerform | Name of the action requested by the user
Public property | App | Interface the tool must use to invoke MADCAT's functionalities
Public property | BeforeCancel | Handler to invoke when the user cancels the action
Public property | DataContext | Data the tool can read/modify to perform the action
Public property | Log | Interface the tool must use to log messages in MADCAT logbooks for the action
Public property | OnResume | Handler to invoke when the user resumes the action
Public property | OnSuspend | Handler invoked by MADCAT when the user suspends the action. May be null.
Public property | Parameters | Array of parameters for the requested action
Public property | ProcessTitle | Title of the process which will be performed

See Also

IProcessContext Interface
ToolInterfaces Namespace


IProcessContext Methods

[image] [image]

MADCAT Software Developer Guide
IProcessContext Methods
IProcessContext Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IProcessContext type exposes the following members.

Methods

Name Description
Public method ActivateTransactions
Activates the transaction manager for a Data packet Tools must invoke this method every time they want to modify the XML data of a data packet which is not the initial Data context given by MADCAT through the interfaces InitializeAction and PerformAction. If this method is not called before modifying the XML data, all the changes will be lost. MADCAT protects user data in data packets. Modifications performed on data packets must be traced by a transaction manager in order to be reproduced on the real XML data of the project of the user. This system is safe as all modifications performed during a long period of time by the tool during the execution of an action will be performed very shortly by MADCAT only if execution is successfull and the tool invokes the method CommitTransactions. Data is always coherent even if action has crashed during the execution or the user canceled the operation. User can also see all the transactions performed on his data in the list of actions of MADCAT. Note that the Data context provided by the interface IProcessContext is automatically connected to a transaction manager if the action is not defined as "readonly" in the tool definition file (xtl).
Public method AddStep
Tools use this method to add a step to the current execution. Invoke this method to add a step in the progress window of the current action.
Public method AddSteps
Tools use this method to add a serie of short steps to the current execution. Invoke this method to add a serie of short steps in the progress window of the current action. Each step should be executed rapidly for the user as the duration of each step can't be specified with this method.
Public method CancelStep(Int32)
Indicates that a step has been canceled by the tool As a step is not automatically set to Canceled when the tool starts a new one, this method must be invoked any time a step is over with an error.
Public method CancelStep(Int32, Int32)
Indicates that a step has been canceled by the tool and that a new step is starting As a step is not automatically set to Canceled when the tool starts a new one, this method must be invoked any time a step is over with an error.
Public method CommitTransactions
Commits all the pending data transactions of an action Tools invoke this method if they want to commit all the transactions performed on data packets BEFORE the end of the execution of an action. Transactions can be Creation/Modification/Deletion of an XML node (item or attribute). After the commit, there will be no more pending transactions. If an action is not defined as "readonly" in the tool definition file, MADCAT always automatically invokes this method at the end of an action when it is successfull. Note that project data is only updated in RAM. The user has to perform a "Save" to write all the modifications on disk before leaving MADCAT.
Public method CompleteStep(Int32)
Indicates that a step has been completed by the tool As a step is not automatically set to Complete when the tool starts a new one, this method must be invoked any time a step is over. This is the only way to signal the end of a step. Setting the progress of a step to its maximum value with SetStepProgress doesn't change its status.
Public method CompleteStep(Int32, Int32)
Indicates that a step has been completed by the tool and that a new step is starting As a step is not automatically set to Complete when the tool starts a new one, this method must be invoked any time a step is over. This is the only way to signal the end of a step. Setting the progress of a step to its maximum value with SetStepProgress doesn't change its status.
Public method GetTemporaryPath
Returns a path in the temporary folder of the user Use this method to get a path to a temporary storage place on user's disk.
Public method GetUserConfig
This method returns the list of global parameters and their values for a tool. Values are taken from the user profile. These parameters are modified by the user when he activates the configuration panel with the command "Options" of the menu of the main window of MADCAT. MADCAT gets the parameters of the configuration set by using the method GetConfigSet of the interface ITool implemented by the tool.
Public method HeartBeat
Indicates a process is still alive Invoke this method periodically when your tool performs an endless action just to indicate that the action is still running.
Public method RunWizard
Method used to run a wizard to ask a serie of questions to the user for the requested action. It is recommended to invoke this method during the "Init" phase of an action. Data entered by the user is saved by MADCAT so that the same action can be run multiple times without asking the user the same questions. The values entered by the user in a wizard is a part of the context of an action along with the XML data coming from the project.
Public method SetStepProgress
Changes the progression of a step Invoke this method to indicate the progression of a step. Ticks is relative to the total number of Ticks attached to the step when it has been created with the method AddStep. So progress in percentage can be computed as follow : P = 100 x Ticks / (TotalTicks). Tools can perform several steps in parallel so this method can be invoked in separate threads with different step numbers.
Public method SetUserConfig
This method saves in the user profile the list of global parameters and their values for a tool. These parameters are modified by the user when he activates the configuration panel with the command "Options" of the menu of the main window of MADCAT.
Public method StartStep
Tools use this method to start a step Invoke this method to indicate in the progress window that a new step has started. Note that it doesn't change the status of the preceding step as a tool can start several steps and execute them in parallel. See methods CompleteStep and CancelStep if you want to indicate the end of a step to the user.

See Also

IProcessContext Interface
ToolInterfaces Namespace


ActivateTransactions Method

[image]

MADCAT Software Developer Guide
IProcessContext..::..ActivateTransactions Method
IProcessContext Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Activates the transaction manager for a Data packet Tools must invoke this method every time they want to modify the XML data of a data packet which is not the initial Data context given by MADCAT through the interfaces InitializeAction and PerformAction. If this method is not called before modifying the XML data, all the changes will be lost. MADCAT protects user data in data packets. Modifications performed on data packets must be traced by a transaction manager in order to be reproduced on the real XML data of the project of the user. This system is safe as all modifications performed during a long period of time by the tool during the execution of an action will be performed very shortly by MADCAT only if execution is successfull and the tool invokes the method CommitTransactions. Data is always coherent even if action has crashed during the execution or the user canceled the operation. User can also see all the transactions performed on his data in the list of actions of MADCAT. Note that the Data context provided by the interface IProcessContext is automatically connected to a transaction manager if the action is not defined as "readonly" in the tool definition file (xtl).

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void ActivateTransactions(
    DataPacket dp
)
Visual Basic
Sub ActivateTransactions ( _
    dp As DataPacket _
)
Visual C++
void ActivateTransactions(
    DataPacket^ dp
)

Parameters

dp
Type: ToolInterfaces..::..DataPacket
Data packet which must be connected to a transaction manager

Examples

This example shows how to find items in the database of the workspace, put them in a data packet, and update the content of these items using transactions.
CopyC++
ExecutionResult Tool::PerformAction(IProcessContext ^Context)
{
   // Look for an item of type ITEM having the attribute FIRSTNAME equal to 'HELLO'
   DataPacket ^dp = Context->App->PerformSearch(nullptr,L"//ITEM[@FIRSTNAME='HELLO']");
   // Check if an item has been found
   if(dp&&dp->Items->Count==1)
   {
       // Activates transactions because we want to modify the item in the database (and not only locally)
       Context->ActivateTransactions(dp);
       // Modify the item
       XmlNode ^itm = (XmlNode ^)dp->Items[0];
       // by setting its attribute LASTNAME to 'WORLD'
       itm->Attributes[L"LASTNAME"]->Value = L"WORLD";
       // End the action. MADCAT will automatically commit the transactions performed in the data packet
       return ExecutionResult::Successfull;
   }
   // Item not found. Something went wrong.
   return ExecutionResult::Failed;
}

See Also

IProcessContext Interface
IProcessContext Members
ToolInterfaces Namespace


AddStep Method

[image]

MADCAT Software Developer Guide
IProcessContext..::..AddStep Method
IProcessContext Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Tools use this method to add a step to the current execution. Invoke this method to add a step in the progress window of the current action.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void AddStep(
    string Name,
    int TotalTicks
)
Visual Basic
Sub AddStep ( _
    Name As String, _
    TotalTicks As Integer _
)
Visual C++
void AddStep(
    String^ Name,
    int TotalTicks
)

Parameters

Name
Type: System..::..String
Name of the step
TotalTicks
Type: System..::..Int32
Any arbitrary number indicating the number of units to reach to complete the step.

Examples

This example shows how to use the progress management methods (AddStep, CompleteStep, CancelStep)
CopyC++
Tool::Tool(void)
{
   // Initialize two groups of parameters for the wizard
   // The 1st group is used to select the steps to execute
   // The 2nd group is used to select the results of the steps
   this->stepOne = gcnew BooleanInput();
   this->stepOne->Name = L"STEPONE";
   this->stepOne->Description = L"Step one";
   this->stepOne->Value = L"YES";
   this->stepOneIsOK = gcnew BooleanInput();
   this->stepOneIsOK->Name = L"STEPONERESULT";
   this->stepOneIsOK->Description = L"Step one is successfull";
   this->stepOneIsOK->Value = L"YES";
   this->stepTwo = gcnew BooleanInput();
   this->stepTwo->Name = L"STEPTWO";
   this->stepTwo->Description = L"Step two";
   this->stepTwo->Value = L"YES";
   this->stepTwoIsOK = gcnew BooleanInput();
   this->stepTwoIsOK->Name = L"STEPTWORESULT";
   this->stepTwoIsOK->Description = L"Step two is successfull";
   this->stepTwoIsOK->Value = L"YES";
   this->stepThree = gcnew BooleanInput();
   this->stepThree->Name = L"STEPTHREE";
   this->stepThree->Description = L"Step three";
   this->stepThree->Value = L"YES";
   this->stepThreeIsOK = gcnew BooleanInput();
   this->stepThreeIsOK->Name = L"STEPTHREERESULT";
   this->stepThreeIsOK->Description = L"Step three is successfull";
   this->stepThreeIsOK->Value = L"YES";

   this->stepOptions = gcnew GroupOfFields();
   this->stepOptions->Name = L"STEPOPTIONS";
   this->stepOptions->Description = L"Steps to run";
   Hashtable ^opt = gcnew Hashtable();
   opt[L"height"] = L"200";
   this->stepOptions->Options = opt;
   this->stepOptions->Parameters = gcnew cli::array<IParameter ^>(3){this->stepOne,this->stepTwo,this->stepThree};

   this->stepResults = gcnew GroupOfFields();
   this->stepResults->Name = L"STEPRESULTS";
   this->stepResults->Description = L"Steps results";
   this->stepResults->Options = opt;
   this->stepResults->Parameters = gcnew cli::array<IParameter ^>(3){this->stepOneIsOK,this->stepTwoIsOK,this->stepThreeIsOK};
}

InitResult Tool::InitializeAction(IProcessContext ^Context)
{
   bool something_todo = false;

   // We check the requested action
   if(Context->ActionToPerform==L"TESTSTEPS")
   {
       // We ask the user to select the steps and their results with a wizard
       if(Context->RunWizard(L"Select the steps to run",gcnew cli::array<IParameter ^>(2){this->stepOptions,this->stepResults})==DialogResult::OK)
       {
           // The user didn't cancel his request, so let's check his choices
           if(this->stepOne->Value==L"YES")
           {
               Context->AddStep(L"Running Step one",100);
               something_todo = true;
           }
           if(this->stepTwo->Value==L"YES")
           {
               Context->AddStep(L"Running Step two",100);
               something_todo = true;
           }
           if(this->stepThree->Value==L"YES")
           {
               Context->AddStep(L"Running Step three",100);
               something_todo = true;
           }
       }
       if(something_todo)
       {
           return InitResult::Continue;
       }
   }
   return InitResult::Abort;
}

ExecutionResult Tool::PerformAction(IProcessContext ^Context)
{
   int n = 1;
   int p = 0;
   bool is_cancelled = false;

   // We check the requested action
   if(Context->ActionToPerform==L"TESTSTEPS")
   {
       // We execute the requested steps
       if(this->stepOne->Value==L"YES")
       {
           Context->StartStep(n);
           if(this->stepOneIsOK->Value==L"YES")
           {
               for(p=0;p=100;p++)
               {
                   Thread::CurrentThread::Sleep(50);
                   Context->SetStepProgress(n,p);
               }
               Context->CompleteStep(n++);
           }
           else
           {
               Context->CancelStep(n++);
               is_cancelled = true;
           }
       }
       if(this->stepTwo->Value==L"YES")
       {
           Context->StartStep(n);
           if(this->stepTwoIsOK->Value==L"YES")
           {
               for(p=0;p=100;p++)
               {
                   Thread::CurrentThread::Sleep(50);
                   Context->SetStepProgress(n,p);
               }
               Context->CompleteStep(n++);
           }
           else
           {
               Context->CancelStep(n++);
               is_cancelled = true;
           }
       }
       if(this->stepThree->Value==L"YES")
       {
           Context->StartStep(n);
           if(this->stepThreeIsOK->Value==L"YES")
           {
               for(p=0;p=100;p++)
               {
                   Thread::CurrentThread::Sleep(50);
                   Context->SetStepProgress(n,p);
               }
               Context->CompleteStep(n++);
           }
           else
           {
               Context->CancelStep(n++);
               is_cancelled = true;
           }
       }
       if(is_cancelled)
       {
           return ExecutionResult::Cancelled;
       }
       return ExecutionResult::Successfull;
   }
   return ExecutionResult::Failed;
}

See Also

IProcessContext Interface
IProcessContext Members
ToolInterfaces Namespace


AddSteps Method

[image]

MADCAT Software Developer Guide
IProcessContext..::..AddSteps Method
IProcessContext Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Tools use this method to add a serie of short steps to the current execution. Invoke this method to add a serie of short steps in the progress window of the current action. Each step should be executed rapidly for the user as the duration of each step can't be specified with this method.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void AddSteps(
    string[] StepNames
)
Visual Basic
Sub AddSteps ( _
    StepNames As String() _
)
Visual C++
void AddSteps(
    array<String^>^ StepNames
)

Parameters

StepNames
Type: array< System..::..String >[]()[][]
Array of String objects. 1 object = 1 step. Steps must be ordered in the array.

See Also

IProcessContext Interface
IProcessContext Members
ToolInterfaces Namespace


CancelStep Method

[image] [image]

MADCAT Software Developer Guide
IProcessContext..::..CancelStep Method
IProcessContext Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | CancelStep(Int32) | Indicates that a step has been canceled by the tool As a step is not automatically set to Canceled when the tool starts a new one, this method must be invoked any time a step is over with an error.
Public method | CancelStep(Int32, Int32) | Indicates that a step has been canceled by the tool and that a new step is starting As a step is not automatically set to Canceled when the tool starts a new one, this method must be invoked any time a step is over with an error.

See Also

IProcessContext Interface
IProcessContext Members
ToolInterfaces Namespace


CancelStep Method (Int32)

[image]

MADCAT Software Developer Guide
IProcessContext..::..CancelStep Method (Int32)
IProcessContext Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Indicates that a step has been canceled by the tool As a step is not automatically set to Canceled when the tool starts a new one, this method must be invoked any time a step is over with an error.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void CancelStep(
    int StepNumber
)
Visual Basic
Sub CancelStep ( _
    StepNumber As Integer _
)
Visual C++
void CancelStep(
    int StepNumber
)

Parameters

StepNumber
Type: System..::..Int32
Index of the step canceled

Examples

See AddStep(String, Int32).

See Also

IProcessContext Interface
IProcessContext Members
CancelStep Overload
ToolInterfaces Namespace


CancelStep Method (Int32, Int32)

[image]

MADCAT Software Developer Guide
IProcessContext..::..CancelStep Method (Int32, Int32)
IProcessContext Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Indicates that a step has been canceled by the tool and that a new step is starting As a step is not automatically set to Canceled when the tool starts a new one, this method must be invoked any time a step is over with an error.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void CancelStep(
    int StepNumber,
    int NextStep
)
Visual Basic
Sub CancelStep ( _
    StepNumber As Integer, _
    NextStep As Integer _
)
Visual C++
void CancelStep(
    int StepNumber,
    int NextStep
)

Parameters

StepNumber
Type: System..::..Int32
Index of the step canceled
NextStep
Type: System..::..Int32
Index of the step which has been started

See Also

IProcessContext Interface
IProcessContext Members
CancelStep Overload
ToolInterfaces Namespace


CommitTransactions Method

[image]

MADCAT Software Developer Guide
IProcessContext..::..CommitTransactions Method
IProcessContext Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Commits all the pending data transactions of an action Tools invoke this method if they want to commit all the transactions performed on data packets BEFORE the end of the execution of an action. Transactions can be Creation/Modification/Deletion of an XML node (item or attribute). After the commit, there will be no more pending transactions. If an action is not defined as "readonly" in the tool definition file, MADCAT always automatically invokes this method at the end of an action when it is successfull. Note that project data is only updated in RAM. The user has to perform a "Save" to write all the modifications on disk before leaving MADCAT.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void CommitTransactions()
Visual Basic
Sub CommitTransactions
Visual C++
void CommitTransactions()

See Also

IProcessContext Interface
IProcessContext Members
ToolInterfaces Namespace


CompleteStep Method

[image] [image]

MADCAT Software Developer Guide
IProcessContext..::..CompleteStep Method
IProcessContext Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | CompleteStep(Int32) | Indicates that a step has been completed by the tool As a step is not automatically set to Complete when the tool starts a new one, this method must be invoked any time a step is over. This is the only way to signal the end of a step. Setting the progress of a step to its maximum value with SetStepProgress doesn't change its status.
Public method | CompleteStep(Int32, Int32) | Indicates that a step has been completed by the tool and that a new step is starting As a step is not automatically set to Complete when the tool starts a new one, this method must be invoked any time a step is over. This is the only way to signal the end of a step. Setting the progress of a step to its maximum value with SetStepProgress doesn't change its status.

See Also

IProcessContext Interface
IProcessContext Members
ToolInterfaces Namespace


CompleteStep Method (Int32)

[image]

MADCAT Software Developer Guide
IProcessContext..::..CompleteStep Method (Int32)
IProcessContext Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Indicates that a step has been completed by the tool As a step is not automatically set to Complete when the tool starts a new one, this method must be invoked any time a step is over. This is the only way to signal the end of a step. Setting the progress of a step to its maximum value with SetStepProgress doesn't change its status.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void CompleteStep(
    int StepNumber
)
Visual Basic
Sub CompleteStep ( _
    StepNumber As Integer _
)
Visual C++
void CompleteStep(
    int StepNumber
)

Parameters

StepNumber
Type: System..::..Int32
Index of the step complete

Examples

See AddStep(String, Int32).

See Also

IProcessContext Interface
IProcessContext Members
CompleteStep Overload
ToolInterfaces Namespace


CompleteStep Method (Int32, Int32)

[image]

MADCAT Software Developer Guide
IProcessContext..::..CompleteStep Method (Int32, Int32)
IProcessContext Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Indicates that a step has been completed by the tool and that a new step is starting As a step is not automatically set to Complete when the tool starts a new one, this method must be invoked any time a step is over. This is the only way to signal the end of a step. Setting the progress of a step to its maximum value with SetStepProgress doesn't change its status.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void CompleteStep(
    int StepNumber,
    int NextStep
)
Visual Basic
Sub CompleteStep ( _
    StepNumber As Integer, _
    NextStep As Integer _
)
Visual C++
void CompleteStep(
    int StepNumber,
    int NextStep
)

Parameters

StepNumber
Type: System..::..Int32
Index of the step complete
NextStep
Type: System..::..Int32
Index of the step which has been started

See Also

IProcessContext Interface
IProcessContext Members
CompleteStep Overload
ToolInterfaces Namespace


GetTemporaryPath Method

[image]

MADCAT Software Developer Guide
IProcessContext..::..GetTemporaryPath Method
IProcessContext Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Returns a path in the temporary folder of the user Use this method to get a path to a temporary storage place on user's disk.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
string GetTemporaryPath()
Visual Basic
Function GetTemporaryPath As String
Visual C++
String^ GetTemporaryPath()

Return Value

String object of the path to the folder created by MADCAT

See Also

IProcessContext Interface
IProcessContext Members
ToolInterfaces Namespace


GetUserConfig Method

[image]

MADCAT Software Developer Guide
IProcessContext..::..GetUserConfig Method
IProcessContext Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This method returns the list of global parameters and their values for a tool. Values are taken from the user profile. These parameters are modified by the user when he activates the configuration panel with the command "Options" of the menu of the main window of MADCAT. MADCAT gets the parameters of the configuration set by using the method GetConfigSet of the interface ITool implemented by the tool.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void GetUserConfig(
    IParameter[] Parameters
)
Visual Basic
Sub GetUserConfig ( _
    Parameters As IParameter() _
)
Visual C++
void GetUserConfig(
    array<IParameter^>^ Parameters
)

Parameters

Parameters
Type: array< Parameters..::..IParameter >[]()[][]
Array of parameters. Empty when calling the method, it is filled with the parameters by the method. It remains empty if no parameters are found in the user profile.

Examples

This example shows how to use the GetUserConfig and SetUserConfig methods to get/save some settings.
CopyC++
Tool::Tool(void)
{
   // Initialize it for the 1st time
   this->odir = gcnew DirectoryInput();
   this->odir->Description = L"Output directory";
   this->odir->Name = L"ODIR";

   this->ParamSet = gcnew cli::array<IParameter ^>(1){this->odir};
}

InitResult Tool::InitializeAction(IProcessContext ^Context)
{
   // Check config set
   this->myContext = Context;

   // Let MADCAT fill the parameters of the set
   Context->GetUserConfig(this->ParamSet);
   // Now the set is filled with the user profile settings. We can check the values.
   if(String::IsNullOrEmpty(this->odir->Value))
   {
       Context->Log->ShowError(L"Destination directory is not defined.");
       return InitResult::Abort;
   }

   // Body of the initialization procedure

   // End of the procedure
   return InitResult::Continue;
}

See Also

IProcessContext Interface
IProcessContext Members
ToolInterfaces Namespace
IProcessContext..::..SetUserConfig(array<IParameter>[]()[][])


HeartBeat Method

[image]

MADCAT Software Developer Guide
IProcessContext..::..HeartBeat Method
IProcessContext Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Indicates a process is still alive Invoke this method periodically when your tool performs an endless action just to indicate that the action is still running.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void HeartBeat()
Visual Basic
Sub HeartBeat
Visual C++
void HeartBeat()

See Also

IProcessContext Interface
IProcessContext Members
ToolInterfaces Namespace


RunWizard Method

[image]

MADCAT Software Developer Guide
IProcessContext..::..RunWizard Method
IProcessContext Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Method used to run a wizard to ask a serie of questions to the user for the requested action. It is recommended to invoke this method during the "Init" phase of an action. Data entered by the user is saved by MADCAT so that the same action can be run multiple times without asking the user the same questions. The values entered by the user in a wizard is a part of the context of an action along with the XML data coming from the project.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
DialogResult RunWizard(
    string Title,
    IParameter[] Parameters
)
Visual Basic
Function RunWizard ( _
    Title As String, _
    Parameters As IParameter() _
) As DialogResult
Visual C++
DialogResult RunWizard(
    String^ Title,
    array<IParameter^>^ Parameters
)

Parameters

Title
Type: System..::..String
Title of the wizard
Parameters
Type: array< Parameters..::..IParameter >[]()[][]
Array of objects exposing the IParameter interface. Each parameter will be displayed in a page of the wizard (i.e 5 parameters = 5 pages). User goes through the pages using the "Next" and "Previous" buttons of the wizard.

Return Value

The result of the wizard. Can be "Successfull" if the user has entered all the requested data or "Canceled" if user canceled the operation.

Examples

See AddStep(String, Int32).

See Also

IProcessContext Interface
IProcessContext Members
ToolInterfaces Namespace


SetStepProgress Method

[image]

MADCAT Software Developer Guide
IProcessContext..::..SetStepProgress Method
IProcessContext Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Changes the progression of a step Invoke this method to indicate the progression of a step. Ticks is relative to the total number of Ticks attached to the step when it has been created with the method AddStep. So progress in percentage can be computed as follow : P = 100 x Ticks / (TotalTicks). Tools can perform several steps in parallel so this method can be invoked in separate threads with different step numbers.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void SetStepProgress(
    int StepNumber,
    int Ticks
)
Visual Basic
Sub SetStepProgress ( _
    StepNumber As Integer, _
    Ticks As Integer _
)
Visual C++
void SetStepProgress(
    int StepNumber,
    int Ticks
)

Parameters

StepNumber
Type: System..::..Int32
Index of the step in the step list of the progress window
Ticks
Type: System..::..Int32
Number which represents the amount of work performed by the tool for this step.

Examples

See AddStep(String, Int32).

See Also

IProcessContext Interface
IProcessContext Members
ToolInterfaces Namespace


SetUserConfig Method

[image]

MADCAT Software Developer Guide
IProcessContext..::..SetUserConfig Method
IProcessContext Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This method saves in the user profile the list of global parameters and their values for a tool. These parameters are modified by the user when he activates the configuration panel with the command "Options" of the menu of the main window of MADCAT.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void SetUserConfig(
    IParameter[] Parameters
)
Visual Basic
Sub SetUserConfig ( _
    Parameters As IParameter() _
)
Visual C++
void SetUserConfig(
    array<IParameter^>^ Parameters
)

Parameters

Parameters
Type: array< Parameters..::..IParameter >[]()[][]
Array of parameters filled with the parameters and their values.

See Also

IProcessContext Interface
IProcessContext Members
ToolInterfaces Namespace
IProcessContext..::..GetUserConfig(array<IParameter>[]()[][])


StartStep Method

[image]

MADCAT Software Developer Guide
IProcessContext..::..StartStep Method
IProcessContext Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Tools use this method to start a step Invoke this method to indicate in the progress window that a new step has started. Note that it doesn't change the status of the preceding step as a tool can start several steps and execute them in parallel. See methods CompleteStep and CancelStep if you want to indicate the end of a step to the user.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void StartStep(
    int StepNumber
)
Visual Basic
Sub StartStep ( _
    StepNumber As Integer _
)
Visual C++
void StartStep(
    int StepNumber
)

Parameters

StepNumber
Type: System..::..Int32
Index of the step in the step list of the progress window

Examples

See AddStep(String, Int32).

See Also

IProcessContext Interface
IProcessContext Members
ToolInterfaces Namespace


IProcessContext Properties

[image] [image]

MADCAT Software Developer Guide
IProcessContext Properties
IProcessContext Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IProcessContext type exposes the following members.

Properties

 | Name | Description
Public property | ActionToPerform | Name of the action requested by the user
Public property | App | Interface the tool must use to invoke MADCAT's functionalities
Public property | BeforeCancel | Handler to invoke when the user cancels the action
Public property | DataContext | Data the tool can read/modify to perform the action
Public property | Log | Interface the tool must use to log messages in MADCAT logbooks for the action
Public property | OnResume | Handler to invoke when the user resumes the action
Public property | OnSuspend | Handler invoked by MADCAT when the user suspends the action. May be null.
Public property | Parameters | Array of parameters for the requested action
Public property | ProcessTitle | Title of the process which will be performed

See Also

IProcessContext Interface
ToolInterfaces Namespace


ActionToPerform Property

[image]

MADCAT Software Developer Guide
IProcessContext..::..ActionToPerform Property
IProcessContext Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Name of the action requested by the user

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
string ActionToPerform { get; set; }
Visual Basic
Property ActionToPerform As String
    Get
    Set
Visual C++
property String^ ActionToPerform {
    String^ get ();
    void set (String^ value);
}

See Also

IProcessContext Interface
IProcessContext Members
ToolInterfaces Namespace


App Property

[image]

MADCAT Software Developer Guide
IProcessContext..::..App Property
IProcessContext Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Interface the tool must use to invoke MADCAT's functionalities

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
IWorkspace App { get; }
Visual Basic
ReadOnly Property App As IWorkspace
    Get
Visual C++
property IWorkspace^ App {
    IWorkspace^ get ();
}

See Also

IProcessContext Interface
IProcessContext Members
ToolInterfaces Namespace


BeforeCancel Property

[image]

MADCAT Software Developer Guide
IProcessContext..::..BeforeCancel Property
IProcessContext Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Handler to invoke when the user cancels the action

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
IProcessContext..::..EventHandler BeforeCancel { get; set; }
Visual Basic
Property BeforeCancel As IProcessContext..::..EventHandler
    Get
    Set
Visual C++
property IProcessContext..::..EventHandler^ BeforeCancel {
    IProcessContext..::..EventHandler^ get ();
    void set (IProcessContext..::..EventHandler^ value);
}

Examples

This example shows how to declare a cancel handler and how to implement a simple one.
CopyC++
void Tool::Cancel()
{
   // Set the flag to false to stop the endless loop of the action
   this->not_cancelled = false;
}

InitResult Tool::InitializeAction(IProcessContext ^Context)
{
   // Declare the handler to invoke to cancel the action when it is running
   Context->BeforeCancel = gcnew IProcessContext::EventHandler(this,&Tool::Cancel);
}

ExecutionResult Tool::PerformAction(IProcessContext ^Context)
{
   // Starts an endless action and wait for the user to cancel it !
   this->not_cancelled = true;
   while(this->not_cancelled)
   {
       // Let the OS do something else !
       Thread::CurrentThread::Sleep(1000);
   }
   // Hopefully, the user has cancelled this loop.
   return ExecutionResult::Cancelled;
}

See Also

IProcessContext Interface
IProcessContext Members
ToolInterfaces Namespace


DataContext Property

[image]

MADCAT Software Developer Guide
IProcessContext..::..DataContext Property
IProcessContext Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Data the tool can read/modify to perform the action

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
DataPacket DataContext { get; set; }
Visual Basic
Property DataContext As DataPacket
    Get
    Set
Visual C++
property DataPacket^ DataContext {
    DataPacket^ get ();
    void set (DataPacket^ value);
}

Examples

This example shows how the data context is used to get the user's selection.
CopyC++
InitResult Tool::InitializeAction(IProcessContext ^Context)
{
      // Check if selected item is a workspace item. We get the 1st item selected by the user using the data context provided by MADCAT.
      XmlNode ^itm = (XmlNode ^)Context->DataContext->Items[0];
      if(itm->Name!=L"WORKSPACE")
      {
          // We generate an error message using the Logbook writer provided by MADCAT in the context. This logbook writer is already configured. Nothing to do.
          Context->Log->ShowError(L"Selected item is not a Workspace Item !");
          // We abort the action
          return InitResult::Abort;
      }
      // We can continue the action. MADCAT will then invoke PerformAction right after this.
      return InitResult::Continue;
}

See Also

IProcessContext Interface
IProcessContext Members
ToolInterfaces Namespace


Log Property

[image]

MADCAT Software Developer Guide
IProcessContext..::..Log Property
IProcessContext Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Interface the tool must use to log messages in MADCAT logbooks for the action

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
ILogbookWriter Log { get; set; }
Visual Basic
Property Log As ILogbookWriter
    Get
    Set
Visual C++
property ILogbookWriter^ Log {
    ILogbookWriter^ get ();
    void set (ILogbookWriter^ value);
}

Examples

This example shows how the Log property is used to generate an error message.
CopyC++
InitResult Tool::InitializeAction(IProcessContext ^Context)
{
      // Check if selected item is a workspace item. We get the 1st item selected by the user using the data context provided by MADCAT.
      XmlNode ^itm = (XmlNode ^)Context->DataContext->Items[0];
      if(itm->Name!=L"WORKSPACE")
      {
          // We generate an error message using the Logbook writer provided by MADCAT in the context. This logbook writer is already configured. Nothing to do.
          Context->Log->ShowError(L"Selected item is not a Workspace Item !");
          // We abort the action
          return InitResult::Abort;
      }
      // We can continue the action. MADCAT will then invoke PerformAction right after this.
      return InitResult::Continue;
}

See Also

IProcessContext Interface
IProcessContext Members
ToolInterfaces Namespace


OnResume Property

[image]

MADCAT Software Developer Guide
IProcessContext..::..OnResume Property
IProcessContext Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Handler to invoke when the user resumes the action

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
IProcessContext..::..EventHandler OnResume { get; set; }
Visual Basic
Property OnResume As IProcessContext..::..EventHandler
    Get
    Set
Visual C++
property IProcessContext..::..EventHandler^ OnResume {
    IProcessContext..::..EventHandler^ get ();
    void set (IProcessContext..::..EventHandler^ value);
}

Examples

See OnSuspend

See Also

IProcessContext Interface
IProcessContext Members
ToolInterfaces Namespace


OnSuspend Property

[image]

MADCAT Software Developer Guide
IProcessContext..::..OnSuspend Property
IProcessContext Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Handler invoked by MADCAT when the user suspends the action. May be null.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
IProcessContext..::..EventHandler OnSuspend { get; set; }
Visual Basic
Property OnSuspend As IProcessContext..::..EventHandler
    Get
    Set
Visual C++
property IProcessContext..::..EventHandler^ OnSuspend {
    IProcessContext..::..EventHandler^ get ();
    void set (IProcessContext..::..EventHandler^ value);
}

Examples

This example shows how to declare a cancel, pause and resume handler and how to implement simple ones.
CopyC++
void Tool::Cancel()
{
   // Set the flag to false to stop the endless loop of the action
   this->not_cancelled = false;
}

void Tool::Pause()
{
   // MADCAT will pause the action. Let's do something just before that.
   Context->Log->ShowInfo(L"Pause !");
}

void Tool::Resume()
{
   // MADCAT will resume the action. Let's do something just before that.
   Context->Log->ShowInfo(L"Resume !");
}

InitResult Tool::InitializeAction(IProcessContext ^Context)
{
   // Declare the handler to invoke to cancel the action when it is running
   Context->BeforeCancel = gcnew IProcessContext::EventHandler(this,&Tool::Cancel);
   // Declare the handler to invoke before pausing the action
   Context->OnSuspend = gcnew IProcessContext::EventHandler(this,&Tool::Pause);
   // Declare the handler to invoke before resuming the action
   Context->OnResume = gcnew IProcessContext::EventHandler(this,&Tool::Resume);
}

ExecutionResult Tool::PerformAction(IProcessContext ^Context)
{
   // Starts an endless action and wait for the user to cancel it !
   this->not_cancelled = true;

   while(this->not_cancelled)
   {
       // Let the OS do something else !
       Thread::CurrentThread::Sleep(1000);
   }
   // Hopefully, the user has cancelled this loop.
   return ExecutionResult::Cancelled;
}

See Also

IProcessContext Interface
IProcessContext Members
ToolInterfaces Namespace


Parameters Property

[image]

MADCAT Software Developer Guide
IProcessContext..::..Parameters Property
IProcessContext Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Array of parameters for the requested action

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
Hashtable Parameters { get; set; }
Visual Basic
Property Parameters As Hashtable
    Get
    Set
Visual C++
property Hashtable^ Parameters {
    Hashtable^ get ();
    void set (Hashtable^ value);
}

See Also

IProcessContext Interface
IProcessContext Members
ToolInterfaces Namespace


ProcessTitle Property

[image]

MADCAT Software Developer Guide
IProcessContext..::..ProcessTitle Property
IProcessContext Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Title of the process which will be performed

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
string ProcessTitle { get; set; }
Visual Basic
Property ProcessTitle As String
    Get
    Set
Visual C++
property String^ ProcessTitle {
    String^ get ();
    void set (String^ value);
}

See Also

IProcessContext Interface
IProcessContext Members
ToolInterfaces Namespace


IProcessContext.EventHandler Delegate

[image]

MADCAT Software Developer Guide
IProcessContext..::..EventHandler Delegate
IProcessContext Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Prototype for handlers for the user events Cancel/Pause/Resume

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public delegate void EventHandler()
Visual Basic
Public Delegate Sub EventHandler
Visual C++
public delegate void EventHandler()

See Also

ToolInterfaces Namespace


ITool Interface

[image]

MADCAT Software Developer Guide
ITool Interface
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Interface which must be implemented by tools of MADCAT. This is the entry point of the tool for MADCAT; the interface used by MADCAT to control the tool and perform actions with it.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public interface ITool
Visual Basic
Public Interface ITool
Visual C++
public interface class ITool

See Also

ITool Members
ToolInterfaces Namespace


ITool Members

[image] [image]

MADCAT Software Developer Guide
ITool Members
ITool Interface Methods Properties See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The ITool type exposes the following members.

Methods

 | Name | Description
Public method | BuildDataPacket | Called at Drag Enter to check the nature of the incoming data
Public method | FillDataObject | Called at Item Drag
Public method | GetConfigSet | Called when the 'Option' dialog box is opened.
Public method | Init | Called at Plugin load. Plugin shall returned the Data Sources it requires.
Public method | InitializeAction | Called when user wants to execute an action (1st part)
Public method | PerformAction | Called when user wants to execute an action (2nd part if necessary)

Properties

 | Name | Description
Public property | RunAfter | Tool gives the process context of the action which must be terminated before starting a new action

See Also

ITool Interface
ToolInterfaces Namespace


ITool Methods

[image] [image]

MADCAT Software Developer Guide
ITool Methods
ITool Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The ITool type exposes the following members.

Methods

 | Name | Description
Public method | BuildDataPacket | Called at Drag Enter to check the nature of the incoming data
Public method | FillDataObject | Called at Item Drag
Public method | GetConfigSet | Called when the 'Option' dialog box is opened.
Public method | Init | Called at Plugin load. Plugin shall returned the Data Sources it requires.
Public method | InitializeAction | Called when user wants to execute an action (1st part)
Public method | PerformAction | Called when user wants to execute an action (2nd part if necessary)

See Also

ITool Interface
ToolInterfaces Namespace


BuildDataPacket Method

[image]

MADCAT Software Developer Guide
ITool..::..BuildDataPacket Method
ITool Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Called at Drag Enter to check the nature of the incoming data

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void BuildDataPacket(
    DataPacket pkt,
    DataObject o
)
Visual Basic
Sub BuildDataPacket ( _
    pkt As DataPacket, _
    o As DataObject _
)
Visual C++
void BuildDataPacket(
    DataPacket^ pkt,
    DataObject^ o
)

Parameters

pkt
Type: ToolInterfaces..::..DataPacket
Data packet which contain the data of the dragged object converted into Xml. May be null if the tool doesn't handle the data of the dragged object.
o
Type: System.Windows.Forms..::..DataObject
Data of the dragged object

Examples

This example gets a list of files dragged from Windows Explorer and moved over MADCAT to fill a DataPacket object which may be dropped into a database. The packet can be dropped only if the Xml data of the packet is compliant with the model of the database where the packet is dropped.
CopyC++
void Tool::BuildDataPacket(DataPacket ^pkt, DataObject ^o)
{
   Specialized::StringCollection   ^file_list;

   // We check if the data object contains file names
   if(o->ContainsFileDropList())
   {
       // We get the list of names
       file_list = o->GetFileDropList();
       if(file_list)
       {
           // For each file name, we create a Xml Item named "FILE".
           // If the current workspace has a database which handles items named "FILE", the data packet will be able to create it and sets all its attributes in
           // accordance with the model of this database.
           String ^f_name;
           for each(f_name in file_list)
           {
               XmlNode ^itm = pkt->CreateItem(null,L"FILE");
               // Check if the item could be created
               if(itm)
               {
                   // Item has been created so the required database is certainly available and the item is correctly initialized.
                   // We can fill it safely.
                   itm->Attributes[L"NAME"]->Value = f_name;
               }
           }
       }
   }
}

See Also

ITool Interface
ITool Members
ToolInterfaces Namespace


FillDataObject Method

[image]

MADCAT Software Developer Guide
ITool..::..FillDataObject Method
ITool Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Called at Item Drag

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void FillDataObject(
    DataObject obj,
    DataPacket Item
)
Visual Basic
Sub FillDataObject ( _
    obj As DataObject, _
    Item As DataPacket _
)
Visual C++
void FillDataObject(
    DataObject^ obj,
    DataPacket^ Item
)

Parameters

obj
Type: System.Windows.Forms..::..DataObject
Data of the dragged object converted from the Xml data of the item
Item
Type: ToolInterfaces..::..DataPacket
Data of the dragged item. Its data will be used to build the data of the dragged object.

Examples

This example gets all the items being dragged by the user and put their Xml data into the drag object.
CopyC++
void Tool::FillDataObject(DataObject ^obj,DataPacket ^Dp)
{
  // Building a string representing the object (to be able to copy it to another application)
  XmlNode    ^Item;
  String    ^buf = gcnew String(L"");
  for each(Item in Dp->Items)
  {
        buf = String::Concat(buf,Item->OuterXml);
  }
  obj->SetData(buf->GetType(),buf);
}

See Also

ITool Interface
ITool Members
ToolInterfaces Namespace


GetConfigSet Method

[image]

MADCAT Software Developer Guide
ITool..::..GetConfigSet Method
ITool Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Called when the 'Option' dialog box is opened.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
IParameter[] GetConfigSet()
Visual Basic
Function GetConfigSet As IParameter()
Visual C++
array<IParameter^>^ GetConfigSet()

Return Value

Array of parameters. Each parameter is one option of the config set. The parameter's value is the option's value.

Examples

CopyC++
public ref class Tool : public ITool
{
private:
  BaseParameter               ^Option;
  cli::array<IParameter ^> ^ConfigSet;
public:
  property IProcessContext ^RunAfter { virtual IProcessContext ^get(); };
  Tool(void);
  virtual cli::array<String ^> ^Init(IWorkspace ^wrk, ILogbookWriter ^log);
  virtual void BuildDataPacket(DataPacket    ^, DataObject ^o);
  virtual void FillDataObject(DataObject    ^o, DataPacket ^Item);
  virtual InitResult InitializeAction(IProcessContext ^Context);
  virtual ExecutionResult PerformAction(IProcessContext ^Context);
  virtual cli::array<IParameter ^> ^GetConfigSet();
};

Tool::Tool()
{
  // We intialize the configuration parameters in the constructor.
  this->Option = gcnew BaseParameter();
  this->Option->Value = L"Your name";
  this->Option->MaxNumberOfChars = 30;
  this->Option->Name = L"User name";
  this->Option->Description = L"Your name";

  // All the configuration parameters are put in an array which is the configuration set of the tool.
  this->ConfigSet = gcnew cli::array<IParameter ^>(1){this->Option};
}

cli::array<IParameter ^> ^Tool::GetConfigSet()
{
  return this->ConfigSet;
}

See Also

ITool Interface
ITool Members
ToolInterfaces Namespace


Init Method

[image]

MADCAT Software Developer Guide
ITool..::..Init Method
ITool Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Called at Plugin load. Plugin shall returned the Data Sources it requires.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
string[] Init(
    IWorkspace wrk,
    ILogbookWriter log
)
Visual Basic
Function Init ( _
    wrk As IWorkspace, _
    log As ILogbookWriter _
) As String()
Visual C++
array<String^>^ Init(
    IWorkspace^ wrk,
    ILogbookWriter^ log
)

Parameters

wrk
Type: ToolInterfaces..::..IWorkspace
Workspace which is activating the tool.
log
Type: LogManager..::..ILogbookWriter
Logbook writer to use to generate messages during the Init phase.

Return Value

The tool returns an array of String objects. Each string is the name of the required database for the tool to work. If one of the database is not available in the current workspace, the tool will be deactivated.

Examples

This example shows a tool requesting 5 databases named "MODELS", "WORKSPACES", "RENDERERS", "TOOLS" and "REPORTS". The tool won't be activated by MADCAT if one database is missing.
CopyC++
cli::array<String ^> ^Tool::Init(IWorkspace ^wrk, ILogbookWriter ^log)
{
    return gcnew cli::array<String ^>{L"MODELS",L"WORKSPACES",L"RENDERERS",L"TOOLS",L"REPORTS"};
}

See Also

ITool Interface
ITool Members
ToolInterfaces Namespace


InitializeAction Method

[image]

MADCAT Software Developer Guide
ITool..::..InitializeAction Method
ITool Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Called when user wants to execute an action (1st part)

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
InitResult InitializeAction(
    IProcessContext Context
)
Visual Basic
Function InitializeAction ( _
    Context As IProcessContext _
) As InitResult
Visual C++
InitResult InitializeAction(
    IProcessContext^ Context
)

Parameters

Context
Type: ToolInterfaces..::..IProcessContext
Context of execution of the action.

Return Value

Result of the initialization

Examples

CopyC++
InitResult Tool::InitializeAction(IProcessContext ^Context)
{
      // Check if selected item is a workspace item. We get the 1st item selected by the user using the data context provided by MADCAT.
      XmlNode ^itm = (XmlNode ^)Context->DataContext->Items[0];
      if(itm->Name!=L"WORKSPACE")
      {
          // We generate an error message using the Logbook writer provided by MADCAT in the context. This logbook writer is already configured. Nothing to do.
          Context->Log->ShowError(L"Selected item is not a Workspace Item !");
          // We abort the action
          return InitResult::Abort;
      }
      // We can continue the action. MADCAT will then invoke PerformAction right after this.
      return InitResult::Continue;
}

See Also

ITool Interface
ITool Members
ToolInterfaces Namespace


PerformAction Method

[image]

MADCAT Software Developer Guide
ITool..::..PerformAction Method
ITool Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Called when user wants to execute an action (2nd part if necessary)

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
ExecutionResult PerformAction(
    IProcessContext Context
)
Visual Basic
Function PerformAction ( _
    Context As IProcessContext _
) As ExecutionResult
Visual C++
ExecutionResult PerformAction(
    IProcessContext^ Context
)

Parameters

Context
Type: ToolInterfaces..::..IProcessContext
Context of execution of the action.

Return Value

Result of the execution

Examples

This example runs an action which gets a folder path from an Xml item having an attribute named "DESTINATION_PATH" and deletes it.
CopyC++
ExecutionResult Tool::PerformAction(IProcessContext ^Context)
{
      IO::DirectoryInfo ^dirInfo;
      XmlNode ^itm;
      String ^DestPath;
      cli::array<IO::FileInfo ^> ^list_file;
      cli::array<IO::DirectoryInfo ^> ^list_dir;

      // We are retrieving the Xml item which has been selected by the user before running the action
      itm = (XmlNode ^)Context->DataContext->Items[0];
      // We get the right attribute
      DestPath = itm->Attributes[L"DESTINATION_PATH"]->Value;

      // Write an information message using the logbook writer provided by MADCAT. This message is not displayed but can be captured by a logbook.
      Context->Log->WriteInfo(L"Starting workspace generation...");
      // First check if the destination folder is empty
      dirInfo = gcnew IO::DirectoryInfo(DestPath);
      list_file = dirInfo->GetFiles();
      list_dir = dirInfo->GetDirectories();
      if((list_file->Length > 0)||(list_dir->Length > 0))
      {
          // We ask the user to confirm the destination folder
          if(Context->Log->Confirm(L"Destination folder is not empty. Shall we continue ?")!=DialogResult::OK)
          {
              // User didn't confirm. The action is cancelled.
              return ExecutionResult::Cancelled;
          }
      }

      // We delete the directory
      Context->Log->WriteInfo(L"Deleting folder...");
      IO::Directory::Delete(DestPath,true);
      Context->Log->WriteInfo(L"Done");

      return ExecutionResult::Successfull;
}

See Also

ITool Interface
ITool Members
ToolInterfaces Namespace


ITool Properties

[image] [image]

MADCAT Software Developer Guide
ITool Properties
ITool Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The ITool type exposes the following members.

Properties

 | Name | Description
Public property | RunAfter | Tool gives the process context of the action which must be terminated before starting a new action

See Also

ITool Interface
ToolInterfaces Namespace


RunAfter Property

[image]

MADCAT Software Developer Guide
ITool..::..RunAfter Property
ITool Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Tool gives the process context of the action which must be terminated before starting a new action

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
IProcessContext RunAfter { get; }
Visual Basic
ReadOnly Property RunAfter As IProcessContext
    Get
Visual C++
property IProcessContext^ RunAfter {
    IProcessContext^ get ();
}

See Also

ITool Interface
ITool Members
ToolInterfaces Namespace


IWorkspace Interface

[image]

MADCAT Software Developer Guide
IWorkspace Interface
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Interface exposed by any workspace in MADCAT Any workspace exposes this interface. It can be used to control the user interface and access any element of the workspace such as : actions, items, user preferences, forms layouts, ...

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public interface IWorkspace
Visual Basic
Public Interface IWorkspace
Visual C++
public interface class IWorkspace

See Also

IWorkspace Members
ToolInterfaces Namespace


IWorkspace Members

[image] [image]

MADCAT Software Developer Guide
IWorkspace Members
IWorkspace Interface Methods Properties Events See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IWorkspace type exposes the following members.

Methods

 | Name | Description
Public method | AbsoluteToRelativePath | Converts an absolute path into a path relative to the root path of the current workspace. If given path is relative, it remains unchanged. Example : If workspace is located at C:\MyWorkspace, path "C:\MyWorkspace\bitmaps" will be converted to "bitmaps"
Public method | AppendActions | This method adds a new serie of controls for actions in the user interface of MADCAT. The tool strip items will be appended to the current list of tool strip items of the user interface. They will appear in the button bar and the menus (main and contextual). Note that actions defined in the tool definition file (XTL) are automatically displayed in the user interface and this method is not needed for them. A tool may use this method to add dynamically created actions which may depend on user rights, data context and so on ...
Public method | GetItemSource | Returns the name of the model which defines the given item.
Public method | GetItemTypeDescription | Returns the description of the type of an item. For folder nodes, it can be "Folder of ....". For links, it can be "Link to ..."
Public method | InitializeToolStrip | Initialize a tool strip for MADCAT integration. This method attaches a context menu to the tool strip. The context menu contains items used to change the display appearance of the tool strip (icons only, icon and text, text only, big icons)
Public method | IsAccessGranted(String) | Indicates if a given action can be run by the user on any item of the project. Note that if this method returns true, the user may still not be able to run the action if the action is not attached to all items in the models. Some actions may be run only on specific items. Use the other form of this method to have an exact confirmation.
Public method | IsAccessGranted(String, String) | Indicates if a given action can be run by the user on a given item type.
Public method | PerformSearch | Performs a search in the project's data and returns the result in a DataPacket. Result may contain more than one node.
Public method | RefreshAll | Forces MADCAT to refresh all its forms and their content.
Public method | RelativeToAbsolutePath | Converts a relative path (relative to the workspace directory) into an absolute path. If given path is absolute, it remains unchanged. Example : If workspace is located at C:\MyWorkspace, path "bitmaps" will be converted to "C:\MyWorkspace\bitmaps"
Public method | RestoreFormLayout | Restores the position, state and size of a form saved in the user profile. Use this method when user opens a window. Form's position, state and size are saved with the method SaveFormLayout.
Public method | RunActionWizard | This method runs a wizard which will ask the user to enter a serie of parameters before running an action. The parameters are given by the array Parameters and are displayed one by one in the form. The user can move forward or backward in the wizard with "Previous" and "Next" buttons. He can also confirm his choices or cancel the operation.
Public method | RunWorkspace | Starts a new workspace. If user has modified data, MADCAT will ask him to save his changes.
Public method | SaveFormLayout(String, Form) | Saves the position, state and size of a form into the user profile. Use this method when user closes a window. Form's position, state and size can then be recalled with the method RestoreFormLayout.
Public method | SaveFormLayout(String, Form, Object) | Saves the position, state and size of a form into the user profile. Use this method when user closes a window. Form's position, state and size can then be recalled with the method RestoreFormLayout.
Public method | SetActionsState | This method refreshes the state of the buttons of the actions of the workspace in accordance with a given item. All the actions allowed by the model for the item will be active. All the others will be disabled (button is grayed) This method shall be used by any renderer to guide the user when it selects an item and prevent him from running an action which is not allowed on an item.
Public method | SetFormTitle()()()() | Resets the title of the main form of MADCAT. Only the name of the application remains. Additional information is removed.
Public method | SetFormTitle(String) | Changes the title of the main form of MADCAT. Note that the name of the application remains. String is only appended to it.
Public method | ShowItem | Opens a database explorer focusing on the given item. This method detects the model of the item and then starts a new explorer for this model. Then it opens the needed folders in order to show the item in the explorer. Finally, the user can edit, delete or show its attributes directly. This provides a quick access to the item.

Properties

 | Name | Description
Public property | Baseline | Interface of the current baseline of the workspace. Workspace must have activated baselines to make this work
Public property | DatabaseManager | Interface used to access project's data
Public property | IsInCommandLineMode | Indicates if the workspace is running in command line mode only (no HMI)
Public property | IsLocked | Indicates if the workspace is locked (the user can't add tools, renderers or models through the config panel of the HMI)
Public property | UserProfileForAttributes | Interface used to access user profile for parameters
Public property | UserProfileForRenderers | Interface used to access user profile for renderers
Public property | UserProfileForTools | Interface used to access user profile for tools
Public property | WorkspaceIcon | Gets the icon of the current workspace
Public property | WorkspaceID | Gets the identifer of the current workspace

Events

 | Name | Description
Public event | AccessRightsChanged | Fired when the user access rights change
Public event | BaselineChanged | Fired when one of the following event occurs : AddChild, DeleteChild, UndeleteChild, Edit, Open, Save, Close
Public event | BaselineReferenceChanged | Fired when the reference of a baseline changes
Public event | DatabaseSaved | Fired when the project's data is saved to the disk
Public event | ProjectReloaded | Fired when one of the XML file the project's data has been reloaded from disk due to a file write performed outside the application

See Also

IWorkspace Interface
ToolInterfaces Namespace


IWorkspace Methods

[image] [image]

MADCAT Software Developer Guide
IWorkspace Methods
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IWorkspace type exposes the following members.

Methods

 | Name | Description
Public method | AbsoluteToRelativePath | Converts an absolute path into a path relative to the root path of the current workspace. If given path is relative, it remains unchanged. Example : If workspace is located at C:\MyWorkspace, path "C:\MyWorkspace\bitmaps" will be converted to "bitmaps"
Public method | AppendActions | This method adds a new serie of controls for actions in the user interface of MADCAT. The tool strip items will be appended to the current list of tool strip items of the user interface. They will appear in the button bar and the menus (main and contextual). Note that actions defined in the tool definition file (XTL) are automatically displayed in the user interface and this method is not needed for them. A tool may use this method to add dynamically created actions which may depend on user rights, data context and so on ...
Public method | GetItemSource | Returns the name of the model which defines the given item.
Public method | GetItemTypeDescription | Returns the description of the type of an item. For folder nodes, it can be "Folder of ....". For links, it can be "Link to ..."
Public method | InitializeToolStrip | Initialize a tool strip for MADCAT integration. This method attaches a context menu to the tool strip. The context menu contains items used to change the display appearance of the tool strip (icons only, icon and text, text only, big icons)
Public method | IsAccessGranted(String) | Indicates if a given action can be run by the user on any item of the project. Note that if this method returns true, the user may still not be able to run the action if the action is not attached to all items in the models. Some actions may be run only on specific items. Use the other form of this method to have an exact confirmation.
Public method | IsAccessGranted(String, String) | Indicates if a given action can be run by the user on a given item type.
Public method | PerformSearch | Performs a search in the project's data and returns the result in a DataPacket. Result may contain more than one node.
Public method | RefreshAll | Forces MADCAT to refresh all its forms and their content.
Public method | RelativeToAbsolutePath | Converts a relative path (relative to the workspace directory) into an absolute path. If given path is absolute, it remains unchanged. Example : If workspace is located at C:\MyWorkspace, path "bitmaps" will be converted to "C:\MyWorkspace\bitmaps"
Public method | RestoreFormLayout | Restores the position, state and size of a form saved in the user profile. Use this method when user opens a window. Form's position, state and size are saved with the method SaveFormLayout.
Public method | RunActionWizard | This method runs a wizard which will ask the user to enter a serie of parameters before running an action. The parameters are given by the array Parameters and are displayed one by one in the form. The user can move forward or backward in the wizard with "Previous" and "Next" buttons. He can also confirm his choices or cancel the operation.
Public method | RunWorkspace | Starts a new workspace. If user has modified data, MADCAT will ask him to save his changes.
Public method | SaveFormLayout(String, Form) | Saves the position, state and size of a form into the user profile. Use this method when user closes a window. Form's position, state and size can then be recalled with the method RestoreFormLayout.
Public method | SaveFormLayout(String, Form, Object) | Saves the position, state and size of a form into the user profile. Use this method when user closes a window. Form's position, state and size can then be recalled with the method RestoreFormLayout.
Public method | SetActionsState | This method refreshes the state of the buttons of the actions of the workspace in accordance with a given item. All the actions allowed by the model for the item will be active. All the others will be disabled (button is grayed) This method shall be used by any renderer to guide the user when it selects an item and prevent him from running an action which is not allowed on an item.
Public method | SetFormTitle()()()() | Resets the title of the main form of MADCAT. Only the name of the application remains. Additional information is removed.
Public method | SetFormTitle(String) | Changes the title of the main form of MADCAT. Note that the name of the application remains. String is only appended to it.
Public method | ShowItem | Opens a database explorer focusing on the given item. This method detects the model of the item and then starts a new explorer for this model. Then it opens the needed folders in order to show the item in the explorer. Finally, the user can edit, delete or show its attributes directly. This provides a quick access to the item.

See Also

IWorkspace Interface
ToolInterfaces Namespace


AbsoluteToRelativePath Method

[image]

MADCAT Software Developer Guide
IWorkspace..::..AbsoluteToRelativePath Method
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Converts an absolute path into a path relative to the root path of the current workspace. If given path is relative, it remains unchanged. Example : If workspace is located at C:\MyWorkspace, path "C:\MyWorkspace\bitmaps" will be converted to "bitmaps"

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
string AbsoluteToRelativePath(
    string p
)
Visual Basic
Function AbsoluteToRelativePath ( _
    p As String _
) As String
Visual C++
String^ AbsoluteToRelativePath(
    String^ p
)

Parameters

p
Type: System..::..String
Absolute path

Return Value

Relative path

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace
IWorkspace..::..RelativeToAbsolutePath(String)


AppendActions Method

[image]

MADCAT Software Developer Guide
IWorkspace..::..AppendActions Method
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This method adds a new serie of controls for actions in the user interface of MADCAT. The tool strip items will be appended to the current list of tool strip items of the user interface. They will appear in the button bar and the menus (main and contextual). Note that actions defined in the tool definition file (XTL) are automatically displayed in the user interface and this method is not needed for them. A tool may use this method to add dynamically created actions which may depend on user rights, data context and so on ...

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void AppendActions(
    ToolStripItemCollection MenuItems,
    EventHandler Hdl
)
Visual Basic
Sub AppendActions ( _
    MenuItems As ToolStripItemCollection, _
    Hdl As EventHandler _
)
Visual C++
void AppendActions(
    ToolStripItemCollection^ MenuItems,
    EventHandler^ Hdl
)

Parameters

MenuItems
Type: System.Windows.Forms..::..ToolStripItemCollection
Collection of ToolStripItems. Each one should be associated to an action the tool can perform.
Hdl
Type: System..::..EventHandler
Event handler attached to the items of the collection. Will be invoked when an item is clicked by the user.

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace


GetItemSource Method

[image]

MADCAT Software Developer Guide
IWorkspace..::..GetItemSource Method
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Returns the name of the model which defines the given item.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
string GetItemSource(
    XmlNode Item
)
Visual Basic
Function GetItemSource ( _
    Item As XmlNode _
) As String
Visual C++
String^ GetItemSource(
    XmlNode^ Item
)

Parameters

Item
Type: System.Xml..::..XmlNode
Xml node

Return Value

Name of the model which defines the item. Null if no models have been found.

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace


GetItemTypeDescription Method

[image]

MADCAT Software Developer Guide
IWorkspace..::..GetItemTypeDescription Method
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Returns the description of the type of an item. For folder nodes, it can be "Folder of ....". For links, it can be "Link to ..."

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
string GetItemTypeDescription(
    XmlNode Item
)
Visual Basic
Function GetItemTypeDescription ( _
    Item As XmlNode _
) As String
Visual C++
String^ GetItemTypeDescription(
    XmlNode^ Item
)

Parameters

Item
Type: System.Xml..::..XmlNode
Xml node

Return Value

Description of the type of node. Null if type is unknown (no model or no definition in the models)

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace


InitializeToolStrip Method

[image]

MADCAT Software Developer Guide
IWorkspace..::..InitializeToolStrip Method
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Initialize a tool strip for MADCAT integration. This method attaches a context menu to the tool strip. The context menu contains items used to change the display appearance of the tool strip (icons only, icon and text, text only, big icons)

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void InitializeToolStrip(
    ToolStrip ts
)
Visual Basic
Sub InitializeToolStrip ( _
    ts As ToolStrip _
)
Visual C++
void InitializeToolStrip(
    ToolStrip^ ts
)

Parameters

ts
Type: System.Windows.Forms..::..ToolStrip
ToolStrip object to initialize.

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace


IsAccessGranted Method

[image] [image]

MADCAT Software Developer Guide
IWorkspace..::..IsAccessGranted Method
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | IsAccessGranted(String) | Indicates if a given action can be run by the user on any item of the project. Note that if this method returns true, the user may still not be able to run the action if the action is not attached to all items in the models. Some actions may be run only on specific items. Use the other form of this method to have an exact confirmation.
Public method | IsAccessGranted(String, String) | Indicates if a given action can be run by the user on a given item type.

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace


IsAccessGranted Method (String)

[image]

MADCAT Software Developer Guide
IWorkspace..::..IsAccessGranted Method (String)
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Indicates if a given action can be run by the user on any item of the project. Note that if this method returns true, the user may still not be able to run the action if the action is not attached to all items in the models. Some actions may be run only on specific items. Use the other form of this method to have an exact confirmation.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
bool IsAccessGranted(
    string Action
)
Visual Basic
Function IsAccessGranted ( _
    Action As String _
) As Boolean
Visual C++
bool IsAccessGranted(
    String^ Action
)

Parameters

Action
Type: System..::..String
Name of the action the user may perform

Return Value

  • True : The user can run the action.
  • False : The user is not allowed to run the action.

See Also

IWorkspace Interface
IWorkspace Members
IsAccessGranted Overload
ToolInterfaces Namespace


IsAccessGranted Method (String, String)

[image]

MADCAT Software Developer Guide
IWorkspace..::..IsAccessGranted Method (String, String)
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Indicates if a given action can be run by the user on a given item type.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
bool IsAccessGranted(
    string Action,
    string ItemName
)
Visual Basic
Function IsAccessGranted ( _
    Action As String, _
    ItemName As String _
) As Boolean
Visual C++
bool IsAccessGranted(
    String^ Action,
    String^ ItemName
)

Parameters

Action
Type: System..::..String
Name of the action the user may perform
ItemName
Type: System..::..String
Name of the item as defined in the model on which the action is to be performed.

Return Value

  • True : The user can run the action on the item.
  • False : The user is not allowed to run the action on the item.

See Also

IWorkspace Interface
IWorkspace Members
IsAccessGranted Overload
ToolInterfaces Namespace


PerformSearch Method

[image]

MADCAT Software Developer Guide
IWorkspace..::..PerformSearch Method
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Performs a search in the project's data and returns the result in a DataPacket. Result may contain more than one node.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
DataPacket PerformSearch(
    XmlNode root,
    string XQuery
)
Visual Basic
Function PerformSearch ( _
    root As XmlNode, _
    XQuery As String _
) As DataPacket
Visual C++
DataPacket^ PerformSearch(
    XmlNode^ root,
    String^ XQuery
)

Parameters

root
Type: System.Xml..::..XmlNode
Parent node from where the search is performed. If null, the search is performed on the entire project.
XQuery
Type: System..::..String
XPath expression which defines the matching criterias for the search.

Return Value

DataPacket object containing the Xml node(s) matching the search criterias. Null if nothing is found.

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace


RefreshAll Method

[image]

MADCAT Software Developer Guide
IWorkspace..::..RefreshAll Method
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Forces MADCAT to refresh all its forms and their content.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void RefreshAll()
Visual Basic
Sub RefreshAll
Visual C++
void RefreshAll()

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace


RelativeToAbsolutePath Method

[image]

MADCAT Software Developer Guide
IWorkspace..::..RelativeToAbsolutePath Method
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Converts a relative path (relative to the workspace directory) into an absolute path. If given path is absolute, it remains unchanged. Example : If workspace is located at C:\MyWorkspace, path "bitmaps" will be converted to "C:\MyWorkspace\bitmaps"

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
string RelativeToAbsolutePath(
    string p
)
Visual Basic
Function RelativeToAbsolutePath ( _
    p As String _
) As String
Visual C++
String^ RelativeToAbsolutePath(
    String^ p
)

Parameters

p
Type: System..::..String
Relative path

Return Value

Absolute path

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace
IWorkspace..::..AbsoluteToRelativePath(String)


RestoreFormLayout Method

[image]

MADCAT Software Developer Guide
IWorkspace..::..RestoreFormLayout Method
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Restores the position, state and size of a form saved in the user profile. Use this method when user opens a window. Form's position, state and size are saved with the method SaveFormLayout.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
Object RestoreFormLayout(
    string id,
    Form frm
)
Visual Basic
Function RestoreFormLayout ( _
    id As String, _
    frm As Form _
) As Object
Visual C++
Object^ RestoreFormLayout(
    String^ id,
    Form^ frm
)

Parameters

id
Type: System..::..String
Identifier of the form. Must be unique in the workspace.
frm
Type: System.Windows.Forms..::..Form
Form object on which properties has to be applied

Return Value

Proprietary object which can be used by the form to restore additional properties

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace
IWorkspace..::..SaveFormLayout(String, Form)
IWorkspace..::..SaveFormLayout(String, Form, Object)


RunActionWizard Method

[image]

MADCAT Software Developer Guide
IWorkspace..::..RunActionWizard Method
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This method runs a wizard which will ask the user to enter a serie of parameters before running an action. The parameters are given by the array Parameters and are displayed one by one in the form. The user can move forward or backward in the wizard with "Previous" and "Next" buttons. He can also confirm his choices or cancel the operation.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
DialogResult RunActionWizard(
    string Title,
    ArrayList Parameters
)
Visual Basic
Function RunActionWizard ( _
    Title As String, _
    Parameters As ArrayList _
) As DialogResult
Visual C++
DialogResult RunActionWizard(
    String^ Title,
    ArrayList^ Parameters
)

Parameters

Title
Type: System..::..String
Title of the wizard. Displayed in the title bar of the window
Parameters
Type: System.Collections..::..ArrayList
Array of objects exposing the IParameter interface. Each parameter is displayed in one page.

Return Value

Result of the wizard. DialogResult::OK when user confirms, DialogResult::Cancel when user cancel the operation.

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace


RunWorkspace Method

[image]

MADCAT Software Developer Guide
IWorkspace..::..RunWorkspace Method
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Starts a new workspace. If user has modified data, MADCAT will ask him to save his changes.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void RunWorkspace(
    string WorkspacePath
)
Visual Basic
Sub RunWorkspace ( _
    WorkspacePath As String _
)
Visual C++
void RunWorkspace(
    String^ WorkspacePath
)

Parameters

WorkspacePath
Type: System..::..String
Absolute path to the new workspace

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace


SaveFormLayout Method

[image] [image]

MADCAT Software Developer Guide
IWorkspace..::..SaveFormLayout Method
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | SaveFormLayout(String, Form) | Saves the position, state and size of a form into the user profile. Use this method when user closes a window. Form's position, state and size can then be recalled with the method RestoreFormLayout.
Public method | SaveFormLayout(String, Form, Object) | Saves the position, state and size of a form into the user profile. Use this method when user closes a window. Form's position, state and size can then be recalled with the method RestoreFormLayout.

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace


SaveFormLayout Method (String, Form)

[image]

MADCAT Software Developer Guide
IWorkspace..::..SaveFormLayout Method (String, Form)
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Saves the position, state and size of a form into the user profile. Use this method when user closes a window. Form's position, state and size can then be recalled with the method RestoreFormLayout.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void SaveFormLayout(
    string id,
    Form frm
)
Visual Basic
Sub SaveFormLayout ( _
    id As String, _
    frm As Form _
)
Visual C++
void SaveFormLayout(
    String^ id,
    Form^ frm
)

Parameters

id
Type: System..::..String
Identifier of the form. Must be unique in the workspace.
frm
Type: System.Windows.Forms..::..Form
Form object which has to be saved in the user profile.

See Also

IWorkspace Interface
IWorkspace Members
SaveFormLayout Overload
ToolInterfaces Namespace
IWorkspace..::..RestoreFormLayout(String, Form)


SaveFormLayout Method (String, Form, Object)

[image]

MADCAT Software Developer Guide
IWorkspace..::..SaveFormLayout Method (String, Form, Object)
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Saves the position, state and size of a form into the user profile. Use this method when user closes a window. Form's position, state and size can then be recalled with the method RestoreFormLayout.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void SaveFormLayout(
    string id,
    Form frm,
    Object userDefinedPrefs
)
Visual Basic
Sub SaveFormLayout ( _
    id As String, _
    frm As Form, _
    userDefinedPrefs As Object _
)
Visual C++
void SaveFormLayout(
    String^ id,
    Form^ frm,
    Object^ userDefinedPrefs
)

Parameters

id
Type: System..::..String
Identifier of the form. Must be unique in the workspace.
frm
Type: System.Windows.Forms..::..Form
Form object which has to be saved in the user profile.
userDefinedPrefs
Type: System..::..Object
Proprietary object which can be used by the form to save additional properties

See Also

IWorkspace Interface
IWorkspace Members
SaveFormLayout Overload
ToolInterfaces Namespace
IWorkspace..::..RestoreFormLayout(String, Form)


SetActionsState Method

[image]

MADCAT Software Developer Guide
IWorkspace..::..SetActionsState Method
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This method refreshes the state of the buttons of the actions of the workspace in accordance with a given item. All the actions allowed by the model for the item will be active. All the others will be disabled (button is grayed) This method shall be used by any renderer to guide the user when it selects an item and prevent him from running an action which is not allowed on an item.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void SetActionsState(
    XmlNode n
)
Visual Basic
Sub SetActionsState ( _
    n As XmlNode _
)
Visual C++
void SetActionsState(
    XmlNode^ n
)

Parameters

n
Type: System.Xml..::..XmlNode
XML node of the item selected by the user.

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace


SetFormTitle Method

[image] [image]

MADCAT Software Developer Guide
IWorkspace..::..SetFormTitle Method
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | SetFormTitle()()()() | Resets the title of the main form of MADCAT. Only the name of the application remains. Additional information is removed.
Public method | SetFormTitle(String) | Changes the title of the main form of MADCAT. Note that the name of the application remains. String is only appended to it.

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace


SetFormTitle Method

[image]

MADCAT Software Developer Guide
IWorkspace..::..SetFormTitle Method
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Resets the title of the main form of MADCAT. Only the name of the application remains. Additional information is removed.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void SetFormTitle()
Visual Basic
Sub SetFormTitle
Visual C++
void SetFormTitle()

See Also

IWorkspace Interface
IWorkspace Members
SetFormTitle Overload
ToolInterfaces Namespace


SetFormTitle Method (String)

[image]

MADCAT Software Developer Guide
IWorkspace..::..SetFormTitle Method (String)
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Changes the title of the main form of MADCAT. Note that the name of the application remains. String is only appended to it.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void SetFormTitle(
    string Info
)
Visual Basic
Sub SetFormTitle ( _
    Info As String _
)
Visual C++
void SetFormTitle(
    String^ Info
)

Parameters

Info
Type: System..::..String
String to display in the title after the name of the application.

See Also

IWorkspace Interface
IWorkspace Members
SetFormTitle Overload
ToolInterfaces Namespace


ShowItem Method

[image]

MADCAT Software Developer Guide
IWorkspace..::..ShowItem Method
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Opens a database explorer focusing on the given item. This method detects the model of the item and then starts a new explorer for this model. Then it opens the needed folders in order to show the item in the explorer. Finally, the user can edit, delete or show its attributes directly. This provides a quick access to the item.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
void ShowItem(
    XmlNode Item
)
Visual Basic
Sub ShowItem ( _
    Item As XmlNode _
)
Visual C++
void ShowItem(
    XmlNode^ Item
)

Parameters

Item
Type: System.Xml..::..XmlNode
XML Node to display in an explorer

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace


IWorkspace Properties

[image] [image]

MADCAT Software Developer Guide
IWorkspace Properties
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IWorkspace type exposes the following members.

Properties

 | Name | Description
Public property | Baseline | Interface of the current baseline of the workspace. Workspace must have activated baselines to make this work
Public property | DatabaseManager | Interface used to access project's data
Public property | IsInCommandLineMode | Indicates if the workspace is running in command line mode only (no HMI)
Public property | IsLocked | Indicates if the workspace is locked (the user can't add tools, renderers or models through the config panel of the HMI)
Public property | UserProfileForAttributes | Interface used to access user profile for parameters
Public property | UserProfileForRenderers | Interface used to access user profile for renderers
Public property | UserProfileForTools | Interface used to access user profile for tools
Public property | WorkspaceIcon | Gets the icon of the current workspace
Public property | WorkspaceID | Gets the identifer of the current workspace

See Also

IWorkspace Interface
ToolInterfaces Namespace


Baseline Property

[image]

MADCAT Software Developer Guide
IWorkspace..::..Baseline Property
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Interface of the current baseline of the workspace. Workspace must have activated baselines to make this work

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
IBaseline Baseline { get; }
Visual Basic
ReadOnly Property Baseline As IBaseline
    Get
Visual C++
property IBaseline^ Baseline {
    IBaseline^ get ();
}

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace


DatabaseManager Property

[image]

MADCAT Software Developer Guide
IWorkspace..::..DatabaseManager Property
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Interface used to access project's data

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
IDataManager DatabaseManager { get; }
Visual Basic
ReadOnly Property DatabaseManager As IDataManager
    Get
Visual C++
property IDataManager^ DatabaseManager {
    IDataManager^ get ();
}

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace


IsInCommandLineMode Property

[image]

MADCAT Software Developer Guide
IWorkspace..::..IsInCommandLineMode Property
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Indicates if the workspace is running in command line mode only (no HMI)

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
bool IsInCommandLineMode { get; }
Visual Basic
ReadOnly Property IsInCommandLineMode As Boolean
    Get
Visual C++
property bool IsInCommandLineMode {
    bool get ();
}

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace


IsLocked Property

[image]

MADCAT Software Developer Guide
IWorkspace..::..IsLocked Property
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Indicates if the workspace is locked (the user can't add tools, renderers or models through the config panel of the HMI)

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
bool IsLocked { get; }
Visual Basic
ReadOnly Property IsLocked As Boolean
    Get
Visual C++
property bool IsLocked {
    bool get ();
}

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace


UserProfileForAttributes Property

[image]

MADCAT Software Developer Guide
IWorkspace..::..UserProfileForAttributes Property
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Interface used to access user profile for parameters

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
Hashtable UserProfileForAttributes { get; }
Visual Basic
ReadOnly Property UserProfileForAttributes As Hashtable
    Get
Visual C++
property Hashtable^ UserProfileForAttributes {
    Hashtable^ get ();
}

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace


UserProfileForRenderers Property

[image]

MADCAT Software Developer Guide
IWorkspace..::..UserProfileForRenderers Property
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Interface used to access user profile for renderers

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
Hashtable UserProfileForRenderers { get; }
Visual Basic
ReadOnly Property UserProfileForRenderers As Hashtable
    Get
Visual C++
property Hashtable^ UserProfileForRenderers {
    Hashtable^ get ();
}

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace


UserProfileForTools Property

[image]

MADCAT Software Developer Guide
IWorkspace..::..UserProfileForTools Property
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Interface used to access user profile for tools

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
Hashtable UserProfileForTools { get; }
Visual Basic
ReadOnly Property UserProfileForTools As Hashtable
    Get
Visual C++
property Hashtable^ UserProfileForTools {
    Hashtable^ get ();
}

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace


WorkspaceIcon Property

[image]

MADCAT Software Developer Guide
IWorkspace..::..WorkspaceIcon Property
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the icon of the current workspace

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
Image WorkspaceIcon { get; }
Visual Basic
ReadOnly Property WorkspaceIcon As Image
    Get
Visual C++
property Image^ WorkspaceIcon {
    Image^ get ();
}

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace


WorkspaceID Property

[image]

MADCAT Software Developer Guide
IWorkspace..::..WorkspaceID Property
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the identifer of the current workspace

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
string WorkspaceID { get; }
Visual Basic
ReadOnly Property WorkspaceID As String
    Get
Visual C++
property String^ WorkspaceID {
    String^ get ();
}

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace


IWorkspace Events

[image] [image]

MADCAT Software Developer Guide
IWorkspace Events
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IWorkspace type exposes the following members.

Events

 | Name | Description
Public event | AccessRightsChanged | Fired when the user access rights change
Public event | BaselineChanged | Fired when one of the following event occurs : AddChild, DeleteChild, UndeleteChild, Edit, Open, Save, Close
Public event | BaselineReferenceChanged | Fired when the reference of a baseline changes
Public event | DatabaseSaved | Fired when the project's data is saved to the disk
Public event | ProjectReloaded | Fired when one of the XML file the project's data has been reloaded from disk due to a file write performed outside the application

See Also

IWorkspace Interface
ToolInterfaces Namespace


AccessRightsChanged Event

[image]

MADCAT Software Developer Guide
IWorkspace..::..AccessRightsChanged Event
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Fired when the user access rights change

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
event IWorkspace..::..AccessRightsEventHandler AccessRightsChanged
Visual Basic
Event AccessRightsChanged As IWorkspace..::..AccessRightsEventHandler
Visual C++
 event IWorkspace..::..AccessRightsEventHandler^ AccessRightsChanged {
    void add (IWorkspace..::..AccessRightsEventHandler^ value);
    void remove (IWorkspace..::..AccessRightsEventHandler^ value);
}

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace


BaselineChanged Event

[image]

MADCAT Software Developer Guide
IWorkspace..::..BaselineChanged Event
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Fired when one of the following event occurs : AddChild, DeleteChild, UndeleteChild, Edit, Open, Save, Close

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
event IWorkspace..::..BaselineEventHandler BaselineChanged
Visual Basic
Event BaselineChanged As IWorkspace..::..BaselineEventHandler
Visual C++
 event IWorkspace..::..BaselineEventHandler^ BaselineChanged {
    void add (IWorkspace..::..BaselineEventHandler^ value);
    void remove (IWorkspace..::..BaselineEventHandler^ value);
}

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace


BaselineReferenceChanged Event

[image]

MADCAT Software Developer Guide
IWorkspace..::..BaselineReferenceChanged Event
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Fired when the reference of a baseline changes

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
event IWorkspace..::..BaselineEventHandler BaselineReferenceChanged
Visual Basic
Event BaselineReferenceChanged As IWorkspace..::..BaselineEventHandler
Visual C++
 event IWorkspace..::..BaselineEventHandler^ BaselineReferenceChanged {
    void add (IWorkspace..::..BaselineEventHandler^ value);
    void remove (IWorkspace..::..BaselineEventHandler^ value);
}

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace


DatabaseSaved Event

[image]

MADCAT Software Developer Guide
IWorkspace..::..DatabaseSaved Event
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Fired when the project's data is saved to the disk

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
event IWorkspace..::..DatabaseEventHandler DatabaseSaved
Visual Basic
Event DatabaseSaved As IWorkspace..::..DatabaseEventHandler
Visual C++
 event IWorkspace..::..DatabaseEventHandler^ DatabaseSaved {
    void add (IWorkspace..::..DatabaseEventHandler^ value);
    void remove (IWorkspace..::..DatabaseEventHandler^ value);
}

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace


ProjectReloaded Event

[image]

MADCAT Software Developer Guide
IWorkspace..::..ProjectReloaded Event
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Fired when one of the XML file the project's data has been reloaded from disk due to a file write performed outside the application

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
event IWorkspace..::..ProjectReloadedEventHandler ProjectReloaded
Visual Basic
Event ProjectReloaded As IWorkspace..::..ProjectReloadedEventHandler
Visual C++
 event IWorkspace..::..ProjectReloadedEventHandler^ ProjectReloaded {
    void add (IWorkspace..::..ProjectReloadedEventHandler^ value);
    void remove (IWorkspace..::..ProjectReloadedEventHandler^ value);
}

See Also

IWorkspace Interface
IWorkspace Members
ToolInterfaces Namespace


IWorkspace.AccessRightsEventHandler Delegate

[image]

MADCAT Software Developer Guide
IWorkspace..::..AccessRightsEventHandler Delegate
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Delegate for handlers for User access rights changes

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public delegate void AccessRightsEventHandler()
Visual Basic
Public Delegate Sub AccessRightsEventHandler
Visual C++
public delegate void AccessRightsEventHandler()

See Also

ToolInterfaces Namespace


IWorkspace.BaselineEventHandler Delegate

[image]

MADCAT Software Developer Guide
IWorkspace..::..BaselineEventHandler Delegate
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Delegate for handlers for Baseline's events

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public delegate void BaselineEventHandler(
    Object Baseline,
    BaselineEventArgs e
)
Visual Basic
Public Delegate Sub BaselineEventHandler ( _
    Baseline As Object, _
    e As BaselineEventArgs _
)
Visual C++
public delegate void BaselineEventHandler(
    Object^ Baseline,
    BaselineEventArgs^ e
)

Parameters

Baseline
Type: System..::..Object
e
Type: ToolInterfaces..::..BaselineEventArgs

See Also

ToolInterfaces Namespace


IWorkspace.DatabaseEventHandler Delegate

[image]

MADCAT Software Developer Guide
IWorkspace..::..DatabaseEventHandler Delegate
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Delegate for handlers for Database's events

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public delegate void DatabaseEventHandler(
    Object Workspace
)
Visual Basic
Public Delegate Sub DatabaseEventHandler ( _
    Workspace As Object _
)
Visual C++
public delegate void DatabaseEventHandler(
    Object^ Workspace
)

Parameters

Workspace
Type: System..::..Object

See Also

ToolInterfaces Namespace


IWorkspace.ProjectReloadedEventHandler Delegate

[image]

MADCAT Software Developer Guide
IWorkspace..::..ProjectReloadedEventHandler Delegate
IWorkspace Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Use this delegate to subscribe to the ProjectReloaded event fired by the DataManager when one XML file of the project of the current workspace has been modified by an external program and XML data has been entirely reloaded by the user.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public delegate void ProjectReloadedEventHandler(
    IDataManager Man,
    IDataSource Source
)
Visual Basic
Public Delegate Sub ProjectReloadedEventHandler ( _
    Man As IDataManager, _
    Source As IDataSource _
)
Visual C++
public delegate void ProjectReloadedEventHandler(
    IDataManager^ Man,
    IDataSource^ Source
)

Parameters

Man
Type: ToolInterfaces..::..IDataManager
Source
Type: ToolInterfaces..::..IDataSource

See Also

ToolInterfaces Namespace


IWorkspaceForm Interface

[image]

MADCAT Software Developer Guide
IWorkspaceForm Interface
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Use this interface to control database explorer forms or capture events generated by them. All database explorer forms expose this interface. It is mainly used by renderers for integration with MADCAT.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public interface IWorkspaceForm
Visual Basic
Public Interface IWorkspaceForm
Visual C++
public interface class IWorkspaceForm

See Also

IWorkspaceForm Members
ToolInterfaces Namespace


IWorkspaceForm Members

[image] [image]

MADCAT Software Developer Guide
IWorkspaceForm Members
IWorkspaceForm Interface Properties Events See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IWorkspaceForm type exposes the following members.

Properties

 | Name | Description
Public property | Database | Interface of the database attached to the explorer
Public property | DataManager | Interface of the data manager attached to the explorer
Public property | Model | Interface of the data model attached to the explorer
Public property | RendererContextMenu | Gets the context menu dedicated to the renderer area
Public property | RenderersVisible | Get : Indicates if the renderer bar is visible or not in the explorer form Set : Display or hide the renderer bar in the explorer form
Public property | RootItem | Returns the Xml element corresponding to the current root item of the explorer form
Public property | Tip | ToolTip object of the explorer form. Renderers should use this to display their own tips.
Public property | ToolBarItems | Collection of tool bar items. Use this object to add your own items in the tool bar.
Public property | ToolBars | Use this property to add new tool bar in the explorer form. A tool bar is a ToolStrip object
Public property | ToolBarVisible | Get : Indicates if the tool bar is visible or not in the explorer form Set : Display or hide the tool bar in the explorer form
Public property | TreeVisible | Get : Indicates if the tree control is visible or not in the explorer form Set : Display or hide the tree control in the explorer form
Public property | Workspace | Interface of the workspace which owns the explorer

Events

 | Name | Description
Public event | ClipboardChanged | Fired when the user performed on action on the clipboard : copy/cut
Public event | ItemAdded | Fired when an item has been created by the user and must be added to the displayed items
Public event | ItemChanged | Fired when an item has been modified by the user. Its display must be updated
Public event | ItemDeleted | Fired when an item has been deleted by the user and must be removed from the displayed items
Public event | ItemUnDeleted | Fired when an item has been undeleted by the user and must be added to the displayed items
Public event | Refresh | Fired when the form requests a complete refresh of the display
Public event | RootItemChanged | Fired when the user moves in the explorer tree. The display must be totally refreshed with the new root item.
Public event | SelectionChanged | Fired when the user changes the selection in the explorer form.
Public event | SelectionPaste | Fired when the user paste the clipboard. The content of the clipboard must be displayed

See Also

IWorkspaceForm Interface
ToolInterfaces Namespace


IWorkspaceForm Properties

[image] [image]

MADCAT Software Developer Guide
IWorkspaceForm Properties
IWorkspaceForm Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IWorkspaceForm type exposes the following members.

Properties

 | Name | Description
Public property | Database | Interface of the database attached to the explorer
Public property | DataManager | Interface of the data manager attached to the explorer
Public property | Model | Interface of the data model attached to the explorer
Public property | RendererContextMenu | Gets the context menu dedicated to the renderer area
Public property | RenderersVisible | Get : Indicates if the renderer bar is visible or not in the explorer form Set : Display or hide the renderer bar in the explorer form
Public property | RootItem | Returns the Xml element corresponding to the current root item of the explorer form
Public property | Tip | ToolTip object of the explorer form. Renderers should use this to display their own tips.
Public property | ToolBarItems | Collection of tool bar items. Use this object to add your own items in the tool bar.
Public property | ToolBars | Use this property to add new tool bar in the explorer form. A tool bar is a ToolStrip object
Public property | ToolBarVisible | Get : Indicates if the tool bar is visible or not in the explorer form Set : Display or hide the tool bar in the explorer form
Public property | TreeVisible | Get : Indicates if the tree control is visible or not in the explorer form Set : Display or hide the tree control in the explorer form
Public property | Workspace | Interface of the workspace which owns the explorer

See Also

IWorkspaceForm Interface
ToolInterfaces Namespace


Database Property

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..Database Property
IWorkspaceForm Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Interface of the database attached to the explorer

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
IDatabase Database { get; }
Visual Basic
ReadOnly Property Database As IDatabase
    Get
Visual C++
property IDatabase^ Database {
    IDatabase^ get ();
}

See Also

IWorkspaceForm Interface
IWorkspaceForm Members
ToolInterfaces Namespace


DataManager Property

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..DataManager Property
IWorkspaceForm Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Interface of the data manager attached to the explorer

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
IDataManager DataManager { get; }
Visual Basic
ReadOnly Property DataManager As IDataManager
    Get
Visual C++
property IDataManager^ DataManager {
    IDataManager^ get ();
}

See Also

IWorkspaceForm Interface
IWorkspaceForm Members
ToolInterfaces Namespace


Model Property

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..Model Property
IWorkspaceForm Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Interface of the data model attached to the explorer

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
IDataModel Model { get; }
Visual Basic
ReadOnly Property Model As IDataModel
    Get
Visual C++
property IDataModel^ Model {
    IDataModel^ get ();
}

See Also

IWorkspaceForm Interface
IWorkspaceForm Members
ToolInterfaces Namespace


RendererContextMenu Property

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..RendererContextMenu Property
IWorkspaceForm Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the context menu dedicated to the renderer area

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
ContextMenuStrip RendererContextMenu { get; }
Visual Basic
ReadOnly Property RendererContextMenu As ContextMenuStrip
    Get
Visual C++
property ContextMenuStrip^ RendererContextMenu {
    ContextMenuStrip^ get ();
}

See Also

IWorkspaceForm Interface
IWorkspaceForm Members
ToolInterfaces Namespace


RenderersVisible Property

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..RenderersVisible Property
IWorkspaceForm Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Get : Indicates if the renderer bar is visible or not in the explorer form Set : Display or hide the renderer bar in the explorer form

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
bool RenderersVisible { get; set; }
Visual Basic
Property RenderersVisible As Boolean
    Get
    Set
Visual C++
property bool RenderersVisible {
    bool get ();
    void set (bool value);
}

See Also

IWorkspaceForm Interface
IWorkspaceForm Members
ToolInterfaces Namespace


RootItem Property

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..RootItem Property
IWorkspaceForm Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Returns the Xml element corresponding to the current root item of the explorer form

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
XmlNode RootItem { get; }
Visual Basic
ReadOnly Property RootItem As XmlNode
    Get
Visual C++
property XmlNode^ RootItem {
    XmlNode^ get ();
}

See Also

IWorkspaceForm Interface
IWorkspaceForm Members
ToolInterfaces Namespace


Tip Property

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..Tip Property
IWorkspaceForm Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
ToolTip object of the explorer form. Renderers should use this to display their own tips.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
ToolTip Tip { get; }
Visual Basic
ReadOnly Property Tip As ToolTip
    Get
Visual C++
property ToolTip^ Tip {
    ToolTip^ get ();
}

See Also

IWorkspaceForm Interface
IWorkspaceForm Members
ToolInterfaces Namespace


ToolBarItems Property

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..ToolBarItems Property
IWorkspaceForm Interface Example See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Collection of tool bar items. Use this object to add your own items in the tool bar.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
IWorkspaceForm..::..ToolBarItemCollection ToolBarItems { get; }
Visual Basic
ReadOnly Property ToolBarItems As IWorkspaceForm..::..ToolBarItemCollection
    Get
Visual C++
property IWorkspaceForm..::..ToolBarItemCollection^ ToolBarItems {
    IWorkspaceForm..::..ToolBarItemCollection^ get ();
}

Examples

This example shows how a renderer can use this property to add its own buttons to the explorer tool bar.
CopyC++
void Renderer::Init(IRendererContext ^Context)
{
   Hashtable   ^opts;
   ToolTip     ^tip;

   // We build controls the user can use to change the content of the renderer display dynamically
   // Tool bar will have 3 items
   cli::array<ToolStripItem ^> ^toolbaritems = gcnew cli::array<ToolStripItem ^>(3);
   tip = gcnew ToolTip();

   // 1st item is a boolean parameter used to activate recursion in the display area
   BooleanInput ^is_recursive = gcnew BooleanInput();
   is_recursive->Name = L"IS_RECURSIVE";
   is_recursive->Description = L"Show objects recursively";
   is_recursive->Hint = L"Check this option if you want to see the value of all the objects recursively from the current object";
   opts = gcnew Hashtable();
   opts[L"showas"] = L"greenswitch";
   is_recursive->Options = opts;
   // Activate tips for this control
   tip->SetToolTip(is_recursive->FormControl,is_recursive->Hint);
   // Add it to the tool bar of the renderer
   toolbaritems[0] = gcnew ToolStripControlHost(is_recursive->FormControl);

   // 2nd item is a numeric parameter used to set the refresh period of the display area's values
   NumericInput ^refreshRate = gcnew NumericInput();
   refreshRate->Name = L"RATE";
   refreshRate->Description = L"Refresh rate (sec)";
   refreshRate->Hint = L"Set the period in seconds";
   opts[L"showas"] = L"button";
   opts[L"mini"] = L"1";
   opts[L"maxi"] = L"60";
   opts[L"step"] = L"1";
   refreshRate->Options = opts;
   // Activate tips for this control
   tip->SetToolTip(refreshRate->FormControl,refreshRate->Hint);
   // Add it to the tool bar of the renderer
   toolbaritems[1] = gcnew ToolStripControlHost(refreshRate->FormControl);

   // 3rd item is a button used to force the refresh manually
   // Add it to the tool bar of the renderer
   toolbaritems[2] = gcnew ToolStripButton(L"Apply or refresh now");
   toolbaritems[2]->DisplayStyle = ToolStripItemDisplayStyle::Text;
   toolbaritems[2]->Click += gcnew System::EventHandler(this, &Renderer::OptionChanged);

   // Items are added to the tool bar
   Context->ParentForm->ToolBarItems->Add(this,toolbaritems);
}

See Also

IWorkspaceForm Interface
IWorkspaceForm Members
ToolInterfaces Namespace


ToolBars Property

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..ToolBars Property
IWorkspaceForm Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Use this property to add new tool bar in the explorer form. A tool bar is a ToolStrip object

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
ToolStrip ToolBars { set; }
Visual Basic
WriteOnly Property ToolBars As ToolStrip
    Set
Visual C++
property ToolStrip^ ToolBars {
    void set (ToolStrip^ value);
}

See Also

IWorkspaceForm Interface
IWorkspaceForm Members
ToolInterfaces Namespace


ToolBarVisible Property

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..ToolBarVisible Property
IWorkspaceForm Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Get : Indicates if the tool bar is visible or not in the explorer form Set : Display or hide the tool bar in the explorer form

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
bool ToolBarVisible { get; set; }
Visual Basic
Property ToolBarVisible As Boolean
    Get
    Set
Visual C++
property bool ToolBarVisible {
    bool get ();
    void set (bool value);
}

See Also

IWorkspaceForm Interface
IWorkspaceForm Members
ToolInterfaces Namespace


TreeVisible Property

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..TreeVisible Property
IWorkspaceForm Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Get : Indicates if the tree control is visible or not in the explorer form Set : Display or hide the tree control in the explorer form

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
bool TreeVisible { get; set; }
Visual Basic
Property TreeVisible As Boolean
    Get
    Set
Visual C++
property bool TreeVisible {
    bool get ();
    void set (bool value);
}

See Also

IWorkspaceForm Interface
IWorkspaceForm Members
ToolInterfaces Namespace


Workspace Property

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..Workspace Property
IWorkspaceForm Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Interface of the workspace which owns the explorer

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
IWorkspace Workspace { get; }
Visual Basic
ReadOnly Property Workspace As IWorkspace
    Get
Visual C++
property IWorkspace^ Workspace {
    IWorkspace^ get ();
}

See Also

IWorkspaceForm Interface
IWorkspaceForm Members
ToolInterfaces Namespace


IWorkspaceForm Events

[image] [image]

MADCAT Software Developer Guide
IWorkspaceForm Events
IWorkspaceForm Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IWorkspaceForm type exposes the following members.

Events

 | Name | Description
Public event | ClipboardChanged | Fired when the user performed on action on the clipboard : copy/cut
Public event | ItemAdded | Fired when an item has been created by the user and must be added to the displayed items
Public event | ItemChanged | Fired when an item has been modified by the user. Its display must be updated
Public event | ItemDeleted | Fired when an item has been deleted by the user and must be removed from the displayed items
Public event | ItemUnDeleted | Fired when an item has been undeleted by the user and must be added to the displayed items
Public event | Refresh | Fired when the form requests a complete refresh of the display
Public event | RootItemChanged | Fired when the user moves in the explorer tree. The display must be totally refreshed with the new root item.
Public event | SelectionChanged | Fired when the user changes the selection in the explorer form.
Public event | SelectionPaste | Fired when the user paste the clipboard. The content of the clipboard must be displayed

See Also

IWorkspaceForm Interface
ToolInterfaces Namespace


ClipboardChanged Event

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..ClipboardChanged Event
IWorkspaceForm Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Fired when the user performed on action on the clipboard : copy/cut

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
event IWorkspaceForm..::..SelectionEventHandler ClipboardChanged
Visual Basic
Event ClipboardChanged As IWorkspaceForm..::..SelectionEventHandler
Visual C++
 event IWorkspaceForm..::..SelectionEventHandler^ ClipboardChanged {
    void add (IWorkspaceForm..::..SelectionEventHandler^ value);
    void remove (IWorkspaceForm..::..SelectionEventHandler^ value);
}

See Also

IWorkspaceForm Interface
IWorkspaceForm Members
ToolInterfaces Namespace


ItemAdded Event

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..ItemAdded Event
IWorkspaceForm Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Fired when an item has been created by the user and must be added to the displayed items

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
event IWorkspaceForm..::..ItemEventHandler ItemAdded
Visual Basic
Event ItemAdded As IWorkspaceForm..::..ItemEventHandler
Visual C++
 event IWorkspaceForm..::..ItemEventHandler^ ItemAdded {
    void add (IWorkspaceForm..::..ItemEventHandler^ value);
    void remove (IWorkspaceForm..::..ItemEventHandler^ value);
}

See Also

IWorkspaceForm Interface
IWorkspaceForm Members
ToolInterfaces Namespace


ItemChanged Event

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..ItemChanged Event
IWorkspaceForm Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Fired when an item has been modified by the user. Its display must be updated

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
event IWorkspaceForm..::..ItemEventHandler ItemChanged
Visual Basic
Event ItemChanged As IWorkspaceForm..::..ItemEventHandler
Visual C++
 event IWorkspaceForm..::..ItemEventHandler^ ItemChanged {
    void add (IWorkspaceForm..::..ItemEventHandler^ value);
    void remove (IWorkspaceForm..::..ItemEventHandler^ value);
}

See Also

IWorkspaceForm Interface
IWorkspaceForm Members
ToolInterfaces Namespace


ItemDeleted Event

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..ItemDeleted Event
IWorkspaceForm Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Fired when an item has been deleted by the user and must be removed from the displayed items

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
event IWorkspaceForm..::..ItemEventHandler ItemDeleted
Visual Basic
Event ItemDeleted As IWorkspaceForm..::..ItemEventHandler
Visual C++
 event IWorkspaceForm..::..ItemEventHandler^ ItemDeleted {
    void add (IWorkspaceForm..::..ItemEventHandler^ value);
    void remove (IWorkspaceForm..::..ItemEventHandler^ value);
}

See Also

IWorkspaceForm Interface
IWorkspaceForm Members
ToolInterfaces Namespace


ItemUnDeleted Event

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..ItemUnDeleted Event
IWorkspaceForm Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Fired when an item has been undeleted by the user and must be added to the displayed items

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
event IWorkspaceForm..::..ItemEventHandler ItemUnDeleted
Visual Basic
Event ItemUnDeleted As IWorkspaceForm..::..ItemEventHandler
Visual C++
 event IWorkspaceForm..::..ItemEventHandler^ ItemUnDeleted {
    void add (IWorkspaceForm..::..ItemEventHandler^ value);
    void remove (IWorkspaceForm..::..ItemEventHandler^ value);
}

See Also

IWorkspaceForm Interface
IWorkspaceForm Members
ToolInterfaces Namespace


Refresh Event

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..Refresh Event
IWorkspaceForm Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Fired when the form requests a complete refresh of the display

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
event IWorkspaceForm..::..EventHandler Refresh
Visual Basic
Event Refresh As IWorkspaceForm..::..EventHandler
Visual C++
 event IWorkspaceForm..::..EventHandler^ Refresh {
    void add (IWorkspaceForm..::..EventHandler^ value);
    void remove (IWorkspaceForm..::..EventHandler^ value);
}

See Also

IWorkspaceForm Interface
IWorkspaceForm Members
ToolInterfaces Namespace


RootItemChanged Event

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..RootItemChanged Event
IWorkspaceForm Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Fired when the user moves in the explorer tree. The display must be totally refreshed with the new root item.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
event IWorkspaceForm..::..DisplayEventHandler RootItemChanged
Visual Basic
Event RootItemChanged As IWorkspaceForm..::..DisplayEventHandler
Visual C++
 event IWorkspaceForm..::..DisplayEventHandler^ RootItemChanged {
    void add (IWorkspaceForm..::..DisplayEventHandler^ value);
    void remove (IWorkspaceForm..::..DisplayEventHandler^ value);
}

See Also

IWorkspaceForm Interface
IWorkspaceForm Members
ToolInterfaces Namespace


SelectionChanged Event

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..SelectionChanged Event
IWorkspaceForm Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Fired when the user changes the selection in the explorer form.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
event IWorkspaceForm..::..SelectionEventHandler SelectionChanged
Visual Basic
Event SelectionChanged As IWorkspaceForm..::..SelectionEventHandler
Visual C++
 event IWorkspaceForm..::..SelectionEventHandler^ SelectionChanged {
    void add (IWorkspaceForm..::..SelectionEventHandler^ value);
    void remove (IWorkspaceForm..::..SelectionEventHandler^ value);
}

See Also

IWorkspaceForm Interface
IWorkspaceForm Members
ToolInterfaces Namespace


SelectionPaste Event

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..SelectionPaste Event
IWorkspaceForm Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Fired when the user paste the clipboard. The content of the clipboard must be displayed

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
event IWorkspaceForm..::..SelectionEventHandler SelectionPaste
Visual Basic
Event SelectionPaste As IWorkspaceForm..::..SelectionEventHandler
Visual C++
 event IWorkspaceForm..::..SelectionEventHandler^ SelectionPaste {
    void add (IWorkspaceForm..::..SelectionEventHandler^ value);
    void remove (IWorkspaceForm..::..SelectionEventHandler^ value);
}

See Also

IWorkspaceForm Interface
IWorkspaceForm Members
ToolInterfaces Namespace


IWorkspaceForm.DisplayEventArgs Class

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..DisplayEventArgs Class
IWorkspaceForm Interface Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This class is used to pass arguments to event handlers. This is used for the following events : RootItemChanged by the delegate DisplayEventHandler.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public class DisplayEventArgs : IDisposable
Visual Basic
Public Class DisplayEventArgs _
    Implements IDisposable
Visual C++
public ref class DisplayEventArgs : IDisposable

Inheritance Hierarchy

System..::..Object
ToolInterfaces..::..IWorkspaceForm..::..DisplayEventArgs

See Also

IWorkspaceForm..::..DisplayEventArgs Members
ToolInterfaces Namespace


IWorkspaceForm.DisplayEventArgs Members

[image] [image]

MADCAT Software Developer Guide
IWorkspaceForm..::..DisplayEventArgs Members
IWorkspaceForm..::..DisplayEventArgs Class Constructors Methods Fields See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IWorkspaceForm..::..DisplayEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | IWorkspaceForm..::..DisplayEventArgs()()()() | Constructor
Public method | IWorkspaceForm..::..DisplayEventArgs(XmlNode) | Constructor

Methods

 | Name | Description
Public method | Dispose | Destructor

Fields

 | Name | Description
Public field | DisplayedItems | Array of Xml nodes corresponding to the items to be displayed. Renderer should use this list to get the nodes to display
Public field | ParentItem | Xml node of the new root item of the explorer. Renderer should use this node to display a title or a path
Public field | ReadOnly | Indicates if items can be modified or not. TRUE=No modification is allowed. The renderer should disable all its edit/delete commands

See Also

IWorkspaceForm..::..DisplayEventArgs Class
ToolInterfaces Namespace


IWorkspaceForm.DisplayEventArgs Constructor

[image] [image]

MADCAT Software Developer Guide
IWorkspaceForm..::..DisplayEventArgs Constructor
IWorkspaceForm..::..DisplayEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | IWorkspaceForm..::..DisplayEventArgs()()()() | Constructor
Public method | IWorkspaceForm..::..DisplayEventArgs(XmlNode) | Constructor

See Also

IWorkspaceForm..::..DisplayEventArgs Class
IWorkspaceForm..::..DisplayEventArgs Members
ToolInterfaces Namespace


IWorkspaceForm.DisplayEventArgs Constructor

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..DisplayEventArgs Constructor
IWorkspaceForm..::..DisplayEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public DisplayEventArgs()
Visual Basic
Public Sub New
Visual C++
public:
DisplayEventArgs()

See Also

IWorkspaceForm..::..DisplayEventArgs Class
IWorkspaceForm..::..DisplayEventArgs Members
IWorkspaceForm..::..DisplayEventArgs Overload
ToolInterfaces Namespace


IWorkspaceForm.DisplayEventArgs Constructor (XmlNode)

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..DisplayEventArgs Constructor (XmlNode)
IWorkspaceForm..::..DisplayEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public DisplayEventArgs(
    XmlNode itm
)
Visual Basic
Public Sub New ( _
    itm As XmlNode _
)
Visual C++
public:
DisplayEventArgs(
    XmlNode^ itm
)

Parameters

itm
Type: System.Xml..::..XmlNode
Xml data of the item

See Also

IWorkspaceForm..::..DisplayEventArgs Class
IWorkspaceForm..::..DisplayEventArgs Members
IWorkspaceForm..::..DisplayEventArgs Overload
ToolInterfaces Namespace


IWorkspaceForm.DisplayEventArgs Fields

[image] [image]

MADCAT Software Developer Guide
IWorkspaceForm..::..DisplayEventArgs Fields
IWorkspaceForm..::..DisplayEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IWorkspaceForm..::..DisplayEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | DisplayedItems | Array of Xml nodes corresponding to the items to be displayed. Renderer should use this list to get the nodes to display
Public field | ParentItem | Xml node of the new root item of the explorer. Renderer should use this node to display a title or a path
Public field | ReadOnly | Indicates if items can be modified or not. TRUE=No modification is allowed. The renderer should disable all its edit/delete commands

See Also

IWorkspaceForm..::..DisplayEventArgs Class
ToolInterfaces Namespace


DisplayedItems Field

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..DisplayEventArgs..::..DisplayedItems Field
IWorkspaceForm..::..DisplayEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Array of Xml nodes corresponding to the items to be displayed. Renderer should use this list to get the nodes to display

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public ArrayList DisplayedItems
Visual Basic
Public DisplayedItems As ArrayList
Visual C++
public:
ArrayList^ DisplayedItems

See Also

IWorkspaceForm..::..DisplayEventArgs Class
IWorkspaceForm..::..DisplayEventArgs Members
ToolInterfaces Namespace


ParentItem Field

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..DisplayEventArgs..::..ParentItem Field
IWorkspaceForm..::..DisplayEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Xml node of the new root item of the explorer. Renderer should use this node to display a title or a path

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public XmlNode ParentItem
Visual Basic
Public ParentItem As XmlNode
Visual C++
public:
XmlNode^ ParentItem

See Also

IWorkspaceForm..::..DisplayEventArgs Class
IWorkspaceForm..::..DisplayEventArgs Members
ToolInterfaces Namespace


ReadOnly Field

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..DisplayEventArgs..::..ReadOnly Field
IWorkspaceForm..::..DisplayEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Indicates if items can be modified or not. TRUE=No modification is allowed. The renderer should disable all its edit/delete commands

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public bool ReadOnly
Visual Basic
Public ReadOnly As Boolean
Visual C++
public:
bool ReadOnly

See Also

IWorkspaceForm..::..DisplayEventArgs Class
IWorkspaceForm..::..DisplayEventArgs Members
ToolInterfaces Namespace


IWorkspaceForm.DisplayEventArgs Methods

[image] [image]

MADCAT Software Developer Guide
IWorkspaceForm..::..DisplayEventArgs Methods
IWorkspaceForm..::..DisplayEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IWorkspaceForm..::..DisplayEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Destructor

See Also

IWorkspaceForm..::..DisplayEventArgs Class
ToolInterfaces Namespace


Dispose Method

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..DisplayEventArgs..::..Dispose Method
IWorkspaceForm..::..DisplayEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Destructor

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

IWorkspaceForm..::..DisplayEventArgs Class
IWorkspaceForm..::..DisplayEventArgs Members
ToolInterfaces Namespace


IWorkspaceForm.DisplayEventHandler Delegate

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..DisplayEventHandler Delegate
IWorkspaceForm Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Delegate used for the following events : RootItemChanged

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public delegate void DisplayEventHandler(
    Object Form,
    IWorkspaceForm..::..DisplayEventArgs e
)
Visual Basic
Public Delegate Sub DisplayEventHandler ( _
    Form As Object, _
    e As IWorkspaceForm..::..DisplayEventArgs _
)
Visual C++
public delegate void DisplayEventHandler(
    Object^ Form,
    IWorkspaceForm..::..DisplayEventArgs^ e
)

Parameters

Form
Type: System..::..Object
e
Type: ToolInterfaces..::..IWorkspaceForm..::..DisplayEventArgs

See Also

ToolInterfaces Namespace


IWorkspaceForm.DragDropEventArgs Class

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..DragDropEventArgs Class
IWorkspaceForm Interface Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This class is used to pass arguments to event handlers. This is used for the following events : TBD by the delegate DragDropEventHandler.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public class DragDropEventArgs
Visual Basic
Public Class DragDropEventArgs
Visual C++
public ref class DragDropEventArgs

Inheritance Hierarchy

System..::..Object
ToolInterfaces..::..IWorkspaceForm..::..DragDropEventArgs

See Also

IWorkspaceForm..::..DragDropEventArgs Members
ToolInterfaces Namespace


IWorkspaceForm.DragDropEventArgs Members

[image] [image]

MADCAT Software Developer Guide
IWorkspaceForm..::..DragDropEventArgs Members
IWorkspaceForm..::..DragDropEventArgs Class Constructors Fields See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IWorkspaceForm..::..DragDropEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | IWorkspaceForm..::..DragDropEventArgs | Constructor

Fields

 | Name | Description
Public field | Data | DataPacket which contain all the Xml data of the dragged items
Public field | DragArgs | Argument of the Dran'n'drop operation
Public field | TargetNode | Xml data of the item where the dragged items are dropped

See Also

IWorkspaceForm..::..DragDropEventArgs Class
ToolInterfaces Namespace


IWorkspaceForm.DragDropEventArgs Constructor

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..DragDropEventArgs Constructor
IWorkspaceForm..::..DragDropEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public DragDropEventArgs()
Visual Basic
Public Sub New
Visual C++
public:
DragDropEventArgs()

See Also

IWorkspaceForm..::..DragDropEventArgs Class
IWorkspaceForm..::..DragDropEventArgs Members
ToolInterfaces Namespace


IWorkspaceForm.DragDropEventArgs Fields

[image] [image]

MADCAT Software Developer Guide
IWorkspaceForm..::..DragDropEventArgs Fields
IWorkspaceForm..::..DragDropEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IWorkspaceForm..::..DragDropEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | Data | DataPacket which contain all the Xml data of the dragged items
Public field | DragArgs | Argument of the Dran'n'drop operation
Public field | TargetNode | Xml data of the item where the dragged items are dropped

See Also

IWorkspaceForm..::..DragDropEventArgs Class
ToolInterfaces Namespace


Data Field

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..DragDropEventArgs..::..Data Field
IWorkspaceForm..::..DragDropEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
DataPacket which contain all the Xml data of the dragged items

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public DataPacket Data
Visual Basic
Public Data As DataPacket
Visual C++
public:
DataPacket^ Data

See Also

IWorkspaceForm..::..DragDropEventArgs Class
IWorkspaceForm..::..DragDropEventArgs Members
ToolInterfaces Namespace


DragArgs Field

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..DragDropEventArgs..::..DragArgs Field
IWorkspaceForm..::..DragDropEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Argument of the Dran'n'drop operation

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public DragEventArgs DragArgs
Visual Basic
Public DragArgs As DragEventArgs
Visual C++
public:
DragEventArgs^ DragArgs

See Also

IWorkspaceForm..::..DragDropEventArgs Class
IWorkspaceForm..::..DragDropEventArgs Members
ToolInterfaces Namespace


TargetNode Field

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..DragDropEventArgs..::..TargetNode Field
IWorkspaceForm..::..DragDropEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Xml data of the item where the dragged items are dropped

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public XmlNode TargetNode
Visual Basic
Public TargetNode As XmlNode
Visual C++
public:
XmlNode^ TargetNode

See Also

IWorkspaceForm..::..DragDropEventArgs Class
IWorkspaceForm..::..DragDropEventArgs Members
ToolInterfaces Namespace


IWorkspaceForm.DragDropEventHandler Delegate

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..DragDropEventHandler Delegate
IWorkspaceForm Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Delegate used for the following events : TBD

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public delegate void DragDropEventHandler(
    Object Form,
    IWorkspaceForm..::..DragDropEventArgs e
)
Visual Basic
Public Delegate Sub DragDropEventHandler ( _
    Form As Object, _
    e As IWorkspaceForm..::..DragDropEventArgs _
)
Visual C++
public delegate void DragDropEventHandler(
    Object^ Form,
    IWorkspaceForm..::..DragDropEventArgs^ e
)

Parameters

Form
Type: System..::..Object
e
Type: ToolInterfaces..::..IWorkspaceForm..::..DragDropEventArgs

See Also

ToolInterfaces Namespace


IWorkspaceForm.EventHandler Delegate

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..EventHandler Delegate
IWorkspaceForm Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Delegate used for the following events : Refresh

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public delegate void EventHandler(
    Object Form
)
Visual Basic
Public Delegate Sub EventHandler ( _
    Form As Object _
)
Visual C++
public delegate void EventHandler(
    Object^ Form
)

Parameters

Form
Type: System..::..Object

See Also

ToolInterfaces Namespace


IWorkspaceForm.ItemEventArgs Class

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..ItemEventArgs Class
IWorkspaceForm Interface Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This class is used to pass arguments to event handlers. This is used for the following events : ItemAdded, ItemChanged, ItemDeleted and ItemUndeleted by the delegate ItemEventHandler.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public class ItemEventArgs
Visual Basic
Public Class ItemEventArgs
Visual C++
public ref class ItemEventArgs

Inheritance Hierarchy

System..::..Object
ToolInterfaces..::..IWorkspaceForm..::..ItemEventArgs

See Also

IWorkspaceForm..::..ItemEventArgs Members
ToolInterfaces Namespace


IWorkspaceForm.ItemEventArgs Members

[image] [image]

MADCAT Software Developer Guide
IWorkspaceForm..::..ItemEventArgs Members
IWorkspaceForm..::..ItemEventArgs Class Constructors Fields See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IWorkspaceForm..::..ItemEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | IWorkspaceForm..::..ItemEventArgs()()()() | Constructor
Public method | IWorkspaceForm..::..ItemEventArgs(XmlNode) | Constructor

Fields

 | Name | Description
Public field | NewItem | Xml node reflecting item's state after modification or creation or undelete
Public field | OldItem | Xml node reflecting item's state before modification or deletion
Public field | ParentItem | Xml node parent of the item

See Also

IWorkspaceForm..::..ItemEventArgs Class
ToolInterfaces Namespace


IWorkspaceForm.ItemEventArgs Constructor

[image] [image]

MADCAT Software Developer Guide
IWorkspaceForm..::..ItemEventArgs Constructor
IWorkspaceForm..::..ItemEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | IWorkspaceForm..::..ItemEventArgs()()()() | Constructor
Public method | IWorkspaceForm..::..ItemEventArgs(XmlNode) | Constructor

See Also

IWorkspaceForm..::..ItemEventArgs Class
IWorkspaceForm..::..ItemEventArgs Members
ToolInterfaces Namespace


IWorkspaceForm.ItemEventArgs Constructor

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..ItemEventArgs Constructor
IWorkspaceForm..::..ItemEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public ItemEventArgs()
Visual Basic
Public Sub New
Visual C++
public:
ItemEventArgs()

See Also

IWorkspaceForm..::..ItemEventArgs Class
IWorkspaceForm..::..ItemEventArgs Members
IWorkspaceForm..::..ItemEventArgs Overload
ToolInterfaces Namespace


IWorkspaceForm.ItemEventArgs Constructor (XmlNode)

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..ItemEventArgs Constructor (XmlNode)
IWorkspaceForm..::..ItemEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public ItemEventArgs(
    XmlNode itm
)
Visual Basic
Public Sub New ( _
    itm As XmlNode _
)
Visual C++
public:
ItemEventArgs(
    XmlNode^ itm
)

Parameters

itm
Type: System.Xml..::..XmlNode
Xml data of the item

See Also

IWorkspaceForm..::..ItemEventArgs Class
IWorkspaceForm..::..ItemEventArgs Members
IWorkspaceForm..::..ItemEventArgs Overload
ToolInterfaces Namespace


IWorkspaceForm.ItemEventArgs Fields

[image] [image]

MADCAT Software Developer Guide
IWorkspaceForm..::..ItemEventArgs Fields
IWorkspaceForm..::..ItemEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IWorkspaceForm..::..ItemEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | NewItem | Xml node reflecting item's state after modification or creation or undelete
Public field | OldItem | Xml node reflecting item's state before modification or deletion
Public field | ParentItem | Xml node parent of the item

See Also

IWorkspaceForm..::..ItemEventArgs Class
ToolInterfaces Namespace


NewItem Field

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..ItemEventArgs..::..NewItem Field
IWorkspaceForm..::..ItemEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Xml node reflecting item's state after modification or creation or undelete

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public XmlNode NewItem
Visual Basic
Public NewItem As XmlNode
Visual C++
public:
XmlNode^ NewItem

See Also

IWorkspaceForm..::..ItemEventArgs Class
IWorkspaceForm..::..ItemEventArgs Members
ToolInterfaces Namespace


OldItem Field

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..ItemEventArgs..::..OldItem Field
IWorkspaceForm..::..ItemEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Xml node reflecting item's state before modification or deletion

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public XmlNode OldItem
Visual Basic
Public OldItem As XmlNode
Visual C++
public:
XmlNode^ OldItem

See Also

IWorkspaceForm..::..ItemEventArgs Class
IWorkspaceForm..::..ItemEventArgs Members
ToolInterfaces Namespace


ParentItem Field

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..ItemEventArgs..::..ParentItem Field
IWorkspaceForm..::..ItemEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Xml node parent of the item

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public XmlNode ParentItem
Visual Basic
Public ParentItem As XmlNode
Visual C++
public:
XmlNode^ ParentItem

See Also

IWorkspaceForm..::..ItemEventArgs Class
IWorkspaceForm..::..ItemEventArgs Members
ToolInterfaces Namespace


IWorkspaceForm.ItemEventHandler Delegate

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..ItemEventHandler Delegate
IWorkspaceForm Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Delegate used for the following events : ItemAdded, ItemChanged, ItemDeleted and ItemUnDeleted

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public delegate void ItemEventHandler(
    Object Form,
    IWorkspaceForm..::..ItemEventArgs e
)
Visual Basic
Public Delegate Sub ItemEventHandler ( _
    Form As Object, _
    e As IWorkspaceForm..::..ItemEventArgs _
)
Visual C++
public delegate void ItemEventHandler(
    Object^ Form,
    IWorkspaceForm..::..ItemEventArgs^ e
)

Parameters

Form
Type: System..::..Object
e
Type: ToolInterfaces..::..IWorkspaceForm..::..ItemEventArgs

See Also

ToolInterfaces Namespace


IWorkspaceForm.SelectionEventArgs Class

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..SelectionEventArgs Class
IWorkspaceForm Interface Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This class is used to pass arguments to event handlers. This is used for the following events : SelectionChanged, ClipboardChanged and SelectionPaste by the delegate SelectionEventHandler.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public class SelectionEventArgs
Visual Basic
Public Class SelectionEventArgs
Visual C++
public ref class SelectionEventArgs

Inheritance Hierarchy

System..::..Object
ToolInterfaces..::..IWorkspaceForm..::..SelectionEventArgs

See Also

IWorkspaceForm..::..SelectionEventArgs Members
ToolInterfaces Namespace


IWorkspaceForm.SelectionEventArgs Members

[image] [image]

MADCAT Software Developer Guide
IWorkspaceForm..::..SelectionEventArgs Members
IWorkspaceForm..::..SelectionEventArgs Class Constructors Fields See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IWorkspaceForm..::..SelectionEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | IWorkspaceForm..::..SelectionEventArgs()()()() | Constructor
Public method | IWorkspaceForm..::..SelectionEventArgs(ArrayList) | Constructor

Fields

 | Name | Description
Public field | Selection | Array of Xml nodes corresponding to the items which are selected/copied/pasted by the user

See Also

IWorkspaceForm..::..SelectionEventArgs Class
ToolInterfaces Namespace


IWorkspaceForm.SelectionEventArgs Constructor

[image] [image]

MADCAT Software Developer Guide
IWorkspaceForm..::..SelectionEventArgs Constructor
IWorkspaceForm..::..SelectionEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

Overload List

 | Name | Description
Public method | IWorkspaceForm..::..SelectionEventArgs()()()() | Constructor
Public method | IWorkspaceForm..::..SelectionEventArgs(ArrayList) | Constructor

See Also

IWorkspaceForm..::..SelectionEventArgs Class
IWorkspaceForm..::..SelectionEventArgs Members
ToolInterfaces Namespace


IWorkspaceForm.SelectionEventArgs Constructor

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..SelectionEventArgs Constructor
IWorkspaceForm..::..SelectionEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public SelectionEventArgs()
Visual Basic
Public Sub New
Visual C++
public:
SelectionEventArgs()

See Also

IWorkspaceForm..::..SelectionEventArgs Class
IWorkspaceForm..::..SelectionEventArgs Members
IWorkspaceForm..::..SelectionEventArgs Overload
ToolInterfaces Namespace


IWorkspaceForm.SelectionEventArgs Constructor (ArrayList)

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..SelectionEventArgs Constructor (ArrayList)
IWorkspaceForm..::..SelectionEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public SelectionEventArgs(
    ArrayList l
)
Visual Basic
Public Sub New ( _
    l As ArrayList _
)
Visual C++
public:
SelectionEventArgs(
    ArrayList^ l
)

Parameters

l
Type: System.Collections..::..ArrayList
Array of XmlNode objects which contain the Xml data of the selected item(s)

See Also

IWorkspaceForm..::..SelectionEventArgs Class
IWorkspaceForm..::..SelectionEventArgs Members
IWorkspaceForm..::..SelectionEventArgs Overload
ToolInterfaces Namespace


IWorkspaceForm.SelectionEventArgs Fields

[image] [image]

MADCAT Software Developer Guide
IWorkspaceForm..::..SelectionEventArgs Fields
IWorkspaceForm..::..SelectionEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IWorkspaceForm..::..SelectionEventArgs type exposes the following members.

Fields

 | Name | Description
Public field | Selection | Array of Xml nodes corresponding to the items which are selected/copied/pasted by the user

See Also

IWorkspaceForm..::..SelectionEventArgs Class
ToolInterfaces Namespace


Selection Field

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..SelectionEventArgs..::..Selection Field
IWorkspaceForm..::..SelectionEventArgs Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Array of Xml nodes corresponding to the items which are selected/copied/pasted by the user

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public ArrayList Selection
Visual Basic
Public Selection As ArrayList
Visual C++
public:
ArrayList^ Selection

See Also

IWorkspaceForm..::..SelectionEventArgs Class
IWorkspaceForm..::..SelectionEventArgs Members
ToolInterfaces Namespace


IWorkspaceForm.SelectionEventHandler Delegate

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..SelectionEventHandler Delegate
IWorkspaceForm Interface See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Delegate used for the following events : SelectionChanged, ClipboardChanged and SelectionPaste

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public delegate void SelectionEventHandler(
    Object Form,
    IWorkspaceForm..::..SelectionEventArgs e
)
Visual Basic
Public Delegate Sub SelectionEventHandler ( _
    Form As Object, _
    e As IWorkspaceForm..::..SelectionEventArgs _
)
Visual C++
public delegate void SelectionEventHandler(
    Object^ Form,
    IWorkspaceForm..::..SelectionEventArgs^ e
)

Parameters

Form
Type: System..::..Object
e
Type: ToolInterfaces..::..IWorkspaceForm..::..SelectionEventArgs

See Also

ToolInterfaces Namespace


IWorkspaceForm.ToolBarItemCollection Class

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..ToolBarItemCollection Class
IWorkspaceForm Interface Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
This class manages the ToolStripItems which appears in the explorer form. Renderers should use this class to add new tool bars to explorers.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public class ToolBarItemCollection
Visual Basic
Public Class ToolBarItemCollection
Visual C++
public ref class ToolBarItemCollection

Inheritance Hierarchy

System..::..Object
ToolInterfaces..::..IWorkspaceForm..::..ToolBarItemCollection

See Also

IWorkspaceForm..::..ToolBarItemCollection Members
ToolInterfaces Namespace


IWorkspaceForm.ToolBarItemCollection Members

[image] [image]

MADCAT Software Developer Guide
IWorkspaceForm..::..ToolBarItemCollection Members
IWorkspaceForm..::..ToolBarItemCollection Class Constructors Methods See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IWorkspaceForm..::..ToolBarItemCollection type exposes the following members.

Constructors

 | Name | Description
Public method | IWorkspaceForm..::..ToolBarItemCollection | Constructor

Methods

 | Name | Description
Public method | Add | Adds a new array of ToolStripItems to the collection
Public method | Get | Gets the array of ToolStripItems of one object

See Also

IWorkspaceForm..::..ToolBarItemCollection Class
ToolInterfaces Namespace


IWorkspaceForm.ToolBarItemCollection Constructor

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..ToolBarItemCollection Constructor
IWorkspaceForm..::..ToolBarItemCollection Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public ToolBarItemCollection()
Visual Basic
Public Sub New
Visual C++
public:
ToolBarItemCollection()

See Also

IWorkspaceForm..::..ToolBarItemCollection Class
IWorkspaceForm..::..ToolBarItemCollection Members
ToolInterfaces Namespace


IWorkspaceForm.ToolBarItemCollection Methods

[image] [image]

MADCAT Software Developer Guide
IWorkspaceForm..::..ToolBarItemCollection Methods
IWorkspaceForm..::..ToolBarItemCollection Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The IWorkspaceForm..::..ToolBarItemCollection type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds a new array of ToolStripItems to the collection
Public method | Get | Gets the array of ToolStripItems of one object

See Also

IWorkspaceForm..::..ToolBarItemCollection Class
ToolInterfaces Namespace


Add Method

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..ToolBarItemCollection..::..Add Method
IWorkspaceForm..::..ToolBarItemCollection Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Adds a new array of ToolStripItems to the collection

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public void Add(
    Object Owner,
    ToolStripItem[] Items
)
Visual Basic
Public Sub Add ( _
    Owner As Object, _
    Items As ToolStripItem() _
)
Visual C++
public:
void Add(
    Object^ Owner,
    array<ToolStripItem^>^ Items
)

Parameters

Owner
Type: System..::..Object
Object which is the owner of the items
Items
Type: array< System.Windows.Forms..::..ToolStripItem >[]()[][]
Array of ToolStripItems to add to the collection

See Also

IWorkspaceForm..::..ToolBarItemCollection Class
IWorkspaceForm..::..ToolBarItemCollection Members
ToolInterfaces Namespace


Get Method

[image]

MADCAT Software Developer Guide
IWorkspaceForm..::..ToolBarItemCollection..::..Get Method
IWorkspaceForm..::..ToolBarItemCollection Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Gets the array of ToolStripItems of one object

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public ToolStripItem[] Get(
    Object Owner
)
Visual Basic
Public Function Get ( _
    Owner As Object _
) As ToolStripItem()
Visual C++
public:
array<ToolStripItem^>^ Get(
    Object^ Owner
)

Parameters

Owner
Type: System..::..Object
Object which is the owner of the items to get

Return Value

Array of ToolStripItems attached to the object. Null if nothing is found.

See Also

IWorkspaceForm..::..ToolBarItemCollection Class
IWorkspaceForm..::..ToolBarItemCollection Members
ToolInterfaces Namespace


ProjectHandler Class

[image]

MADCAT Software Developer Guide
ProjectHandler Class
Members See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Handler that defines the location of a data repository which can be loaded in a workspace

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public class ProjectHandler
Visual Basic
Public Class ProjectHandler
Visual C++
public ref class ProjectHandler

Inheritance Hierarchy

System..::..Object
ToolInterfaces..::..ProjectHandler

See Also

ProjectHandler Members
ToolInterfaces Namespace


ProjectHandler Members

[image] [image]

MADCAT Software Developer Guide
ProjectHandler Members
ProjectHandler Class Constructors Fields See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The ProjectHandler type exposes the following members.

Constructors

 | Name | Description
Public method | ProjectHandler | Constructor

Fields

 | Name | Description
Public field | BaselineName | Name of the baseline to load. It is optional. When set, the data is loaded in read-only mode.
Public field | DataModels | Array of IDataModel objects which can handle the data files found in the project location This attribute is filled by the IDataManager when it is loading a workspace.
Public field | Path | Physical location of the data files

See Also

ProjectHandler Class
ToolInterfaces Namespace


ProjectHandler Constructor

[image]

MADCAT Software Developer Guide
ProjectHandler Constructor
ProjectHandler Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Constructor

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public ProjectHandler(
    string p,
    string b
)
Visual Basic
Public Sub New ( _
    p As String, _
    b As String _
)
Visual C++
public:
ProjectHandler(
    String^ p,
    String^ b
)

Parameters

p
Type: System..::..String
Full path of the folder that contains the data files
b
Type: System..::..String
Optional. Name of the baseline to load

See Also

ProjectHandler Class
ProjectHandler Members
ToolInterfaces Namespace


ProjectHandler Fields

[image] [image]

MADCAT Software Developer Guide
ProjectHandler Fields
ProjectHandler Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2

The ProjectHandler type exposes the following members.

Fields

 | Name | Description
Public field | BaselineName | Name of the baseline to load. It is optional. When set, the data is loaded in read-only mode.
Public field | DataModels | Array of IDataModel objects which can handle the data files found in the project location This attribute is filled by the IDataManager when it is loading a workspace.
Public field | Path | Physical location of the data files

See Also

ProjectHandler Class
ToolInterfaces Namespace


BaselineName Field

[image]

MADCAT Software Developer Guide
ProjectHandler..::..BaselineName Field
ProjectHandler Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Name of the baseline to load. It is optional. When set, the data is loaded in read-only mode.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public string BaselineName
Visual Basic
Public BaselineName As String
Visual C++
public:
String^ BaselineName

See Also

ProjectHandler Class
ProjectHandler Members
ToolInterfaces Namespace


DataModels Field

[image]

MADCAT Software Developer Guide
ProjectHandler..::..DataModels Field
ProjectHandler Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Array of IDataModel objects which can handle the data files found in the project location This attribute is filled by the IDataManager when it is loading a workspace.

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public ArrayList DataModels
Visual Basic
Public DataModels As ArrayList
Visual C++
public:
ArrayList^ DataModels

See Also

ProjectHandler Class
ProjectHandler Members
ToolInterfaces Namespace


Path Field

[image]

MADCAT Software Developer Guide
ProjectHandler..::..Path Field
ProjectHandler Class See Also Send Feedback
MADCAT Software Developer Guide for MADCAT v1.2.2
Physical location of the data files

Namespace: ToolInterfaces
Assembly: ToolInterfaces (in ToolInterfaces.dll) Version: 1.0.4787.39865

Syntax

C#
public string Path
Visual Basic
Public Path As String
Visual C++
public:
String^ Path

See Also

ProjectHandler Class
ProjectHandler Members
ToolInterfaces Namespace